automatic version update by autodist [release 1.1.6-1mamba;Tue Mar 19 2013]

This commit is contained in:
Automatic Build System 2024-01-06 05:06:43 +01:00
parent 906d9b827a
commit 777be30c4e
3 changed files with 188 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# libmtp
libmtp is an implementation of Microsoft's Media Transfer Protocol (MTP) in the form of a library suitable primarily for POSIX compliant operating systems.
We implement MTP Basic, the stuff proposed for standardization.

View File

@ -0,0 +1,37 @@
diff -Nru libmtp-1.0.0.orig/examples/Makefile.am libmtp-1.0.0/examples/Makefile.am
--- libmtp-1.0.0.orig/examples/Makefile.am 2009-05-07 01:04:19.000000000 +0200
+++ libmtp-1.0.0/examples/Makefile.am 2009-08-08 21:06:50.000000000 +0200
@@ -27,8 +27,8 @@
EXTRA_DIST=evolution-sync.sh
install-exec-hook:
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-delfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-getfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-newfolder$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendtr$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-delfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-getfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-newfolder$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendtr$(EXEEXT)
diff -Nru libmtp-1.0.0.orig/examples/Makefile.in libmtp-1.0.0/examples/Makefile.in
--- libmtp-1.0.0.orig/examples/Makefile.in 2009-08-01 22:05:33.000000000 +0200
+++ libmtp-1.0.0/examples/Makefile.in 2009-08-08 21:06:28.000000000 +0200
@@ -676,11 +676,11 @@
install-exec-hook:
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-delfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-getfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-newfolder$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendfile$(EXEEXT)
- ln -f -s $(DESTDIR)$(bindir)/mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendtr$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-delfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-getfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-newfolder$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendfile$(EXEEXT)
+ ln -f -s mtp-connect$(EXEEXT) $(DESTDIR)$(bindir)/mtp-sendtr$(EXEEXT)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

148
libmtp.spec Normal file
View File

@ -0,0 +1,148 @@
Name: libmtp
Version: 1.1.6
Release: 1mamba
Summary: A library implementation of the Media Transfer Protocol (MTP)
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://libmtp.sourceforge.net/
Source0: http://downloads.sourceforge.net/project/libmtp/libmtp/%{version}/libmtp-%{version}.tar.gz
Patch0: %{name}-1.0.0-fix_DESTDIR_links.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libusb-devel
BuildRequires: pkg-config
## AUTOBUILDREQ-END
Provides: libmtp7
Obsoletes: libmtp7
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
libmtp is an implementation of Microsoft's Media Transfer Protocol (MTP) in the form of a library suitable primarily for POSIX compliant operating systems.
We implement MTP Basic, the stuff proposed for standardization.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libmtp7-devel
Obsoletes: libmtp7-devel
%description devel
libmtp is an implementation of Microsoft's Media Transfer Protocol (MTP) in the form of a library suitable primarily for POSIX compliant operating systems.
We implement MTP Basic, the stuff proposed for standardization.
This package contains static libraries and header files need for development.
%package -n mtp-tools
Group: System/Tools
Summary: A collection of tools using libmtp
Provides: mtp7-tools
Obsoletes: mtp7-tools
%description -n mtp-tools
libmtp is an implementation of Microsoft's Media Transfer Protocol (MTP) in the form of a library suitable primarily for POSIX compliant operating systems.
We implement MTP Basic, the stuff proposed for standardization.
This package contains a collection of tools using libmtp.
%prep
%setup -q
#%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -f %{buildroot}%{_libdir}/libmtp.a
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libmtp.so.*
/lib/udev/mtp-probe
/lib/udev/rules.d/69-libmtp.rules
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%{_includedir}/libmtp.h
%{_libdir}/libmtp.la
%{_libdir}/libmtp.so
%{_libdir}/pkgconfig/libmtp.pc
%doc ChangeLog README TODO
%files -n mtp-tools
%defattr(-,root,root)
%{_bindir}/mtp-*
%changelog
* Tue Mar 19 2013 Automatic Build System <autodist@mambasoft.it> 1.1.6-1mamba
- automatic version update by autodist
* Tue Oct 02 2012 Davide Madrisan <davide.madrisan@gmail.com> 1.1.5-1mamba
- update to 1.1.5
* Sun Mar 18 2012 Davide Madrisan <davide.madrisan@gmail.com> 1.1.2-1mamba
- update to 1.1.2
* Thu Nov 10 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-1mamba
- update to 1.1.1
* Sun Aug 21 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1mamba
- update to 1.1.0
* Sun Aug 21 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.6-1mamba
- update to 1.0.6
- remove mtp- binary prefix
- remove hal fdi
* Wed Jan 26 2011 Automatic Build System <autodist@mambasoft.it> 1.0.4-1mamba
- automatic update by autodist
* Sat Jun 05 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.0.3-1mamba
- update to 1.0.3
- install the libmtp.fdi file
* Thu May 13 2010 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
- automatic update by autodist
* Sun Aug 09 2009 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
- automatic update by autodist
* Sat Apr 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.7-1mamba
- automatic update by autodist
* Sun Mar 01 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.6-1mamba
- automatic update by autodist
* Mon Dec 15 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.3-1mamba
- automatic update to 0.3.3 by autodist
* Thu Jul 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.6-1mamba
- update to 0.2.6
- install udev rules file from upstream file in sources
* Fri Nov 23 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-2mamba
- added package mtp-tools; binaries created with mtp- prefix
* Thu Nov 22 2007 Aleph0 <aleph0@openmamba.org> 0.2.2-1mamba
- update to 0.2.2
- add rules for udev
* Fri Feb 09 2007 Aleph0 <aleph0@openmamba.org> 0.1.3-1qilnx
- update to version 0.1.3 by autospec
* Tue Oct 31 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.0.21-1qilnx
- package created by autospec