automatic rebuild by autodist [release 20060920-2mamba;Sun Sep 01 2013]

This commit is contained in:
Automatic Build System 2024-01-06 05:06:21 +01:00
parent 126d541573
commit 79e7aee769
3 changed files with 331 additions and 0 deletions

View File

@ -1,2 +1,11 @@
# libmspack
The purpose of libmspack is to provide both compression and decompression of some loosely related file formats used by Microsoft.
The intention is to support all of the following formats:
- COMPRESS.EXE [SZDD]
- Microsoft Help
- COMPRESS.EXE [KWAJ]
- Microsoft Cabinet
- HTML Help
- Microsoft eBook

View File

@ -0,0 +1,228 @@
diff -Nru libmspack-0.0.20040308alpha.orig/mspack/mspack.h libmspack-0.0.20040308alpha/mspack/mspack.h
--- libmspack-0.0.20040308alpha.orig/mspack/mspack.h 2005-05-11 15:05:15.000000000 +0200
+++ libmspack-0.0.20040308alpha/mspack/mspack.h 2005-05-11 15:05:56.000000000 +0200
@@ -260,7 +260,7 @@
* for other mspack_system methods to operate.
* @see close(), read(), write(), seek(), tell(), message()
*/
- struct mspack_file * (*open)(struct mspack_system *this,
+ struct mspack_file * (*open)(struct mspack_system *,
char *filename,
int mode);
@@ -369,7 +369,7 @@
* not enough memory is available
* @see free()
*/
- void * (*alloc)(struct mspack_system *this,
+ void * (*alloc)(struct mspack_system *,
size_t bytes);
/**
@@ -476,12 +476,12 @@
/** Destroys an existing CAB compressor.
* @param this the #mscab_compressor to destroy
*/
-extern void mspack_destroy_cab_compressor(struct mscab_compressor *this);
+extern void mspack_destroy_cab_compressor(struct mscab_compressor *);
/** Destroys an existing CAB decompressor.
* @param this the #mscab_decompressor to destroy
*/
-extern void mspack_destroy_cab_decompressor(struct mscab_decompressor *this);
+extern void mspack_destroy_cab_decompressor(struct mscab_decompressor *);
/** Creates a new CHM compressor.
@@ -501,12 +501,12 @@
/** Destroys an existing CHM compressor.
* @param this the #mschm_compressor to destroy
*/
-extern void mspack_destroy_chm_compressor(struct mschm_compressor *this);
+extern void mspack_destroy_chm_compressor(struct mschm_compressor *);
/** Destroys an existing CHM decompressor.
* @param this the #mschm_decompressor to destroy
*/
-extern void mspack_destroy_chm_decompressor(struct mschm_decompressor *this);
+extern void mspack_destroy_chm_decompressor(struct mschm_decompressor *);
/** Creates a new LIT compressor.
@@ -526,12 +526,12 @@
/** Destroys an existing LIT compressor.
* @param this the #mslit_compressor to destroy
*/
-extern void mspack_destroy_lit_compressor(struct mslit_compressor *this);
+extern void mspack_destroy_lit_compressor(struct mslit_compressor *);
/** Destroys an existing LIT decompressor.
* @param this the #mslit_decompressor to destroy
*/
-extern void mspack_destroy_lit_decompressor(struct mslit_decompressor *this);
+extern void mspack_destroy_lit_decompressor(struct mslit_decompressor *);
/** Creates a new HLP compressor.
@@ -551,12 +551,12 @@
/** Destroys an existing hlp compressor.
* @param this the #mshlp_compressor to destroy
*/
-extern void mspack_destroy_hlp_compressor(struct mshlp_compressor *this);
+extern void mspack_destroy_hlp_compressor(struct mshlp_compressor *);
/** Destroys an existing hlp decompressor.
* @param this the #mshlp_decompressor to destroy
*/
-extern void mspack_destroy_hlp_decompressor(struct mshlp_decompressor *this);
+extern void mspack_destroy_hlp_decompressor(struct mshlp_decompressor *);
/** Creates a new SZDD compressor.
@@ -576,12 +576,12 @@
/** Destroys an existing SZDD compressor.
* @param this the #msszdd_compressor to destroy
*/
-extern void mspack_destroy_szdd_compressor(struct msszdd_compressor *this);
+extern void mspack_destroy_szdd_compressor(struct msszdd_compressor *);
/** Destroys an existing SZDD decompressor.
* @param this the #msszdd_decompressor to destroy
*/
-extern void mspack_destroy_szdd_decompressor(struct msszdd_decompressor *this);
+extern void mspack_destroy_szdd_decompressor(struct msszdd_decompressor *);
/** Creates a new KWAJ compressor.
@@ -601,12 +601,12 @@
/** Destroys an existing KWAJ compressor.
* @param this the #mskwaj_compressor to destroy
*/
-extern void mspack_destroy_kwaj_compressor(struct mskwaj_compressor *this);
+extern void mspack_destroy_kwaj_compressor(struct mskwaj_compressor *);
/** Destroys an existing KWAJ decompressor.
* @param this the #mskwaj_decompressor to destroy
*/
-extern void mspack_destroy_kwaj_decompressor(struct mskwaj_decompressor *this);
+extern void mspack_destroy_kwaj_decompressor(struct mskwaj_decompressor *);
/* --- support for .CAB (MS Cabinet) file format --------------------------- */
@@ -894,7 +894,7 @@
* @return a pointer to a mscabd_cabinet structure, or NULL on failure
* @see close(), search(), last_error()
*/
- struct mscabd_cabinet * (*open) (struct mscab_decompressor *this,
+ struct mscabd_cabinet * (*open) (struct mscab_decompressor *,
char *filename);
/**
@@ -926,7 +926,7 @@
* @param cab the cabinet to close
* @see open(), search(), append(), prepend()
*/
- void (*close)(struct mscab_decompressor *this,
+ void (*close)(struct mscab_decompressor *,
struct mscabd_cabinet *cab);
/**
@@ -963,7 +963,7 @@
* @return a pointer to a mscabd_cabinet structure, or NULL
* @see close(), open(), last_error()
*/
- struct mscabd_cabinet * (*search) (struct mscab_decompressor *this,
+ struct mscabd_cabinet * (*search) (struct mscab_decompressor *,
char *filename);
/**
@@ -1006,7 +1006,7 @@
* @return an error code, or MSPACK_ERR_OK if successful
* @see prepend(), open(), close()
*/
- int (*append) (struct mscab_decompressor *this,
+ int (*append) (struct mscab_decompressor *,
struct mscabd_cabinet *cab,
struct mscabd_cabinet *nextcab);
@@ -1028,7 +1028,7 @@
* @return an error code, or MSPACK_ERR_OK if successful
* @see append(), open(), close()
*/
- int (*prepend) (struct mscab_decompressor *this,
+ int (*prepend) (struct mscab_decompressor *,
struct mscabd_cabinet *cab,
struct mscabd_cabinet *prevcab);
@@ -1054,7 +1054,7 @@
* @param filename the filename of the file being written to
* @return an error code, or MSPACK_ERR_OK if successful
*/
- int (*extract)(struct mscab_decompressor *this,
+ int (*extract)(struct mscab_decompressor *,
struct mscabd_file *file,
char *filename);
@@ -1080,7 +1080,7 @@
* is a problem with either parameter or value.
* @see search(), extract()
*/
- int (*set_param)(struct mscab_decompressor *this,
+ int (*set_param)(struct mscab_decompressor *,
int param,
int value);
@@ -1294,7 +1294,7 @@
* @return a pointer to a mschmd_header structure, or NULL on failure
* @see close()
*/
- struct mschmd_header *(*open)(struct mschm_decompressor *this,
+ struct mschmd_header *(*open)(struct mschm_decompressor *,
char *filename);
/**
@@ -1314,7 +1314,7 @@
* @param chm the CHM helpfile to close
* @see open(), fast_open()
*/
- void (*close)(struct mschm_decompressor *this,
+ void (*close)(struct mschm_decompressor *,
struct mschmd_header *chm);
/**
@@ -1335,7 +1335,7 @@
* @param filename the filename of the file being written to
* @return an error code, or MSPACK_ERR_OK if successful
*/
- int (*extract)(struct mschm_decompressor *this,
+ int (*extract)(struct mschm_decompressor *,
struct mschmd_file *file,
char *filename);
@@ -1350,7 +1350,7 @@
* @return the most recent error code
* @see open(), search()
*/
- int (*last_error)(struct mschm_decompressor *this);
+ int (*last_error)(struct mschm_decompressor *);
/**
* Opens a CHM helpfile quickly.
@@ -1374,7 +1374,7 @@
* @return a pointer to a mschmd_header structure, or NULL on failure
* @see open(), close(), fast_find(), extract()
*/
- struct mschmd_header *(*fast_open)(struct mschm_decompressor *this,
+ struct mschmd_header *(*fast_open)(struct mschm_decompressor *,
char *filename);
/**
@@ -1415,7 +1415,7 @@
* @return MSPACK_ERR_OK, or an error code
* @see open(), close(), fast_find(), extract()
*/
- int (*fast_find)(struct mschm_decompressor *this,
+ int (*fast_find)(struct mschm_decompressor *,
struct mschmd_header *chm,
char *filename,
struct mschmd_file *f_ptr,

94
libmspack.spec Normal file
View File

@ -0,0 +1,94 @@
Name: libmspack
Release: 2mamba
Version: 20060920
Summary: A library for Microsoft compression formats
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.cabextract.org.uk/libmspack
Source: http://www.cabextract.org.uk/libmspack/libmspack-0.0.%{version}alpha.tar.gz
Patch: libmspack-0.0.20040308alpha-gcc3.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The purpose of libmspack is to provide both compression and decompression of some loosely related file formats used by Microsoft.
The intention is to support all of the following formats:
- COMPRESS.EXE [SZDD]
- Microsoft Help
- COMPRESS.EXE [KWAJ]
- Microsoft Cabinet
- HTML Help
- Microsoft eBook
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
The purpose of libmspack is to provide both compression and decompression of some loosely related file formats used by Microsoft.
The intention is to support all of the following formats:
- COMPRESS.EXE [SZDD]
- Microsoft Help
- COMPRESS.EXE [KWAJ]
- Microsoft Cabinet
- HTML Help
- Microsoft eBook
This package contains static libraries and header files need for development.
%prep
%setup -q -n %{name}-0.0.%{version}alpha
#%patch -p1
%build
%configure
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/*.so.*
%doc AUTHORS COPYING.LIB ChangeLog NEWS README TODO
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/*.a
%{_libdir}/*.la
%{_libdir}/*.so
%changelog
* Sun Sep 01 2013 Automatic Build System <autodist@mambasoft.it> 20060920-2mamba
- automatic rebuild by autodist
* Mon Dec 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20060920-1mamba
- update to 20060920
* Sat Apr 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.20060920-2mamba
- specfile updates
* Thu Jan 25 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.0.20060920-1qilnx
- update to version 0.0.20060920 by autospec
* Wed May 11 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.20040308-3qilnx
- gcc3 patch applied to mspack.h
* Tue Mar 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.0.20040308-2qilnx
- rebuilt
* Mon Sep 13 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.0.20040308-1qilnx
- package created by autospec