automatic version update by autodist [release 4.2.1-1mamba;Mon Dec 10 2012]
This commit is contained in:
parent
c634aa0536
commit
e7d9087567
@ -1,2 +1,4 @@
|
||||
# libmsn
|
||||
|
||||
Libmsn is a reusable, open-source, fully documented library for connecting to Microsoft's MSN Messenger service.
|
||||
|
||||
|
17
libmsn-4.1-openssl-1.patch
Normal file
17
libmsn-4.1-openssl-1.patch
Normal file
@ -0,0 +1,17 @@
|
||||
http://bugs.gentoo.org/328031
|
||||
|
||||
--- msntest/msntest.cpp
|
||||
+++ msntest/msntest.cpp
|
||||
@@ -259,7 +259,11 @@
|
||||
if(mySocketsSsl[i].isSSL && !mySocketsSsl[i].isConnected)
|
||||
{
|
||||
BIO *bio_socket_new;
|
||||
- SSL_METHOD *meth=NULL;
|
||||
+ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+ const SSL_METHOD *meth=NULL;
|
||||
+ #else
|
||||
+ SSL_METHOD *meth=NULL;
|
||||
+ #endif
|
||||
meth=SSLv23_client_method();
|
||||
SSLeay_add_ssl_algorithms();
|
||||
mySocketsSsl[i].ctx = SSL_CTX_new(meth);
|
10
libmsn-4.2.1-gcc-4.7.patch
Normal file
10
libmsn-4.2.1-gcc-4.7.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- libmsn-4.2.1/msn/util.cpp 2009-07-22 21:57:10.000000000 +0200
|
||||
+++ libmsn-4.2.1/msn/util.cpp.unistd 2012-01-15 20:44:17.000000000 +0100
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <openssl/rand.h>
|
||||
#include <cstring>
|
||||
#include <sys/timeb.h>
|
||||
+#include <unistd.h>
|
||||
#include "md5.h"
|
||||
#include "libsiren/siren7.h"
|
||||
|
81
libmsn.spec
Normal file
81
libmsn.spec
Normal file
@ -0,0 +1,81 @@
|
||||
Name: libmsn
|
||||
Version: 4.2.1
|
||||
Release: 1mamba
|
||||
Summary: A library for connecting to MSN Messenger service
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://sourceforge.net/projects/libmsn
|
||||
Source: http://downloads.sourceforge.net/libmsn/%{name}-%{version}.tar.bz2
|
||||
Patch0: %{name}-4.1-openssl-1.patch
|
||||
Patch1: libmsn-4.2.1-gcc-4.7.patch
|
||||
License: GPL
|
||||
BuildRequires: cmake
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Libmsn is a reusable, open-source, fully documented library for connecting to Microsoft's MSN Messenger service.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Libmsn is a reusable, open-source, fully documented library for connecting to Microsoft's MSN Messenger service.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p0
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/msntest
|
||||
%{_libdir}/libmsn.so.*
|
||||
%doc COPYING README THANKS TODO
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/msn
|
||||
%{_includedir}/msn/*.h
|
||||
%{_libdir}/libmsn.so
|
||||
%{_libdir}/pkgconfig/libmsn.pc
|
||||
|
||||
%changelog
|
||||
* Mon Dec 10 2012 Automatic Build System <autodist@mambasoft.it> 4.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1-2mamba
|
||||
- rebuilt with openssl 1.0.0
|
||||
|
||||
* Sun Jan 24 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.1-1mamba
|
||||
- update to 4.1
|
||||
|
||||
* Thu Jul 02 2009 Automatic Build System <autodist@mambasoft.it> 4.0.beta6-1mamba
|
||||
- automatic update to 4.0.beta6 by autodist
|
||||
|
||||
* Sat Feb 07 2009 Davide Madrisan <davide.madrisan@gmail.com> beta4-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user