automatic version update by autodist [release 4.0.1-1mamba;Sun Feb 18 2018]
This commit is contained in:
parent
c7644cdbf3
commit
cfa340534b
@ -1,174 +0,0 @@
|
|||||||
diff -Naurd mpfr-3.1.5-a/PATCHES mpfr-3.1.5-b/PATCHES
|
|
||||||
--- mpfr-3.1.5-a/PATCHES 2016-12-15 08:35:46.476430238 +0000
|
|
||||||
+++ mpfr-3.1.5-b/PATCHES 2016-12-15 08:35:46.544430346 +0000
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+vasprintf
|
|
||||||
diff -Naurd mpfr-3.1.5-a/VERSION mpfr-3.1.5-b/VERSION
|
|
||||||
--- mpfr-3.1.5-a/VERSION 2016-09-27 07:58:14.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/VERSION 2016-12-15 08:35:46.544430346 +0000
|
|
||||||
@@ -1 +1 @@
|
|
||||||
-3.1.5
|
|
||||||
+3.1.5-p1
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/mpfr.h mpfr-3.1.5-b/src/mpfr.h
|
|
||||||
--- mpfr-3.1.5-a/src/mpfr.h 2016-09-27 07:58:15.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/mpfr.h 2016-12-15 08:35:46.540430340 +0000
|
|
||||||
@@ -27,7 +27,7 @@
|
|
||||||
#define MPFR_VERSION_MAJOR 3
|
|
||||||
#define MPFR_VERSION_MINOR 1
|
|
||||||
#define MPFR_VERSION_PATCHLEVEL 5
|
|
||||||
-#define MPFR_VERSION_STRING "3.1.5"
|
|
||||||
+#define MPFR_VERSION_STRING "3.1.5-p1"
|
|
||||||
|
|
||||||
/* Macros dealing with MPFR VERSION */
|
|
||||||
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/vasprintf.c mpfr-3.1.5-b/src/vasprintf.c
|
|
||||||
--- mpfr-3.1.5-a/src/vasprintf.c 2016-09-27 07:58:15.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/vasprintf.c 2016-12-15 08:35:46.520430308 +0000
|
|
||||||
@@ -1593,7 +1593,7 @@
|
|
||||||
}
|
|
||||||
else if (spec.spec == 'f' || spec.spec == 'F')
|
|
||||||
{
|
|
||||||
- if (spec.prec == -1)
|
|
||||||
+ if (spec.prec < 0)
|
|
||||||
spec.prec = 6;
|
|
||||||
if (regular_fg (np, p, spec, NULL) == -1)
|
|
||||||
goto error;
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/version.c mpfr-3.1.5-b/src/version.c
|
|
||||||
--- mpfr-3.1.5-a/src/version.c 2016-09-27 07:58:15.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/version.c 2016-12-15 08:35:46.544430346 +0000
|
|
||||||
@@ -25,5 +25,5 @@
|
|
||||||
const char *
|
|
||||||
mpfr_get_version (void)
|
|
||||||
{
|
|
||||||
- return "3.1.5";
|
|
||||||
+ return "3.1.5-p1";
|
|
||||||
}
|
|
||||||
diff -Naurd mpfr-3.1.5-a/tests/tsprintf.c mpfr-3.1.5-b/tests/tsprintf.c
|
|
||||||
--- mpfr-3.1.5-a/tests/tsprintf.c 2016-09-27 07:58:14.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/tests/tsprintf.c 2016-12-15 08:35:46.520430308 +0000
|
|
||||||
@@ -1251,6 +1251,25 @@
|
|
||||||
check_emin_aux (MPFR_EMIN_MIN);
|
|
||||||
}
|
|
||||||
|
|
||||||
+static void
|
|
||||||
+test20161214 (void)
|
|
||||||
+{
|
|
||||||
+ mpfr_t x;
|
|
||||||
+ char buf[32];
|
|
||||||
+ const char s[] = "0x0.fffffffffffff8p+1024";
|
|
||||||
+ int r;
|
|
||||||
+
|
|
||||||
+ mpfr_init2 (x, 64);
|
|
||||||
+ mpfr_set_str (x, s, 16, MPFR_RNDN);
|
|
||||||
+ r = mpfr_snprintf (buf, 32, "%.*RDf", -2, x);
|
|
||||||
+ MPFR_ASSERTN(r == 316);
|
|
||||||
+ r = mpfr_snprintf (buf, 32, "%.*RDf", INT_MIN + 1, x);
|
|
||||||
+ MPFR_ASSERTN(r == 316);
|
|
||||||
+ r = mpfr_snprintf (buf, 32, "%.*RDf", INT_MIN, x);
|
|
||||||
+ MPFR_ASSERTN(r == 316);
|
|
||||||
+ mpfr_clear (x);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
int
|
|
||||||
main (int argc, char **argv)
|
|
||||||
{
|
|
||||||
@@ -1271,6 +1290,7 @@
|
|
||||||
mixed ();
|
|
||||||
check_emax ();
|
|
||||||
check_emin ();
|
|
||||||
+ test20161214 ();
|
|
||||||
|
|
||||||
#if defined(HAVE_LOCALE_H) && defined(HAVE_SETLOCALE)
|
|
||||||
#if MPFR_LCONV_DPTS
|
|
||||||
diff -Naurd mpfr-3.1.5-a/PATCHES mpfr-3.1.5-b/PATCHES
|
|
||||||
--- mpfr-3.1.5-a/PATCHES 2016-12-19 22:11:17.022676737 +0000
|
|
||||||
+++ mpfr-3.1.5-b/PATCHES 2016-12-19 22:11:17.094676820 +0000
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+strtofr
|
|
||||||
diff -Naurd mpfr-3.1.5-a/VERSION mpfr-3.1.5-b/VERSION
|
|
||||||
--- mpfr-3.1.5-a/VERSION 2016-12-15 08:35:46.544430346 +0000
|
|
||||||
+++ mpfr-3.1.5-b/VERSION 2016-12-19 22:11:17.094676820 +0000
|
|
||||||
@@ -1 +1 @@
|
|
||||||
-3.1.5-p1
|
|
||||||
+3.1.5-p2
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/mpfr.h mpfr-3.1.5-b/src/mpfr.h
|
|
||||||
--- mpfr-3.1.5-a/src/mpfr.h 2016-12-15 08:35:46.540430340 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/mpfr.h 2016-12-19 22:11:17.090676815 +0000
|
|
||||||
@@ -27,7 +27,7 @@
|
|
||||||
#define MPFR_VERSION_MAJOR 3
|
|
||||||
#define MPFR_VERSION_MINOR 1
|
|
||||||
#define MPFR_VERSION_PATCHLEVEL 5
|
|
||||||
-#define MPFR_VERSION_STRING "3.1.5-p1"
|
|
||||||
+#define MPFR_VERSION_STRING "3.1.5-p2"
|
|
||||||
|
|
||||||
/* Macros dealing with MPFR VERSION */
|
|
||||||
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/strtofr.c mpfr-3.1.5-b/src/strtofr.c
|
|
||||||
--- mpfr-3.1.5-a/src/strtofr.c 2016-09-27 07:58:15.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/strtofr.c 2016-12-19 22:11:17.066676788 +0000
|
|
||||||
@@ -743,11 +743,14 @@
|
|
||||||
of the pstr_size most significant digits of pstr->mant, with
|
|
||||||
equality in case exact is non-zero. */
|
|
||||||
|
|
||||||
- /* test if rounding is possible, and if so exit the loop */
|
|
||||||
- if (exact || mpfr_can_round_raw (result, ysize,
|
|
||||||
- (pstr->negative) ? -1 : 1,
|
|
||||||
- ysize_bits - err - 1,
|
|
||||||
- MPFR_RNDN, rnd, MPFR_PREC(x)))
|
|
||||||
+ /* test if rounding is possible, and if so exit the loop.
|
|
||||||
+ Note: we also need to be able to determine the correct ternary value,
|
|
||||||
+ thus we use the MPFR_PREC(x) + (rnd == MPFR_RNDN) trick.
|
|
||||||
+ For example if result = xxx...xxx111...111 and rnd = RNDN,
|
|
||||||
+ then we know the correct rounding is xxx...xx(x+1), but we cannot know
|
|
||||||
+ the correct ternary value. */
|
|
||||||
+ if (exact || mpfr_round_p (result, ysize, ysize_bits - err - 1,
|
|
||||||
+ MPFR_PREC(x) + (rnd == MPFR_RNDN)))
|
|
||||||
break;
|
|
||||||
|
|
||||||
next_loop:
|
|
||||||
diff -Naurd mpfr-3.1.5-a/src/version.c mpfr-3.1.5-b/src/version.c
|
|
||||||
--- mpfr-3.1.5-a/src/version.c 2016-12-15 08:35:46.544430346 +0000
|
|
||||||
+++ mpfr-3.1.5-b/src/version.c 2016-12-19 22:11:17.094676820 +0000
|
|
||||||
@@ -25,5 +25,5 @@
|
|
||||||
const char *
|
|
||||||
mpfr_get_version (void)
|
|
||||||
{
|
|
||||||
- return "3.1.5-p1";
|
|
||||||
+ return "3.1.5-p2";
|
|
||||||
}
|
|
||||||
diff -Naurd mpfr-3.1.5-a/tests/tstrtofr.c mpfr-3.1.5-b/tests/tstrtofr.c
|
|
||||||
--- mpfr-3.1.5-a/tests/tstrtofr.c 2016-09-27 07:58:14.000000000 +0000
|
|
||||||
+++ mpfr-3.1.5-b/tests/tstrtofr.c 2016-12-19 22:11:17.066676788 +0000
|
|
||||||
@@ -1191,6 +1191,24 @@
|
|
||||||
mpfr_clears (e, x1, x2, (mpfr_ptr) 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
+/* Note: the number is 5^47/2^9. */
|
|
||||||
+static void
|
|
||||||
+bug20161217 (void)
|
|
||||||
+{
|
|
||||||
+ mpfr_t fp, z;
|
|
||||||
+ static const char * num = "0.1387778780781445675529539585113525390625e31";
|
|
||||||
+ int inex;
|
|
||||||
+
|
|
||||||
+ mpfr_init2 (fp, 110);
|
|
||||||
+ mpfr_init2 (z, 110);
|
|
||||||
+ inex = mpfr_strtofr (fp, num, NULL, 10, MPFR_RNDN);
|
|
||||||
+ MPFR_ASSERTN(inex == 0);
|
|
||||||
+ mpfr_set_str_binary (z, "10001100001000010011110110011101101001010000001011011110010001010100010100100110111101000010001011001100001101E-9");
|
|
||||||
+ MPFR_ASSERTN(mpfr_equal_p (fp, z));
|
|
||||||
+ mpfr_clear (fp);
|
|
||||||
+ mpfr_clear (z);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
int
|
|
||||||
main (int argc, char *argv[])
|
|
||||||
{
|
|
||||||
@@ -1205,6 +1223,7 @@
|
|
||||||
test20100310 ();
|
|
||||||
bug20120814 ();
|
|
||||||
bug20120829 ();
|
|
||||||
+ bug20161217 ();
|
|
||||||
|
|
||||||
tests_end_mpfr ();
|
|
||||||
return 0;
|
|
0
libmpfr-4.0.1-patchset.patch
Normal file
0
libmpfr-4.0.1-patchset.patch
Normal file
@ -1,6 +1,6 @@
|
|||||||
%define pkgver %(echo %version | cut -d. -f1-3)
|
%define pkgver %(echo %version | cut -d. -f1-3)
|
||||||
Name: libmpfr
|
Name: libmpfr
|
||||||
Version: 3.1.5.p2
|
Version: 4.0.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A C library for multiple-precision floating-point computations with exact rounding
|
Summary: A C library for multiple-precision floating-point computations with exact rounding
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -78,9 +78,16 @@ exit 0
|
|||||||
%{_infodir}/mpfr.info.*
|
%{_infodir}/mpfr.info.*
|
||||||
%dir %{_docdir}/mpfr
|
%dir %{_docdir}/mpfr
|
||||||
%{_docdir}/mpfr
|
%{_docdir}/mpfr
|
||||||
|
%{_libdir}/pkgconfig/mpfr.pc
|
||||||
%doc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
|
%doc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 18 2018 Automatic Build System <autodist@mambasoft.it> 4.0.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Automatic Build System <autodist@mambasoft.it> 4.0.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Jan 09 2017 Automatic Build System <autodist@mambasoft.it> 3.1.5.p2-1mamba
|
* Mon Jan 09 2017 Automatic Build System <autodist@mambasoft.it> 3.1.5.p2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user