created mpeg3-tools subpackage [release 1.8-2mamba;Fri Mar 18 2011]
This commit is contained in:
parent
b5ef1af042
commit
9877643bb7
10
README.md
10
README.md
@ -1,2 +1,12 @@
|
|||||||
# libmpeg3
|
# libmpeg3
|
||||||
|
|
||||||
|
LibMPEG3 decodes the many many derivatives of MPEG standards into uncompressed data suitable for editing and playback.
|
||||||
|
|
||||||
|
libmpeg3 currently decodes:
|
||||||
|
* MPEG-1 Layer II/III Audio and program streams
|
||||||
|
* MPEG-2 Layer III Audio, program streams and transport streams
|
||||||
|
* MPEG-1 and MPEG-2 Video
|
||||||
|
* AC3 Audio
|
||||||
|
* IFO files
|
||||||
|
* VOB files
|
||||||
|
|
||||||
|
33
libmpeg3-1.8-Makefile.patch
Normal file
33
libmpeg3-1.8-Makefile.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
--- libmpeg3-1.8/Makefile 2008-08-07 04:33:09.000000000 +0100
|
||||||
|
+++ libmpeg3-1.8-patched/Makefile 2009-07-15 21:59:27.726173705 +0100
|
||||||
|
@@ -1,13 +1,10 @@
|
||||||
|
CC = gcc
|
||||||
|
NASM = nasm
|
||||||
|
+VERSION_NAME := $(shell basename $(PWD))
|
||||||
|
USE_MMX = 0
|
||||||
|
USE_CSS = 1
|
||||||
|
A52DIR := $(shell expr a52dec* )
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-ifeq ("$(DST)", "")
|
||||||
|
-DST=/usr/bin
|
||||||
|
-endif
|
||||||
|
+PREFIX=/usr
|
||||||
|
|
||||||
|
ifeq ($(origin CFLAGS), environment)
|
||||||
|
HAVE_CFLAGS := y
|
||||||
|
@@ -191,7 +188,13 @@
|
||||||
|
-ldl
|
||||||
|
|
||||||
|
install:
|
||||||
|
- cp $(UTILS) $(DST)
|
||||||
|
+ if [ ! -d $(DESTDIR)$(PREFIX)/bin ]; then install -v -m 755 -d $(DESTDIR)$(PREFIX)/bin; fi
|
||||||
|
+ if [ ! -d $(DESTDIR)$(PREFIX)/lib ]; then install -v -m 755 -d $(DESTDIR)$(PREFIX)/lib; fi
|
||||||
|
+ if [ ! -d $(DESTDIR)$(PREFIX)/include ]; then install -v -m 755 -d $(DESTDIR)$(PREFIX)/include; fi
|
||||||
|
+ install -v -m 755 -t $(DESTDIR)$(PREFIX)/bin $(UTILS)
|
||||||
|
+ install -v -m 644 -t $(DESTDIR)$(PREFIX)/lib $(OUTPUT)
|
||||||
|
+ install -v -m 644 -t $(DESTDIR)$(PREFIX)/include libmpeg3.h mpeg3private.h mpeg3protos.h
|
||||||
|
+ install -v -m 644 -D docs/index.html $(DESTDIR)$(PREFIX)/share/doc/$(VERSION_NAME)/index.html
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -rf $(OBJDIR)
|
121
libmpeg3.spec
Normal file
121
libmpeg3.spec
Normal file
@ -0,0 +1,121 @@
|
|||||||
|
Name: libmpeg3
|
||||||
|
Version: 1.8
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Decoder of various derivatives of MPEG standards
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://heroinewarrior.com/libmpeg3.php3
|
||||||
|
Source: http://dl.sf.net/heroines/libmpeg3-%{version}-src.tar.bz2
|
||||||
|
Patch0: %{name}-1.8-Makefile.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: nasm
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
LibMPEG3 decodes the many many derivatives of MPEG standards into uncompressed data suitable for editing and playback.
|
||||||
|
|
||||||
|
libmpeg3 currently decodes:
|
||||||
|
* MPEG-1 Layer II/III Audio and program streams
|
||||||
|
* MPEG-2 Layer III Audio, program streams and transport streams
|
||||||
|
* MPEG-1 and MPEG-2 Video
|
||||||
|
* AC3 Audio
|
||||||
|
* IFO files
|
||||||
|
* VOB files
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Decoder of various derivatives of MPEG standards
|
||||||
|
Group: Development/Libraries
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
LibMPEG3 decodes the many many derivatives of MPEG standards into uncompressed data suitable for editing and playback.
|
||||||
|
|
||||||
|
libmpeg3 currently decodes:
|
||||||
|
* MPEG-1 Layer II/III Audio and program streams
|
||||||
|
* MPEG-2 Layer III Audio, program streams and transport streams
|
||||||
|
* MPEG-1 and MPEG-2 Video
|
||||||
|
* AC3 Audio
|
||||||
|
* IFO files
|
||||||
|
* VOB files
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n mpeg3-tools
|
||||||
|
Summary: mpeg3dump, mpeg3cat and mpeg3toc tools provided by libmpeg3
|
||||||
|
Group: System/Tools
|
||||||
|
|
||||||
|
%description -n mpeg3-tools
|
||||||
|
LibMPEG3 decodes the many many derivatives of MPEG standards into uncompressed data suitable for editing and playback.
|
||||||
|
|
||||||
|
libmpeg3 currently decodes:
|
||||||
|
* MPEG-1 Layer II/III Audio and program streams
|
||||||
|
* MPEG-2 Layer III Audio, program streams and transport streams
|
||||||
|
* MPEG-1 and MPEG-2 Video
|
||||||
|
* AC3 Audio
|
||||||
|
* IFO files
|
||||||
|
* VOB files
|
||||||
|
|
||||||
|
This package contains the mpeg3dump, mpeg3cat and mpeg3toc tools.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
#%{__perl} -pi.orig -e '
|
||||||
|
# s| /usr/bin$| \$(DESTDIR)\$(bindir)|;
|
||||||
|
# ' Makefile
|
||||||
|
echo "#define __USE_LARGEFILE64" >> mpeg3private.h
|
||||||
|
mkdir i686
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make \
|
||||||
|
USE_MMX=0
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
%ifarch x86_64
|
||||||
|
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
|
||||||
|
%endif
|
||||||
|
rm -f %{buildroot}%{_docdir}/%{name}-%{version}/index.html
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-, root, root, 0755)
|
||||||
|
%{_libdir}/libmpeg3.a
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%doc COPYING docs/
|
||||||
|
|
||||||
|
%files -n mpeg3-tools
|
||||||
|
%defattr(-, root, root, 0755)
|
||||||
|
%{_bindir}/mpeg3cat
|
||||||
|
%{_bindir}/mpeg3dump
|
||||||
|
%{_bindir}/mpeg3peek
|
||||||
|
%{_bindir}/mpeg3toc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 18 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8-2mamba
|
||||||
|
- created mpeg3-tools subpackage
|
||||||
|
|
||||||
|
* Tue Jan 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon May 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7-1mamba
|
||||||
|
- update to 1.7
|
||||||
|
|
||||||
|
* Fri Jun 30 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.6-1qilnx
|
||||||
|
- update to version 1.6 by autospec
|
||||||
|
|
||||||
|
* Fri Oct 8 2004 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.5.4-1
|
||||||
|
- rebuilt and moved from devel-contrib to devel branch
|
||||||
|
|
||||||
|
* Fri Sep 10 2004 Matteo Bernasconi <> 1.5.4-1
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user