rebuilt with debug package [release 0.5.1-2mamba;Mon Dec 14 2020]
This commit is contained in:
parent
6cd31dd58a
commit
39f10945d0
35
libmpeg2-0.5.1-arm-disable-asm.patch
Normal file
35
libmpeg2-0.5.1-arm-disable-asm.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -59,7 +59,7 @@
|
||||||
|
AC_TRY_CFLAGS([$TRY_CFLAGS $CFLAGS],[OPT_CFLAGS="$TRY_CFLAGS"])
|
||||||
|
|
||||||
|
dnl arch-specific flags
|
||||||
|
- arm_conditional=false
|
||||||
|
+ build_arm_opt=false
|
||||||
|
case "$host" in
|
||||||
|
i?86-* | k?-* | x86_64-* | amd64-*)
|
||||||
|
AC_DEFINE([ARCH_X86],,[x86 architecture])
|
||||||
|
@@ -102,8 +102,12 @@
|
||||||
|
alpha*)
|
||||||
|
AC_DEFINE([ARCH_ALPHA],,[alpha architecture]);;
|
||||||
|
arm*)
|
||||||
|
- arm_conditional=:
|
||||||
|
- AC_DEFINE([ARCH_ARM],,[ARM architecture]);;
|
||||||
|
+ AC_LANG(C)
|
||||||
|
+ AC_COMPILE_IFELSE(
|
||||||
|
+ [AC_LANG_SOURCE([[
|
||||||
|
+ void foo(void) { __asm__ volatile("pld [r1]"); }]])],
|
||||||
|
+ build_arm_opt=true; AC_DEFINE([ARCH_ARM],,[ARM architecture]),
|
||||||
|
+ build_arm_opt=false);;
|
||||||
|
esac
|
||||||
|
elif test x"$CC" = x"tendracc"; then
|
||||||
|
dnl TenDRA portability checking compiler
|
||||||
|
@@ -123,7 +127,7 @@
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
|
||||||
|
-AM_CONDITIONAL(ARCH_ARM, ${arm_conditional})
|
||||||
|
+AM_CONDITIONAL(ARCH_ARM, test x$build_arm_opt = xtrue)
|
||||||
|
|
||||||
|
dnl Checks for libtool - this must be done after we set cflags
|
||||||
|
AC_LIBTOOL_WIN32_DLL
|
@ -1,6 +1,6 @@
|
|||||||
Name: libmpeg2
|
Name: libmpeg2
|
||||||
Version: 0.5.1
|
Version: 0.5.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: MPEG-2 and MPEG-1 decoding library and test program
|
Summary: MPEG-2 and MPEG-1 decoding library and test program
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://libmpeg2.sourceforge.net/
|
URL: http://libmpeg2.sourceforge.net/
|
||||||
Source: http://libmpeg2.sourceforge.net/files/libmpeg2-%{version}.tar.gz
|
Source: http://libmpeg2.sourceforge.net/files/libmpeg2-%{version}.tar.gz
|
||||||
|
Patch0: libmpeg2-0.5.1-arm-disable-asm.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -33,9 +34,7 @@ Obsoletes: mpeg2dec-devel
|
|||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
A free library for decoding MPEG-2 and MPEG-1 video streams.
|
A free library for decoding MPEG-2 and MPEG-1 video streams.
|
||||||
|
This package contains files needed to build applications that use mpeg2dec's libmpeg2.
|
||||||
This package contains files needed to build applications that use mpeg2dec's
|
|
||||||
libmpeg2.
|
|
||||||
|
|
||||||
%package -n mpeg2dec
|
%package -n mpeg2dec
|
||||||
Summary: A tool for decoding MPEG-2 and MPEG-1 video streams.
|
Summary: A tool for decoding MPEG-2 and MPEG-1 video streams.
|
||||||
@ -45,11 +44,17 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
%description -n mpeg2dec
|
%description -n mpeg2dec
|
||||||
A tool for decoding MPEG-2 and MPEG-1 video streams.
|
A tool for decoding MPEG-2 and MPEG-1 video streams.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," .auto/config.sub
|
||||||
|
%ifarch arm
|
||||||
|
%patch0 -p1
|
||||||
|
./bootstrap
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#./bootstrap
|
|
||||||
%configure --enable-shared
|
%configure --enable-shared
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -65,16 +70,20 @@ A tool for decoding MPEG-2 and MPEG-1 video streams.
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/libmpeg2.so.*
|
||||||
|
%{_libdir}/libmpeg2convert.so.*
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%dir %{_includedir}/mpeg2dec/
|
%dir %{_includedir}/mpeg2dec/
|
||||||
%{_includedir}/mpeg2dec/*.h
|
%{_includedir}/mpeg2dec/*.h
|
||||||
%{_libdir}/*.a
|
%{_libdir}/libmpeg2.a
|
||||||
%{_libdir}/*.la
|
%{_libdir}/libmpeg2.la
|
||||||
%{_libdir}/*.so
|
%{_libdir}/libmpeg2.so
|
||||||
|
%{_libdir}/libmpeg2convert.a
|
||||||
|
%{_libdir}/libmpeg2convert.la
|
||||||
|
%{_libdir}/libmpeg2convert.so
|
||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
%doc doc/*.txt doc/*.c
|
%doc doc/*.txt doc/*.c
|
||||||
%doc NEWS README TODO
|
%doc NEWS README TODO
|
||||||
@ -85,6 +94,9 @@ A tool for decoding MPEG-2 and MPEG-1 video streams.
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-2mamba
|
||||||
|
- rebuilt with debug package
|
||||||
|
|
||||||
* Sun Nov 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
* Sun Nov 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||||
- update to 0.5.1
|
- update to 0.5.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user