automatic version update by autodist [release 1.0.2-1mamba;Mon Jan 27 2014]
This commit is contained in:
parent
a3c88a0950
commit
0b7dd78efb
@ -1,2 +1,4 @@
|
|||||||
# libmpc
|
# libmpc
|
||||||
|
|
||||||
|
Mpc is a C library for the arithmetic of complex numbers with arbitrarily high precision and correct rounding of the result.
|
||||||
|
|
||||||
|
13
libmpc-0.8.1-gmp501.patch
Normal file
13
libmpc-0.8.1-gmp501.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -Nru mpc-0.8.1.orig//src/acos.c mpc-0.8.1/src/acos.c
|
||||||
|
--- mpc-0.8.1.orig//src/acos.c 2009-11-02 12:21:53.000000000 +0100
|
||||||
|
+++ mpc-0.8.1/src/acos.c 2010-07-15 15:54:29.656017924 +0200
|
||||||
|
@@ -188,9 +188,6 @@
|
||||||
|
else
|
||||||
|
rnd_im = rnd_im == GMP_RNDU ? GMP_RNDD
|
||||||
|
: rnd_im == GMP_RNDD ? GMP_RNDU
|
||||||
|
-#if MPFR_VERSION_MAJOR >= 3
|
||||||
|
- : rnd_im == GMP_RNDA ? GMP_RNDZ
|
||||||
|
-#endif
|
||||||
|
: rnd_im;
|
||||||
|
rnd1 = RNDC(GMP_RNDN, rnd_im);
|
||||||
|
mpfr_init2 (pi_over_2, p);
|
88
libmpc.spec
Normal file
88
libmpc.spec
Normal file
@ -0,0 +1,88 @@
|
|||||||
|
Name: libmpc
|
||||||
|
Version: 1.0.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A C library for the arithmetic of complex numbers
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.multiprecision.org/
|
||||||
|
Source: http://www.multiprecision.org/mpc/download/mpc-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.8.1-gmp501.patch
|
||||||
|
License: LGPL
|
||||||
|
Requires(post):%{__install_info}
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
BuildRequires: libmpfr-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Mpc is a C library for the arithmetic of complex numbers with arbitrarily high precision and correct rounding of the result.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Mpc is a C library for the arithmetic of complex numbers with arbitrarily high precision and correct rounding of the result.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n mpc-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
%install_info mpc.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%uninstall_info mpc.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libmpc.so.*
|
||||||
|
%{_infodir}/mpc.info.gz
|
||||||
|
%doc AUTHORS COPYING.LESSER
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libmpc.a
|
||||||
|
%{_libdir}/libmpc.la
|
||||||
|
%{_libdir}/libmpc.so
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%doc NEWS README TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 27 2014 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 03 2012 Automatic Build System <autodist@mambasoft.it> 1.0.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 15 2010 Automatic Build System <autodist@mambasoft.it> 0.8.1-4mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Thu Jul 15 2010 Automatic Build System <autodist@mambasoft.it> 0.8.1-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Jul 12 2010 Automatic Build System <autodist@mambasoft.it> 0.8.1-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sat May 08 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user