rebuilt with patch for glib 2.32 [release 1.0.2-3mamba;Sat Apr 07 2012]
This commit is contained in:
parent
a811064181
commit
1d04be2c8a
@ -1,2 +1,5 @@
|
||||
# libmeanwhile
|
||||
|
||||
Meanwhile is a library for connecting to a LIM (Lotus Instant Messaging, formerly Lotus Sametime, formerly VPBuddy) community.
|
||||
It uses a protocol based in part off of the IMPP draft(*1), and in part off of traces of TCP sessions from existing clients.
|
||||
|
||||
|
282
libmeanwhile-1.0.2-glib-2.32.patch
Normal file
282
libmeanwhile-1.0.2-glib-2.32.patch
Normal file
@ -0,0 +1,282 @@
|
||||
Description: Fix build failure with glib 2.32
|
||||
where including individual glib headers is no longer allowed.
|
||||
Author: Michael Biebl <biebl@debian.org>
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665579
|
||||
Index: meanwhile-1.0.2/samples/logging_proxy.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/samples/logging_proxy.c 2005-12-05 01:51:58.000000000 +0100
|
||||
+++ meanwhile-1.0.2/samples/logging_proxy.c 2012-03-25 19:00:37.446281908 +0200
|
||||
@@ -25,7 +25,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <mw_cipher.h>
|
||||
#include <mw_common.h>
|
||||
Index: meanwhile-1.0.2/samples/login_server.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/samples/login_server.c 2005-12-05 02:02:24.000000000 +0100
|
||||
+++ meanwhile-1.0.2/samples/login_server.c 2012-03-25 19:00:37.714281899 +0200
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <mw_cipher.h>
|
||||
#include <mw_common.h>
|
||||
Index: meanwhile-1.0.2/samples/nocipher_proxy.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/samples/nocipher_proxy.c 2005-12-05 02:05:58.000000000 +0100
|
||||
+++ meanwhile-1.0.2/samples/nocipher_proxy.c 2012-03-25 19:00:37.534281905 +0200
|
||||
@@ -29,7 +29,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <mw_common.h>
|
||||
#include <mw_message.h>
|
||||
Index: meanwhile-1.0.2/samples/redirect_server.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/samples/redirect_server.c 2005-12-05 02:08:25.000000000 +0100
|
||||
+++ meanwhile-1.0.2/samples/redirect_server.c 2012-03-25 19:00:37.626281902 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <mw_common.h>
|
||||
#include <mw_message.h>
|
||||
Index: meanwhile-1.0.2/src/channel.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/channel.c 2005-12-08 23:04:46.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/channel.c 2012-03-25 19:00:39.302281842 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
*/
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/ghash.h>
|
||||
-#include <glib/glist.h>
|
||||
#include <string.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
Index: meanwhile-1.0.2/src/mw_debug.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_debug.c 2005-12-03 04:46:10.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_debug.c 2012-03-25 19:00:38.078281886 +0200
|
||||
@@ -19,7 +19,7 @@
|
||||
*/
|
||||
|
||||
|
||||
-#include <glib/gstring.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_debug.h"
|
||||
|
||||
Index: meanwhile-1.0.2/src/mw_message.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_message.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_message.h 2012-03-25 19:00:39.094281850 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
#define _MW_MESSAGE_H
|
||||
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
#include "mw_common.h"
|
||||
|
||||
|
||||
Index: meanwhile-1.0.2/src/mw_srvc_conf.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_srvc_conf.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_srvc_conf.h 2012-03-25 19:00:37.910281892 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
#define _MW_SRVC_CONF_H
|
||||
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
#include "mw_common.h"
|
||||
|
||||
|
||||
Index: meanwhile-1.0.2/src/mw_srvc_dir.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_srvc_dir.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_srvc_dir.h 2012-03-25 19:00:38.550281869 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
|
||||
#ifdef __cplusplus
|
||||
Index: meanwhile-1.0.2/src/mw_srvc_place.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_srvc_place.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_srvc_place.h 2012-03-25 19:00:38.162281883 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
#define _MW_SRVC_PLACE_H
|
||||
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
#include "mw_common.h"
|
||||
|
||||
|
||||
Index: meanwhile-1.0.2/src/mw_srvc_resolve.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_srvc_resolve.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_srvc_resolve.h 2012-03-25 19:00:37.994281889 +0200
|
||||
@@ -23,7 +23,6 @@
|
||||
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
|
||||
#ifdef __cplusplus
|
||||
Index: meanwhile-1.0.2/src/mw_st_list.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_st_list.h 2005-12-15 01:30:28.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_st_list.h 2012-03-25 19:00:39.370281840 +0200
|
||||
@@ -30,7 +30,6 @@
|
||||
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
#include "mw_common.h"
|
||||
|
||||
|
||||
Index: meanwhile-1.0.2/src/mw_util.h
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/mw_util.h 2004-12-28 21:41:26.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/mw_util.h 2012-03-25 19:00:38.826281859 +0200
|
||||
@@ -23,8 +23,6 @@
|
||||
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/ghash.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
|
||||
#define map_guint_new() \
|
||||
Index: meanwhile-1.0.2/src/srvc_aware.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_aware.c 2005-12-08 23:02:11.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/srvc_aware.c 2012-03-25 19:00:38.742281862 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
*/
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/ghash.h>
|
||||
-#include <glib/glist.h>
|
||||
#include <string.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
Index: meanwhile-1.0.2/src/srvc_conf.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_conf.c 2005-12-28 03:46:54.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/srvc_conf.c 2012-03-25 19:00:37.826281895 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
*/
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/ghash.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
Index: meanwhile-1.0.2/src/srvc_dir.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_dir.c 2005-09-15 22:30:20.000000000 +0200
|
||||
+++ meanwhile-1.0.2/src/srvc_dir.c 2012-03-25 19:00:38.918281856 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
-#include <glib/ghash.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
#include "mw_common.h"
|
||||
Index: meanwhile-1.0.2/src/srvc_ft.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_ft.c 2005-09-15 22:30:37.000000000 +0200
|
||||
+++ meanwhile-1.0.2/src/srvc_ft.c 2012-03-25 19:00:39.010281853 +0200
|
||||
@@ -19,7 +19,7 @@
|
||||
*/
|
||||
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
#include "mw_common.h"
|
||||
Index: meanwhile-1.0.2/src/srvc_im.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_im.c 2005-12-28 03:46:54.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/srvc_im.c 2012-03-25 19:00:38.354281876 +0200
|
||||
@@ -19,7 +19,6 @@
|
||||
*/
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/glist.h>
|
||||
#include <string.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
Index: meanwhile-1.0.2/src/srvc_place.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_place.c 2005-12-03 03:00:29.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/srvc_place.c 2012-03-25 19:00:38.466281872 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
*/
|
||||
|
||||
#include <glib.h>
|
||||
-#include <glib/ghash.h>
|
||||
-#include <glib/glist.h>
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
Index: meanwhile-1.0.2/src/srvc_resolve.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_resolve.c 2005-10-27 02:10:06.000000000 +0200
|
||||
+++ meanwhile-1.0.2/src/srvc_resolve.c 2012-03-25 19:00:38.254281879 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
-#include <glib/ghash.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
#include "mw_common.h"
|
||||
Index: meanwhile-1.0.2/src/srvc_store.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/srvc_store.c 2005-11-19 02:52:42.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/srvc_store.c 2012-03-25 19:00:38.642281866 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_channel.h"
|
||||
#include "mw_debug.h"
|
||||
Index: meanwhile-1.0.2/src/st_list.c
|
||||
===================================================================
|
||||
--- meanwhile-1.0.2.orig/src/st_list.c 2005-12-08 23:01:27.000000000 +0100
|
||||
+++ meanwhile-1.0.2/src/st_list.c 2012-03-25 19:00:39.186281847 +0200
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
-#include <glib/gstring.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "mw_debug.h"
|
||||
#include "mw_util.h"
|
101
libmeanwhile.spec
Normal file
101
libmeanwhile.spec
Normal file
@ -0,0 +1,101 @@
|
||||
Name: libmeanwhile
|
||||
Version: 1.0.2
|
||||
Release: 3mamba
|
||||
Summary: An open implementation of the Lotus Sametime Community Client protocol
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://meanwhile.sourceforge.net/
|
||||
Source: http://switch.dl.sourceforge.net/sourceforge/meanwhile/meanwhile-%{version}.tar.gz
|
||||
Patch0: libmeanwhile-1.0.2-glib-2.32.patch
|
||||
License: LGPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libselinux-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: doxygen
|
||||
|
||||
%description
|
||||
Meanwhile is a library for connecting to a LIM (Lotus Instant Messaging, formerly Lotus Sametime, formerly VPBuddy) community.
|
||||
It uses a protocol based in part off of the IMPP draft(*1), and in part off of traces of TCP sessions from existing clients.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Meanwhile is a library for connecting to a LIM (Lotus Instant Messaging, formerly Lotus Sametime, formerly VPBuddy) community.
|
||||
It uses a protocol based in part off of the IMPP draft(*1), and in part off of traces of TCP sessions from existing clients.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package apidocs
|
||||
Summary: Meanwhile library API documentation
|
||||
Group: Documentation
|
||||
Requires: gtk-doc
|
||||
|
||||
%description apidocs
|
||||
Meanwhile library API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n meanwhile-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
doxygen -u -s doc/Doxyfile
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/meanwhile
|
||||
%{_includedir}/meanwhile/*.h
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog README TODO
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/doc/meanwhile-doc-%{version}/
|
||||
|
||||
%changelog
|
||||
* Sat Apr 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-3mamba
|
||||
- rebuilt with patch for glib 2.32
|
||||
|
||||
* Thu Jun 26 2008 Tiziana Ferro <tiziana.ferro@email.it> 1.0.2-2mamba
|
||||
- update Vendor, Distribution, mantainer
|
||||
- format description
|
||||
- update docs list with doxygen
|
||||
|
||||
* Wed Jan 31 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.2-1qilnx
|
||||
- update to version 1.0.2 by autospec
|
||||
|
||||
* Thu Aug 25 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.2-1qilnx
|
||||
- update to version 0.4.2 by autospec
|
||||
|
||||
* Thu May 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.1-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user