legacy package [release 2.0.3-2mamba;Sun Jan 22 2023]

This commit is contained in:
Silvan Calarco 2024-01-06 05:02:29 +01:00
parent 8ac74a0adf
commit a2faac6e47
3 changed files with 201 additions and 0 deletions

View File

@ -1,2 +1,12 @@
# libmdds20
This library provides a collection of multi-dimensional data structure and indexing algorithm.
All data structures are available as C++ templates, hence this is a header-only library, with no shared library to link against.
It implements the following data structures:
* segment tree
* flat segment tree
* rectangle set
* point quad tree
* mixed type matrix

View File

@ -0,0 +1,15 @@
diff --git a/include/mdds/mixed_type_matrix_storage.hpp b/include/mdds/mixed_type_matrix_storage.hpp
index fa0bf25..bb4e354 100644
--- a/include/mdds/mixed_type_matrix_storage.hpp
+++ misc/build/mdds_0.6.0/include/mdds/mixed_type_matrix_storage.hpp
@@ -32,6 +32,10 @@
#include <boost/ptr_container/ptr_vector.hpp>
#include <boost/ptr_container/ptr_map.hpp>
+// Boost.Pool indirectly pulls in Boost.System, causing linking error
+// with Boost 1.50, because some (deprecated) symbols from System are
+// not found.
+#define BOOST_SYSTEM_NO_DEPRECATED
#include <boost/pool/object_pool.hpp>
namespace mdds {

176
libmdds20.spec Normal file
View File

@ -0,0 +1,176 @@
%define with_mem_tests 0
%define with_perf_tests 0
%define apiver %(echo %version|cut -d. -f1-2)
Name: libmdds20
Version: 2.0.3
Release: 2mamba
Summary: A collection of multi-dimensional data structure and indexing algorithm (mdds)
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://code.google.com/archive/p/multidimalgorithm
Source: https://gitlab.com/mdds/mdds.git/%{version}/mdds-%{version}.tar.bz2
Patch0: libmdds-0.5.3-boost-1.50.patch
License: MIT
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
BuildRequires: libboost-devel
%if %with_mem_tests
BuildRequires: valgrind
BuildRequires: gdb
%endif
%description
This library provides a collection of multi-dimensional data structure and indexing algorithm.
All data structures are available as C++ templates, hence this is a header-only library, with no shared library to link against.
It implements the following data structures:
* segment tree
* flat segment tree
* rectangle set
* point quad tree
* mixed type matrix
%package devel
Group: Development/Libraries
Summary: Headers for %{name}
%description devel
A collection of multi-dimensional data structure and indexing algorithm (mdds).
This package contains header files needed for %{name}.
%prep
%setup -q -n mdds-%{version}
#%patch0 -p1
#sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{optflags} -std/' Makefile.in
./autogen.sh
%build
%configure \
--docdir=%{_docdir}/%{name}-%{version}
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -rf %{buildroot}%{_docdir}
%check
%ifnarch %{ix86} aarch64
%make check
%endif
#for test in fst pqt recset st; do
# make test.$test
#done
#%if %with_perf_tests
# for t in recset st; do
# make test.$t.perf
# done
# make test.stl
#%endif
#%if %with_mem_tests
# for t in fst pqt recset st; do
# make test.$t.mem
# done
#%endif
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files devel
%defattr(-,root,root)
%dir %{_includedir}/mdds-%{apiver}
%dir %{_includedir}/mdds-%{apiver}/mdds
%{_includedir}/mdds-%{apiver}/mdds/*
%{_datadir}/pkgconfig/mdds-%{apiver}.pc
%doc AUTHORS
%changelog
* Sun Jan 22 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.3-2mamba
- legacy package
* Thu May 12 2022 Automatic Build System <autodist@mambasoft.it> 2.0.3-1mamba
- automatic version update by autodist
* Wed Feb 16 2022 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
- automatic version update by autodist
* Thu Jan 13 2022 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
- automatic version update by autodist
* Wed Nov 04 2020 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
- automatic version update by autodist
* Wed Sep 02 2020 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba
- automatic version update by autodist
* Fri Jan 31 2020 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
- automatic version update by autodist
* Mon Dec 10 2018 Automatic Build System <autodist@mambasoft.it> 1.4.3-1mamba
- automatic version update by autodist
* Sat Jan 06 2018 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
- automatic version update by autodist
* Mon Aug 07 2017 Automatic Build System <autodist@mambasoft.it> 1.2.3-1mamba
- automatic version update by autodist
* Mon Sep 12 2016 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
- automatic version update by autodist
* Sat Jun 25 2016 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
- automatic version update by autodist
* Fri May 20 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-1mamba
- update to 1.2.0
* Thu Dec 03 2015 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
- automatic version update by autodist
* Sat Jun 20 2015 Automatic Build System <autodist@mambasoft.it> 0.12.1-1mamba
- automatic version update by autodist
* Sat Feb 07 2015 Automatic Build System <autodist@mambasoft.it> 0.12.0-1mamba
- automatic version update by autodist
* Mon Dec 22 2014 Automatic Build System <autodist@mambasoft.it> 0.11.2-1mamba
- automatic version update by autodist
* Sat Oct 04 2014 Automatic Build System <autodist@mambasoft.it> 0.11.1-1mamba
- automatic version update by autodist
* Sat Sep 20 2014 Automatic Build System <autodist@mambasoft.it> 0.11.0-1mamba
- automatic version update by autodist
* Sun Apr 27 2014 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
- automatic version update by autodist
* Thu Feb 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.2-1mamba
- update to 0.10.2
* Sat Jul 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-1mamba
- update to 0.9.0
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
- update to 0.6.1
* Tue Aug 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-3mamba
- added patch to fix build with libboost 1.50 (and then libreoffice)
* Thu Oct 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-2mamba
- (lost changelog)
* Thu Oct 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-1mamba
- update to 0.5.3
* Sun Apr 10 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.5.1-2mamba
- rebuilt
* Sat Jan 22 2011 gil <puntogil@libero.it> 0.5.1-1mamba
- package created by autospec