automatic version update by autodist [release 0.10.3-1mamba;Sun Apr 27 2014]
This commit is contained in:
parent
517ced60be
commit
cb3dcfb5cf
10
README.md
10
README.md
@ -1,2 +1,12 @@
|
||||
# libmdds
|
||||
|
||||
This library provides a collection of multi-dimensional data structure and indexing algorithm.
|
||||
All data structures are available as C++ templates, hence this is a header-only library, with no shared library to link against.
|
||||
|
||||
It implements the following data structures:
|
||||
* segment tree
|
||||
* flat segment tree
|
||||
* rectangle set
|
||||
* point quad tree
|
||||
* mixed type matrix
|
||||
|
||||
|
15
libmdds-0.5.3-boost-1.50.patch
Normal file
15
libmdds-0.5.3-boost-1.50.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/include/mdds/mixed_type_matrix_storage.hpp b/include/mdds/mixed_type_matrix_storage.hpp
|
||||
index fa0bf25..bb4e354 100644
|
||||
--- a/include/mdds/mixed_type_matrix_storage.hpp
|
||||
+++ misc/build/mdds_0.6.0/include/mdds/mixed_type_matrix_storage.hpp
|
||||
@@ -32,6 +32,10 @@
|
||||
|
||||
#include <boost/ptr_container/ptr_vector.hpp>
|
||||
#include <boost/ptr_container/ptr_map.hpp>
|
||||
+// Boost.Pool indirectly pulls in Boost.System, causing linking error
|
||||
+// with Boost 1.50, because some (deprecated) symbols from System are
|
||||
+// not found.
|
||||
+#define BOOST_SYSTEM_NO_DEPRECATED
|
||||
#include <boost/pool/object_pool.hpp>
|
||||
|
||||
namespace mdds {
|
121
libmdds.spec
Normal file
121
libmdds.spec
Normal file
@ -0,0 +1,121 @@
|
||||
%define with_mem_tests 0
|
||||
%define with_perf_tests 0
|
||||
|
||||
Name: libmdds
|
||||
Version: 0.10.3
|
||||
Release: 1mamba
|
||||
Summary: A collection of multi-dimensional data structure and indexing algorithm (mdds)
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://code.google.com/p/multidimalgorithm/
|
||||
Source: http://kohei.us/files/mdds/src/mdds_%{version}.tar.bz2
|
||||
Patch0: libmdds-0.5.3-boost-1.50.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libboost-devel
|
||||
%if %with_mem_tests
|
||||
BuildRequires: valgrind
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This library provides a collection of multi-dimensional data structure and indexing algorithm.
|
||||
All data structures are available as C++ templates, hence this is a header-only library, with no shared library to link against.
|
||||
|
||||
It implements the following data structures:
|
||||
* segment tree
|
||||
* flat segment tree
|
||||
* rectangle set
|
||||
* point quad tree
|
||||
* mixed type matrix
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Headers for %{name}
|
||||
|
||||
%description devel
|
||||
A collection of multi-dimensional data structure and indexing algorithm (mdds).
|
||||
|
||||
This package contains header files need for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n mdds_%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{optflags} -std/' Makefile.in
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--docdir=%{_docdir}/%{name}-%{version}
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
rm -rf %{buildroot}%{_docdir}
|
||||
|
||||
%check
|
||||
%make check
|
||||
for test in fst pqt recset st; do
|
||||
make test.$test
|
||||
done
|
||||
%if %with_perf_tests
|
||||
for t in recset st; do
|
||||
make test.$t.perf
|
||||
done
|
||||
make test.stl
|
||||
%endif
|
||||
%if %with_mem_tests
|
||||
for t in fst pqt recset st; do
|
||||
make test.$t.mem
|
||||
done
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
#%post -p /sbin/ldconfig
|
||||
#%postun -p /sbin/ldconfig
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/mdds/
|
||||
%{_includedir}/mdds/*.hpp
|
||||
%{_includedir}/mdds/*.inl
|
||||
%dir %{_includedir}/mdds/hash_container
|
||||
%{_includedir}/mdds/hash_container/*.hpp
|
||||
%{_includedir}/mdds/compat/unique_ptr.hpp
|
||||
%{_datadir}/pkgconfig/mdds.pc
|
||||
%doc AUTHORS NEWS README VERSION
|
||||
|
||||
%changelog
|
||||
* Sun Apr 27 2014 Automatic Build System <autodist@mambasoft.it> 0.10.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Feb 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.2-1mamba
|
||||
- update to 0.10.2
|
||||
|
||||
* Sat Jul 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-1mamba
|
||||
- update to 0.9.0
|
||||
|
||||
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
|
||||
- update to 0.6.1
|
||||
|
||||
* Tue Aug 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-3mamba
|
||||
- added patch to fix build with libboost 1.50 (and then libreoffice)
|
||||
|
||||
* Thu Oct 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-2mamba
|
||||
- (lost changelog)
|
||||
|
||||
* Thu Oct 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-1mamba
|
||||
- update to 0.5.3
|
||||
|
||||
* Sun Apr 10 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.5.1-2mamba
|
||||
- rebuilt
|
||||
|
||||
* Sat Jan 22 2011 gil <puntogil@libero.it> 0.5.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user