added patch to add missing link to libm [release 7.12-2mamba;Thu Aug 23 2012]
This commit is contained in:
parent
ec92ed80a6
commit
ace551a762
@ -1,2 +1,4 @@
|
||||
# libmalaga
|
||||
|
||||
A software package for the development and application of grammars that are used for the analysis of words and sentences of natural languages. It is a language-independent system that offers a programming language for the modelling of the language-dependent grammatical information. This language is also called Malaga.
|
||||
|
||||
|
9
libmalaga-7.12-fix-missing-lm.patch
Normal file
9
libmalaga-7.12-fix-missing-lm.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -Naur malaga-7.12.orig/Makefile.in malaga-7.12/Makefile.in
|
||||
--- malaga-7.12.orig/Makefile.in 2008-02-28 20:38:21.000000000 +0200
|
||||
+++ malaga-7.12/Makefile.in 2010-02-10 20:59:54.506702713 +0200
|
||||
@@ -243,7 +243,7 @@
|
||||
malshow: $(MALSHOW_OBJS) libmalaga.la
|
||||
@echo "Linking malshow"
|
||||
@$(LIBTOOL) --mode=link $(LINK) $(MALSHOW_OBJS) $(GTK_LIBS) \
|
||||
- libmalaga.la -o malshow
|
||||
+ -lm libmalaga.la -o malshow # malsym ----------------------------------------------------------------------
|
125
libmalaga.spec
Normal file
125
libmalaga.spec
Normal file
@ -0,0 +1,125 @@
|
||||
Name: libmalaga
|
||||
Version: 7.12
|
||||
Release: 2mamba
|
||||
Summary: Library files for malaga
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://home.arcor.de/bjoern-beutel/malaga/
|
||||
Source: http://home.arcor.de/bjoern-beutel/malaga/malaga-%{version}.tgz
|
||||
Patch0: %{name}-7.12-fix-missing-lm.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libreadline-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires(post): %{__install_info}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
A software package for the development and application of grammars that are used for the analysis of words and sentences of natural languages. It is a language-independent system that offers a programming language for the modelling of the language-dependent grammatical information. This language is also called Malaga.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
A software package for the development and application of grammars that are used for the analysis of words and sentences of natural languages. It is a language-independent system that offers a programming language for the modelling of the language-dependent grammatical information. This language is also called Malaga.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
|
||||
%package static
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries for %{name}
|
||||
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description static
|
||||
A software package for the development and application of grammars that are used for the analysis of words and sentences of natural languages. It is a language-independent system that offers a programming language for the modelling of the language-dependent grammatical information. This language is also called Malaga.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%package -n malaga
|
||||
Group: Development/Languages
|
||||
Summary: A Grammar Development Environment for Natural Languages
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n malaga
|
||||
A software package for the development and application of grammars that are used for the analysis of words and sentences of natural languages. It is a language-independent system that offers a programming language for the modelling of the language-dependent grammatical information. This language is also called Malaga.
|
||||
|
||||
Malaga is based on the grammatical theory of the "Left Associative Grammar" (LAG), developed by Roland Hausser, professor for Computational Linguistics at University of Erlangen, Germany.
|
||||
|
||||
%prep
|
||||
%setup -q -n malaga-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
sed -i.debug -e 's|^\([ \t][ \t]*\)@|\1|' Makefile.in
|
||||
sed -i.strip -e 's| -s | |' Makefile.in
|
||||
sed -i.silent -e 's|--silent||' Makefile.in
|
||||
|
||||
%build
|
||||
%configure --with-readline
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
INSTALL_INFO=/sbin/install-info
|
||||
rm -f %{buildroot}%{_infodir}/dir
|
||||
|
||||
chmod 0755 %{buildroot}%{_libdir}/libmalaga.so*
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n malaga
|
||||
%install_info malaga.info
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%preun -n malaga
|
||||
%uninstall_info malaga.info
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%doc CHANGES.txt GPL.txt README.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/*.so
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
|
||||
%files -n malaga
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/malaga
|
||||
%{_bindir}/mallex
|
||||
%{_bindir}/malmake
|
||||
%{_bindir}/malrul
|
||||
%{_bindir}/malshow
|
||||
%{_bindir}/malsym
|
||||
%dir %{_datadir}/malaga
|
||||
%{_datadir}/malaga/malaga.el
|
||||
%{_infodir}/malaga.info.gz
|
||||
%{_mandir}/man1/mal*.1.gz
|
||||
|
||||
%changelog
|
||||
* Thu Aug 23 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 7.12-2mamba
|
||||
- added patch to add missing link to libm
|
||||
|
||||
* Mon Feb 02 2009 gil <puntogil@libero.it> 7.12-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user