added vbetest subpackage [release 0.10-3mamba;Wed Oct 27 2010]
This commit is contained in:
parent
26ea79bcad
commit
e3b21615b5
@ -1,2 +1,4 @@
|
||||
# liblrmi
|
||||
|
||||
A library for calling real mode BIOS routines under Linux.
|
||||
|
||||
|
13
liblrmi-0.10-Makefile_install.patch
Normal file
13
liblrmi-0.10-Makefile_install.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Nru lrmi-0.10.orig/Makefile lrmi-0.10/Makefile
|
||||
--- lrmi-0.10.orig/Makefile 2005-12-05 00:33:57.000000000 +0100
|
||||
+++ lrmi-0.10/Makefile 2006-07-02 14:07:09.000000000 +0200
|
||||
@@ -39,8 +39,7 @@
|
||||
rm -f $(LIBDIR)/$(LIBNAME).so
|
||||
ln -sf $(LIBNAME).so.$(VERSION) $(LIBDIR)/$(LIBNAME).so.$(MAJOR)
|
||||
ln -sf $(LIBNAME).so.$(MAJOR) $(LIBDIR)/$(LIBNAME).so
|
||||
- install -m 644 -s -p lrmi.h $(INCDIR)/lrmi.h
|
||||
- ldconfig
|
||||
+ install -m 644 -p lrmi.h $(INCDIR)/lrmi.h
|
||||
|
||||
.PHONY: clean
|
||||
clean:
|
18
liblrmi-0.10-missing_defines.patch
Normal file
18
liblrmi-0.10-missing_defines.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Index: zhcon-0.2.6/src/display/lrmi.c
|
||||
===================================================================
|
||||
--- zhcon-0.2.6.orig/src/display/lrmi.c 2009-12-24 22:05:43.000000000 -0500
|
||||
+++ zhcon-0.2.6/src/display/lrmi.c 2009-12-24 22:06:35.000000000 -0500
|
||||
@@ -33,6 +33,13 @@
|
||||
|
||||
#include "lrmi.h"
|
||||
|
||||
+#if defined(__linux__) && !defined(TF_MASK)
|
||||
+ #define TF_MASK X86_EFLAGS_TF
|
||||
+ #define IF_MASK X86_EFLAGS_IF
|
||||
+ #define VIF_MASK X86_EFLAGS_VIF
|
||||
+ #define IOPL_MASK X86_EFLAGS_IOPL
|
||||
+#endif
|
||||
+
|
||||
#define REAL_MEM_BASE ((void *)0x10000)
|
||||
#define REAL_MEM_SIZE 0x10000
|
||||
#define REAL_MEM_BLOCKS 0x100
|
81
liblrmi.spec
Normal file
81
liblrmi.spec
Normal file
@ -0,0 +1,81 @@
|
||||
Name: liblrmi
|
||||
Version: 0.10
|
||||
Release: 3mamba
|
||||
Summary: A library for calling real mode BIOS routines under Linux
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://sourceforge.net/projects/lrmi/
|
||||
Source: http://puzzle.dl.sourceforge.net/sourceforge/lrmi/lrmi-%{version}.tar.gz
|
||||
Patch0: liblrmi-0.10-Makefile_install.patch
|
||||
Patch1: liblrmi-0.10-missing_defines.patch
|
||||
License: MIT
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
A library for calling real mode BIOS routines under Linux.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
A library for calling real mode BIOS routines under Linux.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n vbetest
|
||||
Summary: A Video Bios Extensions text tool using %{name}
|
||||
Group: System/Kernel and Hardware
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n vbetest
|
||||
A Video Bios Extensions text tool using %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n lrmi-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p3
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
install -d %{buildroot}%{_libdir} %{buildroot}%{_includedir} %{buildroot}%{_sbindir}
|
||||
%makeinstall LIBDIR=%{buildroot}%{_libdir} INCDIR=%{buildroot}%{_includedir}
|
||||
install -m 0644 liblrmi.a %{buildroot}%{_libdir}
|
||||
install -m 0755 vbetest %{buildroot}%{_sbindir}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liblrmi.so.*
|
||||
%doc README
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/lrmi.h
|
||||
%{_libdir}/liblrmi.a
|
||||
%{_libdir}/liblrmi.so
|
||||
|
||||
%files -n vbetest
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/vbetest
|
||||
|
||||
%changelog
|
||||
* Wed Oct 27 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10-3mamba
|
||||
- added vbetest subpackage
|
||||
|
||||
* Thu Jun 26 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.10-2mamba
|
||||
- update Vendor, Distribution, buildrequirements list
|
||||
|
||||
* Sun Jul 02 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user