automatic version update by autodist [release 0.2.8-1mamba;Fri Dec 06 2013]
This commit is contained in:
parent
f68bc0d722
commit
62683b47a4
@ -1,2 +1,5 @@
|
||||
# liblensfun
|
||||
|
||||
The goal of the lensfun library is to provide a open source database of photographic lenses and their characteristics.
|
||||
The lensfun library not only provides a way to read the database and search for specific things in it, but also provides a set of algorithms for correcting images based on detailed knowledge of lens properties.
|
||||
|
||||
|
25
liblensfun-0.2.6-pkgconfig.patch
Normal file
25
liblensfun-0.2.6-pkgconfig.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- libs/lensfun/CMakeLists.txt.pkgconfig 2012-02-12 19:19:39.000000000 +0800
|
||||
+++ libs/lensfun/CMakeLists.txt 2012-09-08 15:35:41.654073909 +0800
|
||||
@@ -26,3 +26,11 @@
|
||||
RUNTIME DESTINATION ${BINDIR}
|
||||
LIBRARY DESTINATION ${LIBDIR}
|
||||
ARCHIVE DESTINATION ${LIBDIR})
|
||||
+
|
||||
+set(CONF_VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO})
|
||||
+set(CONF_LIBDIR ${LIBDIR})
|
||||
+set(CONF_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/include)
|
||||
+
|
||||
+configure_file(lensfun.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc)
|
||||
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc
|
||||
+ DESTINATION ${LIBDIR}/pkgconfig)
|
||||
--- CMakeLists.txt.pkgconfig 2012-11-16 16:43:44.642505859 -0500
|
||||
+++ CMakeLists.txt 2012-11-16 16:50:00.503317741 -0500
|
||||
@@ -125,7 +125,7 @@
|
||||
ENDIF()
|
||||
|
||||
# install include files
|
||||
-INSTALL(FILES ${CMAKE_BINARY_DIR}/lensfun.h DESTINATION ${INCLUDEDIR}/lensfun)
|
||||
+INSTALL(FILES ${CMAKE_BINARY_DIR}/lensfun.h DESTINATION ${INCLUDEDIR})
|
||||
IF(NOT HAVE_REGEX_H)
|
||||
INSTALL(FILES include/regex/regex.h DESTINATION ${INCLUDEDIR}/regex)
|
||||
ENDIF()
|
98
liblensfun.spec
Normal file
98
liblensfun.spec
Normal file
@ -0,0 +1,98 @@
|
||||
Name: liblensfun
|
||||
Version: 0.2.8
|
||||
Release: 1mamba
|
||||
Summary: A library to rectify the defects introduced by your photographic equipment
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://lensfun.berlios.de/
|
||||
Source: http://download.berlios.de/lensfun/lensfun-%{version}.tar.bz2
|
||||
Patch0: liblensfun-0.2.6-pkgconfig.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
License: LGPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The goal of the lensfun library is to provide a open source database of photographic lenses and their characteristics.
|
||||
The lensfun library not only provides a way to read the database and search for specific things in it, but also provides a set of algorithms for correcting images based on detailed knowledge of lens properties.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The goal of the lensfun library is to provide a open source database of photographic lenses and their characteristics.
|
||||
The lensfun library not only provides a way to read the database and search for specific things in it, but also provides a set of algorithms for correcting images based on detailed knowledge of lens properties.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n lensfun-%{version}
|
||||
#%patch0 -p0
|
||||
|
||||
%build
|
||||
#./configure \
|
||||
# --cflags="${CFLAGS:-%optflags}" \
|
||||
# --cxxflags="${CXXFLAGS:-%optflags}" \
|
||||
# --prefix=%{_prefix} \
|
||||
# --target=..generic \
|
||||
#%ifarch arm
|
||||
# --vectorization=
|
||||
#%endif
|
||||
%cmake -d build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liblensfun.so.*
|
||||
%dir %{_datadir}/lensfun
|
||||
%{_datadir}/lensfun/*
|
||||
%doc docs/gpl-3.0.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/example
|
||||
%{_bindir}/tfun
|
||||
%{_bindir}/trwxml
|
||||
%dir %{_includedir}/lensfun
|
||||
%{_includedir}/lensfun/lensfun.h
|
||||
%{_libdir}/liblensfun.so
|
||||
%{_libdir}/pkgconfig/lensfun.pc
|
||||
|
||||
%changelog
|
||||
* Fri Dec 06 2013 Automatic Build System <autodist@mambasoft.it> 0.2.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 19 2013 Automatic Build System <autodist@mambasoft.it> 0.2.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.6-2mamba
|
||||
- patched to add pkgconfig support (required by rawstudio)
|
||||
|
||||
* Mon Jan 07 2013 Automatic Build System <autodist@mambasoft.it> 0.2.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 14 2010 Automatic Build System <autodist@mambasoft.it> 0.2.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Oct 16 2009 Automatic Build System <autodist@mambasoft.it> 0.2.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Mar 20 2009 Davide Madrisan <davide.madrisan@gmail.com> 0.2.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user