update to 3.5.0 [release 3.5.0-1mamba;Sun Mar 02 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 04:57:14 +01:00
parent e341b5bd2b
commit 596b3428e6
8 changed files with 4756 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# liblapack
LAPACK is written in Fortran77 and provides routines for solving systems of simultaneous linear equations, least-squares solutions of linear systems of equations, eigenvalue problems, and singular value problems.
The associated matrix factorizations (LU, Cholesky, QR, SVD, Schur, generalized Schur) are also provided, as are related computations such as reordering of the Schur factorizations and estimating condition numbers.
Dense and banded matrices are handled, but not general sparse matrices.
In all areas, similar functionality is provided for real and complex matrices, in both single and double precision.

3312
blasqr.ps Normal file

File diff suppressed because it is too large Load Diff

1078
lapackqref.ps Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,46 @@
diff -Nru lapack-3.1.1.orig/INSTALL/dsecnd_EXT_ETIME_.f lapack-3.1.1/INSTALL/dsecnd_EXT_ETIME_.f
--- lapack-3.1.1.orig/INSTALL/dsecnd_EXT_ETIME_.f 2007-02-23 21:07:35.000000000 +0100
+++ lapack-3.1.1/INSTALL/dsecnd_EXT_ETIME_.f 2007-05-19 15:28:05.000000000 +0200
@@ -20,7 +20,6 @@
* ..
* .. External Functions ..
REAL ETIME_
- EXTERNAL ETIME_
* ..
* .. Executable Statements ..
*
diff -Nru lapack-3.1.1.orig/INSTALL/dsecnd_EXT_ETIME.f lapack-3.1.1/INSTALL/dsecnd_EXT_ETIME.f
--- lapack-3.1.1.orig/INSTALL/dsecnd_EXT_ETIME.f 2007-02-23 21:07:35.000000000 +0100
+++ lapack-3.1.1/INSTALL/dsecnd_EXT_ETIME.f 2007-05-19 15:27:27.000000000 +0200
@@ -20,7 +20,6 @@
* ..
* .. External Functions ..
REAL ETIME
- EXTERNAL ETIME
* ..
* .. Executable Statements ..
*
diff -Nru lapack-3.1.1.orig/INSTALL/second_EXT_ETIME_.f lapack-3.1.1/INSTALL/second_EXT_ETIME_.f
--- lapack-3.1.1.orig/INSTALL/second_EXT_ETIME_.f 2007-02-23 21:07:35.000000000 +0100
+++ lapack-3.1.1/INSTALL/second_EXT_ETIME_.f 2007-05-19 15:28:24.000000000 +0200
@@ -20,7 +20,6 @@
* ..
* .. External Functions ..
REAL ETIME_
- EXTERNAL ETIME_
* ..
* .. Executable Statements ..
*
diff -Nru lapack-3.1.1.orig/INSTALL/second_EXT_ETIME.f lapack-3.1.1/INSTALL/second_EXT_ETIME.f
--- lapack-3.1.1.orig/INSTALL/second_EXT_ETIME.f 2007-02-23 21:07:35.000000000 +0100
+++ lapack-3.1.1/INSTALL/second_EXT_ETIME.f 2007-05-19 15:28:14.000000000 +0200
@@ -20,7 +20,6 @@
* ..
* .. External Functions ..
REAL ETIME
- EXTERNAL ETIME
* ..
* .. Executable Statements ..
*

View File

@ -0,0 +1,23 @@
--- lapack-3.1.1/INSTALL/make.inc.gfortran.BAD 2007-05-25 15:34:55.000000000 -0500
+++ lapack-3.1.1/INSTALL/make.inc.gfortran 2007-05-25 15:35:51.000000000 -0500
@@ -8,7 +8,7 @@ SHELL = /bin/sh
#
# The machine (platform) identifier to append to the library names
#
-PLAT = _LINUX
+PLAT =
#
# Modify the FORTRAN and OPTS definitions to refer to the
# compiler and desired compiler options for your machine. NOOPT
@@ -17,9 +17,9 @@ PLAT = _LINUX
# desired load options for your machine.
#
FORTRAN = gfortran
-OPTS = -O2
+#OPTS = -O2
DRVOPTS = $(OPTS)
-NOOPT = -O0
+NOOPT =
LOADER = gfortran
LOADOPTS =
#

View File

@ -0,0 +1,41 @@
--- lapack-3.4.2/BLAS/SRC/CMakeLists.txt.sover~ 2010-08-10 18:57:20.000000000 +0200
+++ lapack-3.4.2/BLAS/SRC/CMakeLists.txt 2013-02-13 03:42:25.385943586 +0100
@@ -141,4 +141,8 @@ if(UNIX)
target_link_libraries(blas m)
endif()
target_link_libraries(blas)
+set_target_properties(blas PROPERTIES
+ VERSION ${LAPACK_VERSION}
+ SOVERSION ${CPACK_PACKAGE_VERSION_MAJOR}
+)
lapack_install_library(blas)
--- lapack-3.4.2/CMakeLists.txt.sover~ 2013-02-13 03:42:25.385943586 +0100
+++ lapack-3.4.2/CMakeLists.txt 2013-02-13 03:46:41.686836962 +0100
@@ -1,5 +1,7 @@
cmake_minimum_required(VERSION 2.8)
project(LAPACK Fortran)
+set(LAPACK_VERSION 3.4.2)
+set(CPACK_PACKAGE_VERSION_MAJOR 3)
# Configure the warning and code coverage suppression file
configure_file(
@@ -216,8 +218,6 @@ endif(LAPACKE)
SET(CPACK_PACKAGE_NAME "LAPACK")
SET(CPACK_PACKAGE_VENDOR "University of Tennessee, Univ. of California Berkeley, Univ. of Colorado Denver and NAG Ltd")
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "LAPACK- Linear Algebra Package")
-set(LAPACK_VERSION 3.4.2)
-set(CPACK_PACKAGE_VERSION_MAJOR 3)
set(CPACK_PACKAGE_VERSION_MINOR 4)
set(CPACK_PACKAGE_VERSION_PATCH 2)
set(CPACK_RESOURCE_FILE_LICENSE "${CMAKE_CURRENT_SOURCE_DIR}/LICENSE")
--- lapack-3.4.2/SRC/CMakeLists.txt.sover~ 2013-02-13 03:42:25.385943586 +0100
+++ lapack-3.4.2/SRC/CMakeLists.txt 2013-02-13 03:44:42.637506806 +0100
@@ -416,4 +416,8 @@ list(REMOVE_DUPLICATES ALLOBJ)
add_library(lapack ${ALLOBJ} ${ALLXOBJ})
target_link_libraries(lapack ${BLAS_LIBRARIES} ${XBLAS_LIBRARY})
+set_target_properties(lapack PROPERTIES
+ VERSION ${LAPACK_VERSION}
+ SOVERSION ${CPACK_PACKAGE_VERSION_MAJOR}
+)
lapack_install_library(lapack)

View File

@ -0,0 +1,13 @@
--- lapack-3.4.2/CMakeLists.txt.lib64~ 2013-02-13 03:47:26.821336133 +0100
+++ lapack-3.4.2/CMakeLists.txt 2013-02-13 03:54:28.900909438 +0100
@@ -282,8 +282,8 @@ install(FILES
${LAPACK_GNUtoMS_IMPORT}
${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake
${LAPACK_BINARY_DIR}/lapack-config-version.cmake
- DESTINATION lib/cmake/lapack-${LAPACK_VERSION}
+ DESTINATION lib${LIB_SUFFIX}/cmake/lapack-${LAPACK_VERSION}
)
install(EXPORT lapack-targets
- DESTINATION lib/cmake/lapack-${LAPACK_VERSION})
+ DESTINATION lib${LIB_SUFFIX}/cmake/lapack-${LAPACK_VERSION})

238
liblapack.spec Normal file
View File

@ -0,0 +1,238 @@
%define majver %(echo %version | cut -d. -f 1-2)
%define MAJversion %(echo %version | cut -d. -f 1)
%define blasversion %version
%define blasmajversion %MAJversion
Name: liblapack
Version: 3.5.0
Release: 1mamba
Summary: LAPACK - Linear Algebra PACKage
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.netlib.org/lapack/
Source: http://www.netlib.org/lapack/lapack-%{version}.tgz
Source1: http://www.netlib.org/lapack/lapackqref.ps
Source2: http://www.netlib.org/blas/blasqr.ps
Source3: http://www.netlib.org/lapack/manpages.tgz
# http://tianyangma.blogspot.it/2012/03/linux-easiest-way-to-compile-lapack.html
#Source4: http://users.wfu.edu/cottrell/lapack/lapack-%{majver}.0-autoconf.tar.gz
Patch0: %{name}-3.1.1-intrinsec_etime.patch
Patch1: liblapack-3.1.1-make.inc.patch
Patch2: liblapack-3.4.2-cmake-sover.patch
Patch3: liblapack-3.4.2-lib64.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: gcc-fortran
BuildRequires: glibc-devel
BuildRequires: libgcc
%ifnarch arm
BuildRequires: libquadmath-devel
%endif
BuildRequires: libxblas-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
LAPACK is written in Fortran77 and provides routines for solving systems of simultaneous linear equations, least-squares solutions of linear systems of equations, eigenvalue problems, and singular value problems.
The associated matrix factorizations (LU, Cholesky, QR, SVD, Schur, generalized Schur) are also provided, as are related computations such as reordering of the Schur factorizations and estimating condition numbers.
Dense and banded matrices are handled, but not general sparse matrices.
In all areas, similar functionality is provided for real and complex matrices, in both single and double precision.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
LAPACK is written in Fortran77 and provides routines for solving systems of simultaneous linear equations, least-squares solutions of linear systems of equations, eigenvalue problems, and singular value problems.
The associated matrix factorizations (LU, Cholesky, QR, SVD, Schur, generalized Schur) are also provided, as are related computations such as reordering of the Schur factorizations and estimating condition numbers.
Dense and banded matrices are handled, but not general sparse matrices.
In all areas, similar functionality is provided for real and complex matrices, in both single and double precision.
This package contains static libraries and header files need for development.
%package -n libblas
Group: System/Libraries
Summary: BLAS - Basic Linear Algebra Subprograms
%description -n libblas
The BLAS (Basic Linear Algebra Subprograms) are routines that provide standard building blocks for performing basic vector and matrix operations.
The Level 1 BLAS perform scalar, vector and vector-vector operations, the Level 2 BLAS perform matrix-vector operations, and the Level 3 BLAS perform matrix-matrix operations.
Because the BLAS are efficient, portable, and widely available, they are commonly used in the development of high quality linear algebra software, LAPACK for example.
%package -n libblas-devel
Group: Development/Libraries
Summary: Static libraries and headers for libblas
Requires: libblas = %{?epoch:%epoch:}%{version}-%{release}
%description -n libblas-devel
The BLAS (Basic Linear Algebra Subprograms) are routines that provide standard building blocks for performing basic vector and matrix operations.
The Level 1 BLAS perform scalar, vector and vector-vector operations, the Level 2 BLAS perform matrix-vector operations, and the Level 3 BLAS perform matrix-matrix operations.
Because the BLAS are efficient, portable, and widely available, they are commonly used in the development of high quality linear algebra software, LAPACK for example.
This package contains static libraries and header files need for development.
%package apidocs
Group: Documentation
Summary: %{name} API documentation
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description apidocs
This package includes the %{name} API documentation.
%debug_package
%prep
%setup -q -n lapack-%{version}
%setup -q -n lapack-%{version} -D -T -a 3
#-a 4
%patch0 -p1
#% patch1 -p1
%patch2 -p1
%patch3 -p1
cp %{S:1} lapackqref.ps
cp %{S:2} blasqr.ps
%build
%cmake -d build \
-DUSE_XBLAS=ON \
-DBUILD_STATIC_LIBS=ON \
-DBUILD_SHARED_LIBS=OFF \
-DBUILD_TESTING=OFF \
-DCMAKE_Fortran_COMPILER_FORCED=ON \
-DCMAKE_SHARED_LINKER_FLAGS=-lgfortran \
%ifarch x86_64
-DXBLAS_LIBRARY=%{_libdir}/libxblas.so \
-DLIB_SUFFIX=64
%endif
%make
cd ..
%cmake -d build \
-DUSE_XBLAS=ON \
-DBUILD_STATIC_LIBS=OFF \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_TESTING=OFF \
-DCMAKE_Fortran_COMPILER_FORCED=ON \
-DCMAKE_SHARED_LINKER_FLAGS=-lgfortran \
%ifarch x86_64
-DXBLAS_LIBRARY=%{_libdir}/libxblas.so \
-DLIB_SUFFIX=64
%endif
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
install -m0644 build/lib/*.a %{buildroot}%{_libdir}/
### install manfiles
## duplicated
#rm -f manpages/man/manl/lsame.l*
#rm -f manpages/man/manl/xerbla.l*
mkdir -p %{buildroot}%{_mandir}/man3
for manfile in man/man3/* ; do
filename=$(basename $manfile .l).3
install -m 644 -p $manfile \
%{buildroot}%{_mandir}/man3/$filename
echo "%{_mandir}/man3/$filename.gz" >> %{name}mans
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
rm -f .*mans
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post -n libblas -p /sbin/ldconfig
%postun -n libblas -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/%{name}.so.*
%files devel
%defattr(-,root,root)
%{_libdir}/cmake/lapack-3.4.2/lapack-config-version.cmake
%{_libdir}/cmake/lapack-3.4.2/lapack-config.cmake
%{_libdir}/cmake/lapack-3.4.2/lapack-targets-noconfig.cmake
%{_libdir}/cmake/lapack-3.4.2/lapack-targets.cmake
#%{_libdir}/libtmglib.so
%{_libdir}/liblapack.a
%{_libdir}/liblapack.so
%{_libdir}/pkgconfig/lapack.pc
%doc README
%files -n libblas
%defattr(-,root,root)
%{_libdir}/libblas.so.*
%files apidocs -f %{name}mans
%defattr(-,root,root)
%doc lapackqref.ps
%files -n libblas-devel
%defattr(-,root,root)
%{_libdir}/libblas.a
%{_libdir}/libblas.so
%{_libdir}/pkgconfig/blas.pc
%doc blasqr.ps
%changelog
* Sun Mar 02 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5.0-1mamba
- update to 3.5.0
* Mon Aug 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-5mamba
- rebuilt using cmake to fix linking with xblas
- moved man pages to liblapack-apidocs
-
* Mon Aug 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-4mamba
- rebuilt with extended precision support (requires libxblas-devel)
* Thu Aug 22 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-3mamba
- rebuilt static library required to build libatlas
* Wed Aug 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-2mamba
- moved man 3 pages to -devel packages
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
- automatic version update by autodist
* Mon Jul 02 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
- automatic version update by autodist
* Sun May 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-4mamba
- support cross platform gfortran compiler
* Tue Mar 02 2010 gil <puntogil@libero.it> 3.2.1-3mamba
- see http://mail.scipy.org/pipermail/scipy-user/2007-July/012968.html
- rebuilt with fedora Makefiles support
* Mon Mar 01 2010 gil <puntogil@libero.it> 3.2.1-2mamba
- added manpages
* Sun Jul 26 2009 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
- automatic update by autodist
* Thu Jun 04 2009 Automatic Build System <autodist@mambasoft.it> 3.2-1mamba
- automatic update by autodist
* Fri Sep 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-2mamba
- rebuilt against gcc-fortran 4.3.2
* Sat May 19 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-1mamba
- update to 3.1.1
* Sun Feb 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-2qilnx
- rebuilt
* Tue Nov 21 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.1.0-1qilnx
- package created by autospec