automatic version update by autodist [release 3.99.5-1mamba;Sun Dec 02 2012]
This commit is contained in:
parent
889216fcf0
commit
e6adc0f180
@ -1,2 +1,5 @@
|
||||
# liblame
|
||||
|
||||
The lame package contains a MP3 encoder.
|
||||
This is useful for creating compressed audio files.
|
||||
|
||||
|
199
liblame-3.98-gtk-path.patch
Normal file
199
liblame-3.98-gtk-path.patch
Normal file
@ -0,0 +1,199 @@
|
||||
Index: gtk.m4
|
||||
===================================================================
|
||||
--- gtk.m4.orig
|
||||
+++ gtk.m4
|
||||
@@ -0,0 +1,194 @@
|
||||
+# Configure paths for GTK+
|
||||
+# Owen Taylor 97-11-3
|
||||
+
|
||||
+dnl AM_PATH_GTK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
|
||||
+dnl Test for GTK, and define GTK_CFLAGS and GTK_LIBS
|
||||
+dnl
|
||||
+AC_DEFUN(AM_PATH_GTK,
|
||||
+[dnl
|
||||
+dnl Get the cflags and libraries from the gtk-config script
|
||||
+dnl
|
||||
+AC_ARG_WITH(gtk-prefix,[ --with-gtk-prefix=PFX Prefix where GTK is installed (optional)],
|
||||
+ gtk_config_prefix="$withval", gtk_config_prefix="")
|
||||
+AC_ARG_WITH(gtk-exec-prefix,[ --with-gtk-exec-prefix=PFX Exec prefix where GTK is installed (optional)],
|
||||
+ gtk_config_exec_prefix="$withval", gtk_config_exec_prefix="")
|
||||
+AC_ARG_ENABLE(gtktest, [ --disable-gtktest Do not try to compile and run a test GTK program],
|
||||
+ , enable_gtktest=yes)
|
||||
+
|
||||
+ for module in . $4
|
||||
+ do
|
||||
+ case "$module" in
|
||||
+ gthread)
|
||||
+ gtk_config_args="$gtk_config_args gthread"
|
||||
+ ;;
|
||||
+ esac
|
||||
+ done
|
||||
+
|
||||
+ if test x$gtk_config_exec_prefix != x ; then
|
||||
+ gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
|
||||
+ if test x${GTK_CONFIG+set} != xset ; then
|
||||
+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
|
||||
+ fi
|
||||
+ fi
|
||||
+ if test x$gtk_config_prefix != x ; then
|
||||
+ gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
|
||||
+ if test x${GTK_CONFIG+set} != xset ; then
|
||||
+ GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
|
||||
+ fi
|
||||
+ fi
|
||||
+
|
||||
+ AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
|
||||
+ min_gtk_version=ifelse([$1], ,0.99.7,$1)
|
||||
+ AC_MSG_CHECKING(for GTK - version >= $min_gtk_version)
|
||||
+ no_gtk=""
|
||||
+ if test "$GTK_CONFIG" = "no" ; then
|
||||
+ no_gtk=yes
|
||||
+ else
|
||||
+ GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
|
||||
+ GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
|
||||
+ gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
|
||||
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
|
||||
+ gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
|
||||
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
|
||||
+ gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
|
||||
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
|
||||
+ if test "x$enable_gtktest" = "xyes" ; then
|
||||
+ ac_save_CFLAGS="$CFLAGS"
|
||||
+ ac_save_LIBS="$LIBS"
|
||||
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
+ LIBS="$GTK_LIBS $LIBS"
|
||||
+dnl
|
||||
+dnl Now check if the installed GTK is sufficiently new. (Also sanity
|
||||
+dnl checks the results of gtk-config to some extent
|
||||
+dnl
|
||||
+ rm -f conf.gtktest
|
||||
+ AC_TRY_RUN([
|
||||
+#include <gtk/gtk.h>
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ int major, minor, micro;
|
||||
+ char *tmp_version;
|
||||
+
|
||||
+ system ("touch conf.gtktest");
|
||||
+
|
||||
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
|
||||
+ tmp_version = g_strdup("$min_gtk_version");
|
||||
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, µ) != 3) {
|
||||
+ printf("%s, bad version string\n", "$min_gtk_version");
|
||||
+ exit(1);
|
||||
+ }
|
||||
+
|
||||
+ if ((gtk_major_version != $gtk_config_major_version) ||
|
||||
+ (gtk_minor_version != $gtk_config_minor_version) ||
|
||||
+ (gtk_micro_version != $gtk_config_micro_version))
|
||||
+ {
|
||||
+ printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
|
||||
+ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
|
||||
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
||||
+ printf ("*** was found! If gtk-config was correct, then it is best\n");
|
||||
+ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
|
||||
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
|
||||
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
|
||||
+ printf("*** required on your system.\n");
|
||||
+ printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
|
||||
+ printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
|
||||
+ printf("*** before re-running configure\n");
|
||||
+ }
|
||||
+#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
|
||||
+ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
|
||||
+ (gtk_minor_version != GTK_MINOR_VERSION) ||
|
||||
+ (gtk_micro_version != GTK_MICRO_VERSION))
|
||||
+ {
|
||||
+ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
|
||||
+ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
|
||||
+ printf("*** library (version %d.%d.%d)\n",
|
||||
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
||||
+ }
|
||||
+#endif /* defined (GTK_MAJOR_VERSION) ... */
|
||||
+ else
|
||||
+ {
|
||||
+ if ((gtk_major_version > major) ||
|
||||
+ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
|
||||
+ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
|
||||
+ {
|
||||
+ return 0;
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
|
||||
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
||||
+ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
|
||||
+ major, minor, micro);
|
||||
+ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
|
||||
+ printf("***\n");
|
||||
+ printf("*** If you have already installed a sufficiently new version, this error\n");
|
||||
+ printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
|
||||
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
|
||||
+ printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
|
||||
+ printf("*** correct copy of gtk-config. (In this case, you will have to\n");
|
||||
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
|
||||
+ printf("*** so that the correct libraries are found at run-time))\n");
|
||||
+ }
|
||||
+ }
|
||||
+ return 1;
|
||||
+}
|
||||
+],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
|
||||
+ CFLAGS="$ac_save_CFLAGS"
|
||||
+ LIBS="$ac_save_LIBS"
|
||||
+ fi
|
||||
+ fi
|
||||
+ if test "x$no_gtk" = x ; then
|
||||
+ AC_MSG_RESULT(yes)
|
||||
+ ifelse([$2], , :, [$2])
|
||||
+ else
|
||||
+ AC_MSG_RESULT(no)
|
||||
+ if test "$GTK_CONFIG" = "no" ; then
|
||||
+ echo "*** The gtk-config script installed by GTK could not be found"
|
||||
+ echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
|
||||
+ echo "*** your path, or set the GTK_CONFIG environment variable to the"
|
||||
+ echo "*** full path to gtk-config."
|
||||
+ else
|
||||
+ if test -f conf.gtktest ; then
|
||||
+ :
|
||||
+ else
|
||||
+ echo "*** Could not run GTK test program, checking why..."
|
||||
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
+ LIBS="$LIBS $GTK_LIBS"
|
||||
+ AC_TRY_LINK([
|
||||
+#include <gtk/gtk.h>
|
||||
+#include <stdio.h>
|
||||
+], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
|
||||
+ [ echo "*** The test program compiled, but did not run. This usually means"
|
||||
+ echo "*** that the run-time linker is not finding GTK or finding the wrong"
|
||||
+ echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
|
||||
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
|
||||
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
|
||||
+ echo "*** is required on your system"
|
||||
+ echo "***"
|
||||
+ echo "*** If you have an old version installed, it is best to remove it, although"
|
||||
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
|
||||
+ echo "***"
|
||||
+ echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
|
||||
+ echo "*** came with the system with the command"
|
||||
+ echo "***"
|
||||
+ echo "*** rpm --erase --nodeps gtk gtk-devel" ],
|
||||
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
|
||||
+ echo "*** exact error that occured. This usually means GTK was incorrectly installed"
|
||||
+ echo "*** or that you have moved GTK since it was installed. In the latter case, you"
|
||||
+ echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
|
||||
+ CFLAGS="$ac_save_CFLAGS"
|
||||
+ LIBS="$ac_save_LIBS"
|
||||
+ fi
|
||||
+ fi
|
||||
+ GTK_CFLAGS=""
|
||||
+ GTK_LIBS=""
|
||||
+ ifelse([$3], , :, [$3])
|
||||
+ fi
|
||||
+ AC_SUBST(GTK_CFLAGS)
|
||||
+ AC_SUBST(GTK_LIBS)
|
||||
+ rm -f conf.gtktest
|
||||
+])
|
24
liblame-3.98-shared-frontend.patch
Normal file
24
liblame-3.98-shared-frontend.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ur lame-398.old/frontend/Makefile.am lame-398.new/frontend/Makefile.am
|
||||
--- lame-398.old/frontend/Makefile.am 2006-09-30 11:17:05.000000000 +0200
|
||||
+++ lame-398.new/frontend/Makefile.am 2008-07-06 12:36:25.000000000 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
endif
|
||||
|
||||
CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
||||
-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@ -static
|
||||
+LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
|
||||
|
||||
INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
|
||||
|
||||
diff -ur lame-398.old/frontend/Makefile.in lame-398.new/frontend/Makefile.in
|
||||
--- lame-398.old/frontend/Makefile.in 2008-06-25 14:17:51.000000000 +0200
|
||||
+++ lame-398.new/frontend/Makefile.in 2008-07-06 12:36:39.000000000 +0200
|
||||
@@ -152,7 +152,7 @@
|
||||
$(top_builddir)/libmp3lame/libmp3lame.la \
|
||||
@FRONTEND_LDADD@
|
||||
|
||||
-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@ -static
|
||||
+LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LIBS = @LIBS@
|
||||
LIBTOOL = @LIBTOOL@
|
108
liblame.spec
Normal file
108
liblame.spec
Normal file
@ -0,0 +1,108 @@
|
||||
%define pkgver1 %(echo %version | cut -d. -f1)
|
||||
%define pkgver2 %(echo %version | cut -d. -f2)
|
||||
%define pkgver3 %(echo %version | cut -d. -f3)
|
||||
Name: liblame
|
||||
Version: 3.99.5
|
||||
Release: 1mamba
|
||||
Summary: LAME Ain't an MP3 Encoder
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://lame.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/lame/lame-%{version}.tar.gz
|
||||
#Source: http://downloads.sourceforge.net/sourceforge/lame/lame-%{pkgver1}%{pkgver2}-%{pkgver3}.tar.gz
|
||||
Patch0: %{name}-3.98-shared-frontend.patch
|
||||
Patch1: %{name}-3.98-gtk-path.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libncurses-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsndfile-devel >= 1.0.11
|
||||
BuildRequires: nasm
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The lame package contains a MP3 encoder.
|
||||
This is useful for creating compressed audio files.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for cdrdao
|
||||
Group: Development/Libraries
|
||||
|
||||
%description devel
|
||||
The lame package contains a MP3 encoder.
|
||||
This is useful for creating compressed audio files.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n lame-%{version}
|
||||
#%patch0 -p1
|
||||
%patch1 -p0
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-decode-layer1 \
|
||||
--enable-decode-layer2 \
|
||||
--disable-mp3x \
|
||||
--enable-mp3rtp \
|
||||
--enable-shared \
|
||||
--enable-nasm
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/lame
|
||||
%{_bindir}/mp3rtp
|
||||
%{_libdir}/libmp3lame.so.*
|
||||
%{_libdir}/libmp3lame.so
|
||||
%{_mandir}/man1/*
|
||||
%doc ChangeLog COPYING LICENSE README USAGE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/lame
|
||||
%{_includedir}/lame/*.h
|
||||
%{_datadir}/doc/lame/html
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%doc API HACKING STYLEGUIDE DEFINES TODO
|
||||
|
||||
%changelog
|
||||
* Sun Dec 02 2012 Automatic Build System <autodist@mambasoft.it> 3.99.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.98.4-2mamba
|
||||
- disable mp3x build to remove dependency on gtk1
|
||||
|
||||
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 3.98.4-1mamba
|
||||
- update to 3.98.4
|
||||
|
||||
* Wed May 20 2009 Automatic Build System <autodist@mambasoft.it> 3.98.2-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Jan 21 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.98.2-1mamba
|
||||
- update to 3.98.2
|
||||
|
||||
* Wed Feb 13 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.97-1mamba
|
||||
- update to 3.97
|
||||
- moved libmp3lame.so to main package as required by audacity
|
||||
|
||||
* Fri Jun 10 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.96.1-1qilnx
|
||||
- update to version 3.96.1 by autospec
|
||||
- specfile updates/fixes
|
||||
|
||||
* Fri Jul 11 2003 Silvan Calarco <silvan.calarco@qinet.it> 3.93.1-1qilnx
|
||||
- first build for liblame
|
Loading…
Reference in New Issue
Block a user