automatic rebuild by autodist [release 0.1.1-2mamba;Mon Jul 15 2013]

This commit is contained in:
Automatic Build System 2024-01-06 04:43:57 +01:00
parent 196f21026b
commit 05a84310e0
3 changed files with 123 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libkarma # libkarma
libkarma is a C library for managing the Rio Karma mp3 player via TCP/IP. It supports all basic protocol commands and some advanced functions on top of these, like caching of the Rio database. There are two proof-of-concept tools included, riocp and chprop. riocp can be used to upload files to the Karma.

View File

@ -0,0 +1,52 @@
diff -Nru libkarma-0.1.0.orig/Makefile libkarma-0.1.0/Makefile
--- libkarma-0.1.0.orig/Makefile 2007-05-15 18:29:02.000000000 +0200
+++ libkarma-0.1.0/Makefile 2007-08-14 12:07:09.000000000 +0200
@@ -18,10 +18,10 @@
install-sh karma-tools.spec
DOCS=THANKS TODO ChangeLog
-INSTALL_DIR := $(INSTALL) -d -o root -g root -m 0755
-INSTALL_FILE := $(INSTALL) -o root -g root -m 0644
-INSTALL_PROGRAM := $(INSTALL) -o root -g root -m 0755 # -s
-INSTALL_SCRIPT := $(INSTALL) -o root -g root -m 0755
+INSTALL_DIR := $(INSTALL) -d -m 0755
+INSTALL_FILE := $(INSTALL) -m 0644
+INSTALL_PROGRAM := $(INSTALL) -m 0755 # -s
+INSTALL_SCRIPT := $(INSTALL) -m 0755
all: libkarma tools karma-sharp
diff -Nru libkarma-0.1.0.orig/src/Makefile libkarma-0.1.0/src/Makefile
--- libkarma-0.1.0.orig/src/Makefile 2007-05-15 18:29:02.000000000 +0200
+++ libkarma-0.1.0/src/Makefile 2007-08-14 12:07:41.000000000 +0200
@@ -41,11 +41,11 @@
../install-sh -m 0755 -d $(DEST)/include
../install-sh -m 0755 -d $(DEST)/include/libkarma
../install-sh -m 0644 -t $(DEST)/lib/ $(LIBDIR)/$(TARGET).a
- ../install-sh -m 0755 -t $(PREFIX)/lib/ $(LIBDIR)/$(OUT_VERSION)
- $(RM) $(PREFIX)/lib/$(OUT_MAJOR)
- $(RM) $(PREFIX)/lib/$(OUT_BASE)
- $(LN_S) $(OUT_VERSION) $(PREFIX)/lib/$(OUT_MAJOR)
- $(LN_S) $(OUT_VERSION) $(PREFIX)/lib/$(OUT_BASE)
+ ../install-sh -m 0755 -t $(DEST)/lib/ $(LIBDIR)/$(OUT_VERSION)
+ $(RM) $(DEST)/lib/$(OUT_MAJOR)
+ $(RM) $(DEST)/lib/$(OUT_BASE)
+ $(LN_S) $(OUT_VERSION) $(DEST)/lib/$(OUT_MAJOR)
+ $(LN_S) $(OUT_VERSION) $(DEST)/lib/$(OUT_BASE)
../install-sh -m 0644 -t $(DEST)/include/libkarma/ $(INST_HEADERS)
uninstall:
diff -Nru libkarma-0.1.0.orig/tools/Makefile libkarma-0.1.0/tools/Makefile
--- libkarma-0.1.0.orig/tools/Makefile 2007-05-15 18:29:02.000000000 +0200
+++ libkarma-0.1.0/tools/Makefile 2007-08-14 12:07:24.000000000 +0200
@@ -45,8 +45,8 @@
install:
../install-sh -m 0755 -d $(DEST)/bin
../install-sh -m 0755 -t $(DEST)/bin/ $(TOOLS)
- ../install-sh -m 0755 -d $(PREFIX)/share/man/man1
- ../install-sh -m 0755 -t $(PREFIX)/share/man/man1 $(MANPAGES)
+ ../install-sh -m 0755 -d $(DEST)/share/man/man1
+ ../install-sh -m 0755 -t $(DEST)/share/man/man1 $(MANPAGES)
uninstall:
cd $(DEST)/bin && $(RM) $(TOOLS)

69
libkarma.spec Normal file
View File

@ -0,0 +1,69 @@
Name: libkarma
Version: 0.1.1
Release: 2mamba
Summary: A C library for managing the Rio Karma mp3 player via TCP/IP
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.freakysoft.de/html/libkarma/
Source: http://www.freakysoft.de/html/libkarma/libkarma-%{version}.tar.gz
Patch0: libkarma-0.1.0-install_dest.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
libkarma is a C library for managing the Rio Karma mp3 player via TCP/IP. It supports all basic protocol commands and some advanced functions on top of these, like caching of the Rio database. There are two proof-of-concept tools included, riocp and chprop. riocp can be used to upload files to the Karma.
%package devel
Summary: Devel package for libkarma
Group: Development/Libraries
Requires: %{name} = %{version}
%description devel
libkarma is a C library for managing the Rio Karma mp3 player via TCP/IP. It supports all basic protocol commands and some advanced functions on top of these, like caching of the Rio database. There are two proof-of-concept tools included, riocp and chprop. riocp can be used to upload files to the Karma.
This is the development package.
%prep
%setup -q
#%patch0 -p1
%build
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall DEST=%{buildroot}%{_prefix} PREFIX=%{_prefix}
rm -rf %{buildroot}%{_datadir}/doc/libkarma
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/chprop
%{_bindir}/karma_helper
%{_bindir}/riocp
%{_libdir}/karma-sharp/karma-sharp.dll
%{_libdir}/libkarma.so.*
%{_mandir}/man1/chprop.1.gz
%{_mandir}/man1/karma_helper.1.gz
%{_mandir}/man1/riocp.1.gz
%doc COPYING ChangeLog THANKS TODO
%files devel
%defattr(-,root,root)
%{_libdir}/libkarma.a
%{_libdir}/libkarma.so
%{_libdir}/pkgconfig/karma-sharp.pc
%{_includedir}/libkarma/*.h
%changelog
* Mon Jul 15 2013 Automatic Build System <autodist@mambasoft.it> 0.1.1-2mamba
- automatic rebuild by autodist
* Thu Jun 18 2009 Automatic Build System <autodist@mambasoft.it> 0.1.1-1mamba
- automatic update by autodist
* Tue Aug 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.0-1mamba
- package created by autospec