update to 4.2 [release 4.2-1mamba;Thu May 02 2024]
This commit is contained in:
parent
1e313133e6
commit
e20c151679
@ -1,41 +0,0 @@
|
|||||||
Author: Lars Müller <lmuelle at SuSE dot de>
|
|
||||||
Subject: Build libiniparser as shared library
|
|
||||||
|
|
||||||
--- iniparser-2.15/Makefile
|
|
||||||
+++ iniparser-2.15/Makefile 2006-04-11 17:59:16
|
|
||||||
@@ -4,12 +4,16 @@
|
|
||||||
|
|
||||||
# Compiler settings
|
|
||||||
CC = gcc
|
|
||||||
-CFLAGS = -O3
|
|
||||||
+CFLAGS = -O3 -fPIC
|
|
||||||
|
|
||||||
# Ar settings to build the library
|
|
||||||
AR = ar
|
|
||||||
ARFLAGS = rcv
|
|
||||||
|
|
||||||
+SHLD = ${CC} ${CFLAGS}
|
|
||||||
+LDSHFLAGS = -shared -Wl,-Bsymbolic -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
|
|
||||||
+LDFLAGS = -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
|
|
||||||
+
|
|
||||||
# Set RANLIB to ranlib on systems that require it (Sun OS < 4, Mac OSX)
|
|
||||||
# RANLIB = ranlib
|
|
||||||
RANLIB = true
|
|
||||||
@@ -34,12 +38,16 @@
|
|
||||||
OBJS = $(SRCS:.c=.o)
|
|
||||||
|
|
||||||
|
|
||||||
-default: libiniparser.a
|
|
||||||
+default: libiniparser.a libiniparser.so
|
|
||||||
|
|
||||||
libiniparser.a: $(OBJS)
|
|
||||||
@($(AR) $(ARFLAGS) libiniparser.a $(OBJS))
|
|
||||||
@($(RANLIB) libiniparser.a)
|
|
||||||
|
|
||||||
+libiniparser.so: $(OBJS)
|
|
||||||
+ @$(SHLD) $(LDSHFLAGS) -o $@.0 $(OBJS) $(LDFLAGS) \
|
|
||||||
+ -Wl,-soname=`basename $@`.0
|
|
||||||
+
|
|
||||||
clean:
|
|
||||||
$(RM) $(OBJS)
|
|
||||||
|
|
@ -1,19 +1,17 @@
|
|||||||
Name: libiniparser
|
Name: libiniparser
|
||||||
Version: 4.1
|
Version: 4.2
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A free stand-alone ini file parsing library
|
Summary: A free stand-alone ini file parsing library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://ndevilla.free.fr/iniparser/
|
URL: https://github.com/ndevilla/iniparser
|
||||||
Source: https://github.com/ndevilla/iniparser.git/v%{version}/iniparser-%{version}.tar.bz2
|
Source: https://github.com/ndevilla/iniparser.git/v%{version}/iniparser-%{version}.tar.bz2
|
||||||
Patch: %{name}-2.15-shared-library.patch
|
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Libiniparser offers parsing of ini files from the C level.
|
Libiniparser offers parsing of ini files from the C level.
|
||||||
@ -25,7 +23,9 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Libiniparser offers parsing of ini files from the C level.
|
Libiniparser offers parsing of ini files from the C level.
|
||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n iniparser-%{version}
|
%setup -q -n iniparser-%{version}
|
||||||
@ -61,9 +61,11 @@ ln -s libiniparser.so.1 %{buildroot}%{_libdir}/libiniparser.so
|
|||||||
%{_includedir}/iniparser.h
|
%{_includedir}/iniparser.h
|
||||||
%{_libdir}/libiniparser.a
|
%{_libdir}/libiniparser.a
|
||||||
%{_libdir}/libiniparser.so
|
%{_libdir}/libiniparser.so
|
||||||
%doc html
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-1mamba
|
||||||
|
- update to 4.2
|
||||||
|
|
||||||
* Wed Feb 07 2018 Automatic Build System <autodist@mambasoft.it> 4.1-1mamba
|
* Wed Feb 07 2018 Automatic Build System <autodist@mambasoft.it> 4.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user