update to 3.1 [release 3.1-1mamba;Sat Dec 01 2012]
This commit is contained in:
parent
091036cd6f
commit
a5ae759042
@ -1,2 +1,4 @@
|
||||
# libiniparser
|
||||
|
||||
Libiniparser offers parsing of ini files from the C level.
|
||||
|
||||
|
41
libiniparser-2.15-shared-library.patch
Normal file
41
libiniparser-2.15-shared-library.patch
Normal file
@ -0,0 +1,41 @@
|
||||
Author: Lars Müller <lmuelle at SuSE dot de>
|
||||
Subject: Build libiniparser as shared library
|
||||
|
||||
--- iniparser-2.15/Makefile
|
||||
+++ iniparser-2.15/Makefile 2006-04-11 17:59:16
|
||||
@@ -4,12 +4,16 @@
|
||||
|
||||
# Compiler settings
|
||||
CC = gcc
|
||||
-CFLAGS = -O3
|
||||
+CFLAGS = -O3 -fPIC
|
||||
|
||||
# Ar settings to build the library
|
||||
AR = ar
|
||||
ARFLAGS = rcv
|
||||
|
||||
+SHLD = ${CC} ${CFLAGS}
|
||||
+LDSHFLAGS = -shared -Wl,-Bsymbolic -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
|
||||
+LDFLAGS = -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
|
||||
+
|
||||
# Set RANLIB to ranlib on systems that require it (Sun OS < 4, Mac OSX)
|
||||
# RANLIB = ranlib
|
||||
RANLIB = true
|
||||
@@ -34,12 +38,16 @@
|
||||
OBJS = $(SRCS:.c=.o)
|
||||
|
||||
|
||||
-default: libiniparser.a
|
||||
+default: libiniparser.a libiniparser.so
|
||||
|
||||
libiniparser.a: $(OBJS)
|
||||
@($(AR) $(ARFLAGS) libiniparser.a $(OBJS))
|
||||
@($(RANLIB) libiniparser.a)
|
||||
|
||||
+libiniparser.so: $(OBJS)
|
||||
+ @$(SHLD) $(LDSHFLAGS) -o $@.0 $(OBJS) $(LDFLAGS) \
|
||||
+ -Wl,-soname=`basename $@`.0
|
||||
+
|
||||
clean:
|
||||
$(RM) $(OBJS)
|
||||
|
74
libiniparser.spec
Normal file
74
libiniparser.spec
Normal file
@ -0,0 +1,74 @@
|
||||
Name: libiniparser
|
||||
Version: 3.1
|
||||
Release: 1mamba
|
||||
Summary: A free stand-alone ini file parsing library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://ndevilla.free.fr/iniparser/
|
||||
Source: http://ndevilla.free.fr/iniparser/iniparser-%{version}.tar.gz
|
||||
Patch: %{name}-2.15-shared-library.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Libiniparser offers parsing of ini files from the C level.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Libiniparser offers parsing of ini files from the C level.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n iniparser
|
||||
|
||||
%build
|
||||
%make
|
||||
%make check
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
install -d %{buildroot}%{_includedir} \
|
||||
%{buildroot}%{_libdir}
|
||||
|
||||
install -m 0755 libiniparser.{a,so.0} %{buildroot}%{_libdir}
|
||||
install -m 0644 src/{dictionary,iniparser}.h %{buildroot}%{_includedir}
|
||||
ln -s libiniparser.so.0 %{buildroot}%{_libdir}/libiniparser.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libiniparser.so.*
|
||||
%doc AUTHORS LICENSE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/dictionary.h
|
||||
%{_includedir}/iniparser.h
|
||||
%{_libdir}/libiniparser.a
|
||||
%{_libdir}/libiniparser.so
|
||||
%doc README html
|
||||
|
||||
%changelog
|
||||
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 3.1-1mamba
|
||||
- update to 3.1
|
||||
|
||||
* Sat May 23 2009 Davide Madrisan <davide.madrisan@gmail.com> 3.0b-1mamba
|
||||
- update to 3.0b
|
||||
|
||||
* Tue Sep 12 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.15-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user