package created using the webbuild interface [release 12.10.1-1mamba;Tue Mar 15 2016]
This commit is contained in:
parent
e68c5408f3
commit
9201bf9e83
@ -1,2 +1,4 @@
|
|||||||
# libindicator
|
# libindicator
|
||||||
|
|
||||||
|
A set of symbols and convience functions that all indicators would like to use. Not of real use outside of the Ayatana indicators project.
|
||||||
|
|
||||||
|
11
libindicator-12.10.1-configure.patch
Normal file
11
libindicator-12.10.1-configure.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libindicator-12.10.1/configure.ac.orig 2016-03-15 18:43:10.329033103 +0100
|
||||||
|
+++ libindicator-12.10.1/configure.ac 2016-03-15 18:43:14.114030335 +0100
|
||||||
|
@@ -66,7 +66,7 @@
|
||||||
|
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
|
||||||
|
|
||||||
|
LT_LIB_M
|
||||||
|
-LIBINDICATOR_LIBS+="$LIBM"
|
||||||
|
+LIBINDICATOR_LIBS+=" $LIBM"
|
||||||
|
|
||||||
|
##############################
|
||||||
|
# Custom Junk
|
11
libindicator-12.10.1-glib-2.46.patch
Normal file
11
libindicator-12.10.1-glib-2.46.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libindicator-12.10.1/libindicator/indicator-image-helper.c.orig 2016-03-15 18:38:25.689252331 +0100
|
||||||
|
+++ libindicator-12.10.1/libindicator/indicator-image-helper.c 2016-03-15 18:38:38.865241612 +0100
|
||||||
|
@@ -69,7 +69,7 @@
|
||||||
|
GdkPixbuf * pixbuf = gdk_pixbuf_new_from_file(icon_filename, &error);
|
||||||
|
|
||||||
|
if (icon_info != NULL) {
|
||||||
|
- gtk_icon_info_free(icon_info);
|
||||||
|
+ g_object_unref(icon_info);
|
||||||
|
}
|
||||||
|
|
||||||
|
if (pixbuf == NULL) {
|
83
libindicator.spec
Normal file
83
libindicator.spec
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
Name: libindicator
|
||||||
|
Version: 12.10.1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A set of symbols and convience functions that all indicators would like to use
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://launchpad.net/libindicator
|
||||||
|
Source: https://launchpad.net/libindicator/%{version}/+download/libindicator-%{version}.tar.gz
|
||||||
|
Patch0: libindicator-12.10.1-configure.patch
|
||||||
|
Patch1: libindicator-12.10.1-glib-2.46.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A set of symbols and convience functions that all indicators would like to use. Not of real use outside of the Ayatana indicators project.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: pkg-config
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --with-gtk=2 LIBM=" -lm"
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libindicator.so.*
|
||||||
|
%{_libexecdir}/indicator-loader
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/libindicator-0.4
|
||||||
|
%dir %{_includedir}/libindicator-0.4/libindicator
|
||||||
|
%{_includedir}/libindicator-0.4/libindicator/*
|
||||||
|
%{_libdir}/libdummy-indicator-*.a
|
||||||
|
%{_libdir}/libdummy-indicator-*.la
|
||||||
|
%{_libdir}/libdummy-indicator-*.so
|
||||||
|
%{_libdir}/libindicator.a
|
||||||
|
%{_libdir}/libindicator.la
|
||||||
|
%{_libdir}/libindicator.so
|
||||||
|
%{_libdir}/pkgconfig/indicator-0.4.pc
|
||||||
|
%{_datadir}/libindicator/80indicator-debugging
|
||||||
|
%doc ChangeLog NEWS
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Mar 15 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.1-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user