rebuilt as legacy package [release 2.0.1-4mamba;Fri Dec 27 2013]
This commit is contained in:
parent
d48d696b25
commit
335582d952
11
libilmbase-1.0.1-no_undefined.patch
Normal file
11
libilmbase-1.0.1-no_undefined.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ilmbase-1.0.1/m4/threads.m4 2006-12-13 23:51:56.000000000 +0100
|
||||
+++ ilmbase-1.0.1/m4/threads.m4.noundef 2010-03-07 18:08:50.000000000 +0100
|
||||
@@ -87,7 +87,7 @@
|
||||
# which indicates that we try without any flags at all, and "pthread-config"
|
||||
# which is a program returning the flags for the Pth emulation library.
|
||||
|
||||
-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
|
||||
+acx_pthread_flags="pthreads none -Kthread -kthread lthread pthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
|
||||
|
||||
# The ordering *is* (sometimes) important. Some notes on the
|
||||
# individual items follow:
|
11
libilmbase-1.0.2-gcc4_fix_include.patch
Normal file
11
libilmbase-1.0.2-gcc4_fix_include.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -Nru ilmbase-1.0.2.orig//Imath/ImathMatrix.h ilmbase-1.0.2/Imath/ImathMatrix.h
|
||||
--- ilmbase-1.0.2.orig//Imath/ImathMatrix.h 2010-07-17 00:48:40.000000000 +0200
|
||||
+++ ilmbase-1.0.2/Imath/ImathMatrix.h 2010-08-22 15:23:29.821253349 +0200
|
||||
@@ -51,6 +51,7 @@
|
||||
|
||||
#include <iostream>
|
||||
#include <iomanip>
|
||||
+#include <string.h>
|
||||
|
||||
#if (defined _WIN32 || defined _WIN64) && defined _MSC_VER
|
||||
// suppress exception specification warnings
|
12
libilmbase-2.0.1-arm_HAVE_UCONTEXT.patch
Normal file
12
libilmbase-2.0.1-arm_HAVE_UCONTEXT.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN a/IexMath/IexMathFpu.cpp b/IexMath/IexMathFpu.cpp
|
||||
--- a/IexMath/IexMathFpu.cpp 2013-03-06 16:18:50.000000000 -0700
|
||||
+++ b/IexMath/IexMathFpu.cpp 2013-04-20 19:45:33.400749953 -0600
|
||||
@@ -53,7 +53,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#ifdef HAVE_UCONTEXT_H
|
||||
+#if defined(HAVE_UCONTEXT_H) && (defined(__x86_64__) || defined(__i386__))
|
||||
|
||||
|
||||
#include <ucontext.h>
|
143
libilmbase2.spec
Normal file
143
libilmbase2.spec
Normal file
@ -0,0 +1,143 @@
|
||||
Name: libilmbase2
|
||||
Version: 2.0.1
|
||||
Release: 4mamba
|
||||
Summary: OpenEXR ilmbase library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.openexr.com
|
||||
Source: http://download.savannah.nongnu.org/releases/openexr/ilmbase-%{version}.tar.gz
|
||||
Patch0: libilmbase-1.0.1-no_undefined.patch
|
||||
Patch1: libilmbase-1.0.2-gcc4_fix_include.patch
|
||||
Patch2: libilmbase-2.0.1-arm_HAVE_UCONTEXT.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%ifarch x86_64
|
||||
Provides: libIex-2_0.so.10()(64bit)
|
||||
Provides: libIexMath-2_0.so.10()(64bit)
|
||||
Provides: libIlmThread-2_0.so.10()(64bit)
|
||||
Provides: libImath-2_0.so.10()(64bit)
|
||||
%else
|
||||
Provides: libIex-2_0.so.10
|
||||
Provides: libIexMath-2_0.so.10
|
||||
Provides: libIlmThread-2_0.so.10
|
||||
Provides: libImath-2_0.so.10
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
OpenEXR ilmbase library.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
OpenEXR ilmbase library.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n ilmbase-%{version}
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
|
||||
|
||||
%build
|
||||
# for patch0
|
||||
./bootstrap
|
||||
|
||||
%configure \
|
||||
--enable-namespaceversioning=no
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
# compatibility symlinks due to previous release with namespaceversioning enabled
|
||||
for l in Half Iex IexMath IlmThread Imath; do
|
||||
ln -s lib$l.so.10 %{buildroot}%{_libdir}/lib$l-2_0.so.10
|
||||
done
|
||||
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libHalf.so.*
|
||||
%{_libdir}/libIex.so.*
|
||||
%{_libdir}/libIexMath.so.*
|
||||
%{_libdir}/libIlmThread.so.*
|
||||
%{_libdir}/libImath.so.*
|
||||
%{_libdir}/libHalf-2_0.so.10
|
||||
%{_libdir}/libIex-2_0.so.10
|
||||
%{_libdir}/libIexMath-2_0.so.10
|
||||
%{_libdir}/libIlmThread-2_0.so.10
|
||||
%{_libdir}/libImath-2_0.so.10
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/OpenEXR/*.h
|
||||
%{_libdir}/libHalf.a
|
||||
%{_libdir}/libHalf.la
|
||||
%{_libdir}/libHalf.so
|
||||
%{_libdir}/libIex.a
|
||||
%{_libdir}/libIex.la
|
||||
%{_libdir}/libIex.so
|
||||
%{_libdir}/libIexMath.a
|
||||
%{_libdir}/libIexMath.la
|
||||
%{_libdir}/libIexMath.so
|
||||
%{_libdir}/libIlmThread.a
|
||||
%{_libdir}/libIlmThread.la
|
||||
%{_libdir}/libIlmThread.so
|
||||
%{_libdir}/libImath.a
|
||||
%{_libdir}/libImath.la
|
||||
%{_libdir}/libImath.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog LICENSE NEWS README README.CVS
|
||||
|
||||
%changelog
|
||||
* Fri Dec 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-4mamba
|
||||
- rebuilt as legacy package
|
||||
|
||||
* Sat Jul 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-3mamba
|
||||
- rebuilt with --enable-namespaceversioning=no to keep standard library soname
|
||||
|
||||
* Thu Jul 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-2mamba
|
||||
- added compatibility symlinks to allow upgrade from version 2.0.0 without making a legacy package
|
||||
|
||||
* Sun Jul 14 2013 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Mar 14 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Aug 22 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-2mamba
|
||||
- added patch to fix a missing include for openexr to build successfully
|
||||
|
||||
* Sat Jul 24 2010 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Mar 07 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.0.1-4mamba
|
||||
- patched to fix several undefined reference errors at link time
|
||||
- remove documentation for osx and windows platforms
|
||||
|
||||
* Thu Jun 11 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-2mamba
|
||||
- rebuilt
|
||||
|
||||
* Wed Jun 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-1mamba
|
||||
- package created by autospec
|
Reference in New Issue
Block a user