added patch to build with gcc 4.3 [release 3.8.3-5mamba;Fri Apr 30 2010]

This commit is contained in:
Silvan Calarco 2024-01-06 04:37:22 +01:00
parent 8b2fd17b6b
commit 906e27ad50
3 changed files with 182 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libid3 # libid3
A software development library for reading, writing, and manipulating ID3v1 and ID3v2 tags.

102
libid3-3.8.3-gcc43-1.patch Normal file
View File

@ -0,0 +1,102 @@
Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
Date: 2008-11-21
Initial Package Version: 3.8.3
Upstream Status: unknown
Origin: fedora
Description: Allows it to compile with gcc-4.3.
diff -up id3lib-3.8.3/include/id3/id3lib_strings.h~ id3lib-3.8.3/include/id3/id3lib_strings.h
--- id3lib-3.8.3/include/id3/id3lib_strings.h~ 2003-03-02 02:23:00.000000000 +0200
+++ id3lib-3.8.3/include/id3/id3lib_strings.h 2008-01-04 01:30:52.000000000 +0200
@@ -29,6 +29,7 @@
#ifndef _ID3LIB_STRINGS_H_
#define _ID3LIB_STRINGS_H_
+#include <cstring>
#include <string>
#if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
diff -up id3lib-3.8.3/configure.in~ id3lib-3.8.3/configure.in
--- id3lib-3.8.3/configure.in~ 2008-01-04 11:39:01.000000000 +0100
+++ id3lib-3.8.3/configure.in 2008-01-04 11:39:01.000000000 +0100
@@ -227,7 +227,6 @@ AC_CHECK_HEADERS(fstream iostream iomani
)
AC_CHECK_HEADERS( \
string \
- iomanip.h \
,,AC_MSG_ERROR([Missing a vital header file for id3lib])
)
diff -up id3lib-3.8.3/configure~ id3lib-3.8.3/configure
--- id3lib-3.8.3/configure~ 2008-01-04 11:39:10.000000000 +0100
+++ id3lib-3.8.3/configure 2008-01-04 11:39:10.000000000 +0100
@@ -22976,7 +22976,6 @@ done
for ac_header in \
string \
- iomanip.h \
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
diff -up id3lib-3.8.3/include/id3/writers.h~ id3lib-3.8.3/include/id3/writers.h
--- id3lib-3.8.3/include/id3/writers.h~ 2008-01-04 11:59:39.000000000 +0100
+++ id3lib-3.8.3/include/id3/writers.h 2008-01-04 11:59:39.000000000 +0100
@@ -28,9 +28,9 @@
#ifndef _ID3LIB_WRITERS_H_
#define _ID3LIB_WRITERS_H_
+#include <cstring>
#include "id3/writer.h"
#include "id3/id3lib_streams.h"
-//#include <string.h>
class ID3_CPP_EXPORT ID3_OStreamWriter : public ID3_Writer
{
diff -up id3lib-3.8.3/examples/demo_info.cpp~ id3lib-3.8.3/examples/demo_info.cpp
--- id3lib-3.8.3/examples/demo_info.cpp~ 2008-01-04 12:00:56.000000000 +0100
+++ id3lib-3.8.3/examples/demo_info.cpp 2008-01-04 12:00:56.000000000 +0100
@@ -309,7 +309,7 @@ void PrintInformation(const ID3_Tag &myT
#define DEBUG
-int main( unsigned int argc, char * const argv[])
+int main(int argc, char * const argv[])
{
ID3D_INIT_DOUT();
diff -up id3lib-3.8.3/examples/demo_copy.cpp~ id3lib-3.8.3/examples/demo_copy.cpp
--- id3lib-3.8.3/examples/demo_copy.cpp~ 2008-01-04 12:01:26.000000000 +0100
+++ id3lib-3.8.3/examples/demo_copy.cpp 2008-01-04 12:01:26.000000000 +0100
@@ -81,7 +81,7 @@ void DisplayTags(ostream &os, luint nTag
}
}
-int main( unsigned int argc, char * const argv[])
+int main(int argc, char * const argv[])
{
int ulFlag = ID3TT_ID3;
ID3D_INIT_DOUT();
diff -up id3lib-3.8.3/examples/demo_convert.cpp~ id3lib-3.8.3/examples/demo_convert.cpp
--- id3lib-3.8.3/examples/demo_convert.cpp~ 2008-01-04 12:01:20.000000000 +0100
+++ id3lib-3.8.3/examples/demo_convert.cpp 2008-01-04 12:01:20.000000000 +0100
@@ -84,7 +84,7 @@ void DisplayTags(ostream &os, luint nTag
}
}
-int main( unsigned int argc, char * const argv[])
+int main(int argc, char * const argv[])
{
flags_t ulFlag = ID3TT_ALL;
gengetopt_args_info args;
diff -up id3lib-3.8.3/examples/demo_tag.cpp~ id3lib-3.8.3/examples/demo_tag.cpp
--- id3lib-3.8.3/examples/demo_tag.cpp~ 2008-01-04 12:01:41.000000000 +0100
+++ id3lib-3.8.3/examples/demo_tag.cpp 2008-01-04 12:01:41.000000000 +0100
@@ -46,7 +46,7 @@ void DisplayTags(ostream &os, luint nTag
os << "v2";
}
-int main( unsigned int argc, char * const argv[])
+int main(int argc, char * const argv[])
{
int ulFlag = ID3TT_ID3;
ID3D_INIT_DOUT();

78
libid3.spec Normal file
View File

@ -0,0 +1,78 @@
Name: libid3
Version: 3.8.3
Release: 5mamba
Summary: A software development library for reading, writing, and manipulating ID3v1 and ID3v2 tags
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.id3lib.org/
Source: http://cesnet.dl.sourceforge.net/sourceforge/id3lib/id3lib-%{version}.tar.gz
Patch0: %{name}-3.8.3-gcc43-1.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
A software development library for reading, writing, and manipulating ID3v1 and ID3v2 tags.
%package devel
Summary: Header files and static library for development with libid3
Group: Development/Libraries
Requires: %{name} = %{version}
%description devel
A software development library for reading, writing, and manipulating ID3v1 and ID3v2 tags.
This package contains static libraries and header files need for development.
%prep
%setup -q -n id3lib-%{version}
%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/*.so.*
%files devel
%defattr(-, root, root)
%{_libdir}/*.a
%{_libdir}/*.la
%{_libdir}/*.so
%{_includedir}/*.h
%dir %{_includedir}/id3
%{_includedir}/id3/*.h
%changelog
* Fri Apr 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.3-5mamba
- added patch to build with gcc 4.3
* Sun Jun 01 2008 Silvan Calarco <silvan.o at mambasoft.it> 3.8.3-4mamba
- specfile updated
* Mon Mar 27 2006 Stefano Cotta Ramusino <stefano.a at qilinux.it> 3.8.3-3qilnx
- specfile fixed and updated
- fixed license
* Sun Jan 30 2005 Silvan Calarco <silvan.o at mambasoft.it> 3.8.3-2qilnx
- rebuilt with new gcc 3.4 and glibc 2.3.4
* Sun Dec 21 2003 Silvan Calarco <silvan.o at mambasoft.it> 3.8.3-1qilnx
- first build