automatic version update by autodist [release 1.18.1-1mamba;Tue Jul 23 2024]
This commit is contained in:
parent
6383e6602b
commit
114bfbb288
@ -1,22 +0,0 @@
|
|||||||
From a911b26a902c5f89fee2dc20ac4dfaafcb8144ec Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andrey Semashev <Lastique@users.noreply.github.com>
|
|
||||||
Date: Fri, 15 Mar 2024 17:46:48 +0300
|
|
||||||
Subject: [PATCH] Fix compilation with libsvtav1 2.0.0.
|
|
||||||
|
|
||||||
---
|
|
||||||
libheif/plugins/encoder_svt.cc | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/libheif/plugins/encoder_svt.cc b/libheif/plugins/encoder_svt.cc
|
|
||||||
index 4597d7b8fc..1ff3bce2d5 100644
|
|
||||||
--- a/libheif/plugins/encoder_svt.cc
|
|
||||||
+++ b/libheif/plugins/encoder_svt.cc
|
|
||||||
@@ -646,7 +646,7 @@ struct heif_error svt_encode_image(void* encoder_raw, const struct heif_image* i
|
|
||||||
|
|
||||||
if (nclx) {
|
|
||||||
svt_config.color_description_present_flag = true;
|
|
||||||
-#if SVT_AV1_VERSION_MAJOR == 1
|
|
||||||
+#if SVT_AV1_VERSION_MAJOR >= 1
|
|
||||||
svt_config.color_primaries = static_cast<EbColorPrimaries>(nclx->color_primaries);
|
|
||||||
svt_config.transfer_characteristics = static_cast<EbTransferCharacteristics>(nclx->transfer_characteristics);
|
|
||||||
svt_config.matrix_coefficients = static_cast<EbMatrixCoefficients>(nclx->matrix_coefficients);
|
|
14
libheif.spec
14
libheif.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libheif
|
Name: libheif
|
||||||
Version: 1.17.6
|
Version: 1.18.1
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: An HEIF and AVIF file format decoder and encoder
|
Summary: An HEIF and AVIF file format decoder and encoder
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/strukturag/libheif
|
URL: https://github.com/strukturag/libheif
|
||||||
Source: https://github.com/strukturag/libheif.git/v%{version}/libheif-%{version}.tar.bz2
|
Source: https://github.com/strukturag/libheif.git/v%{version}/libheif-%{version}.tar.bz2
|
||||||
Patch0: libheif-1.17.6-svt-av1-2.0.0.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -23,6 +22,7 @@ BuildRequires: libpng-devel
|
|||||||
BuildRequires: librav1e-devel
|
BuildRequires: librav1e-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libsvt-av1-devel
|
BuildRequires: libsvt-av1-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libx265-devel
|
BuildRequires: libx265-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
@ -56,7 +56,6 @@ This package contains utility applications for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 0 -p1 -b .svt-av1-2.0.0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -97,16 +96,17 @@ This package contains utility applications for %{name}.
|
|||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/heif-convert
|
%{_bindir}/heif-dec
|
||||||
%{_bindir}/heif-enc
|
%{_bindir}/heif-enc
|
||||||
%{_bindir}/heif-info
|
%{_bindir}/heif-info
|
||||||
%{_bindir}/heif-thumbnailer
|
%{_bindir}/heif-thumbnailer
|
||||||
#%{_datadir}/mime/packages/avif.xml
|
|
||||||
#%{_datadir}/mime/packages/heif.xml
|
|
||||||
%{_datadir}/thumbnailers/heif.thumbnailer
|
%{_datadir}/thumbnailers/heif.thumbnailer
|
||||||
%{_mandir}/man1/heif-*.1*
|
%{_mandir}/man1/heif-*.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 23 2024 Automatic Build System <autodist@openmamba.org> 1.18.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri May 03 2024 Automatic Build System <autodist@mambasoft.it> 1.17.6-2mamba
|
* Fri May 03 2024 Automatic Build System <autodist@mambasoft.it> 1.17.6-2mamba
|
||||||
- rebuilt by autoport with build requirements: libsvt-av1-devel>=2.0.0-1mamba
|
- rebuilt by autoport with build requirements: libsvt-av1-devel>=2.0.0-1mamba
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user