rebuilt in devel [release 0.8-2mamba;Fri Feb 25 2011]

This commit is contained in:
Silvan Calarco 2024-01-06 04:35:19 +01:00
parent 7e8738aaec
commit 6a836e9323
3 changed files with 121 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libgypsy
Gypsy is a GPS multiplexing daemon which allows multiple clients to access GPS data from multiple GPS sources concurrently.

14
gypsy-0.8-gcc-4.7.patch Normal file
View File

@ -0,0 +1,14 @@
diff -up gypsy-0.8/gypsy/gypsy-time.c.unusedvar gypsy-0.8/gypsy/gypsy-time.c
--- gypsy-0.8/gypsy/gypsy-time.c.unusedvar 2011-03-13 12:12:43.000000000 +0000
+++ gypsy-0.8/gypsy/gypsy-time.c 2011-03-13 12:23:38.000000000 +0000
@@ -155,7 +155,9 @@ get_property (GObject *object,
GValue *value,
GParamSpec *pspec)
{
- GypsyTimePrivate *priv;
+ /* KH: gcc complains about unused var, not sure if GET_PRIVATE hasn't some side effects,
+ * marking that as unused only so that gcc doesn't bail out anymore */
+ __attribute__((__unused__)) GypsyTimePrivate *priv;
priv = GET_PRIVATE (object);
switch (prop_id) {

105
libgypsy.spec Normal file
View File

@ -0,0 +1,105 @@
Name: libgypsy
Version: 0.8
Release: 2mamba
Summary: A GPS Multiplexing Daemon
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://gypsy.freedesktop.org/wiki/
Source: http://gypsy.freedesktop.org/gypsy-releases/gypsy-%{version}.tar.gz
Patch0: gypsy-0.8-gcc-4.7.patch
License: GPL, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbluetooth-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libglib-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Gypsy is a GPS multiplexing daemon which allows multiple clients to access GPS data from multiple GPS sources concurrently.
%package apidocs
Group: Documentation
Summary: %{name} API documentation
%description apidocs
Gypsy is a GPS multiplexing daemon which allows multiple clients to access GPS data from multiple GPS sources concurrently.
This package contains %{name} API documentation.
%package devel
Group: Development/Libraries
Summary: Libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Gypsy is a GPS multiplexing daemon which allows multiple clients to access GPS data from multiple GPS sources concurrently.
This package contains libraries and header files need for development.
%package static
Group: Development/Libraries
Summary: Static libraries for %{name}
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
%description static
Gypsy is a GPS multiplexing daemon which allows multiple clients to access GPS data from multiple GPS sources concurrently.
This package contains static libraries need for development.
%prep
%setup -q -n gypsy-%{version}
%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_sysconfdir}/dbus-1/system.d/Gypsy.conf
%{_libexecdir}/gypsy-daemon
%{_datadir}/dbus-1/system-services/org.freedesktop.Gypsy.service
%{_libdir}/libgypsy.so.*
%doc AUTHORS COPYING COPYING.lib LICENSE
%files apidocs
%defattr(-,root,root)
%dir %{_datadir}/gtk-doc/html/gypsy
%{_datadir}/gtk-doc/html/gypsy/*
%files devel
%defattr(-,root,root)
%dir %{_includedir}/gypsy
%{_includedir}/gypsy/*.h
%{_libdir}/libgypsy.so
%{_libdir}/pkgconfig/gypsy.pc
%files static
%defattr(-,root,root)
%{_libdir}/libgypsy.a
%{_libdir}/libgypsy.la
%changelog
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8-2mamba
- rebuilt in devel
* Tue Nov 09 2010 gil <puntogil@libero.it> 0.8-1mamba
- update to 0.8
* Wed Apr 01 2009 gil <puntogil@libero.it> 0.6-1mamba
- package created by autospec