legacy package [release 1.2.0-4mamba;Mon Sep 11 2023]
This commit is contained in:
parent
5f9811b3d6
commit
1c9973526b
@ -1,2 +1,4 @@
|
||||
# libgupnp-igd10
|
||||
|
||||
A library to handle Internet Gateway Device port mappings.
|
||||
|
||||
|
113
libgupnp-igd-1.2.0-gupnp-1.6.patch
Normal file
113
libgupnp-igd-1.2.0-gupnp-1.6.patch
Normal file
@ -0,0 +1,113 @@
|
||||
From 79a1e4cf8c256132978a1d8ab718c8ad132386de Mon Sep 17 00:00:00 2001
|
||||
From: Jens Georg <mail@jensge.org>
|
||||
Date: Tue, 3 May 2022 22:39:16 +0200
|
||||
Subject: [PATCH] Port to GUPnP 1.6 API
|
||||
|
||||
And thus to libsoup3. The code changes are even compatible with GUPnP
|
||||
1.4.3 so the gupnp version could be a configure option
|
||||
---
|
||||
NEWS | 2 +-
|
||||
README | 4 ++--
|
||||
libgupnp-igd/meson.build | 2 +-
|
||||
meson.build | 6 +++---
|
||||
subprojects/.gitignore | 4 ++--
|
||||
subprojects/{gupnp-1.2.wrap => gupnp-1.6.wrap} | 2 +-
|
||||
tests/gtest/gupnp-simple-igd.c | 6 +++---
|
||||
7 files changed, 13 insertions(+), 13 deletions(-)
|
||||
rename subprojects/{gupnp-1.2.wrap => gupnp-1.6.wrap} (76%)
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index 5979f6d..eabb318 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,5 +1,5 @@
|
||||
*******************
|
||||
-* GUPnP IGD 1.20 *
|
||||
+* GUPnP IGD 1.2.0 *
|
||||
*******************
|
||||
|
||||
- Switch to GUPnP 1.2.0 API
|
||||
diff --git a/README b/README
|
||||
index 4b74b6f..09884d2 100644
|
||||
--- a/README
|
||||
+++ b/README
|
||||
@@ -1,9 +1,9 @@
|
||||
This is a library to handle UPnP IGD port mapping.
|
||||
|
||||
-It was written by Olivier Crête <olivier.crete@collabora.co.uk>.
|
||||
+It was written by Olivier Crête <olivier.crete@collabora.com>.
|
||||
|
||||
It is supposed to have a very simple API. Read the gtk-doc.
|
||||
|
||||
The only dependencies are:
|
||||
- - GUPnP 1.2
|
||||
+ - GUPnP 1.6
|
||||
- GLib 2.38
|
||||
diff --git a/libgupnp-igd/meson.build b/libgupnp-igd/meson.build
|
||||
index c37ef3d..6dcd394 100644
|
||||
--- a/libgupnp-igd/meson.build
|
||||
+++ b/libgupnp-igd/meson.build
|
||||
@@ -38,7 +38,7 @@ pkg.generate(
|
||||
subdirs : 'gupnp-igd-1.0',
|
||||
filebase : 'gupnp-igd-1.0',
|
||||
description: 'GUPnP Simple IGD library',
|
||||
- requires_private : 'gupnp-1.2'
|
||||
+ requires_private : 'gupnp-1.6'
|
||||
)
|
||||
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index df2fb24..8377d01 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1,4 +1,4 @@
|
||||
-project('gupnp-igd', 'c', version: '1.2.0')
|
||||
+project('gupnp-igd', 'c', version: '1.5.0')
|
||||
|
||||
gnome = import('gnome')
|
||||
pkg = import('pkgconfig')
|
||||
@@ -7,8 +7,8 @@ glib_req = '>= 2.38'
|
||||
dependencies = [
|
||||
dependency('glib-2.0', version: glib_req, required: true),
|
||||
dependency('gobject-2.0', version: glib_req, required: true),
|
||||
- dependency('gupnp-1.2', version : '>= 1.2.0'),
|
||||
- dependency('gssdp-1.2', version : '>= 1.2.0'),
|
||||
+ dependency('gupnp-1.6', version : '>= 1.5.0'),
|
||||
+ dependency('gssdp-1.6', version : '>= 1.5.0'),
|
||||
dependency('gthread-2.0', required: true)
|
||||
]
|
||||
|
||||
diff --git a/tests/gtest/gupnp-simple-igd.c b/tests/gtest/gupnp-simple-igd.c
|
||||
index 593c46e..ec770ca 100644
|
||||
--- a/tests/gtest/gupnp-simple-igd.c
|
||||
+++ b/tests/gtest/gupnp-simple-igd.c
|
||||
@@ -88,7 +88,7 @@ get_external_ip_address_cb (GUPnPService *service,
|
||||
else
|
||||
g_assert_not_reached ();
|
||||
|
||||
- gupnp_service_action_return (action);
|
||||
+ gupnp_service_action_return_success (action);
|
||||
|
||||
}
|
||||
|
||||
@@ -139,7 +139,7 @@ add_port_mapping_cb (GUPnPService *service,
|
||||
if (return_conflict && external_port == INTERNAL_PORT)
|
||||
gupnp_service_action_return_error (action, 718, "ConflictInMappingEntry");
|
||||
else
|
||||
- gupnp_service_action_return (action);
|
||||
+ gupnp_service_action_return_success (action);
|
||||
}
|
||||
|
||||
static gboolean
|
||||
@@ -172,7 +172,7 @@ delete_port_mapping_cb (GUPnPService *service,
|
||||
g_assert (external_port != INTERNAL_PORT);
|
||||
g_assert (proto && !strcmp (proto, "UDP"));
|
||||
|
||||
- gupnp_service_action_return (action);
|
||||
+ gupnp_service_action_return_success (action);
|
||||
|
||||
g_free (remote_host);
|
||||
g_free (proto);
|
||||
--
|
||||
GitLab
|
||||
|
116
libgupnp-igd10.spec
Normal file
116
libgupnp-igd10.spec
Normal file
@ -0,0 +1,116 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: libgupnp-igd10
|
||||
Version: 1.2.0
|
||||
Release: 4mamba
|
||||
Summary: A library to handle Internet Gateway Device port mappings
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://wiki.gnome.org/Projects/GUPnP
|
||||
Source: https://download.gnome.org/sources/gupnp-igd/%{majver}/gupnp-igd-%{version}.tar.xz
|
||||
Patch0: libgupnp-igd-1.2.0-gupnp-1.6.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgssdp-devel
|
||||
BuildRequires: libgupnp-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgupnp-devel >= 1.6.0
|
||||
|
||||
%description
|
||||
A library to handle Internet Gateway Device port mappings.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
A library to handle Internet Gateway Device port mappings.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n gupnp-igd-%{version}
|
||||
%patch0 -p1 -b .gupnp-1.6
|
||||
|
||||
%build
|
||||
%meson
|
||||
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%meson_install
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libgupnp-igd-1.0.so.*
|
||||
%{_libdir}/girepository-1.0/GUPnPIgd-1.0.typelib
|
||||
#%{python_sitearch}/gupnp/__init__.py*
|
||||
#%{python_sitearch}/gupnp/igd.a
|
||||
#%{python_sitearch}/gupnp/igd.la
|
||||
#%{python_sitearch}/gupnp/igd.so
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/gupnp-igd-1.0/libgupnp-igd/*.h
|
||||
%{_libdir}/libgupnp-igd-1.0.so
|
||||
#%{_datadir}/gtk-doc/html/gupnp-igd/*
|
||||
%{_datadir}/gir-1.0/GUPnPIgd-1.0.gir
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
#%doc NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Mon Sep 11 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-4mamba
|
||||
- legacy package
|
||||
|
||||
* Tue Sep 27 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-3mamba
|
||||
- rebuilt with libgupnp 1.6.0
|
||||
|
||||
* Wed Aug 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-2mamba
|
||||
- rebuilt with libgupnp 1.4.3
|
||||
|
||||
* Thu Sep 24 2020 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Dec 18 2017 Automatic Build System <autodist@mambasoft.it> 0.2.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Oct 01 2014 Automatic Build System <autodist@mambasoft.it> 0.2.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Feb 08 2014 Automatic Build System <autodist@mambasoft.it> 0.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-2mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Fri Nov 23 2012 Automatic Build System <autodist@mambasoft.it> 0.2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 17 2012 Automatic Build System <autodist@mambasoft.it> 0.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Sep 27 2012 Automatic Build System <autodist@mambasoft.it> 0.2.0-1mamba
|
||||
- update to 0.2.0
|
||||
|
||||
* Sun Jun 27 2010 Automatic Build System <autodist@mambasoft.it> 0.1.7-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun May 09 2010 Automatic Build System <autodist@mambasoft.it> 0.1.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Nov 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.4-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user