update to 3.24.41
added triggers to gtk-query-immodules-3.0 [release 3.24.41-1mamba;Sun Apr 21 2024]
This commit is contained in:
parent
5161910495
commit
b139ae1abd
@ -1,327 +0,0 @@
|
||||
diff -up gtk+-2.91.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.91.3/gtk/gtktooltip.c
|
||||
--- gtk+-2.91.3/gtk/gtktooltip.c.fresh-tooltips 2010-10-31 14:28:19.000000000 -0400
|
||||
+++ gtk+-2.91.3/gtk/gtktooltip.c 2010-11-01 14:12:41.027410023 -0400
|
||||
@@ -35,6 +35,9 @@
|
||||
#include "gtkalignment.h"
|
||||
#include "gtksizerequest.h"
|
||||
|
||||
+#ifdef GDK_WINDOWING_X11
|
||||
+#include "gdk/x11/gdkx.h"
|
||||
+#endif
|
||||
|
||||
/**
|
||||
* SECTION:gtktooltip
|
||||
@@ -165,6 +168,7 @@ static void gtk_tooltip_display_cl
|
||||
GtkTooltip *tooltip);
|
||||
static void gtk_tooltip_set_last_window (GtkTooltip *tooltip,
|
||||
GdkWindow *window);
|
||||
+static void update_shape (GtkTooltip *tooltip);
|
||||
|
||||
|
||||
G_DEFINE_TYPE (GtkTooltip, gtk_tooltip, G_TYPE_OBJECT);
|
||||
@@ -180,6 +184,40 @@ gtk_tooltip_class_init (GtkTooltipClass
|
||||
}
|
||||
|
||||
static void
|
||||
+on_composited_changed (GtkWidget *window,
|
||||
+ GtkTooltip *tooltip)
|
||||
+{
|
||||
+ update_shape (tooltip);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+on_screen_changed (GtkWidget *window,
|
||||
+ GdkScreen *previous,
|
||||
+ GtkTooltip *tooltip)
|
||||
+{
|
||||
+ GdkScreen *screen;
|
||||
+ GdkVisual *visual;
|
||||
+
|
||||
+ screen = gtk_widget_get_screen (window);
|
||||
+
|
||||
+
|
||||
+ visual = NULL;
|
||||
+ if (gdk_screen_is_composited (screen))
|
||||
+ visual = gdk_screen_get_rgba_visual (screen);
|
||||
+ if (visual == NULL)
|
||||
+ visual = gdk_screen_get_system_visual (screen);
|
||||
+
|
||||
+ gtk_widget_set_visual (window, visual);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+on_realized (GtkWidget *window,
|
||||
+ GtkTooltip *tooltip)
|
||||
+{
|
||||
+ update_shape (tooltip);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
gtk_tooltip_init (GtkTooltip *tooltip)
|
||||
{
|
||||
GtkStyle *style;
|
||||
@@ -199,8 +237,12 @@ gtk_tooltip_init (GtkTooltip *tooltip)
|
||||
tooltip->last_window = NULL;
|
||||
|
||||
tooltip->window = g_object_ref (gtk_window_new (GTK_WINDOW_POPUP));
|
||||
+
|
||||
+ on_screen_changed (tooltip->window, NULL, tooltip);
|
||||
+
|
||||
gtk_window_set_type_hint (GTK_WINDOW (tooltip->window),
|
||||
GDK_WINDOW_TYPE_HINT_TOOLTIP);
|
||||
+
|
||||
gtk_widget_set_app_paintable (tooltip->window, TRUE);
|
||||
gtk_window_set_resizable (GTK_WINDOW (tooltip->window), FALSE);
|
||||
gtk_widget_set_name (tooltip->window, "gtk-tooltip");
|
||||
@@ -234,6 +276,13 @@ gtk_tooltip_init (GtkTooltip *tooltip)
|
||||
gtk_box_pack_start (GTK_BOX (tooltip->box), tooltip->label,
|
||||
FALSE, FALSE, 0);
|
||||
|
||||
+ g_signal_connect (tooltip->window, "composited-changed",
|
||||
+ G_CALLBACK (on_composited_changed), tooltip);
|
||||
+ g_signal_connect (tooltip->window, "screen-changed",
|
||||
+ G_CALLBACK (on_screen_changed), tooltip);
|
||||
+ g_signal_connect (tooltip->window, "realize",
|
||||
+ G_CALLBACK (on_realized), tooltip);
|
||||
+
|
||||
tooltip->custom_widget = NULL;
|
||||
}
|
||||
|
||||
@@ -583,19 +632,209 @@ gtk_tooltip_window_style_set (GtkTooltip
|
||||
gtk_widget_queue_draw (tooltip->window);
|
||||
}
|
||||
|
||||
+static void
|
||||
+draw_round_rect (cairo_t *cr,
|
||||
+ gdouble aspect,
|
||||
+ gdouble x,
|
||||
+ gdouble y,
|
||||
+ gdouble corner_radius,
|
||||
+ gdouble width,
|
||||
+ gdouble height)
|
||||
+{
|
||||
+ gdouble radius = corner_radius / aspect;
|
||||
+
|
||||
+ cairo_move_to (cr, x + radius, y);
|
||||
+
|
||||
+ /* top-right, left of the corner */
|
||||
+ cairo_line_to (cr, x + width - radius, y);
|
||||
+
|
||||
+ /* top-right, below the corner */
|
||||
+ cairo_arc (cr,
|
||||
+ x + width - radius, y + radius, radius,
|
||||
+ -90.0f * G_PI / 180.0f, 0.0f * G_PI / 180.0f);
|
||||
+
|
||||
+ /* bottom-right, above the corner */
|
||||
+ cairo_line_to (cr, x + width, y + height - radius);
|
||||
+
|
||||
+ /* bottom-right, left of the corner */
|
||||
+ cairo_arc (cr,
|
||||
+ x + width - radius, y + height - radius, radius,
|
||||
+ 0.0f * G_PI / 180.0f, 90.0f * G_PI / 180.0f);
|
||||
+
|
||||
+ /* bottom-left, right of the corner */
|
||||
+ cairo_line_to (cr, x + radius, y + height);
|
||||
+
|
||||
+ /* bottom-left, above the corner */
|
||||
+ cairo_arc (cr,
|
||||
+ x + radius, y + height - radius, radius,
|
||||
+ 90.0f * G_PI / 180.0f, 180.0f * G_PI / 180.0f);
|
||||
+
|
||||
+ /* top-left, below the corner */
|
||||
+ cairo_line_to (cr, x, y + radius);
|
||||
+
|
||||
+ /* top-left, right of the corner */
|
||||
+ cairo_arc (cr,
|
||||
+ x + radius, y + radius, radius,
|
||||
+ 180.0f * G_PI / 180.0f, 270.0f * G_PI / 180.0f);
|
||||
+
|
||||
+ cairo_close_path (cr);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+fill_background (GtkWidget *widget,
|
||||
+ cairo_t *cr)
|
||||
+{
|
||||
+ GdkColor color;
|
||||
+ gdouble r, g, b;
|
||||
+ gint radius;
|
||||
+ gdouble background_alpha;
|
||||
+ GtkStyle *style;
|
||||
+ GtkAllocation allocation;
|
||||
+
|
||||
+ if (gdk_screen_is_composited (gtk_widget_get_screen (widget)))
|
||||
+ background_alpha = 0.90;
|
||||
+ else
|
||||
+ background_alpha = 1.0;
|
||||
+
|
||||
+ style = gtk_widget_get_style (widget);
|
||||
+
|
||||
+ radius = MIN (style->xthickness, style->ythickness);
|
||||
+ radius = MAX (radius, 1);
|
||||
+
|
||||
+ cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
|
||||
+ cairo_paint (cr);
|
||||
+ cairo_set_operator (cr, CAIRO_OPERATOR_OVER);
|
||||
+
|
||||
+ gtk_widget_get_allocation (widget, &allocation);
|
||||
+
|
||||
+ draw_round_rect (cr,
|
||||
+ 1.0, 0.5, 0.5, radius,
|
||||
+ allocation.width - 1,
|
||||
+ allocation.height - 1);
|
||||
+
|
||||
+ color = style->bg [GTK_STATE_NORMAL];
|
||||
+ r = (float)color.red / 65535.0;
|
||||
+ g = (float)color.green / 65535.0;
|
||||
+ b = (float)color.blue / 65535.0;
|
||||
+ cairo_set_source_rgba (cr, r, g, b, background_alpha);
|
||||
+ cairo_fill_preserve (cr);
|
||||
+
|
||||
+ color = style->bg [GTK_STATE_SELECTED];
|
||||
+ r = (float) color.red / 65535.0;
|
||||
+ g = (float) color.green / 65535.0;
|
||||
+ b = (float) color.blue / 65535.0;
|
||||
+
|
||||
+ cairo_set_source_rgba (cr, r, g, b, background_alpha);
|
||||
+ cairo_set_line_width (cr, 1.0);
|
||||
+ cairo_stroke (cr);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+update_shape (GtkTooltip *tooltip)
|
||||
+{
|
||||
+ GdkScreen *screen;
|
||||
+ cairo_t *cr;
|
||||
+ cairo_surface_t *surface;
|
||||
+ cairo_region_t *region;
|
||||
+ gint width, height;
|
||||
+ gboolean new_style;
|
||||
+ gint radius;
|
||||
+ GtkStyle *style;
|
||||
+
|
||||
+ gtk_widget_style_get (tooltip->window, "new-tooltip-style", &new_style, NULL);
|
||||
+
|
||||
+ if (!new_style)
|
||||
+ {
|
||||
+ gtk_widget_shape_combine_region (tooltip->window, NULL);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ screen = gtk_widget_get_screen (tooltip->window);
|
||||
+ style = gtk_widget_get_style (tooltip->window);
|
||||
+
|
||||
+ gtk_window_get_size (GTK_WINDOW (tooltip->window), &width, &height);
|
||||
+
|
||||
+ if (gdk_screen_is_composited (screen))
|
||||
+ {
|
||||
+ const char *wm;
|
||||
+
|
||||
+ gtk_widget_shape_combine_region (tooltip->window, NULL);
|
||||
+#ifdef GDK_WINDOWING_X11
|
||||
+ /* This is a hack to keep the Metacity compositor from slapping a
|
||||
+ * non-shaped shadow around the shaped tooltip
|
||||
+ */
|
||||
+ if (!gtk_widget_get_mapped (tooltip->window))
|
||||
+ {
|
||||
+ wm = gdk_x11_screen_get_window_manager_name (screen);
|
||||
+ if (g_strcmp0 (wm, "Metacity") == 0)
|
||||
+ gtk_window_set_type_hint (GTK_WINDOW (tooltip->window),
|
||||
+ GDK_WINDOW_TYPE_HINT_DND);
|
||||
+ }
|
||||
+#endif
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ radius = MIN (style->xthickness, style->ythickness);
|
||||
+ radius = MAX (radius, 1);
|
||||
+ surface = cairo_image_surface_create (CAIRO_FORMAT_A8, width, height);
|
||||
+ cr = cairo_create (surface);
|
||||
+ if (cairo_status (cr) == CAIRO_STATUS_SUCCESS)
|
||||
+ {
|
||||
+ cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
|
||||
+ cairo_paint (cr);
|
||||
+
|
||||
+ cairo_set_operator (cr, CAIRO_OPERATOR_OVER);
|
||||
+ cairo_set_source_rgb (cr, 1.0, 1.0, 1.0);
|
||||
+ draw_round_rect (cr, 1.0, 0, 0, radius + 1, width, height);
|
||||
+ cairo_fill (cr);
|
||||
+ region = gdk_cairo_region_create_from_surface (surface);
|
||||
+ gtk_widget_shape_combine_region (tooltip->window, region);
|
||||
+ cairo_region_destroy (region);
|
||||
+ }
|
||||
+ cairo_destroy (cr);
|
||||
+ cairo_surface_destroy (surface);
|
||||
+}
|
||||
+
|
||||
static gboolean
|
||||
gtk_tooltip_paint_window (GtkTooltip *tooltip,
|
||||
- cairo_t *cr)
|
||||
+ cairo_t *context)
|
||||
{
|
||||
- gtk_paint_flat_box (gtk_widget_get_style (tooltip->window),
|
||||
- cr,
|
||||
- GTK_STATE_NORMAL,
|
||||
- GTK_SHADOW_OUT,
|
||||
- tooltip->window,
|
||||
- "tooltip",
|
||||
- 0, 0,
|
||||
- gtk_widget_get_allocated_width (tooltip->window),
|
||||
- gtk_widget_get_allocated_height (tooltip->window));
|
||||
+ gboolean new_style;
|
||||
+
|
||||
+ gtk_widget_style_get (tooltip->window, "new-tooltip-style", &new_style, NULL);
|
||||
+
|
||||
+ if (new_style)
|
||||
+ {
|
||||
+ cairo_surface_t *surface;
|
||||
+ cairo_t *cr;
|
||||
+
|
||||
+ cairo_set_operator (context, CAIRO_OPERATOR_SOURCE);
|
||||
+ surface = cairo_surface_create_similar (cairo_get_target (context),
|
||||
+ CAIRO_CONTENT_COLOR_ALPHA,
|
||||
+ gtk_widget_get_allocated_width (tooltip->window),
|
||||
+ gtk_widget_get_allocated_height (tooltip->window));
|
||||
+ cr = cairo_create (surface);
|
||||
+ fill_background (tooltip->window, cr);
|
||||
+ cairo_destroy (cr);
|
||||
+
|
||||
+ cairo_set_source_surface (context, surface, 0, 0);
|
||||
+ cairo_paint (context);
|
||||
+ cairo_surface_destroy (surface);
|
||||
+
|
||||
+ update_shape (tooltip);
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ gtk_paint_flat_box (gtk_widget_get_style (tooltip->window),
|
||||
+ context,
|
||||
+ GTK_STATE_NORMAL,
|
||||
+ GTK_SHADOW_OUT,
|
||||
+ tooltip->window,
|
||||
+ "tooltip",
|
||||
+ 0, 0,
|
||||
+ gtk_widget_get_allocated_width (tooltip->window),
|
||||
+ gtk_widget_get_allocated_height (tooltip->window));
|
||||
+ }
|
||||
|
||||
return FALSE;
|
||||
}
|
||||
diff -up gtk+-2.91.3/gtk/gtkwidget.c.fresh-tooltips gtk+-2.91.3/gtk/gtkwidget.c
|
||||
--- gtk+-2.91.3/gtk/gtkwidget.c.fresh-tooltips 2010-11-01 09:17:21.000000000 -0400
|
||||
+++ gtk+-2.91.3/gtk/gtkwidget.c 2010-11-01 14:11:38.921410003 -0400
|
||||
@@ -3190,6 +3190,14 @@ gtk_widget_class_init (GtkWidgetClass *k
|
||||
1, G_MAXINT, 16,
|
||||
GTK_PARAM_READABLE));
|
||||
|
||||
+ gtk_widget_class_install_style_property (klass,
|
||||
+ g_param_spec_boolean ("new-tooltip-style",
|
||||
+ NULL,
|
||||
+ NULL,
|
||||
+ FALSE,
|
||||
+ GTK_PARAM_READABLE));
|
||||
+
|
||||
+
|
||||
g_type_class_add_private (klass, sizeof (GtkWidgetPrivate));
|
||||
}
|
||||
|
34
db2html
34
db2html
@ -1,34 +0,0 @@
|
||||
#! /bin/sh
|
||||
|
||||
ADMON_GRAPHICS=/usr/share/sgml/docbook/dsssl-stylesheets-1.79/images/*.gif
|
||||
|
||||
output=docbook2html-dir
|
||||
skip=0
|
||||
for arg in "$@"
|
||||
do
|
||||
if [ $skip -gt 0 ]
|
||||
then
|
||||
skip=$(($skip - 1))
|
||||
continue
|
||||
fi
|
||||
case $arg in
|
||||
-h|--help|-v|--version) break
|
||||
;;
|
||||
-n|--nostd|-u|--nochunks) ;;
|
||||
-*) skip=1
|
||||
;;
|
||||
*) output="$(echo $arg | sed 's,\.sgml$,,;s,\.sgm$,,;s,\.xml,,')"
|
||||
echo "output is $output"
|
||||
break
|
||||
;;
|
||||
esac
|
||||
done
|
||||
if [ -d ${output} ]
|
||||
then
|
||||
rm -rf ${output}.junk
|
||||
mv ${output} ${output}.junk
|
||||
fi
|
||||
mkdir ${output}
|
||||
mkdir ${output}/stylesheet-images
|
||||
cp ${ADMON_GRAPHICS} ${output}/stylesheet-images
|
||||
jw -f docbook -b html -o ${output} "$@"
|
@ -1,6 +0,0 @@
|
||||
XIM=none
|
||||
XIM_PROGRAM=/bin/true
|
||||
XIM_ARGS=
|
||||
SHORT_DESC=im-cedilla
|
||||
GTK_IM_MODULE=cedilla
|
||||
QT_IM_MODULE=xim
|
@ -1,33 +0,0 @@
|
||||
From 7e29fc5b421a049c2b88453232eddeefed9f1b7b Mon Sep 17 00:00:00 2001
|
||||
From: Cosimo Cecchi <cosimoc@gnome.org>
|
||||
Date: Thu, 13 Jan 2011 15:03:49 +0000
|
||||
Subject: gtkshow: don't call _get_display() on a NULL GdkScreen
|
||||
|
||||
gtk_show_uri() is documented to accept a NULL screen to mean the default
|
||||
one. Calling gdk_screen_get_display() on a NULL object will cause
|
||||
segfaults.
|
||||
---
|
||||
diff --git a/gtk/gtkshow.c b/gtk/gtkshow.c
|
||||
index ac3d1ac..ad396a2 100644
|
||||
--- a/gtk/gtkshow.c
|
||||
+++ b/gtk/gtkshow.c
|
||||
@@ -63,10 +63,16 @@ gtk_show_uri (GdkScreen *screen,
|
||||
{
|
||||
GdkAppLaunchContext *context;
|
||||
gboolean ret;
|
||||
+ GdkDisplay *display;
|
||||
|
||||
g_return_val_if_fail (uri != NULL, FALSE);
|
||||
|
||||
- context = gdk_display_get_app_launch_context (gdk_screen_get_display (screen));
|
||||
+ if (screen != NULL)
|
||||
+ display = gdk_screen_get_display (screen);
|
||||
+ else
|
||||
+ display = gdk_display_get_default ();
|
||||
+
|
||||
+ context = gdk_display_get_app_launch_context (display);
|
||||
gdk_app_launch_context_set_screen (context, screen);
|
||||
gdk_app_launch_context_set_timestamp (context, timestamp);
|
||||
|
||||
--
|
||||
cgit v0.8.3.1
|
171
libgtk3.spec
171
libgtk3.spec
@ -1,14 +1,8 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define libver 3.0
|
||||
%define binver 3.0.0
|
||||
#%define atk_version 2.5.3
|
||||
#%define glib_version 2.33.1
|
||||
#%define pango_version 1.30.0
|
||||
#%define cairo_version 1.10.0
|
||||
#%define gdk_pixbuf_version 2.26.0
|
||||
|
||||
Name: libgtk3
|
||||
Version: 3.24.30
|
||||
Version: 3.24.41
|
||||
Release: 1mamba
|
||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs
|
||||
Group: System/Libraries
|
||||
@ -16,57 +10,37 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://gtk.org/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/gtk+/%{majver}/gtk+-%{version}.tar.xz
|
||||
Source1: db2html
|
||||
Source2: im-cedilla.conf
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=583273
|
||||
Patch0: 0001-New-tooltip-style.patch
|
||||
Patch1: libgtk3-fix-gtk-show-uri-crash.patch
|
||||
Source0: https://download.gnome.org/sources/gtk+/%{majver}/gtk+-%{version}.tar.xz
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libat-spi2-atk-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcloudproviders-devel
|
||||
BuildRequires: libcolord-devel
|
||||
BuildRequires: libcups-devel
|
||||
BuildRequires: libepoxy-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libtracker-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libwayland-egl-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: wayland-protocols
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libcolord-devel >= 1.2.12-1mamba
|
||||
##BuildRequires: libimsettings-devel
|
||||
BuildRequires: bash
|
||||
BuildRequires: binutils
|
||||
BuildRequires: coreutils
|
||||
@ -94,25 +68,6 @@ Requires: shared-mime-info
|
||||
Provides: gtk3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: gtk3+ = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
# FIXME:
|
||||
# checking for db2html... false
|
||||
# checking libpapi... checking for papiServiceCreate in -lpapi... no
|
||||
# checking if <X11/extensions/XIproto.h> is needed for xReply... no
|
||||
|
||||
# GTK+ 3.0.0
|
||||
# ===========
|
||||
|
||||
# GDK backends: x11
|
||||
# X11 extensions: XKB Xinerama XI2 XRANDR XFIXES Composite DAMAGE
|
||||
# Print backends: file lpr cups
|
||||
# Dynamic modules: yes
|
||||
# Included immodules: none
|
||||
# PackageKit support: yes
|
||||
# Introspection: yes
|
||||
# Debugging: minimum
|
||||
# Documentation: no
|
||||
|
||||
|
||||
%description
|
||||
The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating graphical user interfaces for the X Window System.
|
||||
GTK+ was originally written for the GIMP (GNU Image Manipulation Program) image processing program, but is now used by several other programs as well.
|
||||
@ -142,68 +97,43 @@ Requires: gtk-doc
|
||||
%description apidocs
|
||||
gtk+ API documentation.
|
||||
|
||||
#%package immodules
|
||||
#Summary: Input methods for GTK+
|
||||
#Group: System/Libraries
|
||||
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
#Requires: imsettings
|
||||
|
||||
#%description immodules
|
||||
#The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating graphical user interfaces for the X Window System.
|
||||
#GTK+ was originally written for the GIMP (GNU Image Manipulation Program) image processing program, but is now used by several other programs as well.
|
||||
|
||||
#If you are planning on using the GIMP or another program that uses GTK+, you'll need to have the gtk+ package installed.
|
||||
#The %{name}-immodules package contains standalone input methods that are shipped as part of GTK+ 3.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n gtk+-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1 -b .gtk-show-uri-gdk-screen
|
||||
|
||||
#sed -i "s|#!/usr/bin/env python|#!%{__python}|" gtk/gtk-builder-convert-%{libver}
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
#:<< ___EOF
|
||||
#autoreconf -f
|
||||
%configure \
|
||||
--enable-gtk2-dependency \
|
||||
--enable-xkb \
|
||||
--enable-xinerama \
|
||||
--enable-xinput \
|
||||
--enable-xrandr \
|
||||
--enable-xfixes \
|
||||
--enable-xcomposite \
|
||||
--enable-xdamage \
|
||||
--enable-x11-backend \
|
||||
--enable-wayland-backend
|
||||
%meson \
|
||||
-Dbroadway_backend=true \
|
||||
-Dbuiltin_immodules=wayland,waylandgtk \
|
||||
-Dcolord=yes \
|
||||
-Dcloudproviders=true \
|
||||
-Dgtk_doc=true \
|
||||
-Dinstalled_tests=false \
|
||||
-Dman=true \
|
||||
-Dtracker3=true \
|
||||
-Dxinerama=yes
|
||||
|
||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||
|
||||
%make
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall \
|
||||
RUN_QUERY_IMMODULES_TEST=false
|
||||
%meson_install
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/gtk-%{libver}
|
||||
|
||||
# todo mkdir p %{buildroot}%{_sysconfdir}/X11/xinit/xinput.d
|
||||
# todo install -pm 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/X11/xinit/xinput.d/im-cedilla.conf
|
||||
# biarch support
|
||||
install -d -m0755 %{buildroot}%{_libexecdir}
|
||||
mv %{buildroot}%{_bindir}/gtk-query-immodules-3.0 %{buildroot}%{_libexecdir}/gtk-query-immodules-3.0
|
||||
ln -s %{_libexecdir}/gtk-query-immodules-3.0 %{buildroot}%{_bindir}/gtk-query-immodules-3.0
|
||||
|
||||
touch %{buildroot}%{_libdir}/gtk-%{libver}/%{binver}/immodules.cache
|
||||
|
||||
# todo conflict with pkg libgtk vs 2.x
|
||||
# mv %{buildroot}%{_bindir}/gtk-update-icon-cache %{buildroot}%{_bindir}/gtk-update-icon-cache-%{libver}
|
||||
# mv %{buildroot}%{_mandir}/man1/gtk-update-icon-cache.1 %{buildroot}%{_mandir}/man1/gtk-update-icon-cache-%{libver}.1
|
||||
rm -rf %{buildroot}%{_mandir}/man1/gtk-update-icon-cache.1*
|
||||
# mv %{buildroot}%{_bindir}/gtk-builder-convert %{buildroot}%{_bindir}/gtk-builder-convert-%{libver}
|
||||
# mv %{buildroot}%{_mandir}/man1/gtk-builder-convert.1 %{buildroot}%{_mandir}/man1/gtk-builder-convert-%{libver}.1
|
||||
|
||||
%find_lang gtk30
|
||||
%find_lang gtk30-properties
|
||||
@ -211,33 +141,21 @@ rm -rf %{buildroot}%{_mandir}/man1/gtk-update-icon-cache.1*
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
%{_bindir}/gtk-query-immodules-%{libver} --update-cache
|
||||
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
if [ $1 -gt 0 ]; then
|
||||
%{_bindir}/gtk-query-immodules-%{libver} --update-cache
|
||||
fi
|
||||
%{_bindir}/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
|
||||
%posttrans
|
||||
FS=`stat -c %s %{_sysconfdir}/gtk-%{libver}/gtk-pixbuf.loaders 2>/dev/null`
|
||||
[ "$FS" == "0" -o ! "$FS" ] && \
|
||||
%{_bindir}/gdk-pixbuf-query-loaders > %{_sysconfdir}/gtk-%{libver}/gdk-pixbuf.loaders
|
||||
FS=`stat -c %s %{_sysconfdir}/gtk-%{libver}/gtk.immodules 2>/dev/null`
|
||||
[ "$FS" == "0" -o ! "$FS" ] && \
|
||||
%{_bindir}/gtk-query-immodules-%{libver} > %{_sysconfdir}/gtk-%{libver}/gtk.immodules
|
||||
exit 0
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%transfiletriggerin -- %{_libdir}/gtk-3.0/3.0.0/immodules
|
||||
%{_libexecdir}/gtk-query-immodules-3.0 --update-cache &>/dev/null || :
|
||||
|
||||
%transfiletriggerpostun -- %{_libdir}/gtk-3.0/3.0.0/immodules
|
||||
%{_libexecdir}/gtk-query-immodules-3.0 --update-cache &>/dev/null || :
|
||||
|
||||
%files -f gtk30.lang
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/gtk-%{libver}
|
||||
%config(noreplace) %{_sysconfdir}/gtk-%{libver}/im-multipress.conf
|
||||
%{_bindir}/broadwayd
|
||||
%{_bindir}/gtk-launch
|
||||
#sysconfdir}/X11/xinit/xinput.d/im-cedilla.conf
|
||||
%{_bindir}/gtk-query-immodules-%{libver}
|
||||
%{_bindir}/gtk-update-icon-cache
|
||||
%{_bindir}/gtk-query-settings
|
||||
@ -245,37 +163,30 @@ exit 0
|
||||
%{_libdir}/libgdk-*.so.*
|
||||
%{_libdir}/libgtk-*.so.*
|
||||
%dir %{_libdir}/gtk-%{libver}
|
||||
%{_datadir}/gtk-%{libver}/emoji/*.gresource
|
||||
%dir %{_libdir}/gtk-%{libver}/%{binver}
|
||||
%ghost %{_libdir}/gtk-%{libver}/%{binver}/immodules.cache
|
||||
%dir %{_libdir}/gtk-%{libver}/%{binver}/immodules
|
||||
%{_libdir}/gtk-%{libver}/%{binver}/immodules/im-*.la
|
||||
%{_libdir}/gtk-%{libver}/%{binver}/immodules/im-*.so
|
||||
#%dir %{_libdir}/gtk-%{libver}/modules
|
||||
#%{_libdir}/gtk-%{libver}/modules/libferret.la
|
||||
#%{_libdir}/gtk-%{libver}/modules/libferret.so
|
||||
#%{_libdir}/gtk-%{libver}/modules/libgail.la
|
||||
#%{_libdir}/gtk-%{libver}/modules/libgail.so
|
||||
%dir %{_libdir}/gtk-%{libver}/%{binver}/printbackends
|
||||
%{_libdir}/gtk-%{libver}/%{binver}/printbackends/libprintbackend-*.la
|
||||
%{_libdir}/gtk-%{libver}/%{binver}/printbackends/libprintbackend-*.so
|
||||
%{_libdir}/girepository-1.0/Gdk-%{libver}.typelib
|
||||
%{_libdir}/girepository-1.0/GdkX11-%{libver}.typelib
|
||||
%{_libdir}/girepository-1.0/Gtk-%{libver}.typelib
|
||||
%{_libexecdir}/gtk-query-immodules-3.0
|
||||
%{_datadir}/icons/hicolor/*/apps/gtk3-demo-symbolic.symbolic.png
|
||||
%{_datadir}/icons/hicolor/*/apps/gtk3-widget-factory-symbolic.symbolic.png
|
||||
%dir %{_datadir}/themes/Default/gtk-%{libver}
|
||||
%{_datadir}/themes/Default/gtk-%{libver}/*
|
||||
%dir %{_datadir}/themes/Emacs/gtk-%{libver}
|
||||
%{_datadir}/themes/Emacs/gtk-%{libver}/*
|
||||
#%dir %{_datadir}/themes/Raleigh/gtk-%{libver}
|
||||
#%{_datadir}/themes/Raleigh/gtk-%{libver}/*
|
||||
%{_datadir}/glib-2.0/schemas/org.gtk.Settings.*.gschema.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gtk.exampleapp.gschema.xml
|
||||
%{_mandir}/man1/broadwayd.1*
|
||||
%{_mandir}/man1/gtk-query-immodules-%{libver}.1*
|
||||
%{_mandir}/man1/gtk-launch.1*
|
||||
%{_mandir}/man1/gtk-query-settings.1*
|
||||
%doc AUTHORS COPYING
|
||||
%doc COPYING
|
||||
|
||||
%files devel -f gtk30-properties.lang
|
||||
%defattr(-,root,root)
|
||||
@ -285,9 +196,6 @@ exit 0
|
||||
%{_bindir}/gtk3-demo-application
|
||||
%{_bindir}/gtk3-icon-browser
|
||||
%{_bindir}/gtk3-widget-factory
|
||||
#%{_bindir}/gtk-builder-convert-%{libver}
|
||||
#%dir %{_includedir}/gail-%{libver}/gail
|
||||
#%{_includedir}/gail-%{libver}/gail/*.h
|
||||
%dir %{_includedir}/gail-%{libver}/libgail-util
|
||||
%{_includedir}/gail-%{libver}/libgail-util/*.h
|
||||
%dir %{_includedir}/gtk-%{libver}
|
||||
@ -309,11 +217,10 @@ exit 0
|
||||
%{_includedir}/gtk-%{libver}/gdk/x11/*.h
|
||||
%dir %{_includedir}/gtk-%{libver}/gdk/deprecated
|
||||
%{_includedir}/gtk-%{libver}/gdk/deprecated/gdkcolor.h
|
||||
%{_libdir}/libgailutil-*.la
|
||||
%dir %{_includedir}/gtk-%{libver}/gdk/broadway
|
||||
%{_includedir}/gtk-%{libver}/gdk/broadway/gdkbroadway*.h
|
||||
%{_libdir}/libgailutil-*.so
|
||||
%{_libdir}/libgdk-*.la
|
||||
%{_libdir}/libgdk-*.so
|
||||
%{_libdir}/libgtk-*.la
|
||||
%{_libdir}/libgtk-*.so
|
||||
%{_datadir}/aclocal/gtk-%{libver}.m4
|
||||
%{_datadir}/gettext/its/gtkbuilder.*
|
||||
@ -331,6 +238,8 @@ exit 0
|
||||
%{_libdir}/pkgconfig/gail-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gdk-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gdk-x11-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gdk-broadway-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gtk+-broadway-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gtk+-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gtk+-unix-print-%{libver}.pc
|
||||
%{_libdir}/pkgconfig/gtk+-x11-%{libver}.pc
|
||||
@ -342,7 +251,7 @@ exit 0
|
||||
%{_mandir}/man1/gtk3-widget-factory.1*
|
||||
%{_mandir}/man1/gtk3-demo.1*
|
||||
%{_mandir}/man1/gtk3-demo-application.1*
|
||||
%doc ChangeLog HACKING NEWS README
|
||||
%doc NEWS README.md
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
@ -354,6 +263,10 @@ exit 0
|
||||
%{_datadir}/gtk-doc/html/gtk3/*
|
||||
|
||||
%changelog
|
||||
* Sun Apr 21 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.24.41-1mamba
|
||||
- update to 3.24.41
|
||||
- added triggers to gtk-query-immodules-3.0
|
||||
|
||||
* Wed Dec 08 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.24.30-1mamba
|
||||
- update to 3.24.30
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user