added triggers to gtk-query-immodules-2.0; specfile cleanups [release 2.24.33-2mamba;Sun Apr 21 2024]
This commit is contained in:
parent
e5b7741a4f
commit
239956ff7b
@ -3,5 +3,3 @@
|
||||
The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating graphical user interfaces for the X Window System.
|
||||
GTK+ was originally written for the GIMP (GNU Image Manipulation Program) image processing program, but is now used by several other programs as well.
|
||||
|
||||
If you are planning on using the GIMP or another program that uses GTK+, you'll need to have the gtk+ package installed.
|
||||
|
||||
|
@ -1,61 +0,0 @@
|
||||
From dbe4cf21970ec47ad56ab41b8ca1081f35b04130 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Nordholts <martinn@src.gnome.org>
|
||||
Date: Fri, 22 May 2009 21:57:14 +0200
|
||||
Subject: [PATCH] =?utf-8?q?Bug=20580511=20=E2=80=93=20gdk=5Fx11=5Fatom=5Fto=5Fxatom=5Ffor=5Fdisplay=20translates=20GDK=5FNONE=20as?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=utf-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Allow None <=> GDK_NONE conversions and remove special casing. If we
|
||||
don't allow these conversions we need to add special casing to more
|
||||
places so it's better to just allow the conversions.
|
||||
---
|
||||
gdk/x11/gdkproperty-x11.c | 8 ++++++--
|
||||
gdk/x11/gdkselection-x11.c | 5 +----
|
||||
2 files changed, 7 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/gdk/x11/gdkproperty-x11.c b/gdk/x11/gdkproperty-x11.c
|
||||
index 116f47d..fff30f9 100644
|
||||
--- a/gdk/x11/gdkproperty-x11.c
|
||||
+++ b/gdk/x11/gdkproperty-x11.c
|
||||
@@ -189,7 +189,9 @@ gdk_x11_atom_to_xatom_for_display (GdkDisplay *display,
|
||||
Atom xatom = None;
|
||||
|
||||
g_return_val_if_fail (GDK_IS_DISPLAY (display), None);
|
||||
- g_return_val_if_fail (atom != GDK_NONE, None);
|
||||
+
|
||||
+ if (atom == GDK_NONE)
|
||||
+ return None;
|
||||
|
||||
if (display->closed)
|
||||
return None;
|
||||
@@ -293,7 +295,9 @@ gdk_x11_xatom_to_atom_for_display (GdkDisplay *display,
|
||||
GdkAtom virtual_atom = GDK_NONE;
|
||||
|
||||
g_return_val_if_fail (GDK_IS_DISPLAY (display), GDK_NONE);
|
||||
- g_return_val_if_fail (xatom != None, GDK_NONE);
|
||||
+
|
||||
+ if (xatom == None)
|
||||
+ return GDK_NONE;
|
||||
|
||||
if (display->closed)
|
||||
return GDK_NONE;
|
||||
diff --git a/gdk/x11/gdkselection-x11.c b/gdk/x11/gdkselection-x11.c
|
||||
index 6045dad..fd482e2 100644
|
||||
--- a/gdk/x11/gdkselection-x11.c
|
||||
+++ b/gdk/x11/gdkselection-x11.c
|
||||
@@ -404,10 +404,7 @@ gdk_selection_send_notify_for_display (GdkDisplay *display,
|
||||
xevent.requestor = requestor;
|
||||
xevent.selection = gdk_x11_atom_to_xatom_for_display (display, selection);
|
||||
xevent.target = gdk_x11_atom_to_xatom_for_display (display, target);
|
||||
- if (property == GDK_NONE)
|
||||
- xevent.property = None;
|
||||
- else
|
||||
- xevent.property = gdk_x11_atom_to_xatom_for_display (display, property);
|
||||
+ xevent.property = gdk_x11_atom_to_xatom_for_display (display, property);
|
||||
xevent.time = time;
|
||||
|
||||
_gdk_send_xevent (display, requestor, False, NoEventMask, (XEvent*) & xevent);
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -Nru gtk+-2.18.6.orig/gdk/x11/gdkwindow-x11.c gtk+-2.18.6/gdk/x11/gdkwindow-x11.c
|
||||
--- gtk+-2.18.6.orig/gdk/x11/gdkwindow-x11.c 2010-01-11 21:57:37.000000000 +0100
|
||||
+++ gtk+-2.18.6/gdk/x11/gdkwindow-x11.c 2010-02-01 00:37:00.909823000 +0100
|
||||
@@ -252,8 +252,9 @@
|
||||
else
|
||||
xpixmap = GDK_DRAWABLE_XID (obj->bg_pixmap);
|
||||
|
||||
- XSetWindowBackgroundPixmap (GDK_DRAWABLE_XDISPLAY (window),
|
||||
- GDK_DRAWABLE_XID (window), xpixmap);
|
||||
+/* FIXME: this products crash with nautilus and lxde
|
||||
+ XSetWindowBackgroundPixmap (GDK_DRAWABLE_XDISPLAY (window),
|
||||
+ GDK_DRAWABLE_XID (window), xpixmap);*/
|
||||
}
|
||||
else
|
||||
{
|
77
libgtk2.spec
77
libgtk2.spec
@ -3,50 +3,35 @@
|
||||
|
||||
Name: libgtk2
|
||||
Version: 2.24.33
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gtk.org
|
||||
# bugfixes: http://ftp.acc.umu.se/pub/GNOME/sources/%{pkgname}
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/%{majver}/gtk+-%{version}.tar.xz
|
||||
Patch1: libgtk-2.16.4-gdk_x11_atom_to_xatom_for_display_tra.patch
|
||||
Patch2: libgtk-2.18.6-fix_nautilus_crash.patch
|
||||
URL: https://www.gtk.org/
|
||||
Source: https://download.gnome.org/sources/gtk+/%{majver}/gtk+-%{version}.tar.xz
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcups-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: p11-kit-devel
|
||||
@ -64,8 +49,7 @@ Provides: gtk2 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libgtk2 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: gtk+ = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libgail
|
||||
Obsoletes: libgail
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: libgail < 2.24.33
|
||||
|
||||
# FIXME:
|
||||
# checking for db2html... false
|
||||
@ -74,40 +58,25 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating graphical user interfaces for the X Window System.
|
||||
GTK+ was originally written for the GIMP (GNU Image Manipulation Program) image processing program, but is now used by several other programs as well.
|
||||
|
||||
If you are planning on using the GIMP or another program that uses GTK+, you'll need to have the gtk+ package installed.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for GTK+
|
||||
Group: Development/Libraries
|
||||
Requires: pkgconfig
|
||||
Requires: libglib-devel
|
||||
Requires: libatk-devel
|
||||
Requires: libcairo-devel
|
||||
Requires: libpango-devel
|
||||
Requires: glproto-devel
|
||||
Requires: libharfbuzz-devel
|
||||
Requires: libXxf86vm-devel
|
||||
Requires: libXdamage-devel
|
||||
Requires: libXfixes-devel
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: gtk+-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libgail-devel
|
||||
Obsoletes: libgail-devel
|
||||
Obsoletes: libgail-devel < 2.24.33
|
||||
|
||||
%description devel
|
||||
The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating graphical user interfaces for the X Window System.
|
||||
GTK+ was originally written for the GIMP (GNU Image Manipulation Program) image processing program, but is now used by several other programs as well.
|
||||
|
||||
If you are planning on using the GIMP or another program that uses GTK+, you'll need to have the gtk+ package installed.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%package apidocs
|
||||
Summary: libgtk API documentation
|
||||
Group: Documentation
|
||||
Requires: gtk-doc
|
||||
Provides: libgail-apidocs
|
||||
Obsoletes: libgail-apidocs
|
||||
Obsoletes: libgail-apidocs < 2.24.33
|
||||
|
||||
%description apidocs
|
||||
gtk+ API documentation.
|
||||
@ -116,15 +85,13 @@ gtk+ API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n gtk+-%{version}
|
||||
#%patch1 -p1
|
||||
# FIXME: recheck this patch because it removes pixmap bg reset functionality to fix segfault with nautilus
|
||||
%patch2 -p1
|
||||
|
||||
# Prevents errors due to rebuilding html
|
||||
sed -i 's#l \(gtk-.*\).sgml#& -o \1#' docs/{faq,tutorial}/Makefile.in
|
||||
|
||||
%build
|
||||
%configure \
|
||||
%ifnarch arm
|
||||
--enable-gtk-doc
|
||||
%endif
|
||||
|
||||
%make
|
||||
|
||||
@ -148,14 +115,11 @@ cat gtk20.lang gtk20-properties.lang > %{name}.lang
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%posttrans
|
||||
FS=`stat -c %s %{_sysconfdir}/gtk-2.0/gtk-pixbuf.loaders 2>/dev/null`
|
||||
[ "$FS" == "0" -o ! "$FS" ] && \
|
||||
%{_bindir}/gdk-pixbuf-query-loaders > %{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
|
||||
FS=`stat -c %s %{_sysconfdir}/gtk-2.0/gtk.immodules 2>/dev/null`
|
||||
[ "$FS" == "0" -o ! "$FS" ] && \
|
||||
%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/gtk.immodules
|
||||
exit 0
|
||||
%transfiletriggerin -- %{_libdir}/gtk-2.0/immodules/ %{_libdir}/gtk-2.0/%{bin_version}/immodules/
|
||||
gtk-query-immodules-2.0-%{__isa_bits} --update-cache
|
||||
|
||||
%transfiletriggerpostun -- %{_libdir}/gtk-2.0/immodules/ %{_libdir}/gtk-2.0/%{bin_version}/immodules/
|
||||
gtk-query-immodules-2.0 --update-cache
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
@ -163,7 +127,6 @@ exit 0
|
||||
%{_sysconfdir}/gtk-2.0/im-multipress.conf
|
||||
%{_bindir}/gtk-builder-convert
|
||||
%{_bindir}/gtk-query-immodules-2.0
|
||||
#%{_bindir}/gtk-update-icon-cache
|
||||
%{_datadir}/themes/*
|
||||
%dir %{_datadir}/gtk-2.0
|
||||
%{_datadir}/gtk-2.0/*
|
||||
@ -181,11 +144,8 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gtk-demo
|
||||
%{_datadir}/aclocal/*
|
||||
%{_libdir}/libgailutil.la
|
||||
%{_libdir}/libgailutil.so
|
||||
%{_libdir}/libgdk-x11-%{libver}.la
|
||||
%{_libdir}/libgdk-x11-%{libver}.so
|
||||
%{_libdir}/libgtk-x11-%{libver}.la
|
||||
%{_libdir}/libgtk-x11-%{libver}.so
|
||||
%{_libdir}/gtk-2.0/include
|
||||
%{_datadir}/gir-1.0/Gdk*.gir
|
||||
@ -204,11 +164,14 @@ exit 0
|
||||
%dir %{_datadir}/gtk-doc/html/gail-libgail-util
|
||||
%{_datadir}/gtk-doc/html/gail-libgail-util/*
|
||||
%dir %{_datadir}/gtk-doc/html/gdk2
|
||||
%{_datadir}/gtk-doc/html/gdk2/*
|
||||
%{_datadir}/gtk-doc/html/gdk2/
|
||||
%dir %{_datadir}/gtk-doc/html/gtk2
|
||||
%{_datadir}/gtk-doc/html/gtk2/*
|
||||
|
||||
%changelog
|
||||
* Sun Apr 21 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.33-2mamba
|
||||
- added triggers to gtk-query-immodules-2.0; specfile cleanups
|
||||
|
||||
* Mon Dec 21 2020 Automatic Build System <autodist@mambasoft.it> 2.24.33-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user