libgpod/libgpod.spec

192 lines
5.8 KiB
RPMSpec

%define majver %(echo %version | cut -d. -f1-2)
Name: libgpod
Version: 0.8.3
Release: 5mamba
Summary: A shared library to access the contents of an iPod
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/fadingred/libgpod
Source: http://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-%{majver}/libgpod-%{version}.tar.bz2
Patch0: libgpod-0.8.0-blue_nano_8g.patch
Patch1: libgpod-0.8.3-Segmentation-fault-when-opening-ipod.patch
Patch2: libgpod-0.8.3-pkgconfig_overlinking.patch
Patch3: libgpod-0.8.3-swig.patch
Patch4: libgpod-0.8.3-udev.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: gtk-sharp2-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libimobiledevice-devel
BuildRequires: libopenssl-devel
BuildRequires: libplist-devel
BuildRequires: libsg3_utils-devel
BuildRequires: libsqlite-devel
BuildRequires: libudev-devel
BuildRequires: libusb-devel
BuildRequires: libusbmuxd-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
BuildRequires: mono-devel
## AUTOBUILDREQ-END
BuildRequires: libsg3_utils-devel >= 1.48-1mamba
BuildRequires: libplist-devel >= 2.2.0
BuildRequires: libimobiledevice-devel >= 1.1.4
BuildRequires: intltool
BuildRequires: gettext-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: perl-XML-Parser
BuildRequires: libtag-devel
BuildRequires: libffi-devel
BuildRequires: mono-devel
BuildRequires: swig
%description
libgpod is a shared library to access the contents of an iPod.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
libgpod is a shared library to access the contents of an iPod.
This package contains static libraries and header files needed for development.
%package apidocs
Summary: Libgpod API documentation
Group: Documentation
Requires: gtk-doc
%description apidocs
Libgpod API documentation.
%debug_package
%prep
%setup -q
#%patch0 -p1
%patch 1 -p1 -b .Segmentation-fault-when-opening-ipod
%patch 2 -p1 -b .pkgconfig_overlinking
%patch 3 -p1 -b .swig
%patch 4 -p0 -b .udev
sed -e 's|libplist >= 1.0|libplist-2.0 >= 2.2|' -i configure.ac # support libplist 2.2
autoreconf -f -i
%build
%configure \
--enable-gtk-doc \
--with-udev-dir=%{_prefix}/lib/udev \
--enable-udev \
--with-python=no
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
rm -f %{buildroot}%{_libdir}/libgpod.a
%{find_lang} %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/ipod-read-sysinfo-extended
%{_libdir}/libgpod.so.*
%{_libdir}/libgpod/libgpod-sharp-test.exe*
%{_libdir}/libgpod/libgpod-sharp.dll*
%{_prefix}/lib/udev/iphone-set-info
%{_prefix}/lib/udev/ipod-set-info
%{_prefix}/lib/udev/rules.d/90-libgpod.rules
#%{python_sitearch}/gpod/*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/gpod-1.0/gpod
%{_includedir}/gpod-1.0/gpod/*.h
%{_libdir}/libgpod.so
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog README
%files apidocs
%defattr(-,root,root)
%dir %{_datadir}/gtk-doc/html/libgpod
%{_datadir}/gtk-doc/html/libgpod/*
%changelog
* Sun Aug 20 2023 Automatic Build System <autodist@mambasoft.it> 0.8.3-5mamba
- rebuilt by autoport with build requirements: libsg3_utils-devel>=:1.48-1mamba
* Sat May 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.3-4mamba
- rebuilt with libsg3_utils 1.47
* Sun Oct 31 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.3-3mamba
- removed obsolete python requirement; added patches from Arch Linux; added debug package
* Fri Sep 05 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.3-2mamba
- rebuilt by autoport with build requirements: libplist-devel>=1.11-1mamba
* Mon Jan 27 2014 Automatic Build System <autodist@mambasoft.it> 0.8.3-1mamba
- automatic version update by autodist
* Sat Jun 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.2-2mamba
- python 2.7 mass rebuild
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 0.8.2-1mamba
- update to 0.8.2
* Fri Sep 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-3mamba
- replace buildrequirement for hal-devel with a buildconflict
* Mon May 14 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-2mamba
- rebuilt with libimobiledevice 1.1.4
* Thu Feb 17 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-1mamba
- update to 0.8.0
- added patch for 8GB Blue Nano 6g
* Mon Sep 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.94-1mamba
- update to 0.7.94
* Tue Jul 28 2009 Automatic Build System <autodist@mambasoft.it> 0.7.2-1mamba
- update to 0.7.2
* Mon Feb 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.0-1mamba
- automatic update by autodist
* Thu Aug 28 2008 gil <puntogil@libero.it> 0.6.0-1mamba
- update to 0.6.0
* Sun Sep 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.2-1mamba
- update to 0.5.2
* Fri Feb 09 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.2-1qilnx
- update to version 0.4.2 by autospec
- new subpackage apidocs with API documentation
* Mon Oct 02 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1qilnx
- update to version 0.4.0 by autospec
* Thu May 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-2qilnx
- rebuilt
* Mon Apr 03 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-1qilnx
- update to version 0.3.2 by autospec
* Tue Dec 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.0-1qilnx
- update to version 0.3.0 by autospec
* Tue Nov 22 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.6-1qilnx
- package created by autospec