automatic version update by autodist [release 0.8.3-1mamba;Mon Jan 27 2014]
This commit is contained in:
parent
572278fe3b
commit
54b7e4b14c
@ -1,2 +1,4 @@
|
||||
# libgpod
|
||||
|
||||
libgpod is a shared library to access the contents of an iPod.
|
||||
|
||||
|
11
libgpod-0.8.0-blue_nano_8g.patch
Normal file
11
libgpod-0.8.0-blue_nano_8g.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -Nru libgpod-0.8.0.orig//src/itdb_device.c libgpod-0.8.0/src/itdb_device.c
|
||||
--- libgpod-0.8.0.orig//src/itdb_device.c 2010-10-10 17:56:01.000000000 +0200
|
||||
+++ libgpod-0.8.0/src/itdb_device.c 2011-02-17 20:59:52.352190510 +0100
|
||||
@@ -819,6 +819,7 @@
|
||||
|
||||
{ "CMN", "C525" }, /* 8GB Silver Nano 6g */
|
||||
{ "DVX", "C688" }, /* 8GB Black Nano 6g */
|
||||
+ { "DVY", "C689" }, /* 8GB Blue Nano 6g */
|
||||
{ "DW2", "C692" }, /* 8GB Pink Nano 6g */
|
||||
{ "CMP", "C526" }, /* 16GB Silver Nano 6g */
|
||||
{ "DW9", "C699" }, /* 16GB Red Nano 6g */
|
182
libgpod.spec
Normal file
182
libgpod.spec
Normal file
@ -0,0 +1,182 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: libgpod
|
||||
Version: 0.8.3
|
||||
Release: 1mamba
|
||||
Summary: A shared library to access the contents of an iPod
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gtkpod.org/libgpod.html
|
||||
Source: http://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-%{majver}/libgpod-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.8.0-blue_nano_8g.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: gtk-sharp-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgnutls-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libimobiledevice-devel
|
||||
BuildRequires: libplist-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libselinux-devel
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: libsmbios-devel
|
||||
%endif
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libusbmuxd-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildConflicts:hal-devel
|
||||
BuildRequires: libimobiledevice-devel >= 1.1.4
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: perl-XML-Parser
|
||||
BuildRequires: libtag-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: python-mutagen
|
||||
BuildRequires: mono-devel
|
||||
BuildRequires: swig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
libgpod is a shared library to access the contents of an iPod.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
libgpod is a shared library to access the contents of an iPod.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package apidocs
|
||||
Summary: Libgpod API documentation
|
||||
Group: Documentation
|
||||
Requires: gtk-doc
|
||||
|
||||
%description apidocs
|
||||
Libgpod API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
# FIXME: mono bindings don't build on x86_64
|
||||
#./autogen.sh
|
||||
%configure --enable-gtk-doc \
|
||||
%ifarch x86_64
|
||||
--without-mono
|
||||
%endif
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/libgpod.a
|
||||
|
||||
%{find_lang} %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/ipod-read-sysinfo-extended
|
||||
%{_libdir}/libgpod.so.*
|
||||
%ifnarch x86_64
|
||||
%{_libdir}/libgpod/libgpod-sharp-test.exe*
|
||||
%{_libdir}/libgpod/libgpod-sharp.dll*
|
||||
%endif
|
||||
/lib/udev/iphone-set-info
|
||||
/lib/udev/ipod-set-info
|
||||
/lib/udev/rules.d/90-libgpod.rules
|
||||
%{python_sitearch}/gpod/*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_datadir}/gtk-doc/html/libgpod
|
||||
%{_libdir}/libgpod.la
|
||||
%{_libdir}/libgpod.so
|
||||
%dir %{_includedir}/gpod-1.0/gpod
|
||||
%{_includedir}/gpod-1.0/gpod/*.h
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog README
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/gtk-doc/html/libgpod/
|
||||
|
||||
%changelog
|
||||
* Mon Jan 27 2014 Automatic Build System <autodist@mambasoft.it> 0.8.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jun 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.2-2mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 0.8.2-1mamba
|
||||
- update to 0.8.2
|
||||
|
||||
* Fri Sep 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-3mamba
|
||||
- replace buildrequirement for hal-devel with a buildconflict
|
||||
|
||||
* Mon May 14 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-2mamba
|
||||
- rebuilt with libimobiledevice 1.1.4
|
||||
|
||||
* Thu Feb 17 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-1mamba
|
||||
- update to 0.8.0
|
||||
- added patch for 8GB Blue Nano 6g
|
||||
|
||||
* Mon Sep 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.94-1mamba
|
||||
- update to 0.7.94
|
||||
|
||||
* Tue Jul 28 2009 Automatic Build System <autodist@mambasoft.it> 0.7.2-1mamba
|
||||
- update to 0.7.2
|
||||
|
||||
* Mon Feb 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Aug 28 2008 gil <puntogil@libero.it> 0.6.0-1mamba
|
||||
- update to 0.6.0
|
||||
|
||||
* Sun Sep 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.2-1mamba
|
||||
- update to 0.5.2
|
||||
|
||||
* Fri Feb 09 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.4.2-1qilnx
|
||||
- update to version 0.4.2 by autospec
|
||||
- new subpackage apidocs with API documentation
|
||||
|
||||
* Mon Oct 02 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1qilnx
|
||||
- update to version 0.4.0 by autospec
|
||||
|
||||
* Thu May 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-2qilnx
|
||||
- rebuilt
|
||||
|
||||
* Mon Apr 03 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-1qilnx
|
||||
- update to version 0.3.2 by autospec
|
||||
|
||||
* Tue Dec 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.0-1qilnx
|
||||
- update to version 0.3.0 by autospec
|
||||
|
||||
* Tue Nov 22 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.6-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user