rebuilt by autoport with build requirements: libusbmuxd-devel>=0:2.1.0-1mamba [release 0.8.3-6mamba;Sat Jan 04 2025]
This commit is contained in:
parent
75ebfb4c67
commit
50d5d46cdc
@ -1,11 +0,0 @@
|
|||||||
diff -Nru libgpod-0.8.0.orig//src/itdb_device.c libgpod-0.8.0/src/itdb_device.c
|
|
||||||
--- libgpod-0.8.0.orig//src/itdb_device.c 2010-10-10 17:56:01.000000000 +0200
|
|
||||||
+++ libgpod-0.8.0/src/itdb_device.c 2011-02-17 20:59:52.352190510 +0100
|
|
||||||
@@ -819,6 +819,7 @@
|
|
||||||
|
|
||||||
{ "CMN", "C525" }, /* 8GB Silver Nano 6g */
|
|
||||||
{ "DVX", "C688" }, /* 8GB Black Nano 6g */
|
|
||||||
+ { "DVY", "C689" }, /* 8GB Blue Nano 6g */
|
|
||||||
{ "DW2", "C692" }, /* 8GB Pink Nano 6g */
|
|
||||||
{ "CMP", "C526" }, /* 16GB Silver Nano 6g */
|
|
||||||
{ "DW9", "C699" }, /* 16GB Red Nano 6g */
|
|
22
libgpod-0.8.3-libglib-2.82.4.patch
Normal file
22
libgpod-0.8.3-libglib-2.82.4.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- a/src/ithumb-writer.c~ 2011-07-24 06:08:03.000000000 -0500
|
||||||
|
+++ b/src/ithumb-writer.c 2024-01-31 10:24:16.329797712 -0600
|
||||||
|
@@ -968,7 +968,7 @@
|
||||||
|
else if (thumb->data_type == ITDB_THUMB_TYPE_PIXBUF)
|
||||||
|
{
|
||||||
|
Itdb_Thumb_Pixbuf *thumb_pixbuf = (Itdb_Thumb_Pixbuf *)thumb;
|
||||||
|
- pixbuf = g_object_ref (G_OBJECT (thumb_pixbuf->pixbuf));
|
||||||
|
+ pixbuf = (GdkPixbuf *)(g_object_ref (G_OBJECT (thumb_pixbuf->pixbuf)));
|
||||||
|
}
|
||||||
|
|
||||||
|
if (pixbuf == NULL)
|
||||||
|
--- libgpod-0.8.3/src/ithumb-writer.c~ 2024-01-31 10:24:16.329797712 -0600
|
||||||
|
+++ libgpod-0.8.3/src/ithumb-writer.c 2024-01-31 10:33:27.699960523 -0600
|
||||||
|
@@ -728,7 +728,7 @@
|
||||||
|
{
|
||||||
|
return gdk_pixbuf_rotate_simple (pixbuf, *rotation);
|
||||||
|
}
|
||||||
|
- return g_object_ref (G_OBJECT (pixbuf));
|
||||||
|
+ return (GdkPixbuf *)(g_object_ref (G_OBJECT (pixbuf)));
|
||||||
|
}
|
||||||
|
|
||||||
|
/* On the iPhone, thumbnails are presented as squares in a grid.
|
30
libgpod-0.8.3-libplist-2.6.0.patch
Normal file
30
libgpod-0.8.3-libplist-2.6.0.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- a/tools/ipod-lockdown.c
|
||||||
|
+++ b/tools/ipod-lockdown.c
|
||||||
|
@@ -100,7 +100,7 @@ read_sysinfo_extended_by_uuid (const cha
|
||||||
|
plist_get_string_val(ptr, &str);
|
||||||
|
if (str != NULL) {
|
||||||
|
ptr = plist_new_string(str);
|
||||||
|
- plist_dict_insert_item(value, "SerialNumber", ptr);
|
||||||
|
+ plist_dict_set_item(value, "SerialNumber", ptr);
|
||||||
|
free(str);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -112,15 +112,15 @@ read_sysinfo_extended_by_uuid (const cha
|
||||||
|
plist_get_string_val(ptr, &str);
|
||||||
|
if (str != NULL) {
|
||||||
|
ptr = plist_new_string(str);
|
||||||
|
- plist_dict_insert_item(value, "VisibleBuildID", ptr);
|
||||||
|
+ plist_dict_set_item(value, "VisibleBuildID", ptr);
|
||||||
|
free(str);
|
||||||
|
}
|
||||||
|
|
||||||
|
ptr = plist_new_string(uuid);
|
||||||
|
- plist_dict_insert_item(value, "FireWireGUID", ptr);
|
||||||
|
+ plist_dict_set_item(value, "FireWireGUID", ptr);
|
||||||
|
|
||||||
|
ptr = plist_new_string(uuid);
|
||||||
|
- plist_dict_insert_item(value, "UniqueDeviceID", ptr);
|
||||||
|
+ plist_dict_set_item(value, "UniqueDeviceID", ptr);
|
||||||
|
|
||||||
|
plist_to_xml(value, &xml, &xml_length);
|
||||||
|
|
18
libgpod-0.8.3-libusb-1.0.27.patch
Normal file
18
libgpod-0.8.3-libusb-1.0.27.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
Clang16 will not allow implicit integers by default.
|
||||||
|
|
||||||
|
Pascal Jäger <pascal.jaeger@leimstift.de> (2022-12-11)
|
||||||
|
|
||||||
|
origin: https://sourceforge.net/p/gtkpod/patches/47/
|
||||||
|
|
||||||
|
--- a/tools/generic-callout.c
|
||||||
|
+++ b/tools/generic-callout.c
|
||||||
|
@@ -663,8 +663,7 @@ static gboolean write_sysinfo_extended (const char *mountpoint,
|
||||||
|
return success;
|
||||||
|
}
|
||||||
|
|
||||||
|
-
|
||||||
|
-static char *get_info_from_usb (usb_bus_number, usb_device_number)
|
||||||
|
+static char *get_info_from_usb (guint usb_bus_number,guint usb_device_number)
|
||||||
|
{
|
||||||
|
#ifdef HAVE_LIBUSB
|
||||||
|
return read_sysinfo_extended_from_usb (usb_bus_number,
|
22
libgpod.spec
22
libgpod.spec
@ -1,7 +1,7 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: libgpod
|
Name: libgpod
|
||||||
Version: 0.8.3
|
Version: 0.8.3
|
||||||
Release: 5mamba
|
Release: 6mamba
|
||||||
Summary: A shared library to access the contents of an iPod
|
Summary: A shared library to access the contents of an iPod
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,11 +9,13 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/fadingred/libgpod
|
URL: https://github.com/fadingred/libgpod
|
||||||
Source: http://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-%{majver}/libgpod-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-%{majver}/libgpod-%{version}.tar.bz2
|
||||||
Patch0: libgpod-0.8.0-blue_nano_8g.patch
|
|
||||||
Patch1: libgpod-0.8.3-Segmentation-fault-when-opening-ipod.patch
|
Patch1: libgpod-0.8.3-Segmentation-fault-when-opening-ipod.patch
|
||||||
Patch2: libgpod-0.8.3-pkgconfig_overlinking.patch
|
Patch2: libgpod-0.8.3-pkgconfig_overlinking.patch
|
||||||
Patch3: libgpod-0.8.3-swig.patch
|
Patch3: libgpod-0.8.3-swig.patch
|
||||||
Patch4: libgpod-0.8.3-udev.patch
|
Patch4: libgpod-0.8.3-udev.patch
|
||||||
|
Patch5: libgpod-0.8.3-libglib-2.82.4.patch
|
||||||
|
Patch6: libgpod-0.8.3-libplist-2.6.0.patch
|
||||||
|
Patch7: libgpod-0.8.3-libusb-1.0.27.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -21,17 +23,15 @@ BuildRequires: gtk-sharp2-devel
|
|||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libimobiledevice-devel
|
BuildRequires: libimobiledevice-devel
|
||||||
BuildRequires: libopenssl-devel
|
|
||||||
BuildRequires: libplist-devel
|
BuildRequires: libplist-devel
|
||||||
BuildRequires: libsg3_utils-devel
|
BuildRequires: libsg3_utils-devel
|
||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libudev-devel
|
|
||||||
BuildRequires: libusb-devel
|
BuildRequires: libusb-devel
|
||||||
BuildRequires: libusbmuxd-devel
|
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: mono-devel
|
BuildRequires: mono-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libusbmuxd-devel >= 0:2.1.0-1mamba
|
||||||
BuildRequires: libsg3_utils-devel >= 1.48-1mamba
|
BuildRequires: libsg3_utils-devel >= 1.48-1mamba
|
||||||
BuildRequires: libplist-devel >= 2.2.0
|
BuildRequires: libplist-devel >= 2.2.0
|
||||||
BuildRequires: libimobiledevice-devel >= 1.1.4
|
BuildRequires: libimobiledevice-devel >= 1.1.4
|
||||||
@ -64,15 +64,16 @@ Requires: gtk-doc
|
|||||||
%description apidocs
|
%description apidocs
|
||||||
Libgpod API documentation.
|
Libgpod API documentation.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
%patch 1 -p1 -b .Segmentation-fault-when-opening-ipod
|
%patch 1 -p1 -b .Segmentation-fault-when-opening-ipod
|
||||||
%patch 2 -p1 -b .pkgconfig_overlinking
|
%patch 2 -p1 -b .pkgconfig_overlinking
|
||||||
%patch 3 -p1 -b .swig
|
%patch 3 -p1 -b .swig
|
||||||
%patch 4 -p0 -b .udev
|
%patch 4 -p0 -b .udev
|
||||||
|
%patch 5 -p1 -b .libglib-2.82.4
|
||||||
|
%patch 6 -p1 -b .libplist-2.6.0
|
||||||
|
%patch 7 -p1 -b .libusb-1.0.27
|
||||||
|
|
||||||
sed -e 's|libplist >= 1.0|libplist-2.0 >= 2.2|' -i configure.ac # support libplist 2.2
|
sed -e 's|libplist >= 1.0|libplist-2.0 >= 2.2|' -i configure.ac # support libplist 2.2
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
|
|
||||||
@ -96,8 +97,6 @@ rm -f %{buildroot}%{_libdir}/libgpod.a
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -125,6 +124,9 @@ rm -f %{buildroot}%{_libdir}/libgpod.a
|
|||||||
%{_datadir}/gtk-doc/html/libgpod/*
|
%{_datadir}/gtk-doc/html/libgpod/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 04 2025 Automatic Build System <autodist@mambasoft.it> 0.8.3-6mamba
|
||||||
|
- rebuilt by autoport with build requirements: libusbmuxd-devel>=0:2.1.0-1mamba
|
||||||
|
|
||||||
* Sun Aug 20 2023 Automatic Build System <autodist@mambasoft.it> 0.8.3-5mamba
|
* Sun Aug 20 2023 Automatic Build System <autodist@mambasoft.it> 0.8.3-5mamba
|
||||||
- rebuilt by autoport with build requirements: libsg3_utils-devel>=:1.48-1mamba
|
- rebuilt by autoport with build requirements: libsg3_utils-devel>=:1.48-1mamba
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user