update to 2.5.5.1
added -common subpackage for multiarch library cohexistence [release 2.5.5.1-1mamba;Thu Dec 11 2014]
This commit is contained in:
parent
ce6ec96fff
commit
cf72f9c3ae
@ -1,2 +1,5 @@
|
||||
# libgphoto2
|
||||
|
||||
Libgphoto2 is the core of gphoto2 software.
|
||||
It is a portable library to gives access to more than 400 digital cameras.
|
||||
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- libgphoto2-2.4.6/libgphoto2_port/serial/Makefile.in 2009-05-17 00:27:40.000000000 +0200
|
||||
+++ libgphoto2-2.4.6/libgphoto2_port/serial/Makefile.in.fix 2009-08-11 21:28:25.000000000 +0200
|
||||
@@ -179,7 +179,7 @@
|
||||
RANLIB = @RANLIB@
|
||||
REQUIREMENTS_FOR_LIBUSB = @REQUIREMENTS_FOR_LIBUSB@
|
||||
SED = @SED@
|
||||
-SERIAL_LIBS = @SERIAL_LIBS@
|
||||
+SERIAL_LIBS = @SERIAL_LIBS@ -lresmgr
|
||||
SET_MAKE = @SET_MAKE@
|
||||
SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
11
libgphoto-2.4.7-Canon_A580.patch
Normal file
11
libgphoto-2.4.7-Canon_A580.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -Nru libgphoto2-2.4.7.orig/camlibs/ptp2/library.c libgphoto2-2.4.7/camlibs/ptp2/library.c
|
||||
--- libgphoto2-2.4.7.orig/camlibs/ptp2/library.c 2009-08-16 15:58:17.000000000 +0200
|
||||
+++ libgphoto2-2.4.7/camlibs/ptp2/library.c 2009-12-11 06:59:32.756728281 +0100
|
||||
@@ -862,6 +862,7 @@
|
||||
{"Canon:PowerShot SD850 (PTP mode)", 0x04a9, 0x314b, PTPBUG_DELETE_SENDS_EVENT},
|
||||
{"Canon:PowerShot A570 IS (PTP mode)", 0x04a9, 0x314c, PTPBUG_DELETE_SENDS_EVENT},
|
||||
{"Canon:PowerShot A560 (PTP mode)", 0x04a9, 0x314d, PTPBUG_DELETE_SENDS_EVENT},
|
||||
+ {"Canon:PowerShot A580 (PTP mode)", 0x04a9, 0x3177, PTPBUG_DELETE_SENDS_EVENT},
|
||||
/* mailreport from sec@dschroeder.info */
|
||||
{"Canon:Digital IXUS 75 (PTP mode)", 0x04a9, 0x314e, PTPBUG_DELETE_SENDS_EVENT},
|
||||
{"Canon:PowerShot SD750 (PTP mode)", 0x04a9, 0x314e, PTPBUG_DELETE_SENDS_EVENT},
|
32
libgphoto-usbcam
Normal file
32
libgphoto-usbcam
Normal file
@ -0,0 +1,32 @@
|
||||
#!/bin/bash
|
||||
# $Id: usbcam.group 6766 2003-09-16 16:42:44Z hun $
|
||||
#
|
||||
# /etc/hotplug/usb/usbcam
|
||||
#
|
||||
# Sets up newly plugged in USB camera so that only members of the
|
||||
# group
|
||||
|
||||
GROUP=camera
|
||||
|
||||
# can access it from user space. (Replace camera with the name of the
|
||||
# group you want to have access to the cameras.)
|
||||
#
|
||||
# Note that for this script to work, you'll need all of the following:
|
||||
# a) a line in the file /etc/hotplug/usermap that corresponds to the
|
||||
# camera you are using. You can get the correct lines for all cameras
|
||||
# supported by libgphoto2 by running "print-usb-usermap".
|
||||
# b) a group "camera" where all users allowed access to the
|
||||
# camera are listed
|
||||
# c) a Linux kernel supporting hotplug and usbdevfs
|
||||
# d) the hotplug package (http://linux-hotplug.sourceforge.net/)
|
||||
#
|
||||
# In the usermap file, the first field "usb module" should be named
|
||||
# "usbcam" like this script.
|
||||
#
|
||||
|
||||
if [ "${ACTION}" = "add" ] && [ -e "${DEVNAME}" ]
|
||||
then
|
||||
chmod o-rwx "${DEVNAME}"
|
||||
chgrp "${GROUP}" "${DEVNAME}"
|
||||
chmod g+rw "${DEVNAME}"
|
||||
fi
|
259
libgphoto2.spec
Normal file
259
libgphoto2.spec
Normal file
@ -0,0 +1,259 @@
|
||||
Name: libgphoto2
|
||||
Version: 2.5.5.1
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: A portable library to gives access to more than 400 digital cameras
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gphoto.org
|
||||
Source0: http://downloads.sourceforge.net/project/gphoto/libgphoto/%{version}/libgphoto2-%{version}.tar.bz2
|
||||
Source1: libgphoto-usbcam
|
||||
Patch0: libgphoto-2.4.6-serial.so_undef_symbol_rsm_unlock_device.patch
|
||||
Patch1: libgphoto-2.4.7-Canon_A580.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgd-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libusb-compat-devel
|
||||
BuildRequires: libusbx-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: avahi-compat-libdns_sd-devel
|
||||
%endif
|
||||
BuildRequires: liblockdev >= 1.0.1
|
||||
BuildRequires: libpopt-devel >= 4.4.5
|
||||
BuildRequires: libuuid-devel
|
||||
Provides: libgphoto
|
||||
Obsoletes: libgphoto
|
||||
Requires: udev >= 103
|
||||
Requires: %{name}-common = %{epoch}:%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Libgphoto2 is the core of gphoto2 software.
|
||||
It is a portable library to gives access to more than 400 digital cameras.
|
||||
|
||||
%package devel
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Provides: libgphoto-devel
|
||||
Obsoletes: libgphoto-devel
|
||||
|
||||
%description devel
|
||||
Libgphoto2 is the core of gphoto2 software.
|
||||
It is a portable library to gives access to more than 400 digital cameras.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package common
|
||||
Summary: Arch independent files for %{name}
|
||||
Group: System/Libraries
|
||||
|
||||
%description common
|
||||
Arch independent files for %{name}.
|
||||
|
||||
%package apidocs
|
||||
Summary: Libgphoto2 API documentation
|
||||
Group: Documentation
|
||||
Provides: libgphoto-apidocs
|
||||
Obsoletes: libgphoto-apidocs
|
||||
|
||||
%description apidocs
|
||||
Libgphoto2 API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n libgphoto2-%{version}
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-gnu-ld \
|
||||
--with-ltdl \
|
||||
--with-drivers=all \
|
||||
--with-camlibdir=%{_libdir}/libgphoto2 \
|
||||
--without-resmgr \
|
||||
--without-hal \
|
||||
--enable-static
|
||||
|
||||
# --with-cdk \
|
||||
# --without-baudboy \
|
||||
# --without-ttylock \
|
||||
# --without-lockdev
|
||||
# --enable-docs
|
||||
|
||||
%make udevscriptdir=/lib/udev/
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall udevscriptdir=/lib/udev/
|
||||
|
||||
install -d %{buildroot}/lib/udev/rules.d/
|
||||
install -d %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
|
||||
install -D -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/udev/scripts/usbcam
|
||||
|
||||
cd packaging/generic
|
||||
./print-camera-list udev-rules version 136 \
|
||||
mode 660 owner root group camera > \
|
||||
%{buildroot}/lib/udev/rules.d/40-libgphoto2.rules
|
||||
|
||||
cd ../..
|
||||
|
||||
%find_lang libgphoto2-6
|
||||
%find_lang libgphoto2_port-10
|
||||
cat *.lang > %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/libgphoto2
|
||||
%{_libdir}/libgphoto2.so.*
|
||||
%{_libdir}/libgphoto2_port.so.*
|
||||
%dir %{_libdir}/libgphoto2_port
|
||||
%{_libdir}/libgphoto2_port/*
|
||||
%{_libdir}/libgphoto2/*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files common
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/udev/scripts/usbcam
|
||||
/lib/udev/rules.d/40-libgphoto2.rules
|
||||
%dir %{_datadir}/libgphoto2/%{version}
|
||||
%{_datadir}/libgphoto2/%{version}/*
|
||||
/lib/udev/check-ptp-camera
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gphoto2-config
|
||||
%{_bindir}/gphoto2-port-config
|
||||
%{_libdir}/libgphoto2.so
|
||||
%{_libdir}/libgphoto2.a
|
||||
%{_libdir}/libgphoto2.la
|
||||
%{_libdir}/libgphoto2_port.so
|
||||
%{_libdir}/libgphoto2_port.a
|
||||
%{_libdir}/libgphoto2_port.la
|
||||
%{_libdir}/pkgconfig/libgphoto2.pc
|
||||
%{_libdir}/pkgconfig/libgphoto2_port.pc
|
||||
%dir %{_includedir}/gphoto2
|
||||
%{_includedir}/gphoto2/*
|
||||
%{_mandir}/man3/*
|
||||
%doc ChangeLog HACKING TESTERS
|
||||
%doc NEWS README
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%dir %{_datadir}/doc/libgphoto2
|
||||
%{_datadir}/doc/libgphoto2/*
|
||||
%dir %{_datadir}/doc/libgphoto2_port
|
||||
%{_datadir}/doc/libgphoto2_port/*
|
||||
|
||||
%changelog
|
||||
* Thu Dec 11 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.5.1-1mamba
|
||||
- update to 2.5.5.1
|
||||
- added -common subpackage for multiarch library cohexistence
|
||||
|
||||
* Fri May 02 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.11-3mamba
|
||||
- remove hal files to fix i586 vs x86_64 conflict
|
||||
|
||||
* Sun Nov 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.11-2mamba
|
||||
- disable hal
|
||||
|
||||
* Wed Nov 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.11-1mamba
|
||||
- update to 2.4.11
|
||||
|
||||
* Fri Aug 27 2010 Automatic Build System <autodist@mambasoft.it> 2.4.10.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue May 11 2010 Automatic Build System <autodist@mambasoft.it> 2.4.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Dec 11 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.7-2mamba
|
||||
- added patch for Canon A580 (04a9:3177) support
|
||||
- udev rules file built for version >= 136
|
||||
|
||||
* Mon Aug 31 2009 Automatic Build System <autodist@mambasoft.it> 2.4.7-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Aug 10 2009 Davide Madrisan <davide.madrisan@gmail.com> 2.4.6-2mamba
|
||||
- build requires libusb0-devel and libuuid-devel
|
||||
- fix "undefined symbol rsm_unlock_device" error in serial.so
|
||||
- new subpackage %{name}-apidocs
|
||||
|
||||
* Fri Jul 03 2009 Automatic Build System <autodist@mambasoft.it> 2.4.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Mar 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-2mamba
|
||||
- rebuilt against avahi-compat-libdns_sd
|
||||
|
||||
* Wed Feb 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Nov 01 2008 gil <puntogil@libero.it> 2.4.3-1mamba
|
||||
- update to 2.4.3
|
||||
|
||||
* Sun Jul 20 2008 gil <puntogil@libero.it> 2.4.2-1mamba
|
||||
- update to 2.4.2
|
||||
|
||||
* Wed Mar 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-1mamba
|
||||
- update to 2.4.0
|
||||
- fixed udev rules file that was setting "camera" group to all usbdev's
|
||||
|
||||
* Sun Jun 17 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-2mamba
|
||||
- configure with correct udevscriptdir for check-ptp-camera script
|
||||
|
||||
* Thu Jun 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-1mamba
|
||||
- update to 2.3.1
|
||||
- added fixed usbcam udev script (use $DEVNAME instead of $DEVICE)
|
||||
- print-camera-list-udev-rules: generate udev >= 0.98 rules
|
||||
|
||||
* Mon Oct 30 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-2qilnx
|
||||
- add udev/HAL support and remove dependency on hotplug
|
||||
|
||||
* Mon Apr 04 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.1-1qilnx
|
||||
- update to version 2.2.1 by autospec
|
||||
- specfile fixed
|
||||
|
||||
* Tue Apr 13 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-4qilnx
|
||||
- serial locking mechanism disabled because lockdev does not support devfs
|
||||
|
||||
* Fri Apr 09 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-3qilnx
|
||||
- added LD_LIBRARY_PATH to fix linking problems with port plugins
|
||||
|
||||
* Fri Apr 09 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-2qilnx
|
||||
- linux hotplug support added
|
||||
|
||||
* Thu Apr 08 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-1qilnx
|
||||
- new version build
|
||||
|
||||
* Thu Jan 01 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user