-devel: require libqgpgme [release 1.8.0-3mamba;Mon Jan 02 2017]

This commit is contained in:
Silvan Calarco 2024-01-06 04:27:16 +01:00
parent fa252d4fbb
commit a7777bf96c
2 changed files with 103 additions and 6 deletions

View File

@ -0,0 +1,12 @@
diff -Nru gpgme-1.8.0.orig/lang/cpp/src/GpgmeppConfig.cmake.in.in gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in
--- gpgme-1.8.0.orig/lang/cpp/src/GpgmeppConfig.cmake.in.in 2016-11-16 10:17:20.000000000 +0100
+++ gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in 2016-12-27 00:54:44.588503618 +0100
@@ -63,7 +63,7 @@
set_target_properties(Gpgmepp PROPERTIES
INTERFACE_INCLUDE_DIRECTORIES "@resolved_includedir@/gpgme++;@resolved_includedir@"
- INTERFACE_LINK_LIBRARIES "pthread;@resolved_libdir@/libgpgme@libsuffix@;@LIBASSUAN_LIBS@"
+ INTERFACE_LINK_LIBRARIES "pthread;@resolved_libdir@/libgpgme.so;@LIBASSUAN_LIBS@"
IMPORTED_LOCATION "@resolved_libdir@/libgpgmepp.so"
)

View File

@ -1,18 +1,25 @@
Name: libgpgme Name: libgpgme
Version: 1.6.0 Version: 1.8.0
Release: 1mamba Release: 3mamba
Summary: A library designed to make access to GnuPG easier for applications Summary: A library designed to make access to GnuPG easier for applications
Group: System/Libraries Group: System/Libraries
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.gnupg.org/(en)/related_software/gpgme/index.html URL: https://www.gnupg.org/related_software/gpgme/
Source: ftp://ftp.gnupg.org/GnuPG/gpgme/gpgme-%{version}.tar.bz2 Source: https://www.gnupg.org/ftp/gcrypt/gpgme/gpgme-%{version}.tar.bz2
Patch0: libgpgme-1.8.0-cmake-fix-libsuffix.patch
License: LGPL License: LGPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libassuan-devel
BuildRequires: libgcc
BuildRequires: libgpg-error-devel BuildRequires: libgpg-error-devel
BuildRequires: libpth-devel BuildRequires: libpython-devel
BuildRequires: libpython27-devel
BuildRequires: libpython3-devel
BuildRequires: libqt5-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: pkgconfig BuildRequires: pkgconfig
BuildRequires: gnupg2 >= 1.9.6 BuildRequires: gnupg2 >= 1.9.6
@ -28,6 +35,9 @@ Currently it uses GnuPG as its backend but the API isn't restricted to this engi
Summary: Devel files for libgpgme Summary: Devel files for libgpgme
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release} Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: libgpgmepp = %{?epoch:%epoch:}%{version}-%{release}
Requires: libqgpgme = %{?epoch:%epoch:}%{version}-%{release}
Requires: gpgme = %{?epoch:%epoch:}%{version}-%{release}
%description devel %description devel
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management. GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.
@ -35,6 +45,26 @@ Currently it uses GnuPG as its backend but the API isn't restricted to this engi
This package contains static libraries and header files need for development. This package contains static libraries and header files need for development.
%package -n libgpgmepp
Summary: gpgme C++ shared library
Group: System/Libraries
%description -n libgpgmepp
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.
Currently it uses GnuPG as its backend but the API isn't restricted to this engine; in fact we have already developed a backend for CMS (S/MIME).
This package contains the C++ shared library.
%package -n libqgpgme
Summary: gpgme Qt shared library
Group: System/Libraries
%description -n libqgpgme
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.
Currently it uses GnuPG as its backend but the API isn't restricted to this engine; in fact we have already developed a backend for CMS (S/MIME).
This package contains the Qt shared library.
%package -n gpgme %package -n gpgme
Group: Applications/Security Group: Applications/Security
Summary: gpgme command line tools Summary: gpgme command line tools
@ -44,10 +74,28 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management. GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.
Currently it uses GnuPG as its backend but the API isn't restricted to this engine; in fact we have already developed a backend for CMS (S/MIME). Currently it uses GnuPG as its backend but the API isn't restricted to this engine; in fact we have already developed a backend for CMS (S/MIME).
%package -n python-gpg
Group: System/Libraries/Python
Summary: Python bindings for gpgme
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n python-gpg
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.
Currently it uses GnuPG as its backend but the API isn't restricted to this engine; in fact we have already developed a backend for CMS (S/MIME).
%prep %prep
%setup -q -n gpgme-%{version} %setup -q -n gpgme-%{version}
#-D -T
#:<< _EOF
%patch0 -p1
# build workaround: require python 3.3
sed -i "s|3\.4|3.3|" configure.ac
%build %build
#:<< _EOF
./autogen.sh
%configure %configure
%make %make
@ -70,9 +118,27 @@ exit 0
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_libdir}/*.so.* %{_libdir}/libgpgme.so.*
%doc AUTHORS COPYING %doc AUTHORS COPYING
%files -n libgpgmepp
%defattr(-,root,root)
%{_libdir}/libgpgmepp.so.*
%files -n libqgpgme
%defattr(-,root,root)
%{_libdir}/libqgpgme.so.*
%files -n python-gpg
%defattr(-,root,root)
%{python3_sitelib}/gpg/install_files.txt
%{python27_sitearch}/gpg-1.8.0-py2.7.egg-info
%dir %{python27_sitearch}/gpg
%{python27_sitearch}/gpg/*
%{python3_sitearch}/gpg-1.8.0-py3.3.egg-info
%dir %{python3_sitearch}/gpg
%{python3_sitearch}/gpg/*
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/gpgme-config %{_bindir}/gpgme-config
@ -82,6 +148,16 @@ exit 0
%{_libdir}/*.so %{_libdir}/*.so
%{_infodir}/gpgme.info* %{_infodir}/gpgme.info*
%{_datadir}/common-lisp/source/gpgme/* %{_datadir}/common-lisp/source/gpgme/*
%dir %{_includedir}/QGpgME
%{_includedir}/QGpgME/*
%dir %{_includedir}/gpgme++
%{_includedir}/gpgme++/*
%dir %{_includedir}/qgpgme
%{_includedir}/qgpgme/*
%{_libdir}/cmake/Gpgmepp/GpgmeppConfig.cmake
%{_libdir}/cmake/Gpgmepp/GpgmeppConfigVersion.cmake
%{_libdir}/cmake/QGpgme/QGpgmeConfig.cmake
%{_libdir}/cmake/QGpgme/QGpgmeConfigVersion.cmake
%doc ChangeLog NEWS README THANKS TODO %doc ChangeLog NEWS README THANKS TODO
%files -n gpgme %files -n gpgme
@ -89,6 +165,15 @@ exit 0
%{_bindir}/gpgme-tool %{_bindir}/gpgme-tool
%changelog %changelog
* Mon Jan 02 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.0-3mamba
- -devel: require libqgpgme
* Tue Dec 27 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.0-2mamba
- fix cmake file and split libraries into packages
* Mon Dec 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.0-1mamba
- update to 1.8.0
* Sat Sep 05 2015 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba * Sat Sep 05 2015 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba
- automatic version update by autodist - automatic version update by autodist