168 lines
4.6 KiB
RPMSpec
168 lines
4.6 KiB
RPMSpec
%define gnomever 2.32.0
|
|
%define gnomemajver %(echo %gnomever | cut -d. -f 1-2)
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
#%define gnomegroup platform
|
|
#%define pkgname libgnomeui
|
|
Name: libgnomeui
|
|
Version: 2.24.5
|
|
Release: 1mamba
|
|
Summary: User interface library for libgnome
|
|
Group: Graphical Desktop/Libraries/GNOME
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.gnome.org
|
|
# bugfixes: http://ftp.acc.umu.se/pub/GNOME/sources/%{pkgname}
|
|
Source: http://ftp.gnome.org/pub/GNOME/sources/libgnomeui/%{majver}/libgnomeui-%{version}.tar.gz
|
|
License: LGPL
|
|
#BuildRequires: docbook-xsl
|
|
BuildRequires: gettext-devel
|
|
BuildRequires: pkgconfig
|
|
BuildRequires: libgnome-keyring-devel
|
|
BuildRequires: libgnome-vfs-devel
|
|
BuildRequires: libjpeg-devel
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: GConf-devel
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: gtk-doc
|
|
BuildRequires: libart_lgpl-devel
|
|
BuildRequires: libatk-devel
|
|
BuildRequires: libbonobo-devel
|
|
BuildRequires: libbonoboui-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libglade-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgnomecanvas-devel
|
|
BuildRequires: libgnome-devel
|
|
BuildRequires: libgnome-keyring-devel
|
|
BuildRequires: libgnome-vfs-devel
|
|
BuildRequires: libgtk-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libpopt-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: ORBit2-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
User interface library for libgnome.
|
|
|
|
%package devel
|
|
Summary: Devel package for libgnomeui
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
User interface library for libgnome.
|
|
Devel files for the user interface library for libgnome.
|
|
|
|
%package apidocs
|
|
Summary: %{name} API documentation
|
|
Group: Documentation
|
|
Requires: gtk-doc
|
|
|
|
%description apidocs
|
|
%{name} API documentation.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
|
|
%configure \
|
|
--libexecdir=%{_sbindir} \
|
|
--enable-gtk-doc
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%find_lang %{name}-2.0
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files -f %{name}-2.0.lang
|
|
%defattr(-,root,root)
|
|
##%{_sbindir}/gnome_segv2
|
|
%{_datadir}/pixmaps/*.png
|
|
%{_libdir}/libgnomeui-2.so.*
|
|
%{_libdir}/libglade/2.0/*
|
|
#%{_libdir}/gtk-2.0/2.10.0/filesystems/libgio.a
|
|
#%{_libdir}/gtk-2.0/2.10.0/filesystems/libgio.la
|
|
#%{_libdir}/gtk-2.0/2.10.0/filesystems/libgio.so
|
|
#%{_libdir}/gtk-2.0/*/filesystems/libgnome-vfs.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/*.a
|
|
%{_libdir}/*.la
|
|
%{_libdir}/*.so
|
|
%{_libdir}/pkgconfig/libgnomeui-2.0.pc
|
|
%{_includedir}/libgnomeui-2.0/
|
|
|
|
%files apidocs
|
|
%defattr(-,root,root)
|
|
%{_datadir}/gtk-doc/html/%{name}/
|
|
|
|
%changelog
|
|
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 2.24.5-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Sep 27 2010 Automatic Build System <autodist@mambasoft.it> 2.24.4-1mamba
|
|
- automatic update to 2.24.4 by autodist
|
|
|
|
* Thu Jul 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.3-2mamba
|
|
- rebuilt with libpng 1.4
|
|
|
|
* Sun May 30 2010 Automatic Build System <autodist@mambasoft.it> 2.24.3-1mamba
|
|
- update to 2.24.3
|
|
|
|
* Wed May 20 2009 Automatic Build System <autodist@mambasoft.it> 2.24.1-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Mar 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Oct 19 2008 gil <puntogil@libero.it> 2.24.0-1mamba
|
|
- update to 2.24.0
|
|
|
|
* Sat Jul 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.22.1-2mamba
|
|
- fixed packager email
|
|
- fixed descriptions
|
|
- set %gnomever to latest stable release
|
|
|
|
* Tue May 20 2008 gil <puntogil@libero.it> 2.22.1-1mamba
|
|
- update to version 2.22.1
|
|
- updated build requirements
|
|
- File not found: gnome_segv2
|
|
|
|
* Wed Jan 10 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.16.1-1qilnx
|
|
- update to version 2.16.1 by autospec
|
|
- new subpackage apidocs with API documentation
|
|
- updated build requirements
|
|
|
|
* Mon Aug 29 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.10.1-1qilnx
|
|
- update to version 2.10.1 by autospec
|
|
|
|
* Fri Dec 17 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-1qilnx
|
|
- update to version 2.8.0 by autospec
|
|
|
|
* Mon Aug 16 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1.1-1qilnx
|
|
- new version build
|
|
|
|
* Tue Dec 30 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0.1-1qilnx
|
|
- first build
|
|
|