automatic rebuild by autodist [release 1.2.10-5mamba;Mon Aug 19 2013]
This commit is contained in:
parent
daf54634d5
commit
139eb117fc
@ -1,2 +1,8 @@
|
||||
# libglib1
|
||||
|
||||
Glib is a handy library of utility functions.
|
||||
This C library is designed to solve some portability problems and provide other useful functionality which most programs require.
|
||||
|
||||
Glib is used by GDK, GTK+ and many applications.
|
||||
You should install Glib because many of your applications will depend on this library.
|
||||
|
||||
|
46
libglib1-1.2.10-gcc4.patch
Normal file
46
libglib1-1.2.10-gcc4.patch
Normal file
@ -0,0 +1,46 @@
|
||||
--- glib-1.2.10/gstrfuncs.c 2001-02-27 07:00:22.000000000 +0100
|
||||
+++ glib-1.2.10/gstrfuncs.c 2004-08-02 21:35:44.323958675 +0200
|
||||
@@ -867,8 +867,8 @@
|
||||
/* beware of positional parameters
|
||||
*/
|
||||
case '$':
|
||||
- g_warning (G_GNUC_PRETTY_FUNCTION
|
||||
- "(): unable to handle positional parameters (%%n$)");
|
||||
+ g_warning ("%s(): unable to handle positional parameters (%%n$)",
|
||||
+ G_GNUC_PRETTY_FUNCTION );
|
||||
len += 1024; /* try adding some safety padding */
|
||||
break;
|
||||
|
||||
@@ -1034,8 +1034,8 @@
|
||||
/* n . dddddddddddddddddddddddd E +- eeee */
|
||||
conv_len += 1 + 1 + MAX (24, spec.precision) + 1 + 1 + 4;
|
||||
if (spec.mod_extra_long)
|
||||
- g_warning (G_GNUC_PRETTY_FUNCTION
|
||||
- "(): unable to handle long double, collecting double only");
|
||||
+ g_warning ("%s(): unable to handle long double, collecting double only",
|
||||
+ G_GNUC_PRETTY_FUNCTION);
|
||||
#ifdef HAVE_LONG_DOUBLE
|
||||
#error need to implement special handling for long double
|
||||
#endif
|
||||
@@ -1077,8 +1077,8 @@
|
||||
conv_done = TRUE;
|
||||
if (spec.mod_long)
|
||||
{
|
||||
- g_warning (G_GNUC_PRETTY_FUNCTION
|
||||
- "(): unable to handle wide char strings");
|
||||
+ g_warning ("%s(): unable to handle wide char strings",
|
||||
+ G_GNUC_PRETTY_FUNCTION);
|
||||
len += 1024; /* try adding some safety padding */
|
||||
}
|
||||
break;
|
||||
@@ -1108,8 +1108,8 @@
|
||||
conv_len += format - spec_start;
|
||||
break;
|
||||
default:
|
||||
- g_warning (G_GNUC_PRETTY_FUNCTION
|
||||
- "(): unable to handle `%c' while parsing format",
|
||||
+ g_warning ("%s(): unable to handle `%c' while parsing format",
|
||||
+ G_GNUC_PRETTY_FUNCTION,
|
||||
c);
|
||||
break;
|
||||
}
|
11
libglib1-1.2.10-m4_underquoted_warning.patch
Normal file
11
libglib1-1.2.10-m4_underquoted_warning.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- glib-1.2.10/glib.m4 1998-12-31 21:58:03.000000000 +0100
|
||||
+++ glib-1.2.10/glib.m4.fix 2006-06-07 15:41:23.000000000 +0200
|
||||
@@ -5,7 +5,7 @@
|
||||
dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or
|
||||
dnl gthread is specified in MODULES, pass to glib-config
|
||||
dnl
|
||||
-AC_DEFUN(AM_PATH_GLIB,
|
||||
+AC_DEFUN([AM_PATH_GLIB],
|
||||
[dnl
|
||||
dnl Get the cflags and libraries from the glib-config script
|
||||
dnl
|
98
libglib1.spec
Normal file
98
libglib1.spec
Normal file
@ -0,0 +1,98 @@
|
||||
Name: libglib1
|
||||
Version: 1.2.10
|
||||
Release: 5mamba
|
||||
Summary: GIMP Toolkit and GIMP Drawing Kit support library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gtk.org/
|
||||
Source: ftp://ftp.gtk.org/pub/gtk/v1.2/glib-%{version}.tar.gz
|
||||
Patch0: %{name}-1.2.10-gcc4.patch
|
||||
Patch1: %{name}-1.2.10-m4_underquoted_warning.patch
|
||||
License: LGPL
|
||||
Requires(post):%{__install_info}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
Glib is a handy library of utility functions.
|
||||
This C library is designed to solve some portability problems and provide other useful functionality which most programs require.
|
||||
|
||||
Glib is used by GDK, GTK+ and many applications.
|
||||
You should install Glib because many of your applications will depend on this library.
|
||||
|
||||
%package devel
|
||||
Summary: Static libraries and header files of glib
|
||||
Group: Development/Libraries
|
||||
|
||||
%description devel
|
||||
Static libraries and header files for the support library for the GIMP's X libraries, which are available as public libraries.
|
||||
GLIB includes generally useful data structures.
|
||||
|
||||
%prep
|
||||
%setup -q -n glib-%{version}
|
||||
%patch0 -p1 -b .gcc4
|
||||
%patch1 -p1 -b .aclocal_warn
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeoldinstall
|
||||
|
||||
# fixup strange shared library permissions
|
||||
chmod 755 %{buildroot}%{_libdir}/libgmodule-*.so.*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%post devel
|
||||
%install_info glib.info
|
||||
|
||||
%preun devel
|
||||
%uninstall_info glib.info
|
||||
:
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/glib-1.2
|
||||
%{_includedir}/glib-1.2/*.h
|
||||
%{_libdir}/glib/include/glibconfig.h
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*
|
||||
%{_mandir}/man1/*
|
||||
%{_bindir}/glib-config
|
||||
%{_datadir}/aclocal/glib.m4
|
||||
%{_datadir}/info/*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 19 2013 Automatic Build System <autodist@mambasoft.it> 1.2.10-5mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Sun Jun 22 2008 Fabio Giani <fabio.giani@gmail.com> 1.2.10-4mamba
|
||||
- update Vendor, Distribution, Packager and buildrequirements list
|
||||
|
||||
* Wed Jun 07 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.10-3qilnx
|
||||
- fixed underquoted definition of AM_PATH_GLIB in glib.m4
|
||||
|
||||
* Tue Dec 13 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.2.10-2qilnx
|
||||
- specfile updated and fixed
|
||||
- added gcc4 patch
|
||||
|
||||
* Mon Jun 16 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.2.10-1qilnx
|
||||
- first build of compatibility version 1.2.10
|
Reference in New Issue
Block a user