fix library x permission [release 2.1.0-3mamba;Mon May 04 2020]
This commit is contained in:
parent
41200d5258
commit
70debfb7f1
@ -1,2 +1,7 @@
|
||||
# libglew21
|
||||
|
||||
The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source C/C++ extension loading library.
|
||||
GLEW provides efficient run-time mechanisms for determining which OpenGL extensions are supported on the target platform.
|
||||
OpenGL core and extension functionality is exposed in a single header file.
|
||||
GLEW has been tested on a variety of operating systems, including Windows, Linux, Mac OS X, FreeBSD, Irix, and Solaris.
|
||||
|
||||
|
71
libglew-1.5.1-makefile.patch
Normal file
71
libglew-1.5.1-makefile.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -ru glew.orig/config/Makefile.linux glew/config/Makefile.linux
|
||||
--- glew.orig/config/Makefile.linux 2009-06-03 22:53:27.000000000 +0200
|
||||
+++ glew/config/Makefile.linux 2009-06-03 22:54:00.000000000 +0200
|
||||
@@ -7,14 +7,8 @@
|
||||
PICFLAG = -fPIC
|
||||
LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
||||
M_ARCH ?= $(shell arch)
|
||||
-ifeq (x86_64,${M_ARCH})
|
||||
-LDFLAGS.EXTRA = -L/usr/X11R6/lib64
|
||||
-LIBDIR = $(GLEW_DEST)/lib64
|
||||
-else
|
||||
-LDFLAGS.EXTRA = -L/usr/X11R6/lib
|
||||
-LIBDIR = $(GLEW_DEST)/lib
|
||||
-endif
|
||||
-LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
|
||||
+LIBDIR = $(GLEW_DEST)$(libdir)
|
||||
+LDFLAGS.GL = -lGL
|
||||
LDFLAGS.STATIC = -Wl,-Bstatic
|
||||
LDFLAGS.DYNAMIC = -Wl,-Bdynamic
|
||||
NAME = GLEW
|
||||
diff -ru glew.orig/Makefile glew/Makefile
|
||||
--- glew.orig/Makefile 2009-06-03 22:53:27.000000000 +0200
|
||||
+++ glew/Makefile 2009-06-03 22:57:17.000000000 +0200
|
||||
@@ -41,16 +41,16 @@
|
||||
endif
|
||||
|
||||
GLEW_DEST ?= /usr
|
||||
-BINDIR ?= $(GLEW_DEST)/bin
|
||||
-LIBDIR ?= $(GLEW_DEST)/lib
|
||||
-INCDIR ?= $(GLEW_DEST)/include/GL
|
||||
+BINDIR ?= $(GLEW_DEST)$(bindir)
|
||||
+LIBDIR ?= $(GLEW_DEST)$(libdir)
|
||||
+INCDIR ?= $(GLEW_DEST)$(includedir)/GL
|
||||
SHARED_OBJ_EXT ?= o
|
||||
TARDIR = ../glew-$(GLEW_VERSION)
|
||||
TARBALL = ../glew_$(GLEW_VERSION).tar.gz
|
||||
|
||||
AR = ar
|
||||
INSTALL = install
|
||||
-STRIP = strip
|
||||
+STRIP = true
|
||||
RM = rm -f
|
||||
LN = ln -sf
|
||||
ifeq ($(MAKECMDGOALS), debug)
|
||||
@@ -95,7 +95,7 @@
|
||||
$(CC) $(CFLAGS) -o $@ $(GLEWINFO.BIN.SRCS) $(BIN.LIBS)
|
||||
|
||||
bin/$(VISUALINFO.BIN): $(VISUALINFO.BIN.SRCS) lib/$(LIB.SHARED)
|
||||
- $(CC) $(CFLAGS) -o $@ $(VISUALINFO.BIN.SRCS) $(BIN.LIBS)
|
||||
+ $(CC) $(CFLAGS) -o $@ $(VISUALINFO.BIN.SRCS) $(BIN.LIBS) -lGLU
|
||||
|
||||
%.o: %.c
|
||||
$(CC) -c $(CFLAGS) -o $@ $<
|
||||
@@ -117,7 +117,7 @@
|
||||
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
|
||||
else
|
||||
$(STRIP) -x lib/$(LIB.SHARED)
|
||||
- $(INSTALL) -m 0644 lib/$(LIB.SHARED) $(LIBDIR)/
|
||||
+ $(INSTALL) -m 0755 lib/$(LIB.SHARED) $(LIBDIR)/
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
|
||||
endif
|
||||
# development files
|
||||
@@ -132,7 +132,7 @@
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
|
||||
endif
|
||||
# utilities
|
||||
- $(INSTALL) -s -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
|
||||
+ $(INSTALL) -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
|
||||
|
||||
uninstall:
|
||||
$(RM) $(INCDIR)/wglew.h
|
118
libglew21.spec
Normal file
118
libglew21.spec
Normal file
@ -0,0 +1,118 @@
|
||||
Name: libglew21
|
||||
Version: 2.1.0
|
||||
Release: 3mamba
|
||||
Summary: The OpenGL Extension Wrangler Library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://glew.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/glew/%{version}/glew-%{version}.tgz
|
||||
Patch0: libglew-1.5.1-makefile.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libX11-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source C/C++ extension loading library.
|
||||
GLEW provides efficient run-time mechanisms for determining which OpenGL extensions are supported on the target platform.
|
||||
OpenGL core and extension functionality is exposed in a single header file.
|
||||
GLEW has been tested on a variety of operating systems, including Windows, Linux, Mac OS X, FreeBSD, Irix, and Solaris.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source C/C++ extension loading library.
|
||||
GLEW provides efficient run-time mechanisms for determining which OpenGL extensions are supported on the target platform.
|
||||
OpenGL core and extension functionality is exposed in a single header file.
|
||||
GLEW has been tested on a variety of operating systems, including Windows, Linux, Mac OS X, FreeBSD, Irix, and Solaris.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n glew-%{version}
|
||||
#%patch0 -p1
|
||||
sed -i -e 's/\r//g' config/config.guess
|
||||
|
||||
%build
|
||||
%make CFLAGS.EXTRA="$RPM_OPT_FLAGS -fPIC" CC=%{_host}-gcc
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
install -d -m0755 %{buildroot}%{_libdir}/pkgconfig/
|
||||
%makeinstall \
|
||||
PKGDIR=%{_libdir}/pkgconfig \
|
||||
BINDIR=%{_bindir} LIBDIR=%{_libdir} INCDIR=%{_includedir}/GL
|
||||
|
||||
chmod +x %{buildroot}%{_libdir}/libGLEW.so.*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libGLEW.so.*
|
||||
%doc LICENSE.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/GL/*.h
|
||||
%{_libdir}/libGLEW.a
|
||||
%{_libdir}/libGLEW.so
|
||||
%{_libdir}/pkgconfig/glew.pc
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Mon May 04 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-3mamba
|
||||
- fix library x permission
|
||||
|
||||
* Sun May 03 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-2mamba
|
||||
- legacy package
|
||||
|
||||
* Fri Aug 04 2017 Automatic Build System <autodist@mambasoft.it> 2.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 08 2016 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 25 2016 Automatic Build System <autodist@mambasoft.it> 1.13.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Feb 06 2015 Automatic Build System <autodist@mambasoft.it> 1.12.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Aug 20 2014 Automatic Build System <autodist@mambasoft.it> 1.11.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 24 2013 Automatic Build System <autodist@mambasoft.it> 1.10.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Dec 02 2012 Automatic Build System <autodist@mambasoft.it> 1.9.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 1.5.4-1mamba
|
||||
- update to 1.5.4
|
||||
|
||||
* Wed Jun 03 2009 Davide Madrisan <davide.madrisan@gmail.com> 1.5.1-2mamba
|
||||
- fixed specfile
|
||||
|
||||
* Sat Jan 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Aug 15 2008 gil <puntogil@libero.it> 1.5.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user