rebuilt to update .la file [release 2.0.12-2mamba;Sun Jun 02 2013]
This commit is contained in:
parent
d5505f026a
commit
2e2307d2ac
@ -1,2 +1,4 @@
|
||||
# libgksu
|
||||
|
||||
GKSu is a library that provides a Gtk+ frontend to su and sudo. It supports login shells and preserving environment when acting as a su frontend. It is useful to menu items or other graphical programs that need to ask a user's password to run another program as another user.
|
||||
|
||||
|
25
libgksu-2.0.12-automake-1.11.2.patch
Normal file
25
libgksu-2.0.12-automake-1.11.2.patch
Normal file
@ -0,0 +1,25 @@
|
||||
Due to the following change, pkglib_PROGRAMS is invalid:
|
||||
http://git.savannah.gnu.org/cgit/automake.git/commit/?id=9ca632642b006ac6b0fc4ce0ae5b34023faa8cbf
|
||||
|
||||
https://savannah.nongnu.org/bugs/index.php?35241
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=397411
|
||||
|
||||
---
|
||||
libgksu/Makefile.am | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libgksu/Makefile.am b/libgksu/Makefile.am
|
||||
index 49362f9..3cb1090 100644
|
||||
--- a/libgksu/Makefile.am
|
||||
+++ b/libgksu/Makefile.am
|
||||
@@ -22,8 +22,8 @@ includedir = ${prefix}/include/${PACKAGE}
|
||||
pkgconfigdir = ${libdir}/pkgconfig
|
||||
pkgconfig_DATA = libgksu2.pc
|
||||
|
||||
-pkglibdir = ${libdir}/${PACKAGE}
|
||||
-pkglib_PROGRAMS = gksu-run-helper
|
||||
+gksulibdir = ${libdir}/${PACKAGE}
|
||||
+gksulib_PROGRAMS = gksu-run-helper
|
||||
gksu_run_helper_LDADD = ${GLIB_LIBS}
|
||||
gksu_run_helper_SOURCES = gksu-run-helper.c
|
||||
|
76
libgksu-2.0.12-configure-libs.patch
Normal file
76
libgksu-2.0.12-configure-libs.patch
Normal file
@ -0,0 +1,76 @@
|
||||
# https://savannah.nongnu.org/bugs/?25362
|
||||
# https://bugs.gentoo.org/show_bug.cgi?id=226837
|
||||
diff -Nura a/configure.ac b/configure.ac
|
||||
--- a/configure.ac 2009-01-19 22:15:30.000000000 +0100
|
||||
+++ b/configure.ac 2009-01-19 22:18:10.000000000 +0100
|
||||
@@ -43,6 +43,9 @@
|
||||
PKG_CHECK_MODULES(LIBGKSU, [gtk+-2.0 >= 2.4.0, gconf-2.0, libstartup-notification-1.0, gnome-keyring-1, libgtop-2.0])
|
||||
PKG_CHECK_MODULES(GKSU_PROPERTIES, [gtk+-2.0 >= 2.4.0, gconf-2.0, libglade-2.0])
|
||||
|
||||
+PKG_CHECK_MODULES(GLIB, [glib-2.0 gthread-2.0])
|
||||
+PKG_CHECK_MODULES(GTK, [gtk+-2.0 gconf-2.0])
|
||||
+
|
||||
# Checks for library functions.
|
||||
ALL_LINGUAS="ca cs da de es eu fr hu it ko lt pl pt_BR ro ru sk sv nb nl zh_CN"
|
||||
|
||||
diff -Nura a/gksu-properties/Makefile.am b/gksu-properties/Makefile.am
|
||||
--- a/gksu-properties/Makefile.am 2009-01-19 22:15:59.000000000 +0100
|
||||
+++ b/gksu-properties/Makefile.am 2009-01-19 22:19:13.000000000 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" -DDATA_DIR=\"$(datadir)\" -DPREFIX=\"$(prefix)\"
|
||||
|
||||
bin_PROGRAMS = gksu-properties
|
||||
-gksu_properties_LDFLAGS = ${GKSU_PROPERTIES_LIBS}
|
||||
+gksu_properties_LDADD = ${GKSU_PROPERTIES_LIBS}
|
||||
gksu_properties_SOURCES = gksu-properties.c
|
||||
|
||||
gladedir = ${prefix}/share/${PACKAGE}
|
||||
diff -Nura a/libgksu/Makefile.am b/libgksu/Makefile.am
|
||||
--- a/libgksu/Makefile.am 2009-01-19 22:15:59.000000000 +0100
|
||||
+++ b/libgksu/Makefile.am 2009-01-19 22:18:25.000000000 +0100
|
||||
@@ -8,8 +8,8 @@
|
||||
# major -> breaks backward compatibility (changes to existing ABI)
|
||||
# minor -> keeps compatibility (additions to the API)
|
||||
# micro -> no change to the API/ABI
|
||||
-libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la
|
||||
-libgksu2_la_LDFLAGS = -version-info 0:2:0 -Wl,-O1 -lutil ${LIBGKSU_LIBS}
|
||||
+libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la -lutil ${LIBGKSU_LIBS}
|
||||
+libgksu2_la_LDFLAGS = -version-info 0:2:0 -Wl,-O1
|
||||
if USE_VERSION_SCRIPT
|
||||
libgksu2_la_LDFLAGS += -Wl,--version-script=libgksu.ver
|
||||
endif
|
||||
@@ -24,12 +24,11 @@
|
||||
|
||||
pkglibdir = ${libdir}/${PACKAGE}
|
||||
pkglib_PROGRAMS = gksu-run-helper
|
||||
-gksu_run_helper_LDFLAGS = `pkg-config --libs glib-2.0`
|
||||
+gksu_run_helper_LDADD = ${GLIB_LIBS}
|
||||
gksu_run_helper_SOURCES = gksu-run-helper.c
|
||||
|
||||
noinst_PROGRAMS = test-gksu
|
||||
test_gksu_SOURCES = test-gksu.c
|
||||
-test_gksu_LDADD = libgksu2.la
|
||||
-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
+test_gksu_LDADD = libgksu2.la ${GLIB_LIBS}
|
||||
|
||||
EXTRA_DIST = libgksu.ver
|
||||
diff -Nura a/libgksuui/Makefile.am b/libgksuui/Makefile.am
|
||||
--- a/libgksuui/Makefile.am 2009-01-19 22:15:59.000000000 +0100
|
||||
+++ b/libgksuui/Makefile.am 2009-01-19 22:18:54.000000000 +0100
|
||||
@@ -4,12 +4,13 @@
|
||||
|
||||
noinst_LTLIBRARIES = libgksuui1.0.la
|
||||
libgksuui1_0_la_SOURCES = gksuui-dialog.c
|
||||
-libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-config --libs gtk+-2.0 gconf-2.0`
|
||||
+libgksuui1_0_la_LDFLAGS = -Wl,-O1
|
||||
+libgksuui1_0_la_LIBADD = ${GTK_LIBS}
|
||||
|
||||
noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
|
||||
includedir = ${prefix}/include/$(PACKAGE)
|
||||
|
||||
noinst_PROGRAMS = test-gksuui
|
||||
test_gksuui_SOURCES = test-gksuui.c
|
||||
-test_gksuui_LDADD = libgksuui1.0.la
|
||||
-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
+test_gksuui_LDADD = libgksuui1.0.la ${GLIB_LIBS}
|
||||
+
|
60
libgksu-2.0.12-fbsd.patch
Normal file
60
libgksu-2.0.12-fbsd.patch
Normal file
@ -0,0 +1,60 @@
|
||||
diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/libgksu.c libgksu-2.0.0/libgksu/libgksu.c
|
||||
--- libgksu-2.0.0.orig/libgksu/libgksu.c 2006-09-14 22:35:51.000000000 -0400
|
||||
+++ libgksu-2.0.0/libgksu/libgksu.c 2006-12-12 11:28:01.000000000 -0500
|
||||
@@ -23,7 +23,12 @@
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <libutil.h>
|
||||
+#include <termios.h>
|
||||
+#else
|
||||
#include <pty.h>
|
||||
+#endif
|
||||
#include <pwd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/Makefile.am libgksu-2.0.0/libgksu/Makefile.am
|
||||
--- libgksu-2.0.0.orig/libgksu/Makefile.am 2006-09-14 22:35:52.000000000 -0400
|
||||
+++ libgksu-2.0.0/libgksu/Makefile.am 2006-12-12 11:28:01.000000000 -0500
|
||||
@@ -30,6 +30,6 @@ gksu_run_helper_SOURCES = gksu-run-helpe
|
||||
noinst_PROGRAMS = test-gksu
|
||||
test_gksu_SOURCES = test-gksu.c
|
||||
test_gksu_LDADD = libgksu2.la
|
||||
-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0`
|
||||
+test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
|
||||
EXTRA_DIST = libgksu.ver
|
||||
diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/Makefile.in libgksu-2.0.0/libgksu/Makefile.in
|
||||
--- libgksu-2.0.0.orig/libgksu/Makefile.in 2006-09-23 15:37:44.000000000 -0400
|
||||
+++ libgksu-2.0.0/libgksu/Makefile.in 2006-12-12 11:30:09.000000000 -0500
|
||||
@@ -283,7 +283,7 @@ gksu_run_helper_LDFLAGS = `pkg-config --
|
||||
gksu_run_helper_SOURCES = gksu-run-helper.c
|
||||
test_gksu_SOURCES = test-gksu.c
|
||||
test_gksu_LDADD = libgksu2.la
|
||||
-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0`
|
||||
+test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
EXTRA_DIST = libgksu.ver
|
||||
all: all-am
|
||||
|
||||
diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksuui/Makefile.am libgksu-2.0.0/libgksuui/Makefile.am
|
||||
--- libgksu-2.0.0.orig/libgksuui/Makefile.am 2006-09-14 22:35:31.000000000 -0400
|
||||
+++ libgksu-2.0.0/libgksuui/Makefile.am 2006-12-12 11:28:01.000000000 -0500
|
||||
@@ -12,4 +12,4 @@ includedir = ${prefix}/include/$(PACKAGE
|
||||
noinst_PROGRAMS = test-gksuui
|
||||
test_gksuui_SOURCES = test-gksuui.c
|
||||
test_gksuui_LDADD = libgksuui1.0.la
|
||||
-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0`
|
||||
+test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksuui/Makefile.in libgksu-2.0.0/libgksuui/Makefile.in
|
||||
--- libgksu-2.0.0.orig/libgksuui/Makefile.in 2006-09-23 15:37:44.000000000 -0400
|
||||
+++ libgksu-2.0.0/libgksuui/Makefile.in 2006-12-12 11:30:22.000000000 -0500
|
||||
@@ -250,7 +250,7 @@ libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-c
|
||||
noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
|
||||
test_gksuui_SOURCES = test-gksuui.c
|
||||
test_gksuui_LDADD = libgksuui1.0.la
|
||||
-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0`
|
||||
+test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
19
libgksu-2.0.12-make-3.82.patch
Normal file
19
libgksu-2.0.12-make-3.82.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- Makefile.am-orig 2010-08-22 16:11:19.872577459 -0500
|
||||
+++ Makefile.am 2010-08-22 16:11:55.289599110 -0500
|
||||
@@ -17,11 +17,11 @@
|
||||
|
||||
if GCONF_SCHEMAS_INSTALL
|
||||
install-data-local:
|
||||
- if test -z "$(DESTDIR)" ; then \
|
||||
- for p in $(schemas_DATA) ; do \
|
||||
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
|
||||
- done \
|
||||
- fi
|
||||
+ if test -z "$(DESTDIR)" ; then \
|
||||
+ for p in $(schemas_DATA) ; do \
|
||||
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
|
||||
+ done \
|
||||
+ fi
|
||||
else
|
||||
install-data-local:
|
||||
endif
|
40
libgksu-2.0.12-polinguas.patch
Normal file
40
libgksu-2.0.12-polinguas.patch
Normal file
@ -0,0 +1,40 @@
|
||||
# https://savannah.nongnu.org/bugs/?25360
|
||||
diff -Nura a/configure.ac b/configure.ac
|
||||
--- a/configure.ac 2009-01-19 21:50:57.000000000 +0100
|
||||
+++ b/configure.ac 2009-01-19 21:53:21.000000000 +0100
|
||||
@@ -50,7 +50,7 @@
|
||||
GETTEXT_PACKAGE=AC_PACKAGE_NAME
|
||||
AC_SUBST(GETTEXT_PACKAGE)
|
||||
|
||||
-IT_PROG_INTLTOOL
|
||||
+IT_PROG_INTLTOOL([0.35.5])
|
||||
AM_GLIB_GNU_GETTEXT
|
||||
|
||||
##################################################
|
||||
diff -Nura a/po/LINGUAS b/po/LINGUAS
|
||||
--- a/po/LINGUAS 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/po/LINGUAS 2009-01-19 21:54:24.000000000 +0100
|
||||
@@ -0,0 +1,23 @@
|
||||
+# please keep this list sorted alphabetically
|
||||
+# http://live.gnome.org/GnomeGoals/PoLinguas
|
||||
+#
|
||||
+ca
|
||||
+cs
|
||||
+da
|
||||
+de
|
||||
+es
|
||||
+eu
|
||||
+fr
|
||||
+hu
|
||||
+it
|
||||
+ko
|
||||
+lt
|
||||
+pl
|
||||
+pt_BR
|
||||
+ro
|
||||
+ru
|
||||
+sk
|
||||
+sv
|
||||
+nb
|
||||
+nl
|
||||
+zh_CN
|
117
libgksu.spec
Normal file
117
libgksu.spec
Normal file
@ -0,0 +1,117 @@
|
||||
Name: libgksu
|
||||
Version: 2.0.12
|
||||
Release: 2mamba
|
||||
Summary: A library that provides a Gtk+ frontend to su and sudo
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.nongnu.org/gksu/
|
||||
Source: http://people.debian.org/~kov/gksu/libgksu-%{version}.tar.gz
|
||||
Patch0: libgksu-2.0.12-fbsd.patch
|
||||
Patch1: libgksu-2.0.12-configure-libs.patch
|
||||
Patch2: libgksu-2.0.12-automake-1.11.2.patch
|
||||
Patch3: libgksu-2.0.12-make-3.82.patch
|
||||
Patch4: libgksu-2.0.12-polinguas.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: GConf-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libgtop-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstartup-notification-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: ORBit2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
GKSu is a library that provides a Gtk+ frontend to su and sudo. It supports login shells and preserving environment when acting as a su frontend. It is useful to menu items or other graphical programs that need to ask a user's password to run another program as another user.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
GKSu is a library that provides a Gtk+ frontend to su and sudo. It supports login shells and preserving environment when acting as a su frontend. It is useful to menu items or other graphical programs that need to ask a user's password to run another program as another user.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p0
|
||||
%patch4 -p1
|
||||
touch NEWS README
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
%configure
|
||||
%make LIBS="-lX11"
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
# -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/gconf/schemas/gksu.schemas
|
||||
%{_bindir}/gksu-properties
|
||||
%{_libdir}/libgksu2.so.*
|
||||
%{_libdir}/libgksu/gksu-run-helper
|
||||
%{_datadir}/applications/gksu-properties.desktop
|
||||
%dir %{_datadir}/libgksu
|
||||
%{_datadir}/libgksu/gksu-properties.ui
|
||||
%{_mandir}/man1/gksu-properties.1*
|
||||
%{_datadir}/pixmaps/gksu.png
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/include/libgksu/*.h
|
||||
%{_libdir}/libgksu2.a
|
||||
%{_libdir}/libgksu2.la
|
||||
%{_libdir}/libgksu2.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%dir %{_datadir}/gtk-doc/html/libgksu
|
||||
%{_datadir}/gtk-doc/html/libgksu/*
|
||||
%doc ChangeLog
|
||||
|
||||
%changelog
|
||||
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.12-2mamba
|
||||
- rebuilt to update .la file
|
||||
|
||||
* Mon Sep 28 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.12-1mamba
|
||||
- package created by autospec
|
Loading…
x
Reference in New Issue
Block a user