automatic update by autodist [release 3.4.2-1mamba;Tue Aug 27 2013]
This commit is contained in:
parent
4a8f8dcd45
commit
07dcbd9b9d
@ -1,2 +1,4 @@
|
|||||||
# libgeos
|
# libgeos
|
||||||
|
|
||||||
|
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS). As such, it aims to contain the complete functionality of JTS in C++. This includes all the OpenGIS Simple Features for SQL spatial predicate functions and spatial operators, as well as specific JTS topology functions.
|
||||||
|
|
||||||
|
10
libgeos-3.2.1-gcc43.patch
Normal file
10
libgeos-3.2.1-gcc43.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- tests/unit/geos_unit.cpp.old 2009-12-02 13:21:54.000000000 +0200
|
||||||
|
+++ tests/unit/geos_unit.cpp 2009-12-02 13:22:12.000000000 +0200
|
||||||
|
@@ -9,6 +9,7 @@
|
||||||
|
#include <tut_reporter.hpp>
|
||||||
|
// geos
|
||||||
|
#include <geos/unload.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
// std
|
||||||
|
#include <cstdlib>
|
||||||
|
#include <iomanip>
|
16
libgeos-3.2.1-swig.patch
Normal file
16
libgeos-3.2.1-swig.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up geos-3.2.1/configure.swig geos-3.2.1/configure
|
||||||
|
--- geos-3.2.1/configure.swig 2010-07-20 23:28:45.000000000 +0200
|
||||||
|
+++ geos-3.2.1/configure 2010-07-21 08:36:39.000000000 +0200
|
||||||
|
@@ -18996,9 +18996,9 @@ echo "${ECHO_T}$swig_version" >&6; }
|
||||||
|
if test -z "$available_patch" ; then
|
||||||
|
available_patch=0
|
||||||
|
fi
|
||||||
|
- if test $available_major -ne $required_major \
|
||||||
|
- -o $available_minor -ne $required_minor \
|
||||||
|
- -o $available_patch -lt $required_patch ; then
|
||||||
|
+ required_full=`printf %2.2d%2.2d%2.2d%2.2d $required_major $required_minor $required_patch`
|
||||||
|
+ available_full=`printf %2.2d%2.2d%2.2d%2.2d $available_major $available_minor $available_patch`
|
||||||
|
+ if test $available_full -lt $required_full; then
|
||||||
|
{ echo "$as_me:$LINENO: WARNING: SWIG version >= 1.3.28 is required. You have $swig_version. You should look at http://www.swig.org" >&5
|
||||||
|
echo "$as_me: WARNING: SWIG version >= 1.3.28 is required. You have $swig_version. You should look at http://www.swig.org" >&2;}
|
||||||
|
SWIG=''
|
161
libgeos.spec
Normal file
161
libgeos.spec
Normal file
@ -0,0 +1,161 @@
|
|||||||
|
%define with_python 1
|
||||||
|
%define with_ruby 1
|
||||||
|
%if %with_ruby
|
||||||
|
%define ruby_sitearchdir %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
|
||||||
|
%endif
|
||||||
|
Name: libgeos
|
||||||
|
Version: 3.4.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS)
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://trac.osgeo.org/geos/
|
||||||
|
Source: http://download.osgeo.org/geos/geos-%{version}.tar.bz2
|
||||||
|
Patch0: libgeos-3.2.1-gcc43.patch
|
||||||
|
Patch1: libgeos-3.2.1-swig.patch
|
||||||
|
License: LGPL
|
||||||
|
BuildRequires: doxygen
|
||||||
|
BuildRequires: libtool
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
%if %with_python
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
%if %with_ruby
|
||||||
|
BuildRequires: ruby-devel
|
||||||
|
%endif
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: swig
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS). As such, it aims to contain the complete functionality of JTS in C++. This includes all the OpenGIS Simple Features for SQL spatial predicate functions and spatial operators, as well as specific JTS topology functions.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS).
|
||||||
|
|
||||||
|
This package contains static libraries and headers need for development.
|
||||||
|
|
||||||
|
%package -n python-geos
|
||||||
|
Group: Development/Libraries/Python
|
||||||
|
Summary: Python module for GEOS
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: python
|
||||||
|
|
||||||
|
%description -n python-geos
|
||||||
|
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS).
|
||||||
|
|
||||||
|
This package contains Python module to build applications using GEOS and Python.
|
||||||
|
|
||||||
|
%package -n ruby-geos
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Ruby module for Player
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: ruby
|
||||||
|
|
||||||
|
%description -n ruby-geos
|
||||||
|
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS).
|
||||||
|
|
||||||
|
This package contains Ruby module to build applications using GEOS and Ruby.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n geos-%{version}
|
||||||
|
%patch0 -p0 -b .gcc43
|
||||||
|
#%patch1 -p1 -b .swig
|
||||||
|
|
||||||
|
for makefile in `find . -type f -name 'Makefile.in'`; do
|
||||||
|
sed -i 's|@LIBTOOL@|%{_bindir}/libtool|g' $makefile
|
||||||
|
done
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
%if %with_python
|
||||||
|
--enable-python \
|
||||||
|
%endif
|
||||||
|
%if %with_ruby
|
||||||
|
--enable-ruby \
|
||||||
|
%endif
|
||||||
|
--disable-static \
|
||||||
|
--disable-dependency-tracking \
|
||||||
|
|
||||||
|
%make RUBY_SO_NAME=ruby
|
||||||
|
|
||||||
|
cd doc
|
||||||
|
make doxygen-html
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%check
|
||||||
|
%make check || exit 0
|
||||||
|
|
||||||
|
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||||
|
find %{buildroot} -name '*.a' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgeos-%{version}.so
|
||||||
|
%{_libdir}/libgeos_c.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/geos-config
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%dir %{_includedir}/geos
|
||||||
|
%{_includedir}/geos/*
|
||||||
|
%{_libdir}/libgeos.so
|
||||||
|
%{_libdir}/libgeos_c.so
|
||||||
|
%doc doc/doxygen_docs
|
||||||
|
%doc ChangeLog NEWS README TODO
|
||||||
|
|
||||||
|
%if %with_python
|
||||||
|
%files -n python-geos
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{python_sitelib}/geos.pth
|
||||||
|
%dir %{python_sitelib}/geos
|
||||||
|
%{python_sitelib}/geos/geos.py*
|
||||||
|
%{python_sitearch}/geos/*.so
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if %with_ruby
|
||||||
|
%files -n ruby-geos
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{ruby_sitearchdir}/geos.so
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Mar 02 2013 Automatic Build System <autodist@mambasoft.it> 3.3.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Feb 24 2013 Automatic Build System <autodist@mambasoft.it> 3.3.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Nov 20 2012 Automatic Build System <autodist@mambasoft.it> 3.3.6-1mamba
|
||||||
|
- update to 3.3.6
|
||||||
|
|
||||||
|
* Mon Aug 06 2012 Automatic Build System <autodist@mambasoft.it> 3.3.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jan 17 2011 gil <puntogil@libero.it> 3.2.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user