automatic version update by autodist [release 0.4.8-1mamba;Sun Oct 07 2018]
This commit is contained in:
parent
5baff00216
commit
a55654cdf2
46
libgegl-0.4.8-upstream-openexr-2.3.0.patch
Normal file
46
libgegl-0.4.8-upstream-openexr-2.3.0.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From c1c3541caab485384087bbbcf1c83ef2d5bd4d43 Mon Sep 17 00:00:00 2001
|
||||
From: Hussam Al-Tayeb <me@hussam.eu.org>
|
||||
Date: Wed, 22 Aug 2018 14:55:31 +0200
|
||||
Subject: [PATCH] exr-save: avoid hard-coding Imath_2_2 name space
|
||||
|
||||
---
|
||||
operations/external/exr-save.cc | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/operations/external/exr-save.cc b/operations/external/exr-save.cc
|
||||
index b2032046c..018e5d9af 100644
|
||||
--- a/operations/external/exr-save.cc
|
||||
+++ b/operations/external/exr-save.cc
|
||||
@@ -145,10 +145,10 @@ write_tiled_exr (const float *pixels,
|
||||
&blue[0], &blue[1],
|
||||
NULL, NULL, NULL);
|
||||
{
|
||||
- Imf::Chromaticities c1 (Imath_2_2::V2f(red[0],red[1]),
|
||||
- Imath_2_2::V2f(green[0],green[1]),
|
||||
- Imath_2_2::V2f(blue[0],blue[1]),
|
||||
- Imath_2_2::V2f(wp[0],wp[1]));
|
||||
+ Imf::Chromaticities c1 (Imath::V2f(red[0],red[1]),
|
||||
+ Imath::V2f(green[0],green[1]),
|
||||
+ Imath::V2f(blue[0],blue[1]),
|
||||
+ Imath::V2f(wp[0],wp[1]));
|
||||
Imf::addChromaticities (header, c1);
|
||||
}
|
||||
}
|
||||
@@ -184,10 +184,10 @@ write_scanline_exr (const float *pixels,
|
||||
&green[0], &green[1],
|
||||
&blue[0], &blue[1],
|
||||
NULL, NULL, NULL);
|
||||
- Imf::Chromaticities c1 (Imath_2_2::V2f(red[0],red[1]),
|
||||
- Imath_2_2::V2f(green[0],green[1]),
|
||||
- Imath_2_2::V2f(blue[0],blue[1]),
|
||||
- Imath_2_2::V2f(wp[0],wp[1]));
|
||||
+ Imf::Chromaticities c1 (Imath::V2f(red[0],red[1]),
|
||||
+ Imath::V2f(green[0],green[1]),
|
||||
+ Imath::V2f(blue[0],blue[1]),
|
||||
+ Imath::V2f(wp[0],wp[1]));
|
||||
Imf::addChromaticities (header, c1);
|
||||
}
|
||||
|
||||
--
|
||||
2.18.1
|
||||
|
24
libgegl.spec
24
libgegl.spec
@ -2,7 +2,7 @@
|
||||
%define apiver %{majver}
|
||||
|
||||
Name: libgegl
|
||||
Version: 0.3.34
|
||||
Version: 0.4.8
|
||||
Release: 1mamba
|
||||
Summary: GEGL (Generic Graphics Library) is a graph based image processing framework.
|
||||
Group: System/Libraries
|
||||
@ -14,6 +14,7 @@ Source: http://download.gimp.org/pub/gegl/%{majver}/gegl-%{version}.tar.b
|
||||
Patch0: %{name}-0.1.8-fix_build.patch
|
||||
Patch1: %{name}-0.1.8-ffmpeg.patch
|
||||
Patch2: libgegl-0.2.0-liblua-5.2.patch
|
||||
Patch3: libgegl-0.4.8-upstream-openexr-2.3.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -58,6 +59,7 @@ BuildRequires: libwebp-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libraw-devel >= 0.19.0-1mamba
|
||||
BuildRequires: liblensfun-devel >= 0.3.2-1mamba
|
||||
Requires: asciidoc
|
||||
Requires: enscript
|
||||
@ -120,9 +122,10 @@ Obsoletes: %{name}-api
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# workaround for a libtool error
|
||||
mkdir operations/workshop/external/lib
|
||||
mkdir -p operations/workshop/external/lib
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -134,7 +137,7 @@ mkdir operations/workshop/external/lib
|
||||
--without-vala \
|
||||
LDFLAGS="-ltermcap"
|
||||
|
||||
%make -j1 ||%make -j1
|
||||
%make -j1 || %make -j1
|
||||
#make check
|
||||
|
||||
%install
|
||||
@ -207,6 +210,21 @@ install -d %{buildroot}%{_datadir}/pixmaps
|
||||
%{_datadir}/gtk-doc/html/gegl/*
|
||||
|
||||
%changelog
|
||||
* Sun Oct 07 2018 Automatic Build System <autodist@mambasoft.it> 0.4.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 27 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.4-2mamba
|
||||
- rebuilt by autoport with build requirements: libraw-devel>=0.19.0-1mamba
|
||||
|
||||
* Fri Jul 06 2018 Automatic Build System <autodist@mambasoft.it> 0.4.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 23 2018 Automatic Build System <autodist@mambasoft.it> 0.4.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 12 2018 Automatic Build System <autodist@mambasoft.it> 0.4.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 19 2018 Automatic Build System <autodist@mambasoft.it> 0.3.34-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user