rebuilt with libsuitesparse 4.0.2 [release 0.2.0-3mamba;Mon Feb 18 2013]
This commit is contained in:
parent
833966d085
commit
8f926813f6
@ -1,2 +1,5 @@
|
||||
# libgegl
|
||||
|
||||
GEGL provides infrastructure to do demand based cached non destructive image editing on larger than RAM buffers.
|
||||
Through babl it provides support for a wide range of color models and pixel storage formats for input and output.
|
||||
|
||||
|
38
libgegl-0.1.8-ffmpeg.patch
Normal file
38
libgegl-0.1.8-ffmpeg.patch
Normal file
@ -0,0 +1,38 @@
|
||||
--- gegl-0.1.8.orig/operations/workshop/external/ff-save.c 2012-02-11 15:53:58.347480007 +0100
|
||||
+++ gegl-0.1.8/operations/workshop/external/ff-save.c 2012-02-11 15:55:57.422072494 +0100
|
||||
@@ -455,7 +455,7 @@
|
||||
p->audio_outbuf_size, p->samples);
|
||||
|
||||
pkt.pts = c->coded_frame->pts;
|
||||
- pkt.flags |= PKT_FLAG_KEY;
|
||||
+ pkt.flags |= AV_PKT_FLAG_KEY;
|
||||
pkt.stream_index = st->index;
|
||||
pkt.data = p->audio_outbuf;
|
||||
|
||||
@@ -496,7 +496,7 @@
|
||||
|
||||
c = st->codec;
|
||||
c->codec_id = codec_id;
|
||||
- c->codec_type = CODEC_TYPE_VIDEO;
|
||||
+ c->codec_type = AVMEDIA_TYPE_VIDEO;
|
||||
|
||||
/* put sample propeters */
|
||||
c->bit_rate = op->bitrate;
|
||||
@@ -689,7 +689,7 @@
|
||||
AVPacket pkt;
|
||||
av_init_packet (&pkt);
|
||||
|
||||
- pkt.flags |= PKT_FLAG_KEY;
|
||||
+ pkt.flags |= AV_PKT_FLAG_KEY;
|
||||
pkt.stream_index = st->index;
|
||||
pkt.data = (uint8_t *) picture_ptr;
|
||||
pkt.size = sizeof (AVPicture);
|
||||
@@ -712,7 +712,7 @@
|
||||
|
||||
pkt.pts = c->coded_frame->pts;
|
||||
if (c->coded_frame->key_frame)
|
||||
- pkt.flags |= PKT_FLAG_KEY;
|
||||
+ pkt.flags |= AV_PKT_FLAG_KEY;
|
||||
pkt.stream_index = st->index;
|
||||
pkt.data = p->video_outbuf;
|
||||
pkt.size = out_size;
|
26
libgegl-0.1.8-fix_build.patch
Normal file
26
libgegl-0.1.8-fix_build.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 60c5abed6c97559ac75d8550e29e5e1c425fb733 Mon Sep 17 00:00:00 2001
|
||||
From: Øyvind Kolås <pippin@gimp.org>
|
||||
Date: Wed, 04 Jan 2012 04:52:23 +0000
|
||||
Subject: build: add GEGL-0.1.deps to EXTRA_DIST
|
||||
|
||||
---
|
||||
diff --git a/gegl/Makefile.am b/gegl/Makefile.am
|
||||
index 3d3605f..02a540e 100644
|
||||
--- a/gegl/Makefile.am
|
||||
+++ b/gegl/Makefile.am
|
||||
@@ -138,6 +138,8 @@ vapi_DATA = \
|
||||
|
||||
endif # HAVE_VALA
|
||||
|
||||
+EXTRA_DIST = gegl-@GEGL_API_VERSION@.deps
|
||||
+
|
||||
endif # HAVE_INTROSPECTION
|
||||
|
||||
#
|
||||
--
|
||||
cgit v0.9.0.2
|
||||
diff -Nru gegl-0.1.8.orig/gegl/gegl-0.1.deps gegl-0.1.8/gegl/gegl-0.1.deps
|
||||
--- gegl-0.1.8.orig/gegl/gegl-0.1.deps 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ gegl-0.1.8/gegl/gegl-0.1.deps 2012-01-05 19:58:45.593314031 +0100
|
||||
@@ -0,0 +1 @@
|
||||
+babl-0.1
|
269
libgegl-0.2.0-liblua-5.2.patch
Normal file
269
libgegl-0.2.0-liblua-5.2.patch
Normal file
@ -0,0 +1,269 @@
|
||||
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
|
||||
<html xmlns="http://www.w3.org/1999/xhtml">
|
||||
<head>
|
||||
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
|
||||
<title>commit a5b601502d3293966994911cfcab6a0eb0d68e41 Author: Vincent Untz <vuntz@gno - Pastebin.com</title>
|
||||
<link rel="shortcut icon" href="/favicon.ico" />
|
||||
<link href="/cache/css/text.css" rel="stylesheet" type="text/css" /> <link href="/i/main.css" rel="stylesheet" type="text/css" />
|
||||
|
||||
<script type="text/javascript" src="/js/jquery.js"></script>
|
||||
<script type="text/javascript" src="/js/main.js"></script>
|
||||
<meta property="fb:page_id" content="150549571626327" />
|
||||
<meta property="og:title" content="commit a5b601502d3293966994911cfcab6a0eb0d68e41 Author: Vincent Untz <vuntz@gno - Pastebin.com" />
|
||||
<meta property="og:url" content="http://pastebin.com/KqsF3i9s" />
|
||||
<meta property="og:image" content="http://pastebin.com/i/fb.jpg" />
|
||||
<meta property="og:site_name" content="Pastebin" />
|
||||
<meta name="google-site-verification" content="jkUAIOE8owUXu8UXIhRLB9oHJsWBfOgJbZzncqHoF4A" />
|
||||
<link rel="canonical" href="http://pastebin.com/KqsF3i9s" />
|
||||
<!--[if SafMob]>
|
||||
<style>body{-webkit-text-size-adjust:none;}</style>
|
||||
<![endif]-->
|
||||
<script type="text/javascript">
|
||||
var _gaq = _gaq || [];
|
||||
_gaq.push(['_setAccount', 'UA-58643-34']);
|
||||
_gaq.push(['_trackPageview']);
|
||||
(function() {
|
||||
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
|
||||
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
|
||||
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
|
||||
})();
|
||||
</script>
|
||||
</head>
|
||||
<body>
|
||||
<div id="super_frame">
|
||||
<div id="logo" onclick="location.href='/'" title="Create New Paste"></div>
|
||||
<div id="header">
|
||||
<div id="header_top">
|
||||
<span class="span_left more">PASTEBIN</span><span class="span_left less"> | #1 paste tool since 2002</span><span class="min_max_span narrow_it" title="Change layout width"></span><span class="min_max_span wide_it" style="display:none" title="Change layout width"></span> <ul class="top_menu">
|
||||
<li class="no_border_li"><a href="/" accesskey="n">create new paste</a></li><li><a href="/tools">tools</a></li><li><a href="/api">api</a></li><li><a href="/archive">archive</a></li><li><a href="/faq">faq</a></li>
|
||||
</ul>
|
||||
</div>
|
||||
<div id="header_middle">
|
||||
<span class="span_left big"><a href="/">PASTEBIN</a></span>
|
||||
<a href="http://twitter.com/pastebin" target="_blank"><img src="/i/t.gif" alt="" class="i_tf" width="122" height="20" border="0" /></a> <iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2Fpastebin&send=false&layout=button_count&width=100&show_faces=false&action=like&colorscheme=light&font=segoe+ui&height=21&appId=231493360234820" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100px; height:21px;margin:13px 0 0 10px;vertical-align:top" allowTransparency="true"></iframe>
|
||||
<div id="header_middle_search">
|
||||
<form class="search_form" name="search_form" method="get" action="/search" id="cse-search-box">
|
||||
<input type="hidden" name="cx" value="partner-pub-4339714761096906:1qhz41g8k4m" />
|
||||
<input type="hidden" name="cof" value="FORID:10" />
|
||||
<input type="hidden" name="ie" value="UTF-8" />
|
||||
<input class="search_input" type="text" name="q" size="5" value="search..." onfocus="this.value=''" /><input name="sa" class="search_button" src="/i/t.gif" alt="Search..." type="image" value="Search" />
|
||||
</form>
|
||||
</div>
|
||||
</div>
|
||||
<div id="header_bottom">
|
||||
<div class="div_top_menu">
|
||||
<img src="/i/t.gif" class="i_n" width="16" height="16" alt="" border="0" /> <a href="/">create new paste</a>
|
||||
<img src="/i/t.gif" class="i_t" width="16" height="16" alt="" border="0" /> <a href="/trends">trending pastes</a>
|
||||
</div>
|
||||
<ul class="top_menu">
|
||||
<li class="no_border_li"><a href="/signup">sign up</a></li><li><a href="/login">login</a></li><li><a href="/alerts">my alerts</a></li><li><a href="/settings">my settings</a></li><li><a href="/profile">my profile</a></li> </ul>
|
||||
</div>
|
||||
</div>
|
||||
|
||||
<div class="frame_spacer"><!-- --></div>
|
||||
<div id="monster_frame">
|
||||
<div id="content_frame">
|
||||
<div id="content_right">
|
||||
<div class="content_right_menu">
|
||||
<div class="content_right_title"><a href="/archive">Public Pastes</a></div>
|
||||
<div id="menu_2">
|
||||
<ul class="right_menu"><li><a href="/JQCCEmvF">Untitled</a><span>3 sec ago</span></li><li><a href="/YNGijm7H">Untitled</a><span>3 sec ago</span></li><li><a href="/fvkUgxES">Untitled</a><span>3 sec ago</span></li><li><a href="/YCHrqbpK">ser_1353373250203</a><span>18 sec ago</span></li><li><a href="/k1c4SxU8">Log Diamante 16-nov</a><span>18 sec ago</span></li><li><a href="/3A4kJRP8">For Jill</a><span>PHP | 25 sec ago</span></li><li><a href="/Uf9jJtyk">Untitled</a><span>36 sec ago</span></li><li><a href="/dVCTuYDw">Untitled</a><span>30 sec ago</span></li></ul></div></div>
|
||||
<div style="padding: 0 0 10px 0;width:160px;height:600px;clear:left;">
|
||||
<iframe src="/etc/ads/160x600_tribal.html" width="160" height="600" scrolling="no" frameborder="0" name="ad1"></iframe>
|
||||
</div> </div>
|
||||
<div id="content_left">
|
||||
<div class="paste_box_frame">
|
||||
<div class="tweet">
|
||||
<div onclick="facebookpopup('/KqsF3i9s'); return false;" id="b_facebook2"><span id="b_facebook"></span></div>
|
||||
<div onclick="twitpopup('/KqsF3i9s'); return false;" id="b_twitter2"><span id="b_twitter"></span></div>
|
||||
</div>
|
||||
<div class="paste_box_icon">
|
||||
<img src="/i/t.gif" class="i_gb" alt="Guest" border="0" />
|
||||
</div>
|
||||
<div class="paste_box_info">
|
||||
<div class="paste_box_line1" title="Untitled"><img src="/i/t.gif" class="i_p0" width="16" height="16" title="Public paste, everybody can see this paste." alt="" border="0" /><h1>Untitled</h1> </div>
|
||||
<div class="paste_box_line2">By: a guest on Nov 19th, 2012 | syntax: <a href="/archive/text">None</a> | size: 1.26 KB | hits: 3 | expires: in 58 min</div>
|
||||
<div class="paste_box_line3"><a href="/download.php?i=KqsF3i9s" rel="nofollow">download</a> | <a href="/raw.php?i=KqsF3i9s" target="_blank" rel="nofollow">raw</a> | <a href="/embed.php?i=KqsF3i9s" rel="nofollow">embed</a> | <a href="/report.php?i=KqsF3i9s" rel="nofollow">report abuse</a></div>
|
||||
</div>
|
||||
</div>
|
||||
|
||||
<div class="banner_728">
|
||||
<iframe src="/etc/ads/728x90_tribal.html" width="728" height="90" scrolling="no" frameborder="0" name="ad1"></iframe>
|
||||
</div>
|
||||
<div class="layout_clear"></div><div id="code_frame2">
|
||||
<div id="code_frame">
|
||||
<div id="code_buttons">
|
||||
|
||||
<a href="javascript:togglev();" title="Show/Hide line numbers"><img src="/i/t.gif" border="0" alt="" class="i16 line" /></a>
|
||||
<a href="javascript:togglew('text');" title="Toggle text wrapping"><img src="/i/t.gif" border="0" alt="" class="i16 wrap" /></a>
|
||||
<a href="#" class="copyme" title="Copy text to clipboard"><img src="/i/t.gif" border="0" alt="" class="i16 clipboard" /></a><span id="copied">Copied</span>
|
||||
</div>
|
||||
<div class="text"><ol><li class="li1"><div class="de1">commit a5b601502d3293966994911cfcab6a0eb0d68e41</div></li>
|
||||
<li class="li2"><div class="de2">Author: Vincent Untz <vuntz@gnome.org></div></li>
|
||||
<li class="li1"><div class="de1">Date: Wed Jan 11 09:52:25 2012 +0100</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1"> Fix build with lua 5.2 by not using API deprecated in 5.1 already</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1"> https://bugzilla.gnome.org/show_bug.cgi?id=667675</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1">diff --git a/operations/workshop/external/gluas.c b/operations/workshop/external/gluas.c</div></li>
|
||||
<li class="li2"><div class="de2">index 536f1d9..dbcc362 100644</div></li>
|
||||
<li class="li1"><div class="de1">--- a/operations/workshop/external/gluas.c</div></li>
|
||||
<li class="li2"><div class="de2">+++ b/operations/workshop/external/gluas.c</div></li>
|
||||
<li class="li1"><div class="de1">@@ -97,7 +97,7 @@ static int l_progress (lua_State * lua);</div></li>
|
||||
<li class="li2"><div class="de2"> static int l_flush (lua_State * lua);</div></li>
|
||||
<li class="li1"><div class="de1"> static int l_print (lua_State * lua);</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1">-static const luaL_reg gluas_functions[] =</div></li>
|
||||
<li class="li2"><div class="de2">+static const luaL_Reg gluas_functions[] =</div></li>
|
||||
<li class="li1"><div class="de1"> {</div></li>
|
||||
<li class="li2"><div class="de2"> {"set_rgba", l_set_rgba},</div></li>
|
||||
<li class="li1"><div class="de1"> {"get_rgba", l_get_rgba},</div></li>
|
||||
<li class="li2"><div class="de2">@@ -122,7 +122,7 @@ static const luaL_reg gluas_functions[] =</div></li>
|
||||
<li class="li1"><div class="de1"> };</div></li>
|
||||
<li class="li2"><div class="de2"> static void</div></li>
|
||||
<li class="li1"><div class="de1"> register_functions (lua_State *L,</div></li>
|
||||
<li class="li2"><div class="de2">- const luaL_reg *l)</div></li>
|
||||
<li class="li1"><div class="de1">+ const luaL_Reg *l)</div></li>
|
||||
<li class="li2"><div class="de2"> {</div></li>
|
||||
<li class="li1"><div class="de1"> for (;l->name; l++)</div></li>
|
||||
<li class="li2"><div class="de2"> lua_register (L, l->name, l->func);</div></li>
|
||||
<li class="li1"><div class="de1">@@ -146,7 +146,7 @@ drawable_lua_process (GeglOperation *op,</div></li>
|
||||
<li class="li2"><div class="de2"> lua_State *L;</div></li>
|
||||
<li class="li1"><div class="de1"> Priv p;</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1">- L = lua_open ();</div></li>
|
||||
<li class="li2"><div class="de2">+ L = luaL_newstate ();</div></li>
|
||||
<li class="li1"><div class="de1"> luaL_openlibs (L);</div></li>
|
||||
<li class="li2"><div class="de2"> </div></li>
|
||||
<li class="li1"><div class="de1"> register_functions (L, gluas_functions);</div></li>
|
||||
</ol></div>
|
||||
</div></div>
|
||||
<div class="content_title">
|
||||
<span class="span_right raw_links"><a href="/index/KqsF3i9s" rel="nofollow">create a <u>new version</u> of this paste</a></span>
|
||||
RAW Paste Data
|
||||
</div>
|
||||
<form class="paste_form" id="myform" method="post" action="/post.php">
|
||||
<div class="textarea_border">
|
||||
<textarea id="paste_code" class="paste_code" name="paste_code" onkeydown="return catchTab(this,event)">commit a5b601502d3293966994911cfcab6a0eb0d68e41
|
||||
Author: Vincent Untz <vuntz@gnome.org>
|
||||
Date: Wed Jan 11 09:52:25 2012 +0100
|
||||
|
||||
Fix build with lua 5.2 by not using API deprecated in 5.1 already
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=667675
|
||||
|
||||
diff --git a/operations/workshop/external/gluas.c b/operations/workshop/external/gluas.c
|
||||
index 536f1d9..dbcc362 100644
|
||||
--- a/operations/workshop/external/gluas.c
|
||||
+++ b/operations/workshop/external/gluas.c
|
||||
@@ -97,7 +97,7 @@ static int l_progress (lua_State * lua);
|
||||
static int l_flush (lua_State * lua);
|
||||
static int l_print (lua_State * lua);
|
||||
|
||||
-static const luaL_reg gluas_functions[] =
|
||||
+static const luaL_Reg gluas_functions[] =
|
||||
{
|
||||
{"set_rgba", l_set_rgba},
|
||||
{"get_rgba", l_get_rgba},
|
||||
@@ -122,7 +122,7 @@ static const luaL_reg gluas_functions[] =
|
||||
};
|
||||
static void
|
||||
register_functions (lua_State *L,
|
||||
- const luaL_reg *l)
|
||||
+ const luaL_Reg *l)
|
||||
{
|
||||
for (;l->name; l++)
|
||||
lua_register (L, l->name, l->func);
|
||||
@@ -146,7 +146,7 @@ drawable_lua_process (GeglOperation *op,
|
||||
lua_State *L;
|
||||
Priv p;
|
||||
|
||||
- L = lua_open ();
|
||||
+ L = luaL_newstate ();
|
||||
luaL_openlibs (L);
|
||||
|
||||
register_functions (L, gluas_functions);</textarea>
|
||||
</div>
|
||||
</form>
|
||||
<script type="text/javascript" language="javascript">
|
||||
$(document).ready(function(){
|
||||
$("a.copyme").zclip({
|
||||
copy:$('#paste_code').text(),
|
||||
afterCopy:function(){
|
||||
$("#copied").show();
|
||||
|
||||
$("#copied").fadeOut("slow");
|
||||
}
|
||||
});
|
||||
$('textarea').autoResize({minHeight: 80,maxHeight: 250});
|
||||
geturl = "http://pastebin.com/KqsF3i9s";
|
||||
$.getJSON('http://graph.facebook.com/'+geturl+'&callback=?',
|
||||
function(data) {
|
||||
$('#b_facebook').append(data.shares || 0);
|
||||
});
|
||||
$.getJSON('http://urls.api.twitter.com/1/urls/count.json?url='+geturl+'&callback=?',
|
||||
function(data) {
|
||||
$('#b_twitter').append(data.count);
|
||||
});
|
||||
})
|
||||
</script>
|
||||
|
||||
<script type="text/javascript"><!--
|
||||
e9 = new Object();
|
||||
e9.size = "336x280,300x250,300x600";
|
||||
e9.noAd = 1;
|
||||
//--></script>
|
||||
<script type="text/javascript" src="http://tags.expo9.exponential.com/tags/Pastebincom/ROS/tags.js"></script> <div style="margin:10px 0;clear:left"></div>
|
||||
</div>
|
||||
<div class="frame_spacer"><!-- --></div>
|
||||
<div id="footer_top" style="clear:both">
|
||||
<div class="footer_top_title">Pastebin.com Tools & Applications</div>
|
||||
<div class="footer_top_text">
|
||||
<img src="/i/t.gif" alt="" class="icon24 iphone" /><a href="/tools#iphone">iPhone/iPad</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 windows" /><a href="/tools#windows">Windows</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 firefox" /><a href="/tools#firefox">Firefox</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 chrome" /><a href="/tools#chrome">Chrome</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 webos" /><a href="/tools#webos">WebOS</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 android" /><a href="/tools#android">Android</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 macos" /><a href="/tools#macos">Mac</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 opera" /><a href="/tools#opera">Opera</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 clickto" /><a href="/tools#clickto">Click.to</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 unix" /><a href="/tools#pastebincl">UNIX</a>
|
||||
<img src="/i/t.gif" alt="" class="icon24 windowsphone" /><a href="/tools#windowsphone">WinPhone</a>
|
||||
</div>
|
||||
</div>
|
||||
</div>
|
||||
</div>
|
||||
</div>
|
||||
<div id="footer">
|
||||
<div id="logo_small"></div>
|
||||
<div id="footer_links">
|
||||
<a href="/">create new paste</a> | <a href="/api">api</a> | <a href="/trends">trends</a> | <a href="/users">users</a> | <a href="/faq">faq</a> | <a href="/tools">tools</a> | <a href="/domains">domains center</a> | <a href="/privacy.php">privacy</a> | <a href="/contact">contact</a> | <a href="/stats">stats</a> | <a href="/pro">go pro</a>
|
||||
<br />Follow us: <a href="http://www.facebook.com/pages/Pastebincom/150549571626327" target="_blank">pastebin on facebook</a> | <a href="http://twitter.com/#!/pastebin" target="blank">pastebin on twitter</a> | <a href="https://www.google.com/search?gl=us&pz=1&cf=all&ned=us&hl=en&tbm=nws&as_oq=pastebin&as_occt=any&as_qdr=d&authuser=0" target="_blank">pastebin in the news</a>
|
||||
|
||||
<br />Pastebin v3.1 rendered in: 0.005 seconds
|
||||
</div>
|
||||
<div id="footer_right" title="DDoS Protection and Dedicated Server provided by Gigenet.com" onclick="location.href='http://www.gigenet.com/'"></div>
|
||||
</div>
|
||||
<script type="text/javascript">
|
||||
$('.narrow_it').click(function(){
|
||||
$('#super_frame').animate({width:'100%'}, 500);
|
||||
$('#footer').animate({width:'100%'}, 500);
|
||||
$(".narrow_it").hide();
|
||||
$(".wide_it").show();
|
||||
$.get('/layout.php', function(data) {
|
||||
});
|
||||
});
|
||||
$('.wide_it').click(function(){
|
||||
$('#super_frame').animate({width:'960px'}, 500);
|
||||
$('#footer').animate({width:'960px'}, 500);
|
||||
$(".wide_it").hide();
|
||||
$(".narrow_it").show();
|
||||
$.get('/layout.php', function(data) {
|
||||
});
|
||||
});
|
||||
</script>
|
||||
<script type="text/javascript" src="http://goaww.com/stats.php"></script>
|
||||
</body>
|
||||
</html>
|
245
libgegl.spec
Normal file
245
libgegl.spec
Normal file
@ -0,0 +1,245 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define apiver %{majver}
|
||||
|
||||
Name: libgegl
|
||||
Version: 0.2.0
|
||||
Release: 3mamba
|
||||
Summary: GEGL (Generic Graphics Library) is a graph based image processing framework.
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://gegl.org/
|
||||
Source: ftp://ftp.gimp.org/pub/gegl/%{majver}/gegl-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.1.8-fix_build.patch
|
||||
Patch1: %{name}-0.1.8-ffmpeg.patch
|
||||
Patch2: libgegl-0.2.0-liblua-5.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libbabl-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcroco-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libilmbase-devel
|
||||
BuildRequires: libjasper-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblensfun-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libopenraw-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libspiro-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libswscale-ffmpeg-devel
|
||||
BuildRequires: libts-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: asciidoc
|
||||
Requires: enscript
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
#Optional features:
|
||||
# GEGL docs: yes
|
||||
# Build workshop: yes
|
||||
# Build website: yes
|
||||
# SIMD: sse:yes mmx:yes
|
||||
|
||||
#Optional dependencies:
|
||||
# GTK+: yes
|
||||
# GIO: yes
|
||||
# Ruby: yes
|
||||
# Lua: yes
|
||||
# Cairo: yes
|
||||
# Pango: yes
|
||||
# pangocairo: yes
|
||||
# GDKPixbuf: yes
|
||||
# JPEG: yes
|
||||
# PNG: yes
|
||||
# OpenEXR: yes
|
||||
# rsvg: yes
|
||||
# SDL: yes
|
||||
# openraw: yes
|
||||
# asciidoc: yes
|
||||
# enscript: yes
|
||||
# graphviz: yes
|
||||
# avcodec: yes
|
||||
# avformat: yes
|
||||
# V4L: yes
|
||||
%description
|
||||
GEGL provides infrastructure to do demand based cached non destructive image editing on larger than RAM buffers.
|
||||
Through babl it provides support for a wide range of color models and pixel storage formats for input and output.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
GEGL (Generic Graphics Library) is a graph based image processing framework.
|
||||
GEGL provides infrastructure to do demand based cached non destructive image editing on larger than RAM buffers.
|
||||
Through babl it provides support for a wide range of color models and pixel storage formats for input and output.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package apidocs
|
||||
Summary: %{name} API documentation
|
||||
Group: Documentation
|
||||
Provides: %{name}-api
|
||||
Obsoletes: %{name}-api
|
||||
|
||||
%description apidocs
|
||||
%{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n gegl-%{version}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# workaround for a libtool error
|
||||
mkdir operations/workshop/external/lib
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
#export CAIRO_CFLAGS=-I/usr/include/cairo
|
||||
%configure \
|
||||
--enable-gtk-doc \
|
||||
--enable-workshop \
|
||||
--enable-static \
|
||||
--without-vala
|
||||
|
||||
%make
|
||||
#make check
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall gtkdochtmldir=%{_datadir}/gtk-doc/html/gegl
|
||||
install -d %{buildroot}%{_datadir}/applications
|
||||
install -d %{buildroot}%{_datadir}/pixmaps
|
||||
|
||||
#install -m 644 docs/gallery/data/gegl.png %{buildroot}%{_datadir}/pixmaps
|
||||
|
||||
#cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
#[Desktop Entry]
|
||||
#Name=GEGL
|
||||
#GenericName=Generic Graphics Library
|
||||
#Comment=A graph based image processing framework
|
||||
#Exec=/usr/bin/gegl
|
||||
#Icon=/usr/share/pixmaps/gegl.png
|
||||
#Terminal=false
|
||||
#Type=Application
|
||||
#Categories=KDE;Graphics;
|
||||
#EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gegl
|
||||
%{_libdir}/*.so.*
|
||||
#%{_datadir}/gir-1.0/Gegl-0.1.gir
|
||||
%dir %{_libdir}/gegl-%{apiver}
|
||||
%{_libdir}/gegl-%{apiver}/*.a
|
||||
%{_libdir}/gegl-%{apiver}/*.la
|
||||
%{_libdir}/gegl-%{apiver}/*.so
|
||||
%{_datadir}/locale/*/LC_MESSAGES/gegl-0.2.mo
|
||||
%doc AUTHORS COPYING COPYING.LESSER
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/gegl-%{apiver}
|
||||
%{_includedir}/gegl-%{apiver}/*.h
|
||||
%{_includedir}/gegl-%{apiver}/opencl/*.h
|
||||
%dir %{_includedir}/gegl-%{apiver}/operation
|
||||
%{_includedir}/gegl-%{apiver}/operation/*.h
|
||||
%dir %{_libdir}/gegl-%{apiver}
|
||||
#%{_libdir}/girepository-1.0/Gegl-0.1.typelib
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog NEWS README
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/gtk-doc/html/gegl/*.html
|
||||
%{_datadir}/gtk-doc/html/gegl/gegl.css
|
||||
%{_datadir}/gtk-doc/html/gegl/gegl.devhelp
|
||||
|
||||
%changelog
|
||||
* Mon Feb 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.0-3mamba
|
||||
- rebuilt with libsuitesparse 4.0.2
|
||||
|
||||
* Tue Nov 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.0-2mamba
|
||||
- rebuilt (added lua 5.2 patch)
|
||||
|
||||
* Thu May 03 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.2.0-1mamba
|
||||
- update to 0.2.0
|
||||
|
||||
* Mon Mar 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.8-3mamba
|
||||
- rebuilt with libsuitesparse (obsoleting libumfpack)
|
||||
|
||||
* Sat Feb 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.8-2mamba
|
||||
- move plugin libraries from devel to main package
|
||||
|
||||
* Thu Jan 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.8-1mamba
|
||||
- update to 0.1.8
|
||||
|
||||
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 0.1.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Feb 09 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.4-1mamba
|
||||
- update to 0.1.4
|
||||
|
||||
* Mon Oct 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.2-2mamba
|
||||
- rebuilt with libpng 1.4
|
||||
|
||||
* Sat May 22 2010 Automatic Build System <autodist@mambasoft.it> 0.1.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Jul 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.0-1mamba
|
||||
- update to 0.1.0
|
||||
|
||||
* Tue Mar 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.22-1mamba
|
||||
- update to 0.0.22
|
||||
- removed desktop entry
|
||||
- api package renamed to apidocs
|
||||
|
||||
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.18-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.18-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Oct 15 2008 gil <puntogil@libero.it> 0.0.18-1mamba
|
||||
- update to 0.0.18
|
||||
- renamed libgegl
|
||||
- optional features added (workshop, website)
|
||||
- added desktop file
|
||||
|
||||
* Wed Oct 01 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.0.10-1mamba
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user