190 lines
6.4 KiB
RPMSpec
190 lines
6.4 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f 1-2)
|
|
Name: libgee
|
|
Version: 0.20.6
|
|
Release: 1mamba
|
|
Summary: GObject collection library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://wiki.gnome.org/Projects/Libgee
|
|
Source: http://ftp.acc.umu.se/pub/GNOME/sources/libgee/%{majver}/libgee-%{version}.tar.xz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libglib-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: gobject-introspection-devel
|
|
BuildRequires: vala-devel
|
|
|
|
%description
|
|
Libgee is a collection library providing GObject-based interfaces and classes for commonly used data structures.
|
|
Libgee provides the following interfaces:
|
|
|
|
* Iterable
|
|
* Collection
|
|
* List
|
|
* Set
|
|
* MultiSet
|
|
* Queue
|
|
* Deque
|
|
* Iterator
|
|
* Map
|
|
* MultiMap
|
|
|
|
The ArrayList, HashSet, HashMap, HashMultiSet, HashMultiMap, LinkedList, PriorityQueue, TreeSet, TreeMap, TreeMultiSet, and TreeMultiMap classes provide a reasonable sample implementation of those interfaces. In addition, a set of abstract classes are provided to ease the implementation of new collections.
|
|
Around that, the API provide means to retrieve read-only views, efficient sort algorithms, simple, bi-directional or index-based mutable iterators depending on the collection type.
|
|
Libgee is written in Vala and can be used like any GObject-based C library.
|
|
It's planned to provide bindings for further languages.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: vala
|
|
Obsoletes: %{name}-static
|
|
|
|
%description devel
|
|
Libgee is a collection library providing GObject-based interfaces and classes for commonly used data structures.
|
|
This package contains libraries and header files needed for development.
|
|
|
|
%package static
|
|
Group: Development/Libraries
|
|
Summary: Static libraries for %{name}
|
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description static
|
|
Libgee is a collection library providing GObject-based interfaces and classes for commonly used data structures.
|
|
This package contains static libraries needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%configure
|
|
%make
|
|
|
|
%check
|
|
make check
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libgee-*.so.*
|
|
%{_libdir}/girepository-?.?/Gee-?.?.typelib
|
|
%doc AUTHORS COPYING
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/gee-?.?
|
|
%{_includedir}/gee-?.?/*.h
|
|
%{_libdir}/libgee-*.so
|
|
%{_libdir}/pkgconfig/gee-?.?.pc
|
|
%{_datadir}/gir-?.?/Gee-?.?.gir
|
|
%{_datadir}/vala/vapi/gee-?.?.vapi
|
|
%doc ChangeLog* NEWS README
|
|
|
|
%changelog
|
|
* Sun Sep 18 2022 Automatic Build System <autodist@mambasoft.it> 0.20.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 28 2022 Automatic Build System <autodist@mambasoft.it> 0.20.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 19 2021 Automatic Build System <autodist@mambasoft.it> 0.20.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 10 2020 Automatic Build System <autodist@mambasoft.it> 0.20.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 05 2019 Automatic Build System <autodist@mambasoft.it> 0.20.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 12 2018 Automatic Build System <autodist@mambasoft.it> 0.20.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 07 2017 Automatic Build System <autodist@mambasoft.it> 0.20.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 13 2016 Automatic Build System <autodist@mambasoft.it> 0.18.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 09 2015 Automatic Build System <autodist@mambasoft.it> 0.18.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 17 2014 Automatic Build System <autodist@mambasoft.it> 0.16.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Oct 03 2014 Automatic Build System <autodist@mambasoft.it> 0.16.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jun 23 2014 Automatic Build System <autodist@mambasoft.it> 0.15.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 25 2014 Automatic Build System <autodist@mambasoft.it> 0.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 04 2014 Automatic Build System <autodist@mambasoft.it> 0.13.91-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 18 2014 Automatic Build System <autodist@mambasoft.it> 0.13.90-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 11 2014 Automatic Build System <autodist@mambasoft.it> 0.13.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 04 2014 Automatic Build System <autodist@mambasoft.it> 0.13.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 17 2013 Automatic Build System <autodist@mambasoft.it> 0.13.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 28 2013 Automatic Build System <autodist@mambasoft.it> 0.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 08 2013 Automatic Build System <autodist@mambasoft.it> 0.9.92-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 17 2013 Automatic Build System <autodist@mambasoft.it> 0.9.91-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 04 2012 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 11 2012 Automatic Build System <autodist@mambasoft.it> 0.8.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 14 2012 Automatic Build System <autodist@mambasoft.it> 0.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 03 2012 Automatic Build System <autodist@mambasoft.it> 0.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 06 2012 Automatic Build System <autodist@mambasoft.it> 0.6.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 27 2012 Automatic Build System <autodist@mambasoft.it> 0.6.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 14 2011 Automatic Build System <autodist@mambasoft.it> 0.6.3-1mamba
|
|
- update to 0.6.3
|
|
|
|
* Mon Jan 31 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
|
|
- automatic port from devel-gil
|
|
|
|
* Tue Oct 19 2010 gil <puntogil@libero.it> 0.6.0-1mamba
|
|
- update to 0.6.0
|
|
|
|
* Tue Dec 16 2008 gil <puntogil@libero.it> 0.1.4-1mamba
|
|
- package created by autospec |