added a patch to fix typo in build script
added more configure options added triggers to gdk-pixbuf-query-loaders [release 2.42.11-2mamba;Sun Apr 21 2024]
This commit is contained in:
parent
612dc95290
commit
4839a5a3a5
32
libgdk-pixbuf-2.42.11-fix_typo_in_build_script.patch
Normal file
32
libgdk-pixbuf-2.42.11-fix_typo_in_build_script.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Heusel <christian@heusel.eu>
|
||||
Date: Sat, 20 Apr 2024 11:07:32 +0200
|
||||
Subject: [PATCH] fix build failure due to typo in the build script
|
||||
|
||||
The fixed commit had a typo where it would try to call a nonexistant
|
||||
function instead of the .contains method of the relevant array.
|
||||
This was only made visible when the "other" loaders were enabled so it
|
||||
is triggered all the time.
|
||||
|
||||
This was made visible when working on
|
||||
https://gitlab.archlinux.org/archlinux/packaging/packages/gdk-pixbuf2/-/merge_requests/1
|
||||
|
||||
Fixes: 81a77399a ("Update the testsuite")
|
||||
Signed-off-by: Christian Heusel <christian@heusel.eu>
|
||||
---
|
||||
tests/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/meson.build b/tests/meson.build
|
||||
index 78d0ad92e5e2..78ae43af17f9 100644
|
||||
--- a/tests/meson.build
|
||||
+++ b/tests/meson.build
|
||||
@@ -71,7 +71,7 @@ installed_tests = {
|
||||
'pixbuf-construction': { 'suites': ['conform'], },
|
||||
'animation': {
|
||||
'suites': ['format'],
|
||||
- 'skip': not (enabled_loaders.contains('ani') and enabled_loaders_contains('gif')),
|
||||
+ 'skip': not (enabled_loaders.contains('ani') and enabled_loaders.contains('gif')),
|
||||
},
|
||||
'cve-2015-4491': {
|
||||
'suites': ['security'],
|
@ -2,8 +2,8 @@
|
||||
|
||||
Name: libgdk-pixbuf
|
||||
Epoch: 1
|
||||
Version: 2.42.10
|
||||
Release: 1mamba
|
||||
Version: 2.42.11
|
||||
Release: 2mamba
|
||||
Summary: An image loading library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -11,6 +11,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.gnome.org
|
||||
Source: https://download-fallback.gnome.org/sources/gdk-pixbuf/%{majversion}/gdk-pixbuf-%{version}.tar.xz
|
||||
Patch0: libgdk-pixbuf-2.42.11-fix_typo_in_build_script.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -21,13 +22,10 @@ BuildRequires: libtiff-devel
|
||||
BuildRequires: shared-mime-info
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: vim
|
||||
BuildRequires: xdg-utils
|
||||
BuildRequires: %{_bindir}/rst2man
|
||||
Requires: gdk-pixbuf = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
# checking for mediaLib 2.3... checking for mlib_ImageSetStruct in -lmlib... no
|
||||
# see http://docs.sun.com/app/docs/doc/816-5173/libmlib-3lib?l=en&a=view
|
||||
# Require gobject-introspection >= 0.9.5
|
||||
|
||||
%description
|
||||
%{name} is an image loading library that can be extended by loadable modules for new image formats. It is used by toolkits such as GTK+ or clutter.
|
||||
|
||||
@ -60,10 +58,21 @@ This package contains %{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n gdk-pixbuf-%{version}
|
||||
%patch 0 -p1 -b .fix_typo_in_build_script
|
||||
|
||||
%build
|
||||
%meson \
|
||||
-Dgtk_doc=true
|
||||
-Dgtk_doc=true \
|
||||
-Dbuiltin_loaders=all \
|
||||
-Dinstalled_tests=false \
|
||||
-Dintrospection=enabled \
|
||||
-Dman=true \
|
||||
-Dothers=enabled \
|
||||
%ifarch aarch64
|
||||
-Dgio_sniffing=false
|
||||
%endif
|
||||
|
||||
# FIXME: -Dgio_sniffing=false fixes runtime on docker buildvm
|
||||
|
||||
%meson_build
|
||||
|
||||
@ -71,10 +80,7 @@ This package contains %{name} API documentation.
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%meson_install
|
||||
|
||||
#% makeinstall \
|
||||
# RUN_QUERY_LOADER_TEST=false
|
||||
|
||||
touch %{buildroot}%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
|
||||
install -d -m0755 %{buildroot}%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
|
||||
|
||||
%find_lang gdk-pixbuf
|
||||
|
||||
@ -96,10 +102,10 @@ ln -s %{_libexecdir}/gdk-pixbuf-query-loaders %{buildroot}%{_bindir}/gdk-pixbuf-
|
||||
|
||||
%posttrans
|
||||
if [ $1 -ge 1 ]; then
|
||||
%{_libexecdir}/gdk-pixbuf-query-loaders --update-cache || :
|
||||
# legacy cleanups
|
||||
rm -f /etc/gtk-2.0/gdk-pixbuf.loaders
|
||||
rm -f /etc/gtk-3.0/gdk-pixbuf.loaders
|
||||
rm -f /etc/gtk-4.0/gdk-pixbuf.loaders
|
||||
rm -f /etc/gtk-2.0/%{_target_platform}/gdk-pixbuf.loaders
|
||||
rm -f /etc/gtk-3.0/%{_target_platform}/gdk-pixbuf.loaders
|
||||
rmdir /etc/gtk-2.0/%{_target_platform} 2>/dev/null || true
|
||||
@ -107,6 +113,12 @@ if [ $1 -ge 1 ]; then
|
||||
fi
|
||||
:
|
||||
|
||||
%transfiletriggerin -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
|
||||
%{_libexecdir}/gdk-pixbuf-query-loaders --update-cache
|
||||
|
||||
%transfiletriggerpostun -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
|
||||
%{_libexecdir}/gdk-pixbuf-query-loaders --update-cache
|
||||
|
||||
%pre devel
|
||||
if [ $1 -ge 1 ]; then
|
||||
[ -L %{_bindir}/gdk-pixbuf-csource ] && rm -f %{_bindir}/gdk-pixbuf-csource
|
||||
@ -120,7 +132,6 @@ fi
|
||||
%dir %{_libdir}/gdk-pixbuf-2.0
|
||||
%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
|
||||
%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
|
||||
%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-*.so
|
||||
%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
|
||||
%{_libdir}/girepository-1.0/GdkPixbuf-2.0.typelib
|
||||
%{_libdir}/girepository-1.0/GdkPixdata-2.0.typelib
|
||||
@ -144,10 +155,6 @@ fi
|
||||
%{_libdir}/libgdk_pixbuf-2.0.so
|
||||
%{_datadir}/gir-1.0/GdkPixbuf-2.0.gir
|
||||
%{_datadir}/gir-1.0/GdkPixdata-2.0.gir
|
||||
%dir %{_libexecdir}/installed-tests/gdk-pixbuf
|
||||
%{_libexecdir}/installed-tests/gdk-pixbuf/*
|
||||
%dir %{_datadir}/installed-tests/gdk-pixbuf
|
||||
%{_datadir}/installed-tests/gdk-pixbuf/*
|
||||
%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
|
||||
%{_mandir}/man1/gdk-pixbuf-csource.1*
|
||||
%doc NEWS
|
||||
@ -160,6 +167,14 @@ fi
|
||||
%{_docdir}/gdk-pixdata/*
|
||||
|
||||
%changelog
|
||||
* Sun Apr 21 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.42.11-2mamba
|
||||
- added a patch to fix typo in build script
|
||||
- added more configure options
|
||||
- added triggers to gdk-pixbuf-query-loaders
|
||||
|
||||
* Fri Apr 19 2024 Automatic Build System <autodist@openmamba.org> 2.42.11-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Oct 26 2022 Automatic Build System <autodist@mambasoft.it> 2.42.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user