automatic version update by autodist [release 5.2.2-1mamba;Mon Dec 23 2013]

This commit is contained in:
Automatic Build System 2024-01-06 04:20:20 +01:00
parent 7591778f8b
commit 2ceec0b677
5 changed files with 816 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libgda
A library implementing a free unified data access architecture.

View File

@ -0,0 +1,51 @@
From cc5d429567e21ec62bf61b7e3b54348af11965b9 Mon Sep 17 00:00:00 2001
From: Haïkel Guémar <hguemar@fedoraproject.org>
Date: Sun, 10 Mar 2013 09:15:36 +0000
Subject: fix calls to deprecated graphviz graph API
---
diff --git a/tools/browser/canvas/browser-canvas.c b/tools/browser/canvas/browser-canvas.c
index a67f2f0..b228fd3 100644
--- a/tools/browser/canvas/browser-canvas.c
+++ b/tools/browser/canvas/browser-canvas.c
@@ -851,13 +851,13 @@ browser_canvas_perform_auto_layout (BrowserCanvas *canvas, gboolean animate, Bro
if (!gvc)
gvc = gvContext ();
- graph = agopen ("BrowserCanvasLayout", AGRAPH);
- agnodeattr (graph, "shape", "box");
- agnodeattr (graph, "height", ".1");
- agnodeattr (graph, "width", ".1");
- agnodeattr (graph, "fixedsize", "true");
- agnodeattr (graph, "pack", "true");
- agnodeattr (graph, "packmode", "node");
+ graph = agopen ("BrowserCanvasLayout", Agdirected, NULL);
+ agnode (graph, "shape", "box");
+ agset (graph, "height", ".1");
+ agset (graph, "width", ".1");
+ agset (graph, "fixedsize", "true");
+ agset (graph, "pack", "true");
+ agset (graph, "packmode", "node");
if (class->get_layout_items)
@@ -885,7 +885,7 @@ browser_canvas_perform_auto_layout (BrowserCanvas *canvas, gboolean animate, Bro
nodes_list = g_slist_prepend (nodes_list, nl);
tmp = g_strdup_printf ("%p", item);
- node = agnode (graph, tmp);
+ node = agnode (graph, tmp, 0);
nl->node = node;
g_hash_table_insert (nodes_hash, item, node);
@@ -929,7 +929,7 @@ browser_canvas_perform_auto_layout (BrowserCanvas *canvas, gboolean animate, Bro
from_node = (Agnode_t*) g_hash_table_lookup (nodes_hash, from);
to_node = (Agnode_t*) g_hash_table_lookup (nodes_hash, to);
if (from_node && to_node)
- agedge (graph, from_node, to_node);
+ agedge (graph, from_node, to_node, "", 0);
}
}
--
cgit v0.9.2

View File

@ -0,0 +1,247 @@
diff -Nru libgda-5.0.4.orig/doc/C/data-model-writing.xml libgda-5.0.4/doc/C/data-model-writing.xml
--- libgda-5.0.4.orig/doc/C/data-model-writing.xml 1970-01-01 01:00:00.000000000 +0100
+++ libgda-5.0.4/doc/C/data-model-writing.xml 2013-07-18 02:34:39.868134274 +0200
@@ -0,0 +1,199 @@
+<?xml version="1.0"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"[
+<!ENTITY LIBGDA "<application>Libgda</application>">
+]>
+<sect1 id="gda-data-model-writing">
+ <title>Implementing your own data model</title>
+ <para>
+ You may need at some point to implement your own data model because the implementations in
+ &LIBGDA; don't suit your needs. This section is dedicated to explaining to you how this can be done.
+ </para>
+ <para>
+ Implementing a new <link linkend="GdaDataModel">GdaDataModel</link> is simply a matter of
+ creating a new GObject which implements the <link linkend="GdaDataModel">GdaDataModel</link>
+ interface, which is described below. Thos new class needs to inherit GObject, but needs not
+ be direct descendant of it. The way to subclass an object using GLib
+ is not covered in this documentation, for this matter reref to
+ <link linkend="howto-gobject-code">GObject's documentation</link>, or
+ <ulink url="http://developer.gnome.org/gobject/stable/howto-gobject.html">online</ulink>.
+ </para>
+
+ <sect2 id="gda-data-model-writing-virtual-methods">
+ <title>Virtual methods</title>
+ <para>
+ The interface's methods which can and/or need to be implemented are defined below.
+ </para>
+
+ <sect3 id="i_get_n_rows">
+ <title>i_get_n_rows() - optional</title>
+ <para>This method, if implemented, returns the total number of rows in the data model, or -1 if
+ unknown. If it's not implemented, then it is assumed that -1 is returned in all cases.</para>
+ </sect3>
+
+ <sect3 id="i_get_n_columns">
+ <title>i_get_n_columns() - required</title>
+ <para>This method, returns the total number of columns in the data model, or -1 if unknown.</para>
+ </sect3>
+
+ <sect3 id="i_describe_column">
+ <title>i_describe_column() - required</title>
+ <para>This method describes a column; it returns (without any ownership to the caller) a
+ <link linkend="GdaColumn">GdaColumn</link> for each existing column, or NULL otherwise.</para>
+ </sect3>
+
+ <sect3 id="i_get_access_flags">
+ <title>i_get_access_flags() - required</title>
+ <para>This method defines how the data model may be accessed (randomly, only using a cursor, ...)</para>
+ </sect3>
+
+ <sect3 id="i_get_value_at">
+ <title>i_get_value_at() - required for random access</title>
+ <para>This method is used to access the contents of a data model, specifically
+ a <link linkend="GValue">GValue</link> is returned for each (column,row) position.
+ It must return NULL if the data model experienced an error for the specific (column,row)
+ position. See <link linkend="gda-data-model-get-value-at">gda_data_model_get_value_at()</link>
+ for more information about the lifetime of the returned GValue.</para>
+ </sect3>
+
+ <sect3 id="i_get_attributes_at">
+ <title>i_get_attributes_at() - optional</title>
+ <para>This method returns, for a (column,row) position in the data model, the attributes
+ of the adressed "cell".</para>
+ </sect3>
+
+ <sect3 id="i_create_iter">
+ <title>i_create_iter() - optional</title>
+ <para>This method can be implemented to create specific
+ <link linkend="GdaDataModelIter">GdaDataModelIter</link> or to customize them.</para>
+ </sect3>
+
+ <sect3 id="i_iter_at_row">
+ <title>i_iter_at_row() - optional</title>
+ <para>This method can be implemented if a specific implementation allows an iterator
+ to be moved quickly to a specific row (faster than iterating from row to row to the
+ requested row).</para>
+ </sect3>
+
+ <sect3 id="i_iter_next">
+ <title>i_iter_next() - required for cursor based access</title>
+ <para>This method is called to move an iterator to the next row; it's not necessary to
+ implement it if the data models supports random access.</para>
+ </sect3>
+
+ <sect3 id="i_iter_prev">
+ <title>i_iter_prev() - optional for cursor based access</title>
+ <para>This method is called to move an iterator to the previous row. It is only necessary to
+ implement it if the data model does not support random access and supports moving the
+ cursor backward.</para>
+ </sect3>
+
+ <sect3 id="i_set_value_at">
+ <title>i_set_value_at() - optional</title>
+ <para>This method needs to be defined if the data model allows each value in a (column,row) position
+ to be modified individually.
+ </para>
+ </sect3>
+
+ <sect3 id="i_iter_set_value">
+ <title>i_iter_set_value() - optional</title>
+ <para>This method can be defined if a specific treatment is required when a modification made
+ to a <link linkend="GdaDataModelIter">GdaDataModelIter</link> is propagated to the data model.
+ It should seldom, if ever, be necessary to implement it.</para>
+ </sect3>
+
+ <sect3 id="i_set_values">
+ <title>i_set_values() - optional</title>
+ <para>This method needs to be defined if the data model allows modifications to be made for
+ one complete row at a time. See the
+ <link linkend="gda-data-model-set-values">gda_data_model_set_values()</link> method for
+ more information about the arguments</para>
+ </sect3>
+
+ <sect3 id="i_append_values">
+ <title>i_append_values() - optional</title>
+ <para>This method can be implemented if the data model needs to support adding a row and defining the
+ values to be added in the same operation.
+ See <link linkend="gda-data-model-append-values">gda_data_model_append_values()</link> for
+ more information.</para>
+ </sect3>
+
+ <sect3 id="i_append_row">
+ <title>i_append_row() - optional</title>
+ <para>This method needs to be defined if the data model needs to support adding an empty row (i.e.
+ without any value specified in the new row).</para>
+ </sect3>
+
+ <sect3 id="i_remove_row">
+ <title>i_remove_row() - optional</title>
+ <para>This method should be implemented if the data model needs to support row removal.</para>
+ </sect3>
+
+ <sect3 id="i_find_row">
+ <title>i_find_row() - optional</title>
+ <para>This method can be implemented if the data model implements an indexing scheme which
+ allows it to find rows from values quickly than by analysing each row after another to
+ find the requested values.</para>
+ </sect3>
+
+ <sect3 id="i_set_notify">
+ <title>i_set_notify() - optional</title>
+ <para>This method should be implemented if the data model needs to honor the
+ <link linkend="gda-data-model-freeze">gda_data_model_freeze()</link> and
+ <link linkend="gda-data-model-thaw">gda_data_model_thaw()</link> methods. If
+ this method is not implemented, then these two methods will have no effect.
+ </para>
+ </sect3>
+
+ <sect3 id="i_get_notify">
+ <title>i_get_notify() - optional</title>
+ <para>This method should be implemented if the data model needs to honor the
+ <link linkend="gda-data-model-freeze">gda_data_model_freeze()</link> and
+ <link linkend="gda-data-model-thaw">gda_data_model_thaw()</link> methods. If
+ this method is not implemented, then these two methods will have no effect.</para>
+ </sect3>
+
+ <sect3 id="i_send_hint">
+ <title>i_send_hint() - optional</title>
+ <para>This method should be implemented if the data model needs to be able to treat
+ hints, see <link linkend="gda-data-model-send-hint">gda_data_model_send_hint()</link> for
+ more information</para>
+ </sect3>
+
+ <sect3 id="i_get_exceptions">
+ <title>i_get_exceptions() - optional</title>
+ <para>This method needs to be implemented if the data model keeps exceptions about the errors
+ it has encountered and may "export" these exceptions using the
+ <link linkend="gda-data-model-get-exceptions">gda_data_model_get_exceptions()</link> method.</para>
+ </sect3>
+ </sect2>
+
+ <sect2 id="gda-data-model-writing-signalling">
+ <title>Signalling changes</title>
+ <para>
+ When the data model changes, it needs to signal its changes. However, only the changes from
+ the initial state need to be notified, in situations such as:
+ <itemizedlist>
+ <listitem><para>a row which has already been accessed is modified or removed</para></listitem>
+ <listitem><para>the total number of rows changes, and that number has already been obtained and
+ was known (i.e. different than -1)</para></listitem>
+ </itemizedlist>
+ </para>
+ <para>
+ To signal changes, one of the following methods has to be used:
+ <itemizedlist>
+ <listitem><para><link linkend="gda-data-model-row-inserted">gda_data_model_row_inserted()</link>: to be called after a row has been inserted</para></listitem>
+ <listitem><para><link linkend="gda-data-model-row-updated">gda_data_model_row_updated()</link>: to be called after a row has been updated</para></listitem>
+ <listitem><para><link linkend="gda-data-model-row-removed">gda_data_model_row_removed()</link>: to be called after a row has been removed</para></listitem>
+ <listitem><para><link linkend="gda-data-model-reset">gda_data_model_reset()</link>: to be called
+ when the data model has changed in a way it's not possible or desirable to signal all the changes
+ using any combination of the above methods (for example when the whole contents has changed, or
+ when the number and/or types of columns has changed)</para></listitem>
+ </itemizedlist>
+ </para>
+ <para>
+ Moreover, when the data model's access flags have changed, the implementation should signal it by
+ emitting the <link linkend="GdaDataModel-access-changed">"access-changed"</link> signal.
+ </para>
+ </sect2>
+</sect1>
diff -Nru libgda-5.0.4.orig/doc/C/migration3.xml libgda-5.0.4/doc/C/migration3.xml
--- libgda-5.0.4.orig/doc/C/migration3.xml 1970-01-01 01:00:00.000000000 +0100
+++ libgda-5.0.4/doc/C/migration3.xml 2013-07-18 02:34:28.803238296 +0200
@@ -0,0 +1,40 @@
+<?xml version="1.0"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"[
+<!ENTITY LIBGDA "<application>Libgda</application>">
+]>
+<chapter id="migration-3" xmlns:xi="http://www.w3.org/2003/XInclude">
+ <title>Migration from 4.X versions</title>
+ <sect1><title>Overview</title>
+ <para>Version 5.0 of &LIBGDA; is a small evolution to adapt to the GTK3 environment; as such it is API
+ compatible with versions 4.0.x or 4.2.x. However there are some few behavioural changes explicited
+ below.
+ </para>
+ </sect1>
+
+ <sect1><title>GDA_TYPE_NULL</title>
+ <para>
+ Previous versions of &LIBGDA; represented SQL NULL values as a <link linkend="GValue">GValue</link> completely filled
+ with zeros (i.e. of type G_TYPE_INVALID), and GDA_TYPE_NULL was thus equivalent to G_TYPE_INVALID.
+ </para>
+ <para>
+ This new version introduces a new specific type for the same GDA_TYPE_NULL (which means
+ GDA_TYPE_NULL no longer equals G_TYPE_INVALID). The most common sources of errors brought by this
+ change are:
+ <itemizedlist>
+ <listitem><para>if you used <link linkend="g-value-init">g_value_init()</link> on a
+ value of type GDA_TYPE_NULL, then you'll have to eight clear the value first, or replace
+ that call with a call to <link linkend="gda-value-reset-with-type">gda_value_reset_with_type()</link></para></listitem>
+ <listitem><para>the <link linkend="gda-g-type-from-string">gda_g_type_from_string()</link> function
+ now returns G_TYPE_INVALID if it does not know how to interpret the argument, so testing the return
+ value now also involves testing for the G_TYPE_INVALID value.</para></listitem>
+ <listitem><para>creating a GValue using <link linkend="g-new0">g_new0()</link> resulted
+ in a GDA_TYPE_NULL value, which is not longer the case; the value needs to be initialized
+ with a call to <link linkend="g-value-init">g_value_init()</link></para></listitem>
+ <listitem><para>testing for NULL values using G_IS_VALUE does not work anymore, you'll have to
+ replace them with <link linkend="GDA-VALUE-HOLDS-NULL:CAPS">GDA_VALUE_HOLDS_NULL()</link></para></listitem>
+ </itemizedlist>
+ </para>
+ </sect1>
+
+</chapter>

476
libgda.spec Normal file
View File

@ -0,0 +1,476 @@
%define pkgname libgda
%define apiver %(echo %version | cut -d. -f 1).0
%define majversion %(echo %version | cut -d. -f 1-2)
Name: libgda
Version: 5.2.2
Release: 1mamba
Summary: A library implementing a free unified data access architecture
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.gnome-db.org/
Source: http://ftp.gnome.org/pub/GNOME/sources/%{pkgname}/%{majversion}/%{pkgname}-%{version}.tar.xz
Patch0: libgda4-3.99.8-java_check.patch
Patch1: libgda-5.0.4-graphviz-2.30.patch
Patch2: libgda-5.0.4-missing-doc-files.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgoocanvas-devel
BuildRequires: libatk-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libelf-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcrypt-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libGL-devel
BuildRequires: libglib-devel
BuildRequires: libgnome-keyring-devel
BuildRequires: libgpg-error-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgraphviz-devel
BuildRequires: libgtk-devel
BuildRequires: libgtksourceview-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libicu-devel
BuildRequires: libltdl-devel
BuildRequires: liblzma-devel
BuildRequires: libmdb-devel
BuildRequires: libmysql5-devel
BuildRequires: libncurses-devel
BuildRequires: libopenldap-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng15-devel
BuildRequires: libpostgresql-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libreadline-devel
BuildRequires: libselinux-devel
BuildRequires: libsoup-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libxml2-devel
BuildRequires: libXrender-devel
BuildRequires: libxslt-devel
BuildRequires: libz-devel
BuildRequires: udev-devel
## AUTOBUILDREQ-END
BuildRequires: intltool
BuildRequires: perl
BuildRequires: perl-XML-Parser
BuildRequires: gettext-devel
BuildRequires: pkgconfig
BuildRequires: libodbc-devel
BuildRequires: libsasl-devel
BuildRequires: libsqlite3-devel
BuildRequires: libpopt-devel
BuildRequires: bison
BuildRequires: flex
BuildRequires: gtk-doc
Provides: libgda2
Obsoletes: libgda2
Obsoletes: libgda-odbc
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
A library implementing a free unified data access architecture.
%package devel
Group: Development/Libraries
Summary: Devel package for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-bdb = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-mysql = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-postgresql = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-sqlite = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-mdb = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-devel
Obsoletes: libgda2-devel
%description devel
A library implementing a free unified data access architecture.
This package contains static libraries and header files need for development.
%package -n gda
Group: Graphical Desktop/Applications/Databases
Summary: Database User Interfaces based on libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n gda
Database User Interfaces based on libgda.
%package mdb
Group: Development/Libraries
Summary: mdb provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-mdb
Obsoletes: libgda2-mdb
%description mdb
mdb provider for %{name}.
%package mysql
Group: Development/Libraries
Summary: MySql provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-mysql
Obsoletes: libgda2-mysql
%description mysql
MySql provider for %{name}.
%package postgresql
Group: Development/Libraries
Summary: PostgreSQL provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-postgresql
Obsoletes: libgda2-postgresql
%description postgresql
PostgreSQL provider for %{name}.
%package jdbc
Group: Development/Libraries
Summary: JDBC provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-jdbc
Obsoletes: libgda2-jdbc
%description jdbc
JDBC provider for %{name}.
%package odbc
Group: Development/Libraries
Summary: ODBC provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-odbc
Obsoletes: libgda2-odbc
%description odbc
ODBC provider for %{name}.
%package ldap
Group: Development/Libraries
Summary: LDAP provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-ldap
Obsoletes: libgda2-ldap
%description ldap
LDAP provider for %{name}.
%package bdb
Group: Development/Libraries
Summary: Berkely DB provider for libgda
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-bdb
Obsoletes: libgda2-bdb
%description bdb
Berkeley DB provider for %{name}.
%package sqlite
Group: Development/Libraries
Summary: SQLite providers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libgda2-sqlite
Obsoletes: libgda2-sqlite
%description sqlite
SQLite provider for %{name}.
%package apidocs
Summary: %{pkgname} API documentation
Group: Documentation
Requires: gtk-doc
Provides: libgda2-apidocs
Obsoletes: libgda2-apidocs
%description apidocs
%{pkgname} API documentation.
# FIXME:
# checking for GTK_SHARP... checking for GAPI... configure: "Not building gda-sharp"
#
# C# bindings = no
# Providers:
# FireBird = no
# FreeTDS = no
# IBM DB2 = no
# MDB (MS Access) = no
# mSQL = no
# Oracle = no
# Sybase = no
# xBase (dBase, Clipper, FoxPro) = no
%prep
%setup -q -n libgda-%{version}
rm -f getsp.class
%{_jvmdir}/jdk/bin/javac getsp.java
#%patch0 -p1
#%patch1 -p1
#%patch2 -p1
#/usr/lib/jvm/jdk/bin/javac getsp.java
%build
CFLAGS="%{optflags} -DGRAPHVIZ_NEW_API=1"
%configure \
--enable-shared \
--disable-static \
--enable-gtk-doc \
--enable-csharp \
--disable-debug \
--with-mysql \
--with-postgres \
--with-odbc=%{_prefix} \
--with-ldap \
--with-bdb \
--with-java \
--disable-introspection \
GRAPHVIZ_LIBS="`pkg-config --libs libcgraph libgvc`"
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
%find_lang libgda-%{apiver}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -n gda
%defattr(-,root,root)
%{_bindir}/gda-*
%{_libdir}/libgda-ui-%{apiver}.so.*
%{_libdir}/libgda-%{apiver}/plugins
%{_libdir}/libgda-%{apiver}/providers/libgda-sqlcipher.so
%{_libdir}/libgda-%{apiver}/providers/libgda-web.so
%{_datadir}/applications/gda-browser-%{apiver}.desktop
%{_datadir}/applications/gda-control-center-%{apiver}.desktop
%{_datadir}/pixmaps/gda-browser-%{apiver}.png
%{_datadir}/icons/hicolor/*/apps/gda-control-center.png
%{_datadir}/libgda-%{apiver}/gda_trml2html/*.py
%{_datadir}/libgda-%{apiver}/gda_trml2pdf/*.py
%{_datadir}/libgda-%{apiver}/icons/hicolor/
%{_datadir}/libgda-%{apiver}/php
%{_datadir}/libgda-%{apiver}/pixmaps
%{_datadir}/libgda-%{apiver}/ui
%{_datadir}/libgda-%{apiver}/web_specs_auth.xml
%{_datadir}/libgda-%{apiver}/web_specs_dsn.xml
%files -f libgda-%{apiver}.lang
%defattr(-,root,root)
%{_sysconfdir}/libgda-%{apiver}/config
%{_sysconfdir}/libgda-%{apiver}/sales_test.db
%{_libdir}/libgda-%{apiver}.so.*
%{_libdir}/libgda-report-%{apiver}.so.*
%{_libdir}/libgda-xslt-%{apiver}.so.*
#%{_libdir}/libgda_handlers-%{apiver}.so.*
#%{_libdir}/libgda_sql_delimiter-%{apiver}.so.*
#%{_libdir}/libgda_sql_transaction-%{apiver}.so.*
#%{_libdir}/libgdasql-%{apiver}.so.*
%{_datadir}/libgda-%{apiver}/import_encodings.xml
%{_datadir}/libgda-%{apiver}/language-specs/gda-sql.lang
%{_datadir}/libgda-%{apiver}/server_operation.glade
%{_datadir}/libgda-%{apiver}/sqlcipher_specs_*.xml
#%{_datadir}/libgda-%{apiver}/xml/*.dtd
#%{_datadir}/libgda-%{apiver}/xml/*.xsl
%{_datadir}/libgda-%{apiver}/information_schema.xml
%{_datadir}/libgda-%{apiver}/dtd/*.dtd
%{_datadir}/libgda-%{apiver}/web/*
%{_mandir}/man1/*
#%{_mandir}/man5/*
%files bdb
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/bdb_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-bdb.so
%files ldap
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/ldap_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-ldap.so
%files mdb
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/mdb_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-mdb.so
%files mysql
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/mysql_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-mysql.so
#%{_datadir}/gnome/help/gda-sql/C/gda-sql-help.xml
%files jdbc
%defattr(-,root,root)
%{_libdir}/libgda-%{apiver}/providers/gdaprovider-%{apiver}.jar
%{_libdir}/libgda-%{apiver}/providers/libgda-jdbc.so
%{_datadir}/libgda-%{apiver}/jdbc_specs_*.xml
#%files odbc
#%defattr(-,root,root)
#%{_datadir}/libgda-%{apiver}/odbc_*.xml
#%{_libdir}/libgda-%{apiver}/providers/libgda-odbc.so
%files postgresql
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/postgres_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-postgres.so
%files sqlite
%defattr(-,root,root)
%{_datadir}/libgda-%{apiver}/sqlite_*.xml
%{_libdir}/libgda-%{apiver}/providers/libgda-sqlite.so
%files devel
%defattr(-,root,root)
%{_bindir}/gdaui-demo-%{apiver}
%dir %{_includedir}/libgda-%{apiver}
%dir %{_includedir}/libgda-%{apiver}/libgda/
%{_includedir}/libgda-%{apiver}/libgda/*
%{_includedir}/libgda-%{apiver}/libgda-ui/
%{_includedir}/libgda-%{apiver}/libgda-xslt/
%{_includedir}/libgda-%{apiver}/libgda-report/
#%{_includedir}/libgda-%{apiver}/providers-support/
#%{_includedir}/libgda-%{apiver}/sql-parser/
#%{_includedir}/libgda-%{apiver}/virtual/
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/libgda-%{apiver}/providers/libgda-*.la
%{_datadir}/libgda-%{apiver}/demo
%{_datadir}/glade/catalogs/gdaui-catalog.xml
%{_datadir}/glade/pixmaps/widget-*.png
%{_libdir}/pkgconfig/libgda*-%{apiver}.pc
%files apidocs
%defattr(-,root,root)
%{_datadir}/gtk-doc/html/%{pkgname}-%{apiver}/
%dir %{_datadir}/help/C/gda-browser
%{_datadir}/help/C/gda-browser
%lang(cs) %{_datadir}/help/cs/gda-browser
%lang(de) %{_datadir}/help/de/gda-browser
%lang(el) %{_datadir}/help/el/gda-browser
%lang(es) %{_datadir}/help/es/gda-browser
%lang(gl) %{_datadir}/help/gl/gda-browser
%lang(id) %{_datadir}/help/id/gda-browser
%lang(pt_BR) %{_datadir}/help/pt_BR/gda-browser
%lang(sl) %{_datadir}/help/sl/gda-browser
%lang(zh_CN) %{_datadir}/help/zh_CN/gda-browser
%{_datadir}/gtk-doc/html/gda-browser
%changelog
* Mon Dec 23 2013 Automatic Build System <autodist@mambasoft.it> 5.2.2-1mamba
- automatic version update by autodist
* Mon Nov 25 2013 Automatic Build System <autodist@mambasoft.it> 5.2.1-1mamba
- automatic version update by autodist
* Thu Nov 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.0-1mamba
- update to 5.2.0
* Thu Nov 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.2-2mamba
- move gnome help and gtk-doc to apidocs subpackage
* Sat Jul 27 2013 Automatic Build System <autodist@mambasoft.it> 5.1.2-1mamba
- automatic version update by autodist
* Wed Jul 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.4-1mamba
- update to 5.0.4
* Wed Jul 17 2013 Automatic Build System <autodist@mambasoft.it> 4.2.13-3mamba
- rebuilt with mdbtools 0.7
* Sun Nov 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.13-2mamba
- rebuilt without old goocanvas (0.15)
* Wed Jun 13 2012 Automatic Build System <autodist@mambasoft.it> 4.2.13-1mamba
- update to 4.2.13
* Fri May 20 2011 Automatic Build System <autodist@mambasoft.it> 4.2.7-1mamba
- automatic update by autodist
* Mon Mar 07 2011 Automatic Build System <autodist@mambasoft.it> 4.2.5-1mamba
- automatic update by autodist
* Sat Jan 15 2011 Automatic Build System <autodist@mambasoft.it> 4.2.3-1mamba
- automatic update by autodist
* Fri Dec 03 2010 Automatic Build System <autodist@mambasoft.it> 4.2.2-1mamba
- automatic update by autodist
* Sat Nov 20 2010 Automatic Build System <autodist@mambasoft.it> 4.2.1-1mamba
- automatic update by autodist
* Thu Oct 28 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.0-1mamba
- update to 4.2.0
* Mon Jun 28 2010 Automatic Build System <autodist@mambasoft.it> 4.0.9-1mamba
- automatic update by autodist
* Sat Jun 05 2010 Automatic Build System <autodist@mambasoft.it> 4.0.8-1mamba
- automatic update by autodist
* Thu Oct 15 2009 Automatic Build System <autodist@mambasoft.it> 4.0.5-1mamba
- automatic update by autodist
* Tue Sep 01 2009 Automatic Build System <autodist@mambasoft.it> 4.0.4-1mamba
- automatic update by autodist
* Sat Jun 13 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.2-1mamba
- update to 4.0.2
* Thu Jan 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.99.8-1mamba
- update to 3.99.8
- renamed to libgda4
* Wed Apr 11 2007 Davide Madrisan <davide.madrisan@gmail.com> 2.99.5-2mamba
- new subpackage apidocs with API documentation
- added missing build requirements
- do not build static libraries
- use %%find_lang macro to package l18n files
- repackage providers for supported db in subpackages
* Tue Apr 10 2007 Tiziano Pratellesi <tiziano.pratellesi@openmamba.org> 2.99.5-1mamba
- update to version 2.99.5
* Mon Dec 19 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-1qilnx
- update to version 1.2.3 by autospec
* Fri Oct 28 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-2qilnx
- security fix QSA-2005-129 (CAN-2005-2958) [QiLinux bug#56]
* Wed Oct 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.2-1qilnx
- update to version 1.2.2 by autospec
- specfile fixes
- added SQLite provider package
* Thu Oct 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.6-1qilnx
- update to version 1.1.6 by autospec
- added bdb provider
* Tue May 18 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.4-1qilnx
- added missing .so in devel package
- database package split
* Tue May 18 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.4-1qilnx
- first build

View File

@ -0,0 +1,40 @@
diff -Nru libgda-3.99.8.orig/getsp.java libgda-3.99.8/getsp.java
--- libgda-3.99.8.orig/getsp.java 1970-01-01 01:00:00.000000000 +0100
+++ libgda-3.99.8/getsp.java 2009-01-15 16:22:42.000000000 +0100
@@ -0,0 +1,36 @@
+/*
+ * Determines that java works correctly and get its libraries path
+ * (originally from the R project)
+ */
+public class getsp {
+ public static void main(String[] args) {
+ if (args!=null && args.length>0) {
+ if (args[0].compareTo("-test")==0) {
+ System.out.println("Test1234OK");
+ }
+ else if (args[0].compareTo("-libs")==0) {
+ String prefix="-L";
+ if (args.length>1) prefix=args[1];
+ String lp=System.getProperty("java.library.path");
+ // we're not using StringTokenizer in case the JVM is very crude
+ int i=0,j,k=0;
+ String r=null;
+ String pss=System.getProperty("path.separator");
+ char ps=':';
+ if (pss!=null && pss.length()>0) ps=pss.charAt(0);
+ j=lp.length();
+ while (i<=j) {
+ if (i==j || lp.charAt(i)==ps) {
+ String lib=lp.substring(k,i);
+ k=i+1;
+ if (lib.compareTo(".")!=0)
+ r=(r==null)?(prefix+lib):(r+" "+prefix+lib);
+ }
+ i++;
+ }
+ if (r!=null) System.out.println(r);
+ } else
+ System.out.println(System.getProperty(args[0]));
+ }
+ }
+}