rebuilt with current libtiff [release 2.3.3-2mamba;Thu Jan 11 2024]
This commit is contained in:
parent
59cb7a9402
commit
f54b0ce1e4
@ -1,13 +0,0 @@
|
|||||||
--- gd-2.0.35/gd_gd.c 2006-04-05 17:52:22.000000000 +0200
|
|
||||||
+++ gd-2.0.35/gd_gd.c_CVE-2007-0455 2008-10-25 11:40:40.000000000 +0200
|
|
||||||
@@ -149,6 +149,10 @@ _gdCreateFromFile (gdIOCtx * in, int *sx
|
|
||||||
{
|
|
||||||
im = gdImageCreate (*sx, *sy);
|
|
||||||
}
|
|
||||||
+ if (!im)
|
|
||||||
+ {
|
|
||||||
+ goto fail1;
|
|
||||||
+ }
|
|
||||||
if (!_gdGetColors (in, im, gd2xFlag))
|
|
||||||
{
|
|
||||||
goto fail2;
|
|
@ -1,11 +0,0 @@
|
|||||||
--- gd-2.0.35/Makefile.in 2007-04-23 16:57:51.000000000 +0200
|
|
||||||
+++ gd-2.0.35/Makefile.in.def_fontpath 2008-10-25 12:17:52.000000000 +0200
|
|
||||||
@@ -227,7 +227,7 @@
|
|
||||||
AWK = @AWK@
|
|
||||||
CC = @CC@
|
|
||||||
CCDEPMODE = @CCDEPMODE@
|
|
||||||
-CFLAGS = @CFLAGS@
|
|
||||||
+CFLAGS = @CFLAGS@ -D_DEFAULT_FONTPATH="/usr/lib/X11/fonts/TTF:/usr/lib/X11/fonts/Type1:/usr/share/fonts/liberation:/usr/share/fonts/msttcorefonts:/usr/share/fonts/truetype"
|
|
||||||
CPP = @CPP@
|
|
||||||
CPPFLAGS = @CPPFLAGS@
|
|
||||||
CXX = @CXX@
|
|
@ -1,23 +0,0 @@
|
|||||||
--- gd-2.0.35/gd_gif_in.c 2007-06-14 21:51:41.000000000 +0200
|
|
||||||
+++ gd-2.0.35/gd_gif_in.c.loop 2008-10-25 11:51:59.000000000 +0200
|
|
||||||
@@ -453,16 +453,17 @@ LWZReadByte_(gdIOCtx *fd, LZW_STATIC_DAT
|
|
||||||
return sd->firstcode;
|
|
||||||
} else if (code == sd->end_code) {
|
|
||||||
int count;
|
|
||||||
+ int max_count = 1024;
|
|
||||||
unsigned char buf[260];
|
|
||||||
|
|
||||||
if (*ZeroDataBlockP)
|
|
||||||
return -2;
|
|
||||||
|
|
||||||
- while ((count = GetDataBlock(fd, buf, ZeroDataBlockP)) > 0)
|
|
||||||
+ while ((count = GetDataBlock(fd, buf, ZeroDataBlockP)) > 0 && --max_count >= 0 )
|
|
||||||
;
|
|
||||||
|
|
||||||
- if (count != 0)
|
|
||||||
- return -2;
|
|
||||||
+ if (count != 0 || max_count < 0 )
|
|
||||||
+ return -2;
|
|
||||||
}
|
|
||||||
|
|
||||||
incode = code;
|
|
@ -1,30 +0,0 @@
|
|||||||
Call the libpng12-confg and libpng-config specified by
|
|
||||||
$LIBPNG12_CONFIG and $LIBPNG_CONFIG variables that are set by
|
|
||||||
ac_cv_path_LIBPNG12_CONFIG and ac_cv_path_LIBPNG_CONFIG. This is
|
|
||||||
important for cross compiler that need to get the staging settings
|
|
||||||
instead of the host settings.
|
|
||||||
|
|
||||||
Signed-off-by: Jean-Christian de Rivaz <jc@eclis.ch>
|
|
||||||
|
|
||||||
diff -Nura gd-2.0.35.orig/configure.ac gd-2.0.35/configure.ac
|
|
||||||
--- gd-2.0.35.orig/configure.ac 2013-01-18 02:00:59.000000000 +0100
|
|
||||||
+++ gd-2.0.35/configure.ac 2013-01-18 02:01:44.000000000 +0100
|
|
||||||
@@ -353,14 +353,14 @@
|
|
||||||
AC_PATH_PROG([LIBPNG12_CONFIG], [libpng12-config])
|
|
||||||
AC_PATH_PROG([LIBPNG_CONFIG], [libpng-config])
|
|
||||||
if test -n "$LIBPNG12_CONFIG"; then
|
|
||||||
- libpng_CPPFLAGS=`libpng12-config --cflags`
|
|
||||||
+ libpng_CPPFLAGS=`$LIBPNG12_CONFIG --cflags`
|
|
||||||
# should be --ldopts, but it's currently broken
|
|
||||||
- libpng_LDFLAGS=`libpng12-config --ldflags`
|
|
||||||
+ libpng_LDFLAGS=`$LIBPNG12_CONFIG --ldflags`
|
|
||||||
libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
|
|
||||||
elif test -n "$LIBPNG_CONFIG"; then
|
|
||||||
- libpng_CPPFLAGS=`libpng-config --cflags`
|
|
||||||
+ libpng_CPPFLAGS=`$LIBPNG_CONFIG --cflags`
|
|
||||||
# should be --ldopts, but it's currently broken
|
|
||||||
- libpng_LDFLAGS=`libpng-config --ldflags`
|
|
||||||
+ libpng_LDFLAGS=`$LIBPNG_CONFIG --ldflags`
|
|
||||||
libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
|
|
||||||
elif test -d "$withval"; then
|
|
||||||
libpng_CPPFLAGS="-I$withval/include"
|
|
42
libgd.spec
42
libgd.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: libgd
|
Name: libgd
|
||||||
Version: 2.3.3
|
Version: 2.3.3
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A library used to create PNG, JPEG, or WBMP images
|
Summary: A library used to create PNG, JPEG, or WBMP images
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,39 +10,22 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://libgd.github.io/
|
URL: https://libgd.github.io/
|
||||||
Source: https://github.com/libgd/libgd.git/gd-%{version}/libgd-%{version}.tar.bz2
|
Source: https://github.com/libgd/libgd.git/gd-%{version}/libgd-%{version}.tar.bz2
|
||||||
Patch0: gd-2.0.35-CVE_2007_0455.patch
|
|
||||||
Patch1: gd-2.0.35-gd_gif_loop.patch
|
|
||||||
# see "DEFAULT_FONTPATH" in index.html
|
|
||||||
Patch2: gd-2.0.35-default_fontpath.patch
|
|
||||||
Patch3: gd-2.0.35-libpng-1.6.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
#libdl.so.2()(64bit): /usr/lib64/libdl.so: file not owned by any package
|
|
||||||
#librt.so.1()(64bit): /usr/lib64/librt.so: file not owned by any package
|
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libXpm-devel
|
BuildRequires: libXpm-devel
|
||||||
BuildRequires: libbrotli-devel
|
BuildRequires: libavif-devel
|
||||||
BuildRequires: libbsd-devel
|
|
||||||
BuildRequires: libbzip2-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libgomp-devel
|
||||||
BuildRequires: libgraphite2-devel
|
BuildRequires: libheif-devel
|
||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libimagequant-devel
|
||||||
BuildRequires: libjbig-devel
|
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: liblzma-devel
|
|
||||||
BuildRequires: libpcre-devel
|
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzstd-devel
|
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: gettext-devel >= 0.14.4
|
BuildRequires: gettext-devel >= 0.14.4
|
||||||
@ -54,7 +37,7 @@ It allows your code to quickly draw images complete with lines, arcs, text, mult
|
|||||||
%package devel
|
%package devel
|
||||||
Summary: Static libraries and headers for %{name}
|
Summary: Static libraries and headers for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: libgd = %{version}-%{release}
|
Requires: libgd = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
GD is a graphics library.
|
GD is a graphics library.
|
||||||
@ -65,18 +48,20 @@ This package contains static libraries and header files need for development.
|
|||||||
%package utils
|
%package utils
|
||||||
Summary: The utils files for %{name}
|
Summary: The utils files for %{name}
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Requires: %{libname} = %{version}-%{release}
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Provides: gd-utils
|
Provides: gd-utils
|
||||||
Obsoletes: gd-utils
|
Obsoletes: gd-utils < 2.3.3
|
||||||
|
|
||||||
%description utils
|
%description utils
|
||||||
The gd-utils package includes utility programs supplied with gd, a graphics library for creating PNG and JPEG images.
|
The gd-utils package includes utility programs supplied with gd, a graphics library for creating PNG and JPEG images.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
./bootstrap.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./bootstrap.sh
|
|
||||||
%configure
|
%configure
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -97,10 +82,8 @@ The gd-utils package includes utility programs supplied with gd, a graphics libr
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
#%{_bindir}/gdlib-config
|
|
||||||
%{_includedir}/*.h
|
%{_includedir}/*.h
|
||||||
%{_libdir}/libgd.a
|
%{_libdir}/libgd.a
|
||||||
%{_libdir}/libgd.la
|
|
||||||
%{_libdir}/libgd.so
|
%{_libdir}/libgd.so
|
||||||
%{_libdir}/pkgconfig/gdlib.pc
|
%{_libdir}/pkgconfig/gdlib.pc
|
||||||
|
|
||||||
@ -120,6 +103,9 @@ The gd-utils package includes utility programs supplied with gd, a graphics libr
|
|||||||
%{_bindir}/webpng
|
%{_bindir}/webpng
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-2mamba
|
||||||
|
- rebuilt with current libtiff
|
||||||
|
|
||||||
* Mon Sep 13 2021 Automatic Build System <autodist@mambasoft.it> 2.3.3-1mamba
|
* Mon Sep 13 2021 Automatic Build System <autodist@mambasoft.it> 2.3.3-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user