libgc/libgc.spec

149 lines
4.5 KiB
RPMSpec

%define majver %(echo %version | sed "s|[a-z]||")
Name: libgc
Epoch: 1
Version: 7.6.0
Release: 1mamba
Summary: Boehm Conservative Garbage Collection for C/C++
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.hboehm.info/gc/
Source: http://www.hboehm.info/gc/gc_source/gc-%{version}.tar.gz
Patch0: libgc-7.1-dup_cpp_headers.patch
Patch1: libgc-7.2alpha4-install_dups.patch
License: BSD
BuildRequires: glibc
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: libatomic_ops-devel
BuildRequires: libtool
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
%description
This is a garbage collecting storage allocator that is intended to be used as a plug-in replacement for C's malloc.
Since the collector does not require pointers to be tagged, it does not attempt to ensure that all inaccessible storage is reclaimed. However, in our experience, it is typically more successful at reclaiming unused memory than most C programs using explicit deallocation. Unlike manually introduced leaks, the amount of unreclaimed memory typically stays bounded.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This is a garbage collecting storage allocator that is intended to be used as a plug-in replacement for C's malloc.
This package contains static libraries and header files need for development.
%package -n libatomic_ops-devel
Summary: Atomic memory update operations
Group: Development/Libraries
%description -n libatomic_ops-devel
Provides implementations for atomic memory update operations on a number of architectures. This allows direct use of these in reasonably portable code. Unlike earlier similar packages, this one explicitly considers memory barrier semantics, and allows the construction of code that involves minimum overhead across a variety of architectures.
This package contains static libraries and header files need for development.
%prep
%setup -q -n gc-%{majver}
#%patch0 -p1
#%patch1 -p1
rm -f libtool libtool.m4
autoreconf -i
%build
%configure \
--prefix=%{_prefix} \
--disable-dependency-tracking \
--disable-static \
--enable-cplusplus \
--enable-large-config \
%ifarch %{ix86} x86_64
--enable-parallel-mark \
%endif
--enable-threads=posix \
--with-libatomic-ops=external
%make
#% make -C libatomic_ops
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall DESTDIR=%{buildroot}
mkdir -p %{buildroot}%{_mandir}/man3
install -pm 644 doc/gc.man %{buildroot}%{_mandir}/man3/gc.3
rm -rf %{buildroot}%{_datadir}/gc/
%ifnarch arm
%check
make check
%endif
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
#%{_datadir}/gc/*
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_includedir}/gc/*.h
#%{_libdir}/*.a
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/pkgconfig/bdw-gc.pc
%{_mandir}/man3
%doc doc/README*
%changelog
* Sun Sep 18 2016 Automatic Build System <autodist@mambasoft.it> 7.6.0-1mamba
- automatic update by autodist
* Sun Aug 07 2016 Automatic Build System <autodist@mambasoft.it> 7.4.4-1mamba
- automatic update by autodist
* Tue Jun 17 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.2-1mamba
- update to 7.4.2
* Tue Nov 26 2013 Automatic Build System <autodist@mambasoft.it> 7.4.0-1mamba
- automatic update by autodist
* Sun Dec 09 2012 Automatic Build System <autodist@mambasoft.it> 7.2d-1mamba
- update to 7.2d
* Sun Aug 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 7.2-1mamba
- update to 7.2
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 7.2alpha6-1mamba
- automatic version update by autodist
* Sun Dec 26 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 7.2alpha4-3mamba
- automatic port from devel-java
* Sat Dec 04 2010 gil <puntogil@libero.it> 7.2alpha4-2mamba
- rebuilt devel
* Sun May 02 2010 gil <puntogil@libero.it> 7.2alpha4-1mamba
- update to 7.2alpha4
* Sat May 31 2008 gil <puntogil@libero.it> 7.1-1mamba
- update to 7.1
- edit URL
* Thu Mar 03 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 6.4-1qilnx
- update to version 6.4 by autospec
* Fri Dec 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 6.3-1qilnx
- package created by autospec