update to 1.4.0 [release 1.4.0-1mamba;Fri Jan 11 2013]
This commit is contained in:
parent
e8cfa74ac1
commit
7bd5852053
@ -1,2 +1,6 @@
|
|||||||
# libgavl
|
# libgavl
|
||||||
|
|
||||||
|
Gavl is short for Gmerlin Audio Video Library. It is a low level library, upon which multimedia APIs can be built. Gavl handles all the details of audio and video formats like colorspaces, samplerates, multichannel configurations etc.
|
||||||
|
It provides standardized definitions for those formats as well as container structures for carrying audio samples or video images inside an application.
|
||||||
|
In addition, it handles the sometimes ugly task to convert between all these formats and provides some elementary operations (copying, scaling, alpha blending etc).
|
||||||
|
|
||||||
|
11
libgavl-1.2.0-overflow.patch
Normal file
11
libgavl-1.2.0-overflow.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- gavl/videoframe.c 2011-01-07 16:30:15.000000000 +0100
|
||||||
|
+++ gavl/videoframe.c-gil 2011-03-10 04:30:15.000000000 +0100
|
||||||
|
@@ -1510,7 +1510,7 @@
|
||||||
|
uint16_t packed_16;
|
||||||
|
uint8_t packed_32[4];
|
||||||
|
uint16_t packed_64[4];
|
||||||
|
- float color_float[2];
|
||||||
|
+ float color_float[4];
|
||||||
|
|
||||||
|
gavl_init_memcpy();
|
||||||
|
|
60
libgavl-1.2.0-system_libgdither.patch
Normal file
60
libgavl-1.2.0-system_libgdither.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
diff -Nru gavl-1.2.0/configure.ac gavl-1.2.0-gil/configure.ac
|
||||||
|
--- gavl-1.2.0/configure.ac 2011-01-05 20:43:29.000000000 +0100
|
||||||
|
+++ gavl-1.2.0-gil/configure.ac 2011-03-10 04:42:14.000000000 +0100
|
||||||
|
@@ -262,6 +262,27 @@
|
||||||
|
AC_SUBST(TOP_SRCDIR)
|
||||||
|
|
||||||
|
dnl
|
||||||
|
+dnl System libraries
|
||||||
|
+dnl
|
||||||
|
+
|
||||||
|
+AC_ARG_ENABLE(libgdither,
|
||||||
|
+ [ --enable-libgdither System libgdither (experimental)])
|
||||||
|
+if test "${enable_libgdither}" = "yes"
|
||||||
|
+then
|
||||||
|
+ PKG_CHECK_MODULES(LIBGDITHER, libgdither,
|
||||||
|
+ [
|
||||||
|
+ AC_DEFINE(HAVE_LIBGDITHER, 1, [Define to 1 if you have the `libgdither' library (-lgdither).])
|
||||||
|
+ have_libgdither="true"
|
||||||
|
+ ],
|
||||||
|
+ [
|
||||||
|
+ have_libgdither="false"
|
||||||
|
+ ]
|
||||||
|
+ )
|
||||||
|
+fi
|
||||||
|
+AM_CONDITIONAL(HAVE_LIBGDITHER, [test x$have_libgdither = xtrue])
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+dnl
|
||||||
|
dnl Output variables
|
||||||
|
dnl
|
||||||
|
|
||||||
|
diff -Nru gavl-1.2.0/gavl/Makefile.am gavl-1.2.0-gil/gavl/Makefile.am
|
||||||
|
--- gavl-1.2.0/gavl/Makefile.am 2010-03-02 01:28:37.000000000 +0100
|
||||||
|
+++ gavl-1.2.0-gil/gavl/Makefile.am 2011-03-10 04:42:14.000000000 +0100
|
||||||
|
@@ -40,8 +40,15 @@
|
||||||
|
threednow_subdirs =
|
||||||
|
endif
|
||||||
|
|
||||||
|
+if HAVE_LIBGDITHER
|
||||||
|
+ MAYBE_LIBGDITHER_LA = @LIBGDITHER_LIBS@
|
||||||
|
+else
|
||||||
|
+ MAYBE_LIBGDITHER = libgdither
|
||||||
|
+ MAYBE_LIBGDITHER_LA = libgdither/libgdither.la
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
|
||||||
|
-SUBDIRS = hq c libgdither libsamplerate $(mmx_subdirs) \
|
||||||
|
+SUBDIRS = hq c $(MAYBE_LIBGDITHER) libsamplerate $(mmx_subdirs) \
|
||||||
|
$(sse_subdirs) \
|
||||||
|
$(sse2_subdirs) \
|
||||||
|
$(sse3_subdirs) \
|
||||||
|
@@ -114,7 +121,7 @@
|
||||||
|
$(threednow_libs) \
|
||||||
|
c/libgavl_c.la \
|
||||||
|
hq/libgavl_hq.la \
|
||||||
|
-libgdither/libgdither.la \
|
||||||
|
+$(MAYBE_LIBGDITHER_LA) \
|
||||||
|
libsamplerate/libsamplerate.la \
|
||||||
|
@LIBGAVL_LIBS@ \
|
||||||
|
-lm
|
101
libgavl.spec
Normal file
101
libgavl.spec
Normal file
@ -0,0 +1,101 @@
|
|||||||
|
Name: libgavl
|
||||||
|
Version: 1.4.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Library for handling uncompressed audio and video data
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://gmerlin.sourceforge.net/
|
||||||
|
Source: http://downloads.sourceforge.net/project/gmerlin/gavl/%{version}/gavl-%{version}.tar.gz
|
||||||
|
Patch0: libgavl-1.2.0-overflow.patch
|
||||||
|
Patch1: libgavl-1.2.0-system_libgdither.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: doxygen
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgdither-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libsamplerate-devel
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Gavl is short for Gmerlin Audio Video Library. It is a low level library, upon which multimedia APIs can be built. Gavl handles all the details of audio and video formats like colorspaces, samplerates, multichannel configurations etc.
|
||||||
|
It provides standardized definitions for those formats as well as container structures for carrying audio samples or video images inside an application.
|
||||||
|
In addition, it handles the sometimes ugly task to convert between all these formats and provides some elementary operations (copying, scaling, alpha blending etc).
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Gavl - A library for handling uncompressed audio and video data.
|
||||||
|
This package contains libraries and header files need for development.
|
||||||
|
|
||||||
|
%package docs
|
||||||
|
Group: Documentation
|
||||||
|
Summary: Documentation for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description docs
|
||||||
|
Gavl - A library for handling uncompressed audio and video data.
|
||||||
|
This package contains documentation for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n gavl-%{version}
|
||||||
|
#%patch0 -p0
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
sed -i -i 's/LQT_TRY_CFLAGS/dnl LQT_TRY_CFLAGS/g' configure.ac
|
||||||
|
sed -i -i 's/LQT_OPT_CFLAGS/dnl LQT_OPT_CFLAGS/g' configure.ac
|
||||||
|
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
|
||||||
|
|
||||||
|
sh autogen.sh
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-shared \
|
||||||
|
--disable-static \
|
||||||
|
--disable-cpu-clip \
|
||||||
|
--enable-libgdither
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
rm -rf %{buildroot}%{_libdir}/lib*.la
|
||||||
|
#touch -r include/gavl/gavl.h %{buildroot}%{_includedir}/gavl/gavl_version.h
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgavl.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/gavl
|
||||||
|
%{_includedir}/gavl/*.h
|
||||||
|
%{_libdir}/libgavl.so
|
||||||
|
%{_libdir}/pkgconfig/gavl.pc
|
||||||
|
%doc README TODO
|
||||||
|
|
||||||
|
%files docs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_docdir}/gavl
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jan 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-1mamba
|
||||||
|
- update to 1.4.0
|
||||||
|
|
||||||
|
* Thu Mar 10 2011 gil <puntogil@libero.it> 1.2.0-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user