specfile fixes; updated URL; closes #1 [release 1.42.0-2mamba;Fri Nov 29 2024]

This commit is contained in:
Silvan Calarco 2024-11-29 16:12:28 +01:00
parent 05f04349e7
commit 58c3413bc8
3 changed files with 20 additions and 94 deletions

View File

@ -1,29 +0,0 @@
diff -up gammu-1.26.1/contrib/smscgi/sms_cgi.c.orig gammu-1.26.1/contrib/smscgi/sms_cgi.c
--- gammu-1.26.1/contrib/smscgi/sms_cgi.c.orig 2010-06-10 14:55:30.000000000 +0200
+++ gammu-1.26.1/contrib/smscgi/sms_cgi.c 2010-06-10 15:01:45.000000000 +0200
@@ -76,6 +76,7 @@ static void NORETURN cgi_child(GSM_State
int errfd;
char script_name[300];
const char*data;
+ char *empty_argv[1] = { NULL };
strcpy(script_name, cgi_path); /**< prepend script path */
/* ---------------------------------------------------- get the script name */
@@ -115,7 +116,7 @@ static void NORETURN cgi_child(GSM_State
smprintf(s, CGI_ENGINE "Executing > %s\n", script_name);
/* Execute script */
- execv(script_name, NULL);
+ execv(script_name, empty_argv);
/* ------------------------------------------------------ failed to execute */
smprintf(s, CGI_ENGINE "Failed to execure %s : %s\n", script_name, strerror(errno));
@@ -140,7 +141,7 @@ static void NORETURN cgi_child(GSM_State
smprintf(s, CGI_ENGINE "Executing > %s\n", script_name);
/* Execute script */
- execv(script_name, NULL);
+ execv(script_name, empty_argv);
error:
/* ------------------------------------------------------ failed to execute */

View File

@ -1,24 +0,0 @@
diff -Nru gammu-1.32.0.orig/python/gammu/src/gammu.c gammu-1.32.0/python/gammu/src/gammu.c
--- gammu-1.32.0.orig/python/gammu/src/gammu.c 2012-06-27 10:02:28.000000000 +0200
+++ gammu-1.32.0/python/gammu/src/gammu.c 2013-05-23 01:42:01.796386347 +0200
@@ -5344,7 +5344,7 @@
#ifdef WITH_THREAD
PyThread_free_lock(self->mutex);
#endif
- self->ob_type->tp_free((PyObject*)self);
+ Py_TYPE(self)->tp_free((PyObject*)self);
}
static PyObject *
diff -Nru gammu-1.32.0.orig/python/gammu/src/smsd.c gammu-1.32.0/python/gammu/src/smsd.c
--- gammu-1.32.0.orig/python/gammu/src/smsd.c 2012-06-27 10:02:28.000000000 +0200
+++ gammu-1.32.0/python/gammu/src/smsd.c 2013-05-23 01:42:40.412918323 +0200
@@ -198,7 +198,7 @@
static void SMSD_dealloc(SMSDObject * self)
{
SMSD_FreeConfig(self->config);
- self->ob_type->tp_free((PyObject *) self);
+ Py_TYPE(self)->tp_free((PyObject *) self);
}
static PyObject *SMSD_new(PyTypeObject * type, PyObject * args, PyObject * kwds)

View File

@ -1,37 +1,32 @@
Name: libgammu
Version: 1.42.0
Release: 1mamba
Release: 2mamba
Summary: A library to work with mobile phones from many vendors
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://wammu.eu/gammu/
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://wammu.eu/gammu/
Source: http://downloads.sourceforge.net/project/gammu/gammu/%{version}/gammu-%{version}.tar.gz
Patch0: libgammu-1.26.1-exec.patch
Patch1: libgammu-1.32.0-python-2.7.patch
License: GPL
BuildRequires: autoconf
BuildRequires: bluez
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: gettext
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbluetooth-devel
BuildRequires: libcurl-devel
BuildRequires: libdbi-devel
BuildRequires: libmysql5-devel
BuildRequires: libglib-devel
BuildRequires: libgudev-devel
BuildRequires: libiodbc-devel
BuildRequires: libmariadb-devel
BuildRequires: libpostgresql-devel
BuildRequires: libpython-devel
BuildRequires: libusb-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libbluez-devel
BuildRequires: autoconf
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: gettext
Requires: bluez
# Requires: dialog http://invisible-island.net/dialog/dialog.html conflicts with file from package ncurses-dialog-1.1.20080819
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# Force using 6210 frames for calendar for DCT4 phones disabled
%description
Gammu is command line utility and library to work with mobile phones from many vendors.
This package contains libraries files that used by Gammu.
@ -62,14 +57,12 @@ Summary: Python bindings for Gammu
%description -n python-gammu
Python bindings for Gammu library.
This package contains Python bindings for Gammu.
%debug_package
%prep
%setup -q -n gammu-%{version}
#%patch0 -p1 -b .exec
#%patch1 -p1
sed -i -e '/-Werror/d' CMakeLists.txt
%build
@ -85,13 +78,6 @@ sed -i -e '/-Werror/d' CMakeLists.txt
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
#mkdir devel_docs
#mkdir -p docs/symbian
#cp -pR %{buildroot}%{_docdir}/gammu/devel/* devel_docs
#cp -pR %{buildroot}%{_docdir}/gammu/symbian/* docs/symbian
#cp -p %{buildroot}%{_docdir}/gammu/*.* .
#rm -rf %{buildroot}%{_docdir}/gammu
%find_lang gammu
%find_lang libgammu
cat libgammu.lang >> gammu.lang
@ -99,9 +85,6 @@ cat libgammu.lang >> gammu.lang
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libGammu.so.*
@ -128,19 +111,15 @@ cat libgammu.lang >> gammu.lang
%{_datadir}/gammu/gammu-s60-remote.sis
%{_datadir}/gammu/gnapplet.ini
%{_datadir}/gammu/gnapplet.sis
%{_mandir}/man1/*.1.gz
%{_mandir}/man5/*.5.gz
%{_mandir}/man7/*.7.gz
%{_mandir}/man1/*.1*
%{_mandir}/man5/*.5*
%{_mandir}/man7/*.7*
%doc COPYING
#%files -n python-gammu
#%defattr(-,root,root)
#%dir %{python_sitearch}/gammu
#%{python_sitearch}/gammu/*.py*
#%{python_sitearch}/gammu/*.so
#%doc README.Python
%changelog
* Fri Nov 29 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.42.0-2mamba
- specfile fixes; updated URL; closes #1
* Sun Oct 11 2020 Automatic Build System <autodist@mambasoft.it> 1.42.0-1mamba
- automatic version update by autodist