automatic version update by autodist [release 1.33.0-1mamba;Thu Jul 11 2013]

This commit is contained in:
Automatic Build System 2024-01-06 04:19:04 +01:00
parent df2d217d31
commit 0bab752516
4 changed files with 212 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# libgammu
Gammu is command line utility and library to work with mobile phones from many vendors.
This package contains libraries files that used by Gammu.

View File

@ -0,0 +1,29 @@
diff -up gammu-1.26.1/contrib/smscgi/sms_cgi.c.orig gammu-1.26.1/contrib/smscgi/sms_cgi.c
--- gammu-1.26.1/contrib/smscgi/sms_cgi.c.orig 2010-06-10 14:55:30.000000000 +0200
+++ gammu-1.26.1/contrib/smscgi/sms_cgi.c 2010-06-10 15:01:45.000000000 +0200
@@ -76,6 +76,7 @@ static void NORETURN cgi_child(GSM_State
int errfd;
char script_name[300];
const char*data;
+ char *empty_argv[1] = { NULL };
strcpy(script_name, cgi_path); /**< prepend script path */
/* ---------------------------------------------------- get the script name */
@@ -115,7 +116,7 @@ static void NORETURN cgi_child(GSM_State
smprintf(s, CGI_ENGINE "Executing > %s\n", script_name);
/* Execute script */
- execv(script_name, NULL);
+ execv(script_name, empty_argv);
/* ------------------------------------------------------ failed to execute */
smprintf(s, CGI_ENGINE "Failed to execure %s : %s\n", script_name, strerror(errno));
@@ -140,7 +141,7 @@ static void NORETURN cgi_child(GSM_State
smprintf(s, CGI_ENGINE "Executing > %s\n", script_name);
/* Execute script */
- execv(script_name, NULL);
+ execv(script_name, empty_argv);
error:
/* ------------------------------------------------------ failed to execute */

View File

@ -0,0 +1,24 @@
diff -Nru gammu-1.32.0.orig/python/gammu/src/gammu.c gammu-1.32.0/python/gammu/src/gammu.c
--- gammu-1.32.0.orig/python/gammu/src/gammu.c 2012-06-27 10:02:28.000000000 +0200
+++ gammu-1.32.0/python/gammu/src/gammu.c 2013-05-23 01:42:01.796386347 +0200
@@ -5344,7 +5344,7 @@
#ifdef WITH_THREAD
PyThread_free_lock(self->mutex);
#endif
- self->ob_type->tp_free((PyObject*)self);
+ Py_TYPE(self)->tp_free((PyObject*)self);
}
static PyObject *
diff -Nru gammu-1.32.0.orig/python/gammu/src/smsd.c gammu-1.32.0/python/gammu/src/smsd.c
--- gammu-1.32.0.orig/python/gammu/src/smsd.c 2012-06-27 10:02:28.000000000 +0200
+++ gammu-1.32.0/python/gammu/src/smsd.c 2013-05-23 01:42:40.412918323 +0200
@@ -198,7 +198,7 @@
static void SMSD_dealloc(SMSDObject * self)
{
SMSD_FreeConfig(self->config);
- self->ob_type->tp_free((PyObject *) self);
+ Py_TYPE(self)->tp_free((PyObject *) self);
}
static PyObject *SMSD_new(PyTypeObject * type, PyObject * args, PyObject * kwds)

156
libgammu.spec Normal file
View File

@ -0,0 +1,156 @@
Name: libgammu
Version: 1.33.0
Release: 1mamba
Summary: A library to work with mobile phones from many vendors
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://wammu.eu/gammu/
Source: http://downloads.sourceforge.net/project/gammu/gammu/%{version}/gammu-%{version}.tar.gz
Patch0: libgammu-1.26.1-exec.patch
Patch1: libgammu-1.32.0-python-2.7.patch
License: GPL
BuildRequires: autoconf
BuildRequires: bluez
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: gettext
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbluetooth-devel
BuildRequires: libcurl-devel
BuildRequires: libdbi-devel
BuildRequires: libmysql5-devel
BuildRequires: libpostgresql-devel
BuildRequires: libpython-devel
BuildRequires: libusb-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libbluez-devel
Requires: bluez
# Requires: dialog http://invisible-island.net/dialog/dialog.html conflicts with file from package ncurses-dialog-1.1.20080819
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# Force using 6210 frames for calendar for DCT4 phones disabled
%description
Gammu is command line utility and library to work with mobile phones from many vendors.
This package contains libraries files that used by Gammu.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for Gammu
Requires: gammu = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Gammu is command line utility and library to work with mobile phones from many vendors.
This package contains static libraries and header files needed for development.
%package -n gammu
Group: System/Tools
Summary: Command Line utility to work with mobile phones
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n gammu
Gammu is command line utility and library to work with mobile phones from many vendors.
Support for different models differs, but basic functions should work with majority of them. Program can work with contacts, messages (SMS, EMS and MMS), calendar, todos, filesystem, integrated radio, camera, etc.
It also supports daemon mode to send and receive SMSes.
%package -n python-gammu
Group: Development/Libraries/Python
Summary: Python bindings for Gammu
%description -n python-gammu
Python bindings for Gammu library.
This package contains Python bindings for Gammu.
%prep
%setup -q -n gammu-%{version}
#%patch0 -p1 -b .exec
%patch1 -p1
sed -i -e '/-Werror/d' CMakeLists.txt
%build
%cmake -d build \
-DENABLE_BACKUP=ON \
-DWITH_NOKIA_SUPPORT=ON \
-DWITH_Bluez=ON \
-DWITH_IrDA=On
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
#mkdir devel_docs
#mkdir -p docs/symbian
#cp -pR %{buildroot}%{_docdir}/gammu/devel/* devel_docs
#cp -pR %{buildroot}%{_docdir}/gammu/symbian/* docs/symbian
#cp -p %{buildroot}%{_docdir}/gammu/*.* .
#rm -rf %{buildroot}%{_docdir}/gammu
%find_lang gammu
%find_lang libgammu
cat libgammu.lang >> gammu.lang
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libGammu.so.*
%{_libdir}/libgsmsd.so.*
%files devel
%defattr(-,root,root)
%dir %{_includedir}/gammu
%{_includedir}/gammu/*.h
%{_libdir}/libGammu.so
%{_libdir}/libgsmsd.so
%{_libdir}/pkgconfig/gammu-smsd.pc
%{_libdir}/pkgconfig/gammu.pc
%dir %{_datadir}/doc/gammu
%{_datadir}/doc/gammu/*
%files -n gammu -f gammu.lang
%defattr(-,root,root)
%{_sysconfdir}/bash_completion.d/gammu
%{_bindir}/gammu*
%{_bindir}/jadmaker
%dir %{_datadir}/gammu
%{_datadir}/gammu/gammu-s60-remote.sis
%{_datadir}/gammu/gnapplet.ini
%{_datadir}/gammu/gnapplet.sis
%{_mandir}/man1/*.1.gz
%{_mandir}/man5/*.5.gz
%{_mandir}/man7/*.7.gz
%doc COPYING
%files -n python-gammu
%defattr(-,root,root)
%dir %{python_sitearch}/gammu
%{python_sitearch}/gammu/*.py*
%{python_sitearch}/gammu/*.so
%doc README.Python
%changelog
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 1.33.0-1mamba
- automatic version update by autodist
* Sun May 26 2013 Automatic Build System <autodist@mambasoft.it> 1.32.0-1mamba
- automatic version update by autodist
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.28.0-2mamba
- rebuilt in devel
* Tue Nov 09 2010 gil <puntogil@libero.it> 1.28.0-1mamba
- update to 1.28.0
* Thu Dec 03 2009 gil <puntogil@libero.it> 1.26.1-1mamba
- package created by autospec