python 2.7 mass rebuild [release 0.1.10-5mamba;Tue Jun 04 2013]
This commit is contained in:
parent
b2ad4d0de9
commit
2b1693f49e
@ -1,2 +1,4 @@
|
||||
# libgamin
|
||||
|
||||
This C library provides an API and ABI compatible file alteration monitor mechanism compatible with FAM but not dependent on a system wide daemon.
|
||||
|
||||
|
46
libgamin-0.1.10-fix-deadlocks.patch
Normal file
46
libgamin-0.1.10-fix-deadlocks.patch
Normal file
@ -0,0 +1,46 @@
|
||||
Index: gamin-0.1.10/server/inotify-helper.c
|
||||
===================================================================
|
||||
--- gamin-0.1.10/server/inotify-helper.c
|
||||
+++ gamin-0.1.10/server/inotify-helper.c 2012-01-03 23:55:35.420488530 +0200
|
||||
@@ -124,10 +124,9 @@
|
||||
/**
|
||||
* Cancels a subscription which was being monitored.
|
||||
*/
|
||||
-gboolean
|
||||
-ih_sub_cancel (ih_sub_t * sub)
|
||||
+static gboolean
|
||||
+ih_sub_cancel_locked (ih_sub_t * sub)
|
||||
{
|
||||
- G_LOCK(inotify_lock);
|
||||
|
||||
|
||||
if (!sub->cancelled)
|
||||
@@ -140,7 +139,6 @@
|
||||
sub_list = g_list_remove (sub_list, sub);
|
||||
}
|
||||
|
||||
- G_UNLOCK(inotify_lock);
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
@@ -159,7 +157,7 @@
|
||||
|
||||
if (f(sub, callerdata))
|
||||
{
|
||||
- ih_sub_cancel (sub); /* Removes sub from sub_list */
|
||||
+ ih_sub_cancel_locked (sub); /* Removes sub from sub_list */
|
||||
if (free)
|
||||
ih_sub_free (sub);
|
||||
}
|
||||
Index: gamin-0.1.10/server/inotify-helper.h
|
||||
===================================================================
|
||||
--- gamin-0.1.10/server/inotify-helper.h
|
||||
+++ gamin-0.1.10/server/inotify-helper.h 2012-01-03 23:54:17.469874801 +0200
|
||||
@@ -34,7 +34,6 @@
|
||||
found_callback_t fcb);
|
||||
gboolean ih_running (void);
|
||||
gboolean ih_sub_add (ih_sub_t *sub);
|
||||
-gboolean ih_sub_cancel (ih_sub_t *sub);
|
||||
|
||||
/* Return FALSE from 'f' if the subscription should be cancelled */
|
||||
void ih_sub_foreach (void *callerdata, gboolean (*f)(ih_sub_t *sub, void *callerdata));
|
50
libgamin-0.1.10-glib-2.30.patch
Normal file
50
libgamin-0.1.10-glib-2.30.patch
Normal file
@ -0,0 +1,50 @@
|
||||
--- gamin-0.1.10.orig/server/gam_node.c 2011-10-12 15:25:45.217178314 +0100
|
||||
+++ gamin-0.1.10/server/gam_node.c 2011-10-12 15:26:17.807178293 +0100
|
||||
@@ -122,7 +122,7 @@
|
||||
* it has finished with the string. If it must keep it longer, it
|
||||
* should makes its own copy. The returned string must not be freed.
|
||||
*/
|
||||
-G_CONST_RETURN char *
|
||||
+const char *
|
||||
gam_node_get_path(GamNode * node)
|
||||
{
|
||||
g_assert(node);
|
||||
Index: gamin-0.1.10/server/gam_node.h
|
||||
===================================================================
|
||||
--- gamin-0.1.10.orig/server/gam_node.h 2011-10-12 15:25:46.857178269 +0100
|
||||
+++ gamin-0.1.10/server/gam_node.h 2011-10-12 15:26:28.637178297 +0100
|
||||
@@ -58,7 +58,7 @@
|
||||
void gam_node_set_is_dir (GamNode *node,
|
||||
gboolean is_dir);
|
||||
|
||||
-G_CONST_RETURN char *gam_node_get_path (GamNode *node);
|
||||
+const char *gam_node_get_path (GamNode *node);
|
||||
|
||||
GList *gam_node_get_subscriptions (GamNode *node);
|
||||
|
||||
Index: gamin-0.1.10/server/gam_subscription.c
|
||||
===================================================================
|
||||
--- gamin-0.1.10.orig/server/gam_subscription.c 2011-10-12 15:25:40.497177525 +0100
|
||||
+++ gamin-0.1.10/server/gam_subscription.c 2011-10-12 15:26:39.867178304 +0100
|
||||
@@ -141,7 +141,7 @@
|
||||
* @param sub the GamSubscription
|
||||
* @returns The path being monitored. It should not be freed.
|
||||
*/
|
||||
-G_CONST_RETURN char *
|
||||
+const char *
|
||||
gam_subscription_get_path(GamSubscription * sub)
|
||||
{
|
||||
if (sub == NULL)
|
||||
Index: gamin-0.1.10/server/gam_subscription.h
|
||||
===================================================================
|
||||
--- gamin-0.1.10.orig/server/gam_subscription.h 2011-10-12 15:25:28.507178266 +0100
|
||||
+++ gamin-0.1.10/server/gam_subscription.h 2011-10-12 15:25:58.817178285 +0100
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
int gam_subscription_get_reqno (GamSubscription *sub);
|
||||
|
||||
-G_CONST_RETURN char *gam_subscription_get_path (GamSubscription *sub);
|
||||
+const char *gam_subscription_get_path (GamSubscription *sub);
|
||||
|
||||
GamListener *gam_subscription_get_listener (GamSubscription *sub);
|
||||
|
113
libgamin.spec
Normal file
113
libgamin.spec
Normal file
@ -0,0 +1,113 @@
|
||||
Name: libgamin
|
||||
Version: 0.1.10
|
||||
Release: 5mamba
|
||||
Summary: Library providing the FAM File Alteration Monitor API
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||
URL: http://www.gnome.org/~veillard/gamin
|
||||
Source: http://www.gnome.org/~veillard/gamin/sources/gamin-%{version}.tar.gz
|
||||
Patch0: libgamin-0.1.10-glib-2.30.patch
|
||||
Patch1: libgamin-0.1.10-fix-deadlocks.patch
|
||||
License: LGPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: fam
|
||||
Obsoletes: libfam
|
||||
Provides: fam
|
||||
Provides: libfam
|
||||
Requires: %{name} >= %{version}
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: pkg-config
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python
|
||||
|
||||
%description
|
||||
This C library provides an API and ABI compatible file alteration monitor mechanism compatible with FAM but not dependent on a system wide daemon.
|
||||
|
||||
%package -n python-gamin
|
||||
Summary: Python bindings for the gamin library
|
||||
Group: Development/Libraries
|
||||
|
||||
%description -n python-gamin
|
||||
This package contains a module that allow monitoring of files and directories
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-1-devel = %{version}
|
||||
Provides: %{name}-devel = %{version}
|
||||
Obsoletes: libfam-devel
|
||||
Provides: libfam-devel
|
||||
Provides: fam-devel
|
||||
|
||||
%description devel
|
||||
This C library provides an API and ABI compatible file alteration monitor mechanism compatible with FAM but not dependent on a system wide daemon.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n gamin-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make pythondir=%{python_sitearch}
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall pythondir=%{python_sitearch}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -n python-gamin
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/_gamin.a
|
||||
%{python_sitearch}/_gamin.la
|
||||
%{python_sitearch}/_gamin.so
|
||||
%{python_sitearch}/gamin.py
|
||||
%{python_sitearch}/gamin.pyc
|
||||
%{python_sitearch}/gamin.pyo
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
%{_libexecdir}/gam_server
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Tue Jun 04 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.10-5mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Sat Sep 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.10-4mamba
|
||||
- added a patch to fix deadlocks; seen with okular (http://lists.debian.org/debian-qt-kde/2012/07/msg00173.html)
|
||||
|
||||
* Wed Sep 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.10-3mamba
|
||||
- rebuilt with glib 2.30 patch
|
||||
|
||||
* Thu Feb 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.10-2mamba
|
||||
- move some python modules from libgamin to python-gamin
|
||||
|
||||
* Fri Feb 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.10-1mamba
|
||||
- update to 0.1.10
|
||||
|
||||
* Fri Oct 10 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.1.9-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user