rebuilt with debug package and cmake swig build patch [release 1.4-2mamba;Wed Dec 09 2020]
This commit is contained in:
parent
e30200cd19
commit
8050123e30
21
libftdi1-1.4-cmake_swig.patch
Normal file
21
libftdi1-1.4-cmake_swig.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- a/python/CMakeLists.txt
|
||||||
|
+++ b/python/CMakeLists.txt
|
||||||
|
@@ -1,3 +1,7 @@
|
||||||
|
+# swig_add_module is deprecated and SWIG_MODULE_<target>_REAL_NAME is no
|
||||||
|
+# longer set by default so set policy to the old behavior.
|
||||||
|
+cmake_policy(SET CMP0078 OLD)
|
||||||
|
+
|
||||||
|
option ( PYTHON_BINDINGS "Build python bindings via swig" ON )
|
||||||
|
option ( LINK_PYTHON_LIBRARY "Link against python libraries" ON )
|
||||||
|
|
||||||
|
@@ -24,8 +28,9 @@ if ( SWIG_FOUND AND PYTHONLIBS_FOUND AND
|
||||||
|
|
||||||
|
if ( DOCUMENTATION AND DOXYGEN_FOUND )
|
||||||
|
set(CMAKE_SWIG_FLAGS -DDOXYGEN=${DOXYGEN_FOUND})
|
||||||
|
+ set_property(SOURCE ftdi1.i PROPERTY DEPENDS ftdi1_doc.i)
|
||||||
|
endif()
|
||||||
|
- swig_add_module ( ftdi1 python ftdi1.i )
|
||||||
|
+ swig_add_library ( ftdi1 LANGUAGE python SOURCES ftdi1.i )
|
||||||
|
swig_link_libraries ( ftdi1 ftdi1 )
|
||||||
|
|
||||||
|
if ( LINK_PYTHON_LIBRARY )
|
@ -1,6 +1,6 @@
|
|||||||
Name: libftdi1
|
Name: libftdi1
|
||||||
Version: 1.4
|
Version: 1.4
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A library to talk to FTDI chips: FT232BM/245BM, FT2232C/D and FT232/245R
|
Summary: A library to talk to FTDI chips: FT232BM/245BM, FT2232C/D and FT232/245R
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,15 +8,17 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.intra2net.com/en/developer/libftdi/index.php
|
URL: http://www.intra2net.com/en/developer/libftdi/index.php
|
||||||
Source: http://www.intra2net.com/en/developer/libftdi/download/libftdi1-%{version}.tar.bz2
|
Source: http://www.intra2net.com/en/developer/libftdi/download/libftdi1-%{version}.tar.bz2
|
||||||
|
Patch0: libftdi1-1.4-cmake_swig.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
BuildRequires: libconfuse-devel
|
BuildRequires: libconfuse-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libpython-devel
|
|
||||||
BuildRequires: libpython3-devel
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libusbx-devel
|
BuildRequires: libusb-devel
|
||||||
|
BuildRequires: python3
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -42,11 +44,17 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n ftdi1-utils
|
%description -n ftdi1-utils
|
||||||
Utilities to talk to FTDI chips: FT232BM/245BM, FT2232C/D and FT232/245R using libusb, including the popular bitbang mode.
|
Utilities to talk to FTDI chips: FT232BM/245BM, FT2232C/D and FT232/245R using libusb, including the popular bitbang mode.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n libftdi1-%{version}
|
%setup -q -n libftdi1-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build \
|
||||||
|
-DEXAMPLES=OFF \
|
||||||
|
-DFTDI_EEPROM=ON
|
||||||
|
|
||||||
%make -j1
|
%make -j1
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -93,6 +101,9 @@ Utilities to talk to FTDI chips: FT232BM/245BM, FT2232C/D and FT232/245R using l
|
|||||||
%{_bindir}/ftdi_eeprom
|
%{_bindir}/ftdi_eeprom
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4-2mamba
|
||||||
|
- rebuilt with debug package and cmake swig build patch
|
||||||
|
|
||||||
* Sun Oct 13 2019 Automatic Build System <autodist@mambasoft.it> 1.4-1mamba
|
* Sun Oct 13 2019 Automatic Build System <autodist@mambasoft.it> 1.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user