automatic version update by autodist [release 1.3.2-1mamba;Tue Dec 11 2012]
This commit is contained in:
parent
0e28b1282a
commit
6780be3794
@ -1,2 +1,5 @@
|
||||
# libfltk
|
||||
|
||||
FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
|
||||
FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.
|
||||
|
||||
|
32
libfltk-1.1.9-gcc44.patch
Normal file
32
libfltk-1.1.9-gcc44.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff -Nru fltk-1.1.9.orig/src/filename_list.cxx fltk-1.1.9/src/filename_list.cxx
|
||||
--- fltk-1.1.9.orig/src/filename_list.cxx 2006-06-09 18:16:34.000000000 +0200
|
||||
+++ fltk-1.1.9/src/filename_list.cxx 2009-07-01 14:25:03.841445929 +0200
|
||||
@@ -67,7 +67,7 @@
|
||||
// The vast majority of UNIX systems want the sort function to have this
|
||||
// prototype, most likely so that it can be passed to qsort without any
|
||||
// changes:
|
||||
- int n = scandir(d, list, 0, (int(*)(const void*,const void*))sort);
|
||||
+ int n = scandir(d, list, 0, (int(*)(const dirent **,const dirent **))sort);
|
||||
#else
|
||||
// This version is when we define our own scandir (WIN32 and perhaps
|
||||
// some Unix systems) and apparently on IRIX:
|
||||
diff -ru fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx fltk-1.1.9/src/fl_set_fonts_xft.cxx
|
||||
--- fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx 2006-10-03 04:35:12.000000000 +0200
|
||||
+++ fltk-1.1.9/src/fl_set_fonts_xft.cxx 2009-07-01 14:28:28.268210527 +0200
|
||||
@@ -253,13 +253,13 @@
|
||||
// So the bit we want is up to the first comma - BUT some strings have
|
||||
// more than one name, separated by, guess what?, a comma...
|
||||
stop = start = first = 0;
|
||||
- stop = strchr((const char *)font, ',');
|
||||
- start = strchr((const char *)font, ':');
|
||||
+ stop = strchr((char *)font, ',');
|
||||
+ start = strchr((char *)font, ':');
|
||||
if ((stop) && (start) && (stop < start))
|
||||
{
|
||||
first = stop + 1; // discard first version of name
|
||||
// find first comma *after* the end of the name
|
||||
- stop = strchr((const char *)start, ',');
|
||||
+ stop = strchr((char *)start, ',');
|
||||
}
|
||||
else
|
||||
{
|
165
libfltk.spec
Normal file
165
libfltk.spec
Normal file
@ -0,0 +1,165 @@
|
||||
Name: libfltk
|
||||
Version: 1.3.2
|
||||
Release: 1mamba
|
||||
Summary: A cross-platform C++ GUI toolkit
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.fltk.org/index.php
|
||||
Source: http://ftp.easysw.com/pub/fltk/%{version}/fltk-%{version}-source.tar.gz
|
||||
Patch0: %{name}-1.1.9-gcc44.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: ImageMagick
|
||||
|
||||
%description
|
||||
FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
|
||||
FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Devel package for libfltk
|
||||
Requires: libfltk == %{version}
|
||||
|
||||
%description devel
|
||||
FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
|
||||
FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n fltk-games
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Summary: Checkers and Sudoku FLTK games
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description -n fltk-games
|
||||
FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
|
||||
FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.
|
||||
|
||||
This package contains the Checkers and Sudoku FLTK games.
|
||||
|
||||
%prep
|
||||
%setup -q -n fltk-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-shared \
|
||||
--enable-threads \
|
||||
--enable-xdbe \
|
||||
--enable-xft \
|
||||
--enable-gl \
|
||||
--enable-largefile
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall install-desktop
|
||||
install -d %{buildroot}%{_datadir}/applications
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libfltk.so.*
|
||||
%{_libdir}/libfltk_forms.so.*
|
||||
%{_libdir}/libfltk_gl.so.*
|
||||
%{_libdir}/libfltk_images.so.*
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/cat1/*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/fltk-config
|
||||
%{_bindir}/fluid
|
||||
%{_datadir}/doc/fltk/*
|
||||
%{_libdir}/libfltk.a
|
||||
%{_libdir}/libfltk.so
|
||||
%{_libdir}/libfltk_forms.a
|
||||
%{_libdir}/libfltk_forms.so
|
||||
%{_libdir}/libfltk_gl.a
|
||||
%{_libdir}/libfltk_gl.so
|
||||
%{_libdir}/libfltk_images.a
|
||||
%{_libdir}/libfltk_images.so
|
||||
%dir %{_includedir}/FL
|
||||
%{_includedir}/FL/*
|
||||
%{_datadir}/applications/fluid.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/fluid.png
|
||||
%{_datadir}/mimelnk/application/x-fluid.desktop
|
||||
%{_mandir}/man3/*
|
||||
%{_mandir}/cat3/*
|
||||
|
||||
%files -n fltk-games
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/blocks
|
||||
%{_bindir}/checkers
|
||||
%{_bindir}/sudoku
|
||||
%{_datadir}/applications/blocks.desktop
|
||||
%{_datadir}/applications/checkers.desktop
|
||||
%{_datadir}/applications/sudoku.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/blocks.png
|
||||
%{_datadir}/icons/hicolor/*/apps/checkers.png
|
||||
%{_datadir}/icons/hicolor/*/apps/sudoku.png
|
||||
%{_mandir}/cat6/blocks.6*
|
||||
%{_mandir}/cat6/sudoku.*
|
||||
%{_mandir}/cat6/checkers.*
|
||||
%{_mandir}/man6/blocks.6*
|
||||
%{_mandir}/man6/sudoku.*
|
||||
%{_mandir}/man6/checkers.*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 11 2012 Automatic Build System <autodist@mambasoft.it> 1.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Sep 25 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1mamba
|
||||
- update to 1.3.0
|
||||
|
||||
* Thu Oct 28 2010 Automatic Build System <autodist@mambasoft.it> 1.1.9-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Jul 01 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.9-2mamba
|
||||
- enabled large file support
|
||||
- added gcc 4.4 patch
|
||||
|
||||
* Sun Nov 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Oct 12 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-2mamba
|
||||
- rebuild with GL support (requires libGL.so pointing to Mesa libGL, not nvidia)
|
||||
- fluid moved to devel package and added desktop menu entry
|
||||
- added games subpackage
|
||||
|
||||
* Mon Apr 03 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.1.7-1qilnx
|
||||
- update to version 1.1.7 by autospec
|
||||
|
||||
* Sun Feb 20 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.6-1qilnx
|
||||
- update to version 1.1.6 by autospec
|
||||
- added missing symlink %{_includedir}/Fl
|
||||
|
||||
* Mon Sep 27 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.5rc3-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user