python 2.7 mass rebuild [release 2.1.0-2mamba;Sun Jun 02 2013]
This commit is contained in:
parent
95e2109a7b
commit
6f281725d2
8
README.ffado
Normal file
8
README.ffado
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
ffado-bridgeco-downloader -- Firmware downloader application for BridgeCo devices
|
||||||
|
ffado-diag -- FFADO diagnostic utility
|
||||||
|
ffado-dbus-server -- Expose the mixer features of connected FFADO devices through DBus
|
||||||
|
ffado-fireworks-downloader -- Firmware downloader application for ECHO Fireworks devices
|
||||||
|
ffado-mixer -- Qt based FFADO device mixer
|
||||||
|
|
||||||
|
FFADO is work in progress, hence there are no useful manpages.
|
||||||
|
Please refer to http://www.ffado.org/ for more information.
|
@ -1,2 +1,4 @@
|
|||||||
# libffado
|
# libffado
|
||||||
|
|
||||||
|
The FFADO project aims to provide a generic, open-source solution for the support of FireWire based audio devices for the Linux platform. It is the successor of the FreeBoB project.
|
||||||
|
|
||||||
|
65
libffado-2.0.1-gcc-4.7.patch
Normal file
65
libffado-2.0.1-gcc-4.7.patch
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
diff -Naur libffado-2.0.1-old/src/bebob/bebob_dl_mgr.cpp libffado-2.0.1/src/bebob/bebob_dl_mgr.cpp
|
||||||
|
--- libffado-2.0.1-old/src/bebob/bebob_dl_mgr.cpp 2009-05-17 23:42:38.000000000 +1000
|
||||||
|
+++ libffado-2.0.1/src/bebob/bebob_dl_mgr.cpp 2012-04-29 15:26:29.011454798 +1000
|
||||||
|
@@ -35,6 +35,7 @@
|
||||||
|
|
||||||
|
#include <cstdio>
|
||||||
|
#include <cstring>
|
||||||
|
+#include <unistd.h>
|
||||||
|
|
||||||
|
namespace BeBoB {
|
||||||
|
enum {
|
||||||
|
diff -Naur libffado-2.0.1-old/src/ffadodevice.cpp libffado-2.0.1/src/ffadodevice.cpp
|
||||||
|
--- libffado-2.0.1-old/src/ffadodevice.cpp 2008-11-23 21:25:32.000000000 +1000
|
||||||
|
+++ libffado-2.0.1/src/ffadodevice.cpp 2012-04-29 15:26:54.883998052 +1000
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
|
||||||
|
#include <iostream>
|
||||||
|
#include <sstream>
|
||||||
|
+#include <unistd.h>
|
||||||
|
|
||||||
|
#include <assert.h>
|
||||||
|
|
||||||
|
diff -Naur libffado-2.0.1-old/src/fireworks/fireworks_device.cpp libffado-2.0.1/src/fireworks/fireworks_device.cpp
|
||||||
|
--- libffado-2.0.1-old/src/fireworks/fireworks_device.cpp 2009-11-23 00:40:08.000000000 +1000
|
||||||
|
+++ libffado-2.0.1/src/fireworks/fireworks_device.cpp 2012-04-29 15:27:24.123105334 +1000
|
||||||
|
@@ -44,6 +44,7 @@
|
||||||
|
#define FIREWORKS_MIN_FIRMWARE_VERSION 0x04080000
|
||||||
|
|
||||||
|
#include <sstream>
|
||||||
|
+#include <unistd.h>
|
||||||
|
using namespace std;
|
||||||
|
|
||||||
|
// FireWorks is the platform used and developed by ECHO AUDIO
|
||||||
|
diff -Naur libffado-2.0.1-old/src/libieee1394/IsoHandlerManager.cpp libffado-2.0.1/src/libieee1394/IsoHandlerManager.cpp
|
||||||
|
--- libffado-2.0.1-old/src/libieee1394/IsoHandlerManager.cpp 2010-04-18 05:15:54.000000000 +1000
|
||||||
|
+++ libffado-2.0.1/src/libieee1394/IsoHandlerManager.cpp 2012-04-29 15:27:44.515816147 +1000
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
#include "libutil/Configuration.h"
|
||||||
|
|
||||||
|
#include <cstring>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <assert.h>
|
||||||
|
|
||||||
|
IMPL_DEBUG_MODULE( IsoHandlerManager, IsoHandlerManager, DEBUG_LEVEL_NORMAL );
|
||||||
|
diff -Naur libffado-2.0.1-old/support/dbus/test-dbus.cpp libffado-2.0.1/support/dbus/test-dbus.cpp
|
||||||
|
--- libffado-2.0.1-old/support/dbus/test-dbus.cpp 2008-04-27 03:30:41.000000000 +1000
|
||||||
|
+++ libffado-2.0.1/support/dbus/test-dbus.cpp 2012-04-29 15:28:31.531047923 +1000
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include <argp.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <iostream>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <signal.h>
|
||||||
|
|
||||||
|
#include "controlclient.h"
|
||||||
|
--- libffado-2.1.0.old/src/libutil/PosixSharedMemory.cpp 2008-05-15 00:38:31.000000000 -0400
|
||||||
|
+++ libffado-2.1.0/src/libutil/PosixSharedMemory.cpp 2012-01-10 23:30:49.767652458 -0500
|
||||||
|
@@ -26,6 +26,7 @@
|
||||||
|
#include <sys/mman.h>
|
||||||
|
#include <errno.h>
|
||||||
|
#include <string.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
|
||||||
|
namespace Util {
|
26
libffado-api-doc-only.patch
Normal file
26
libffado-api-doc-only.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff -rupN libffado.old/doc/reference.doxygen.in libffado/doc/reference.doxygen.in
|
||||||
|
--- libffado.old/doc/reference.doxygen.in 2009-12-18 13:52:13.000000000 -0500
|
||||||
|
+++ libffado/doc/reference.doxygen.in 2010-06-05 21:00:54.000000000 -0400
|
||||||
|
@@ -568,9 +568,7 @@ WARN_LOGFILE =
|
||||||
|
# directories like "/usr/src/myproject". Separate the files or directories
|
||||||
|
# with spaces.
|
||||||
|
|
||||||
|
-INPUT = $top_srcdir/src \
|
||||||
|
- $top_srcdir/doc \
|
||||||
|
- $top_srcdir/libffado
|
||||||
|
+INPUT = $top_srcdir/libffado
|
||||||
|
|
||||||
|
# This tag can be used to specify the character encoding of the source files
|
||||||
|
# that doxygen parses. Internally doxygen uses the UTF-8 encoding, which is
|
||||||
|
diff -rupN libffado.old/SConstruct libffado/SConstruct
|
||||||
|
--- libffado.old/SConstruct 2010-05-10 15:34:07.000000000 -0400
|
||||||
|
+++ libffado/SConstruct 2010-06-05 21:29:43.000000000 -0400
|
||||||
|
@@ -583,7 +583,7 @@ if not env.GetOption('clean'):
|
||||||
|
Default( 'support' )
|
||||||
|
if env['BUILD_TESTS']:
|
||||||
|
Default( 'tests' )
|
||||||
|
-
|
||||||
|
+ Default( 'doc' )
|
||||||
|
#
|
||||||
|
# Deal with the DESTDIR vs. xdg-tools conflict (which is basicely that the
|
||||||
|
# xdg-tools can't deal with DESTDIR, so the packagers have to deal with this
|
17
libffado-desktop.patch
Normal file
17
libffado-desktop.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -rupN libffado.old/support/xdg/ffado.org-ffadomixer.desktop libffado/support/xdg/ffado.org-ffadomixer.desktop
|
||||||
|
--- libffado.old/support/xdg/ffado.org-ffadomixer.desktop 2008-11-16 18:30:46.000000000 -0500
|
||||||
|
+++ libffado/support/xdg/ffado.org-ffadomixer.desktop 2010-07-14 15:42:28.000000000 -0400
|
||||||
|
@@ -1,9 +1,8 @@
|
||||||
|
[Desktop Entry]
|
||||||
|
-Comment=
|
||||||
|
+Name=FFADO Mixer
|
||||||
|
+Comment=Audio mixer for Firewire devices
|
||||||
|
Exec=ffado-mixer
|
||||||
|
-GenericName=
|
||||||
|
+GenericName=Firewire audio mixer
|
||||||
|
Icon=ffado
|
||||||
|
-Name=ffado-mixer
|
||||||
|
-Path=
|
||||||
|
Type=Application
|
||||||
|
-Categories=Mixer;Audio;AudioVideo;HardwareSettings;Qt
|
||||||
|
+Categories=Mixer;Audio;AudioVideo;HardwareSettings;Qt;
|
1148
libffado-dont-use-bundled-libs.patch
Normal file
1148
libffado-dont-use-bundled-libs.patch
Normal file
File diff suppressed because it is too large
Load Diff
12
libffado-libconfig145.patch
Normal file
12
libffado-libconfig145.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- libffado.old/src/libutil/Configuration.cpp 2010-06-19 14:31:27.000000000 -0400
|
||||||
|
+++ libffado/src/libutil/Configuration.cpp 2010-07-14 01:37:57.000000000 -0400
|
||||||
|
@@ -333,7 +333,8 @@ Configuration::getValueForDeviceSetting(
|
||||||
|
libconfig::Setting *s = getDeviceSetting( vendor_id, model_id );
|
||||||
|
if(s) {
|
||||||
|
try {
|
||||||
|
- return s->lookupValue(setting, ref);
|
||||||
|
+ long long int refverylong = ref;
|
||||||
|
+ return s->lookupValue(setting, refverylong);
|
||||||
|
} catch (...) {
|
||||||
|
debugOutput(DEBUG_LEVEL_VERBOSE, "Setting %s not found\n", setting.c_str());
|
||||||
|
return false;
|
83
libffado-no-shebang.patch
Normal file
83
libffado-no-shebang.patch
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/configuration.py libffado/support/mixer-qt4/ffado/configuration.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/configuration.py 2009-11-09 15:34:33.000000000 -0500
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/configuration.py 2010-06-05 21:45:12.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2008-2009 by Arnold Krille
|
||||||
|
#
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/dbus_util.py libffado/support/mixer-qt4/ffado/dbus_util.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/dbus_util.py 2009-08-30 15:05:51.000000000 -0400
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/dbus_util.py 2010-06-05 21:44:01.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2005-2008 by Pieter Palmers
|
||||||
|
# 2007-2008 by Arnold Krille
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/logginghandler.py libffado/support/mixer-qt4/ffado/logginghandler.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/logginghandler.py 2009-09-01 14:30:51.000000000 -0400
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/logginghandler.py 2010-06-05 21:44:41.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2008 by Arnold Krille
|
||||||
|
#
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/mixer/nodevice.py libffado/support/mixer-qt4/ffado/mixer/nodevice.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/mixer/nodevice.py 2009-10-17 14:14:32.000000000 -0400
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/mixer/nodevice.py 2010-06-05 21:44:18.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2005-2008 by Pieter Palmers
|
||||||
|
# 2007-2008 by Arnold Krille
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/panelmanager.py libffado/support/mixer-qt4/ffado/panelmanager.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/panelmanager.py 2010-02-17 17:08:15.000000000 -0500
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/panelmanager.py 2010-06-05 21:43:49.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2005-2008 by Pieter Palmers
|
||||||
|
# 2007-2008 by Arnold Krille
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/registration.py libffado/support/mixer-qt4/ffado/registration.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/registration.py 2009-08-30 15:05:51.000000000 -0400
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/registration.py 2010-06-05 21:45:31.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
#
|
||||||
|
# Copyright (C) 2008-2009 by Pieter Palmers
|
||||||
|
# 2009 by Arnold Krille
|
||||||
|
diff -rupN libffado.old/support/mixer-qt4/ffado/widgets/matrixmixer.py libffado/support/mixer-qt4/ffado/widgets/matrixmixer.py
|
||||||
|
--- libffado.old/support/mixer-qt4/ffado/widgets/matrixmixer.py 2009-12-01 17:49:23.000000000 -0500
|
||||||
|
+++ libffado/support/mixer-qt4/ffado/widgets/matrixmixer.py 2010-06-05 21:43:31.000000000 -0400
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
# coding=utf8
|
||||||
|
#
|
||||||
|
# Copyright (C) 2009 by Arnold Krille
|
||||||
|
diff -rupN libffado.old/support/tools/ffado_diag_helpers.py libffado/support/tools/ffado_diag_helpers.py
|
||||||
|
--- libffado.old/support/tools/ffado_diag_helpers.py 2009-10-12 16:32:00.000000000 -0400
|
||||||
|
+++ libffado/support/tools/ffado_diag_helpers.py 2010-06-05 21:42:49.000000000 -0400
|
||||||
|
@@ -1,6 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
-#
|
||||||
|
-
|
||||||
|
#
|
||||||
|
# Copyright (C) 2008 Pieter Palmers
|
||||||
|
#
|
||||||
|
diff -rupN libffado.old/support/tools/helpstrings.py libffado/support/tools/helpstrings.py
|
||||||
|
--- libffado.old/support/tools/helpstrings.py 2008-04-18 11:36:39.000000000 -0400
|
||||||
|
+++ libffado/support/tools/helpstrings.py 2010-06-05 21:43:04.000000000 -0400
|
||||||
|
@@ -1,6 +1,3 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
-#
|
||||||
|
-
|
||||||
|
#
|
||||||
|
# Copyright (C) 2008 Pieter Palmers
|
||||||
|
#
|
||||||
|
@@ -57,4 +54,4 @@ the user/group permissions.
|
||||||
|
|
||||||
|
def show(self, sid):
|
||||||
|
print self.get(sid)
|
||||||
|
-
|
||||||
|
\ No newline at end of file
|
||||||
|
+
|
11
libffado-python26.patch
Normal file
11
libffado-python26.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- SConstruct 2010-10-02 16:37:58.000000000 +0200
|
||||||
|
+++ SConstruct-gil 2010-10-02 16:45:52.000000000 +0200
|
||||||
|
@@ -129,7 +129,7 @@
|
||||||
|
|
||||||
|
def CheckForPyModule( context, module ):
|
||||||
|
context.Message( "Checking for the python module '" + module + "' " )
|
||||||
|
- ret = context.TryAction( "python $SOURCE", "import %s" % module, ".py" )
|
||||||
|
+ ret = context.TryAction( "python2.6 $SOURCE", "import %s" % module, ".py" )
|
||||||
|
context.Result( ret[0] )
|
||||||
|
return ret[0]
|
||||||
|
|
198
libffado.spec
Normal file
198
libffado.spec
Normal file
@ -0,0 +1,198 @@
|
|||||||
|
Name: libffado
|
||||||
|
Version: 2.1.0
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Free Firewire Audio Drivers Library
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.ffado.org/
|
||||||
|
Source0: http://www.ffado.org/files/libffado-%{version}.tgz
|
||||||
|
## svn export -r 1864 http://subversion.ffado.org/ffado/trunk/libffado libffado
|
||||||
|
## tar czf libffado-2.0.1-src-svn.tar.gz libffado
|
||||||
|
#Source0: libffado-%{version}-src-svn.tar.gz
|
||||||
|
Source1: README.ffado
|
||||||
|
# http://subversion.ffado.org/ticket/293
|
||||||
|
Patch0: libffado-api-doc-only.patch
|
||||||
|
# http://subversion.ffado.org/ticket/291
|
||||||
|
Patch1: libffado-desktop.patch
|
||||||
|
# http://subversion.ffado.org/ticket/292
|
||||||
|
Patch2: libffado-no-shebang.patch
|
||||||
|
# http://subversion.ffado.org/ticket/290
|
||||||
|
Patch3: libffado-dont-use-bundled-libs.patch
|
||||||
|
# http://subversion.ffado.org/ticket/290
|
||||||
|
Patch4: libffado-libconfig145.patch
|
||||||
|
Patch5: libffado-python26.patch
|
||||||
|
Patch6: libffado-2.0.1-gcc-4.7.patch
|
||||||
|
License: GPL, LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: dbus
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libconfig-devel
|
||||||
|
BuildRequires: libdbus-c++-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglibmm-devel
|
||||||
|
BuildRequires: libiec61883-devel
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
BuildRequires: libraw1394-devel
|
||||||
|
BuildRequires: libsigc++-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libxml++-devel
|
||||||
|
BuildRequires: pkg-config
|
||||||
|
BuildRequires: PyQt4-devel
|
||||||
|
BuildRequires: python-dbus-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: doxygen
|
||||||
|
BuildRequires: graphviz
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: scons
|
||||||
|
BuildRequires: subversion
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The FFADO project aims to provide a generic, open-source solution for the support of FireWire based audio devices for the Linux platform. It is the successor of the FreeBoB project.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The FFADO project aims to provide a generic, open-source solution for the support of FireWire based audio devices for the Linux platform. It is the successor of the FreeBoB project.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n ffado
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Applications and utilities for use with %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: dbus
|
||||||
|
Requires: python-dbus
|
||||||
|
Requires: PyQt4
|
||||||
|
|
||||||
|
%description -n ffado
|
||||||
|
The FFADO project aims to provide a generic, open-source solution for the support of FireWire based audio devices for the Linux platform. It is the successor of the FreeBoB project.
|
||||||
|
|
||||||
|
This package contains applications and utilities for use with %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
#%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
#%patch5
|
||||||
|
#%patch6 -p1
|
||||||
|
|
||||||
|
cp -a %{SOURCE1} .
|
||||||
|
|
||||||
|
sed -i '1s|#!/usr/bin/python|#!%{__python}|' support/mixer-qt4/ffado-mixer.in
|
||||||
|
sed -i '1s|#!/usr/bin/python|#!%{__python}|' support/mixer-qt4/ffado-mixer-profiler.in
|
||||||
|
sed -i '1s|#!/usr/bin/python|#!%{__python}|' support/tools/ffado-diag.in
|
||||||
|
sed -i '1s|#!/usr/bin/python|#!%{__python}|' support/tools/ffado-diag-static
|
||||||
|
|
||||||
|
for s in $(find . -name "*~"); do
|
||||||
|
rm -rf $s
|
||||||
|
done
|
||||||
|
|
||||||
|
%build
|
||||||
|
scons %{?_smp_mflags} \
|
||||||
|
COMPILE_FLAGS="%{optflags} -ffast-math -lpthread" \
|
||||||
|
PREFIX=%{_prefix} \
|
||||||
|
LIBDIR=%{_libdir} \
|
||||||
|
MANDIR=%{_mandir} \
|
||||||
|
PYUIC4=%{_bindir}/pyuic4 \
|
||||||
|
PYTHONDIR=%{python26_sitearch} \
|
||||||
|
BUILD_TESTS=0
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
scons DESTDIR=%{buildroot} install
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
|
install -pm 644 support/xdg/ffado.org-ffadomixer.desktop %{buildroot}%{_datadir}/applications/
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/64x64/apps
|
||||||
|
ln -s ../../../../libffado/icons/hi64-apps-ffado.png \
|
||||||
|
%{buildroot}%{_datadir}/icons/hicolor/64x64/apps/ffado.png
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post -n ffado
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
|
%postun -n ffado
|
||||||
|
if [ $1 -eq 0 ] ; then
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||||
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%posttrans -n ffado
|
||||||
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libffado.so.*
|
||||||
|
%dir %{_datadir}/libffado
|
||||||
|
%{_datadir}/libffado/configuration
|
||||||
|
%doc AUTHORS ChangeLog LICENSE.* README
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/libffado
|
||||||
|
%{_includedir}/libffado/ffado.h
|
||||||
|
%{_libdir}/libffado.so
|
||||||
|
%{_libdir}/pkgconfig/libffado.pc
|
||||||
|
#%doc doc/reference/html/*
|
||||||
|
|
||||||
|
%files -n ffado
|
||||||
|
%defattr(-,root,root)
|
||||||
|
/lib/udev/rules.d/60-ffado.rules
|
||||||
|
%{_bindir}/ffado-bridgeco-downloader
|
||||||
|
%{_bindir}/ffado-dbus-server
|
||||||
|
%{_bindir}/ffado-diag
|
||||||
|
%{_bindir}/ffado-dice-firmware
|
||||||
|
%{_bindir}/ffado-fireworks-downloader
|
||||||
|
%{_bindir}/ffado-mixer
|
||||||
|
%{_bindir}/ffado-set-nickname
|
||||||
|
%{_datadir}/libffado/*.xml
|
||||||
|
%{_datadir}/libffado/python
|
||||||
|
%{_datadir}/applications/ffado.org-ffadomixer.desktop
|
||||||
|
%{_datadir}/dbus-1/services/org.ffado.Control.service
|
||||||
|
%{_datadir}/icons/hicolor/64x64/apps/ffado.png
|
||||||
|
%{_datadir}/libffado/icons/hi64-apps-ffado.png
|
||||||
|
%dir %{python_sitearch}/ffado
|
||||||
|
%{python_sitearch}/ffado/*.py*
|
||||||
|
%{python_sitearch}/ffado/*.ui
|
||||||
|
%dir %{python_sitearch}/ffado/mixer
|
||||||
|
%{python_sitearch}/ffado/mixer/*.py*
|
||||||
|
%{python_sitearch}/ffado/mixer/*.ui
|
||||||
|
%dir %{python_sitearch}/ffado/widgets
|
||||||
|
%{python_sitearch}/ffado/widgets/*.py*
|
||||||
|
%{_mandir}/man1/ffado-*.1*
|
||||||
|
%doc README.ffado
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Jun 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-2mamba
|
||||||
|
- python 2.7 mass rebuild
|
||||||
|
|
||||||
|
* Fri Oct 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-1mamba
|
||||||
|
- update to 2.1.0
|
||||||
|
|
||||||
|
* Tue Sep 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-3mamba
|
||||||
|
- rebuild (added gcc 4.7 patch)
|
||||||
|
|
||||||
|
* Sat Dec 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-2mamba
|
||||||
|
- imported from milestone1-contrib to devel
|
||||||
|
|
||||||
|
* Sat Oct 02 2010 gil <puntogil@libero.it> 2.0.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user